Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1210 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  probleme d'utilisation de php5 sous kubuntu 9.04 et apache2

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

probleme d'utilisation de php5 sous kubuntu 9.04 et apache2

n°1177725
joe dalton
Posté le 07-11-2009 à 12:20:51  profilanswer
 

bonjour, je suis pas sur d'etre dans la bonne catégorie,
je suis sous kubuntun 9.04, que je ne maitrise pas du tout pour l'instant vu que je suis en phase d'apprentisage.
j'essai ce systeme pour monter un serveur lamp.
tout avais l'air d'aller, mais lors de mon 1ere page html avec un script php , je me suis rendu compte qu'il n'executé pas mon script. (sous mozilla) apache étant bien lancé.
pourtant quand je fait un phpinfo() la ça marche... donc je suis plutot surpris.
mon script été juste un script bidon:

<?php echo "bonjour";?>


dans kconsole j'ai fais ceci:

joe@serveur:~$ sudo apt-get install php5-cli
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Paquets suggérés :
  php-pear
Les NOUVEAUX paquets suivants seront installés :
  php5-cli
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 2488ko dans les archives.
Après cette opération, 5456ko d'espace disque supplémentaires seront utilisés.
Err http://fr.archive.ubuntu.com jaunty-updates/main php5-cli 5.2.6.dfsg.1-3ubuntu4.1
  404 Not Found
Err http://security.ubuntu.com jaunty-security/main php5-cli 5.2.6.dfsg.1-3ubuntu4.1
  404 Not Found
Impossible de récupérer http://security.ubuntu.com/ubuntu/pool/main/p/php5/php5-cli_5.2.6.dfsg.1-3ubuntu4.1_i386.deb  404 Not Found

joe@serveur:~$ sudo apt-get install php5-cgi
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Paquets suggérés :
  php-pear
Les NOUVEAUX paquets suivants seront installés :
  php5-cgi
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 4935ko dans les archives.
Après cette opération, 10,7Mo d'espace disque supplémentaires seront utilisés.
Err http://fr.archive.ubuntu.com jaunty-updates/main php5-cgi 5.2.6.dfsg.1-3ubuntu4.1
  404 Not Found
Err http://security.ubuntu.com jaunty-security/main php5-cgi 5.2.6.dfsg.1-3ubuntu4.1
  404 Not Found
Impossible de récupérer http://security.ubuntu.com/ubuntu/pool/main/p/php5/php5-cgi_5.2.6.dfsg.1-3ubuntu4.1_i386.deb  404 Not Found
E: Impossible de récupérer quelques archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?


et donc la j'ai l'ipression que  php5 n'est pas installé en mode cli ni cgi...
avez vous une idée d'où peu venir mon problème?
pour ceux qui vont dire que ca viends de moi, j'y ai deja pensé  :sarcastic:

 


merci d'avance pour vos réponses.


Message édité par joe dalton le 07-11-2009 à 12:23:58
mood
Publicité
Posté le 07-11-2009 à 12:20:51  profilanswer
 

n°1177731
e_esprit
Posté le 07-11-2009 à 13:10:31  profilanswer
 

Ta base APT n'est pas à jour :o
 
apt-get update
 
Et ensuite apt-get install ...


---------------
Ce n'est point ma façon de penser qui a fait mon malheur, c'est celle des autres.
n°1177732
e_esprit
Posté le 07-11-2009 à 13:11:45  profilanswer
 

Sinon installes plutot le module php5 pour apache, ce sera beaucoup plus simple ("apt-cache search php5 apache2" devrait te donner le nom du paquet pour ta Ubuntu)


---------------
Ce n'est point ma façon de penser qui a fait mon malheur, c'est celle des autres.
n°1177740
joe dalton
Posté le 07-11-2009 à 13:37:27  profilanswer
 

bon j'ai déja trouvé l'un de mes problème, sous apache, c'est que j'ai pour l'instant que les fichier avec extension .php qui marche alors que mon fichier test été en .htm. donc le script php n'a pas été exécuté.
j'avais essayer apt-get update car la konsole m'avais conseillé de le faire (voir derniere ligne "peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?" )  mais ca n'avais rien changé. quand a l'option --fix -missing j'ai pas su si c'été pour apt-get update ou install donc je  l'ai pas essayé.

n°1178072
joe dalton
Posté le 08-11-2009 à 09:53:04  profilanswer
 

le fait d'obliger d'être admin pour mettre un fichier dans var/www est il propre a ubuntu?
quel fichier dois je modifier (apache2.conf, autre?) pour que les fichiers .htm qui possède du code php, ai ce code php exécuté? car pour l'instant seul les .php s'exécute.
pourquoi dans kconsole apt-get install me dit que c'est pas possible enfin fini toujours par une erreur alors que l'installateur graphique de logiciel marche très bien.... l'installateur graphique n'utilise t'il pas pourtant la même commande?


Message édité par joe dalton le 08-11-2009 à 09:54:58
n°1183071
joe dalton
Posté le 01-12-2009 à 21:42:05  profilanswer
 

up
 
j'ai toujours mon problème d'extension. seul les fichier en .php s'exécute. si j'ai du php dans un .htm ou autre, il se contente de m'affiché mon code php comme un texte. j'ai jeter un oeil dans divers fichiers conf et ini d'apache et de php, mais j'ai rien trouvé. quelqu'un peut il m'éclairer s'il vous plait.


Message édité par joe dalton le 01-12-2009 à 21:45:01
n°1183077
blackhawke​r
IWH and almost anywhere
Posté le 01-12-2009 à 23:07:11  profilanswer
 

pourquoi tu veux exécuter du php dans un fichier html?
 
sinon pour répondre à ta question:  
 
AddType application/x-httpd-php .htm dans httpd.conf il me semble
 
EDIT: voire dans ton .htaccess

Message cité 1 fois
Message édité par blackhawker le 01-12-2009 à 23:08:16

---------------
création de site - photo
n°1183328
joe dalton
Posté le 02-12-2009 à 20:04:20  profilanswer
 

blackhawker a écrit :

pourquoi tu veux exécuter du php dans un fichier html?
 
sinon pour répondre à ta question:  
 
AddType application/x-httpd-php .htm dans httpd.conf il me semble
 
EDIT: voire dans ton .htaccess


 
simplement pour pour pouvoir être libre d'utiliser 1 ou plusieurs lignes de php dans un htm sans pour autant être obligé de créer un fichier php séparé.
 
donc suffit de rajouté chaque type d'extension comme ca? AddType application/x-httpd-php .htm


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  probleme d'utilisation de php5 sous kubuntu 9.04 et apache2

 

Sujets relatifs
[SOLARIS 10 PHP] Probleme d'installation de PHP au lancement d'Apache.Problème de put en SFTP
Problème de mountage de DVD viergesPb Configuration Webdav sur Apache2
[résolu]problème de réseau étrangeprobleme reconnaissance port usb sur ubuntu + driver CG ATI
apache2, user et droitsresolu [XEN] utilisation de plusieurs cartes reseaux physiques debian5
Problème accès disque sous ubuntuProblème installation nconf sous redhat 4 EL
Plus de sujets relatifs à : probleme d'utilisation de php5 sous kubuntu 9.04 et apache2


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR