Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
2043 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  resolu [XEN] utilisation de plusieurs cartes reseaux physiques debian5

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

resolu [XEN] utilisation de plusieurs cartes reseaux physiques debian5

n°1168822
clickclac6
Posté le 02-10-2009 à 17:46:24  profilanswer
 

bonjour à tous,
 
je ne sais pas si je suis dans la bonne catégorie mais il y a un peu de reseau
 
commençons par le debut presentation du materiel et des softs
 
serveur dell R610
double xeon 4 core
4 cartes reseau brodcom
 
systeme debian 5.0.3 amd64
 
j ai installé les paquets pour xen cad  
xen-hypervisor-3.2-1-amd64 xen-linux-system-2.6.26-2-xen-amd64 xen-utils-3.2-1 xenstore-utils xenwatch xen-shell xen-tools  
 
j ai configurer xen en suivant ce tuto
http://www.howtoforge.com/virtuali [...] enny-amd64
reboot
un uname -r donne : 2.6.26-2-xen-amd64
mise à lheure avec ntpdate
utilisation de la carte reseau eth0
mise en bridge de xen avec le script par defaut (network-script network-bridge)
 
ensuite j ai installé une machine virtuel VM1 et tout marche nikel  
le ping vers google fonctionne  
 
 
maintenant je vous explique mon objectif
 
je souhaite utiliser la carte eth1 pour ma nouvelle machine VM1(pour ne pas passer par la même carte reseau que la machine hôte)
 
j ai procéder comme ceci
 
j ai remplacer le script network-bridge par un nouveau contenant

Code :
  1. #!/bin/sh
  2. dir=$(dirname "$0" )
  3. "$dir/network-bridge" "$@" vifnum=1 netdev=eth1 bridge=xenbr1
  4. "$dir/network-bridge" "$@" vifnum=2 netdev=eth2 bridge=xenbr2
  5. "$dir/network-bridge" "$@" vifnum=3 netdev=eth3 bridge=xenbr3


 
je n ai rien preciser pour eth0 pour quil soit utiliser par la machine hote.
j ai fait un petit chmod u+x sur mon script
 
et enfin ajouter cette ligne dans mon fichier VM1.cfg
eth1 pour Dom1
vif = ['mac=00:16:de:ad:be:ef,bridge=xenbr1']
 
un petit reboot pour la prise en compte des nouveau parametres
boot de VM1
mais VM1 na pas acces au reseau, j ai bien une carte eth0 dans VM1
 
voici le resultat de ifconfig sur la machine hote  

Code :
  1. eth0      Link encap:Ethernet  HWaddr 00:22:19:62:3d:43
  2.           inet adr:192.168.100.246  Bcast:192.168.100.255  Masque:255.255.255.0
  3.           adr inet6: fe80::222:19ff:fe62:3d43/64 Scope:Lien
  4.           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
  5.           RX packets:561 errors:0 dropped:0 overruns:0 frame:0
  6.           TX packets:183 errors:0 dropped:0 overruns:0 carrier:0
  7.           collisions:0 lg file transmission:1000
  8.           RX bytes:63830 (62.3 KiB)  TX bytes:31388 (30.6 KiB)
  9.           Interruption:36 Mémoire:d6000000-d6012100
  10. lo        Link encap:Boucle locale
  11.           inet adr:127.0.0.1  Masque:255.0.0.0
  12.           adr inet6: ::1/128 Scope:Hôte
  13.           UP LOOPBACK RUNNING  MTU:16436  Metric:1
  14.           RX packets:18 errors:0 dropped:0 overruns:0 frame:0
  15.           TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
  16.           collisions:0 lg file transmission:0
  17.           RX bytes:1575 (1.5 KiB)  TX bytes:1575 (1.5 KiB)
  18. peth1     Link encap:Ethernet  HWaddr 00:22:19:62:3d:45
  19.           inet adr:192.168.100.86  Bcast:192.168.100.255  Masque:255.255.255.0
  20.           adr inet6: fe80::222:19ff:fe62:3d45/64 Scope:Lien
  21.           UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
  22.           RX packets:328 errors:0 dropped:0 overruns:0 frame:0
  23.           TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
  24.           collisions:0 lg file transmission:1000
  25.           RX bytes:34525 (33.7 KiB)  TX bytes:13010 (12.7 KiB)
  26.           Interruption:48 Mémoire:d8000000-d8012100
  27. peth2     Link encap:Ethernet  HWaddr 00:22:19:62:3d:47
  28.           UP BROADCAST PROMISC MULTICAST  MTU:1500  Metric:1
  29.           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
  30.           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
  31.           collisions:0 lg file transmission:1000
  32.           RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
  33.           Interruption:32 Mémoire:da000000-da012100
  34. peth3     Link encap:Ethernet  HWaddr 00:22:19:62:3d:49
  35.           UP BROADCAST PROMISC MULTICAST  MTU:1500  Metric:1
  36.           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
  37.           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
  38.           collisions:0 lg file transmission:1000
  39.           RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
  40.           Interruption:42 Mémoire:dc000000-dc012100
  41. vif1.0    Link encap:Ethernet  HWaddr fe:ff:ff:ff:ff:ff
  42.           adr inet6: fe80::fcff:ffff:feff:ffff/64 Scope:Lien
  43.           UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
  44.           RX packets:1 errors:0 dropped:0 overruns:0 frame:0
  45.           TX packets:10 errors:0 dropped:6 overruns:0 carrier:0
  46.           collisions:0 lg file transmission:32
  47.           RX bytes:328 (328.0 B)  TX bytes:2717 (2.6 KiB)


et un brctl show donne bien  

Code :
  1. brctl show
  2. bridge name     bridge id               STP enabled     interfaces
  3. xenbr1          8000.002219623d45       no              peth1
  4.                                                         vif1.0
  5. xenbr2          8000.002219623d47       no              peth2
  6. xenbr3          8000.002219623d49       no              peth3


 
je nobtiens pas d'adresse ip pour VM1
je ne comprend pas pourquoi? et je pete un plomb :)
 
si quelqu'un aurai un piste ou un coup de main à me donne afin de pouvoir m'avance ca serai sympa
 
merci d'avoir pris le temps de me lire et bonne soiree


Message édité par clickclac6 le 02-10-2009 à 19:11:35
mood
Publicité
Posté le 02-10-2009 à 17:46:24  profilanswer
 

n°1168845
clickclac6
Posté le 02-10-2009 à 19:10:58  profilanswer
 

c'est bon jai trouve en faisant un ip addr show  
je me suis appercu que xenbr0 ete desactivé
 
je l'ai activé et VM1 a acces au reseau
 
merci


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  resolu [XEN] utilisation de plusieurs cartes reseaux physiques debian5

 

Sujets relatifs
[Résolu] Comment configurer carte physique pour gérer trunk et vlan[resolu] syntaxe pour comparer des chaines lors lecture d'un fichier
[résolu] Quelques statistiques[DEBIAN] Apache2 , vhosts hs depuis la mise a jour...[RESOLU]
[résolu] mettre des [] dans les recettes de .procmailrc?(résolu) Lire et affiché une vidéo sur un serveur par ssh
[RESOLU] Firefox et Flash sour Ubuntu 9.04[RESOLU] Accéder à une partition raid 1 logiciel (ext3) sous Windows
[Résolu][IPTABLES] problème avec NAT[Résolu][SSH] Redirection SSH de VirtualHost
Plus de sujets relatifs à : resolu [XEN] utilisation de plusieurs cartes reseaux physiques debian5


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR