Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2255 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  Fréquence CPU - mystérieux ..

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Fréquence CPU - mystérieux ..

n°840785
nicolasn54
Posté le 04-09-2006 à 21:39:04  profilanswer
 

Hello !  :hello:  
 
Sur un conroe 6300 sur une asrock 775i65G sous Ubuntu 6.06.1 (amd64), se produit un étrange problème de fréquence CPU qui diminue .. (j'ai enlevé dans le bios l'option du style Cool'n quiet qui pourrait réguler la vitesse du CPU en fct de la charge).  Voici ce qui est détecté au boot:
 
$dmesg | grep Detected
[    0.000000] time.c: Detected 2096.496 MHz processor. (nb: au démarrage de la machine le bios affiche 2.1Ghz CPU - sous memtest, il est aussi à 2.1Ghz)
 
$dmesg|fgrep -i bogomips
[   23.631917] Calibrating delay using timer specific routine.. 4198.15 BogoMIPS (lpj=8396306)
 
mais si l'on regarde /proc/cpuinfo:
model name      : Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz
stepping        : 6
cpu MHz         : 1796.996
...
bogomips        : 3594.12
 
C'est comme si le noyau avait descendu la vitesse de la machine autoritairement .. 1800 c'est pas tout à fait la vitesse normale du CPU (un peu moins que la vitesse du 6300) mais il est parfaitement stable à 2100 (j'ai passé le fsb de 266 à 300 dans le bios). Est-ce que vous voyez ce qui se passe et comment y remédier? Toutes les pistes sont bienvenues  :)  
 
Merci pour vos lumières!
 
a+, Nicolas

mood
Publicité
Posté le 04-09-2006 à 21:39:04  profilanswer
 

n°840806
Bi$cotte
:o
Posté le 04-09-2006 à 23:49:51  profilanswer
 

heu i me semble que cool'n quiet c AMD non ?
 
Sinon t'as ptetre un gestionnaire de fréquence cpu qui s'occupe de la baisser quand ton pc glande.
fait voir ce que donne un

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor


 
normalement du devrais avoir un de ceux la :

  • powersave -> ca met la fréquence minimale (cool pour les portables sur batterie)
  • performance -> fréquence au max
  • userland -> la c'est pour qu'un programme externe controle la fréquence
  • conservative -> fréquence minimale sauf quand la charge devient forte, ca alors augmente la fréquence
  • ondemand -> pareil que conservative en moins "conservateur", les seuils pour augmenter les frequences sont plus bas


Ou sinon si t'as rien de tout ca un ptit

ls /sys/devices/system/cpu/cpu0/cpufreq/


 
edit :  
moi sous debian j'ai un fichier /etc/default/cpufrequtils (venu avec le paquet cpufrequtils) qui permet de specifier le comportement que tu veux au boot, c expliqué en commentaire dans le fichier comment s'y prendre

Message cité 1 fois
Message édité par Bi$cotte le 04-09-2006 à 23:56:43
n°840982
nicolasn54
Posté le 05-09-2006 à 14:45:34  profilanswer
 

>heu i me semble que cool'n quiet c AMD non ?
 
Salut,  
 
Tu as raison, c'est pas cool'n quiet mais j'avais plus le nom en tête et ça sonnait bien :)  
 
Merci beaucoup pour tes inputs, je teste cela ce soir en rentrant du boulot et te tiens au courant, pour l'instant une chose est sûre même en charge, la fréquence reste à 1800  :(  donc le gestionnaire de fréquence c'est improbable.
 
Sinon, j'ai déjà vu des messages système (à l'install si je me souviens bien) comme quoi la source du temps ne serait pas stable, ticks perdus etc .. peut-être un composant un peu cheap sur la CM qui ferait qu'on peut pas utiliser à fréquence max ..  le truc c'est qu'il signale rien de cela au boot, l'animal,
 
a+, Nicolas
 

n°841068
nicolasn54
Posté le 05-09-2006 à 21:14:55  profilanswer
 

Cool, problème résolu  :bounce:  :bounce:  
 
j'ai regardé ce que tu m'avais indiqué, j'ai userspace dans scaling_gouvernor, ça doit correspondre à userland chez toi, donc si je comprends bien rien d'automatique pour les chgts de vitesse.  
 
J'ai un peu continué à fouiller et en fait le problème vient de l'apic (http://wiki.linuxquestions.org/wiki/APIC) qui comme souvent marche mal avec Linux, et si on boote avec l'option noapic ou apic=off, ca roule ! et le revoila à 2097Mhgz ! Dans le message de boot, il y avait bien la mention des ticks perdus et de l'horloge pas stable mais je l'avais pas repéré la première fois :pfff:  .. donc pour conclure, cette mobo marche bien sous Linux (tout est reconnu, réseau, carte graphique, pas testé le son car c'est un serveur mais a priori ok) sauf que pour l'install il faut désactiver le support PCMCIA (ne me demandez pas pourquoi!),
 
En tout cas merci pour ton aide !
 
a+, Nicolas
 
 
 
 

Bi$cotte a écrit :

heu i me semble que cool'n quiet c AMD non ?
 
Sinon t'as ptetre un gestionnaire de fréquence cpu qui s'occupe de la baisser quand ton pc glande.
fait voir ce que donne un

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor


 
normalement du devrais avoir un de ceux la :

  • powersave -> ca met la fréquence minimale (cool pour les portables sur batterie)
  • performance -> fréquence au max
  • userland -> la c'est pour qu'un programme externe controle la fréquence
  • conservative -> fréquence minimale sauf quand la charge devient forte, ca alors augmente la fréquence
  • ondemand -> pareil que conservative en moins "conservateur", les seuils pour augmenter les frequences sont plus bas


Ou sinon si t'as rien de tout ca un ptit

ls /sys/devices/system/cpu/cpu0/cpufreq/


 
edit :  
moi sous debian j'ai un fichier /etc/default/cpufrequtils (venu avec le paquet cpufrequtils) qui permet de specifier le comportement que tu veux au boot, c expliqué en commentaire dans le fichier comment s'y prendre


Message édité par nicolasn54 le 05-09-2006 à 21:20:09
n°841075
Bi$cotte
:o
Posté le 05-09-2006 à 21:53:48  profilanswer
 

Oué pour le coup de userland, ma fourche a langué  :p  
 
Par contre ca veut dire que t'as potentiellement un programme qui tourne qui sert à réguler la fréquence. Enfin il se peut aussi bien que t'en ai pas ...
De nom je connais cpudyn, cpufreqd et powernowd, tu peux toujours regarder si t'en a un de ceux la qui tourne.
 
Si désactiver l'acpi a résolu le problème, je vois pas trop le rapport, à moins que le fait de désactiver l'acpi ait également viré a linux la possibilité de réguler la fréquence de ton proc. M'enfin sur ton matos, je pense qu'il doit y avoir mieux comme interface de régulation, passer par l'acpi pour faire ca je crois que c'est reservé au matos pas vraiment prévu pour être régulé.
 
Sinon pour tes ticks perdus, ben .. la je saurais pas dire.
 
M'enfin le principal c'est que ca marche  :hello:


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  Fréquence CPU - mystérieux ..

 

Sujets relatifs
Problème de fréquence de rafraichissement en bi-écran[reglé] probleme de frequence (xorg.conf) - Mal aux yeux ^^
frequence de raffraichissement sous debian... -> mal aux yeuxChangement de CPU: reinstallation?
Charge CPU d'une machine Linux par SNMP?Frequence de rafraichissement écran
Résolution d'écran et fréquence de rafraichissementgraphe CPU multiprocesseur avec MRTG
Gestion de la fréquence cpu Mandriva 2006-Conflit avec cpufreq ?[BOINC] Powenowd qui monte pas la fréquence
Plus de sujets relatifs à : Fréquence CPU - mystérieux ..


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR