Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1957 connectés 

  FORUM HardWare.fr
  Hardware
  Matériels & problèmes divers

  "Reveiller" un port de switch

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

"Reveiller" un port de switch

n°10971166
Plocploc_
Crac boum hue le Seagate
Posté le 25-03-2021 à 17:17:26  profilanswer
 

Bonjour,
 
Je cherche à résoudre un bug un peu agacant sur mon switch D-Link DGS 105, peut-être que quelqu'un aurait une solution.
C'est un switch gigabit 5 ports, tout bête mais il a une fonction "économie d'énergie". En gros quand un port n'est plus sollicité (genre si on éteint l'ordi branché sur ce port), il baisse la tension dudit port en le limitant à 100Mb/s au lieu du gigabit. Par contre si on rallume l'ordi, hop, le port détecte une connexion gigabit et se réveille (la diode est verte en gigabit, orange en 100Mbit/économie d'énergie). Jusque là tout va bien.
Sauf que mon problème est le suivant:
- chez moi, toutes mes prises murales RJ45 sont connectées entre elles pas de souci
- j'ai la box fibre dans mon salon, je la branche sur le port mural RJ45 du salon, et elle distribue internet à tous les ports de la maison
- dans une chambre, je branche le D-Link sur le port mural RJ45 de la chambre (port 1). J'ai 2 NAS que je branche ensuite sur port 2 et port 3
- enfin dans ma propre chambre, je branche mon PC à la prise mural
Rien de bien exotique dans ma configuration donc, j'accède sans problème aux données de mes NAS. Par contre, si je n'utilise pas mes NAS durant plusieurs jours, voire semaines, elles se mettent en veille et les ports passent en orange MAIS le port 1 de ma D-Link passe aussi en veille!
Et quand je réveille mes NAS en y accédant, leurs ports repassent bien en vert/Gigabit mais le port 1 de la switch qui va vers la prise murale reste désespérément orange.. Impossible de la réveiller autrement que débrancher/rebrancher le câble du port 1. Ou carrément éteindre rallumer le switch.. C'est navrant mais je ne sais pas comment faire pour réveiller ce port pour qu'il repasse de 100Mb au Gigabit. Vu qu'il n'est pas vraiment connecté à un ordi physique, je devine qu'il ne reçoit pas de signal Gigabit qui le force à se réveiller? Bref...
Merci d'avance si vous avez un tuyau

mood
Publicité
Posté le 25-03-2021 à 17:17:26  profilanswer
 

n°10971191
artouillas​sse
Schtroumpf qui peut !
Posté le 25-03-2021 à 18:18:16  profilanswer
 

Bonjour
 
A part trouver un firmware moddé sans cette option de mise en veille je ne vois pas trop quoi te conseiller.
Tu as contacté D-link en passant ?


---------------
Un trou noir c'est troublant. Si vous avez un chat un peu collant, appelez le Tertone. Y en a ils ont rien à dire mais ils le font savoir.
n°10971276
Plocploc_
Crac boum hue le Seagate
Posté le 25-03-2021 à 21:01:09  profilanswer
 

Hello, non je n'ai pas contacté le support de DLink, je vais peut-être le faire effectivement. Mais c'est quand même débile leur détection à la noix!

n°10971283
artouillas​sse
Schtroumpf qui peut !
Posté le 25-03-2021 à 21:13:35  profilanswer
 

Si ça se trouve ils sont pas au courant que ça fait ça, mais c'est vrai que c'est débile.
Après pour corriger un firmware ça peut prendre du temps, à moins de virer complètement l'option de veille à la con.


---------------
Un trou noir c'est troublant. Si vous avez un chat un peu collant, appelez le Tertone. Y en a ils ont rien à dire mais ils le font savoir.
n°10971332
naphh
Posté le 25-03-2021 à 23:10:27  profilanswer
 

tu as pas moyen de desac "D-link green" xd?
 
et mettre en ip statique le tout

n°10971374
Nono0000
Posté le 26-03-2021 à 07:39:04  profilanswer
 

As-tu essayé de mettre ce cable sur un autre port? le 5 par exemple qui n'utilise pas le PoE.
Après qu'est-ce que tu utilises pour distribuer les prises réseau dans la maison? Quel modèle de switch? Il n'est pas impossible qu'il y ait un problème sur ce switch qui empêche le D-link de renégocier un bit rate à 1Gbit/s.


Message édité par Nono0000 le 26-03-2021 à 08:48:16

---------------
CPU: 6950X 4.3Ghz (Uncore: 3.8Ghz) WC HM -- Mem: 4x8Go 3200Mhz 14-16-17-32-1T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10971442
Plocploc_
Crac boum hue le Seagate
Posté le 26-03-2021 à 10:17:42  profilanswer
 

hello,
oui, j'ai changé de port sans succès. Les prises murales entre elles sont reliées en gigabit au moment de la construction donc pas de souci de coté là. Et le switch maître, c'est la Livebox 4. D'ailleurs j'ai remplacé pour tester, un switch sans gestion d'énergie intégrée (un tp link) à la place du DLink, ben aucun soucis. Je vais écrire au support DLink. Merci pour vos avis

Message cité 1 fois
Message édité par Plocploc_ le 26-03-2021 à 10:19:36
n°10971460
wgromit
Posté le 26-03-2021 à 10:57:51  profilanswer
 

Bonjour,
 
Ce switch est-il administrable ?
Notamment en passant par un navigateur web et en entrant l'adresse IP du switch.
C'est juste pour savoir s'il n'y aurait pas une option via l'interface web concernant cette fonctionnalité "green".
 
J'ai le modèle GS105E qui est administrable mais je n'arrive pas à avoir l'info concernant ton modèle.

n°10971462
Plocploc_
Crac boum hue le Seagate
Posté le 26-03-2021 à 11:02:55  profilanswer
 

Bonjour, helas non, sinon effectivement c'eut ete facile de webadministrer. Le switch n'a pas d'IP. Pas d'IP pas de chocolat :)

n°10971467
wgromit
Posté le 26-03-2021 à 11:21:15  profilanswer
 

Autre petite question.
 
Si j'ai bien compris, le port 1 est connecté sur une prise murale.
Ensuite, tu dois bien brancher un autre équipement (autre que la Livebox, par ex un PC) sur ton réseau local (via les prises murales) et donc cet équipement se retrouve branché indirectement sur le port 1 du switch ?
 
C'est bien cela ?
 
Et c'est la que le port 1 reste en 100 mb/s ?
J'ai toujours bien compris ?
 
Du coup, voila ma question.
S'il s'agit d'un PC que tu branches, il n'y aurait pas une option dans son interface réseau qui pourrait être aussi en mode "green".
 
Par ex, sur mon PC à base d'un chipset réseau Intel I219-V, j'ai des options qui concerne justement les fonctionnalités "green", notamment une qui se nomme "Energy Efficient Ethernet" (qui est On par défaut).
 
Donc l'idée est de désactiver une telle option côté PC pour "forcer" le switch à désactiver son mode green.
 
Je ne sais pas si cela fonctionne, n'ayant pas ton problème mais comme les interfaces réseaux communiquent entre elles notamment pour savoir quelles fonctionnalités elles peuvent inclure, le fait de forcer une interface réseau non compatible green (côté PC donc) fera peut-être basculer celle du port 1 de ton switch en non "green".

mood
Publicité
Posté le 26-03-2021 à 11:21:15  profilanswer
 

n°10971477
artouillas​sse
Schtroumpf qui peut !
Posté le 26-03-2021 à 11:41:56  profilanswer
 

wgromit a écrit :

Donc l'idée est de désactiver une telle option côté PC pour "forcer" le switch à désactiver son mode green.


Mais toi tu peux le désactiver dans le BIOS de ton PC ?
Si oui alors en effet faudrait chercher une option de ce genre dans le BIOS.
 
Si c'est sous windows ça n'a pas d'importance car c'est quand le PC passe en veille ou qu'il est éteint que le port "s'éteint".


---------------
Un trou noir c'est troublant. Si vous avez un chat un peu collant, appelez le Tertone. Y en a ils ont rien à dire mais ils le font savoir.
n°10971515
Nono0000
Posté le 26-03-2021 à 12:53:49  profilanswer
 

Plocploc_ a écrit :

hello,
oui, j'ai changé de port sans succès. Les prises murales entre elles sont reliées en gigabit au moment de la construction donc pas de souci de coté là. Et le switch maître, c'est la Livebox 4. D'ailleurs j'ai remplacé pour tester, un switch sans gestion d'énergie intégrée (un tp link) à la place du DLink, ben aucun soucis. Je vais écrire au support DLink. Merci pour vos avis

 

Je ne suis pas sûr de comprendre ton point sur la construction.
Les transferts entre nœuds réseau se font de manière dynamique et si le Dlink passe en 100Mbit/s il faut aussi que la Livebox passe en 100Mbit/s.
Il en va de même pour un retour en 1000Mbit/s. Il faut que le switch et le routeur "tombent d'accord" sur le transfert.
Entre les NAS et le D-link ca marche visiblement mais pas entre la LiveBox et le D-link...

 

Après qui est le fautif, difficile à dire... vu l'usine à gaz qu'est l'IEEE 802.1, les constructeurs peuvent prendre des raccourcis et il peut y avoir des incompatibilités.

 

EDIT: Ce que tu peux faire pour éviter que la connexion passe en mode basse énergie, c'est faire un "cron" sur l'un de tes NAS pour faire un ping un peu gros vers la box et simuler du traffic toutes les x heures par exemple. (ping -c2 -s 1500 192.168.x.x)


Message édité par Nono0000 le 26-03-2021 à 19:05:05

---------------
CPU: 6950X 4.3Ghz (Uncore: 3.8Ghz) WC HM -- Mem: 4x8Go 3200Mhz 14-16-17-32-1T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10971747
naphh
Posté le 26-03-2021 à 19:44:01  profilanswer
 

dans le bios, le seul moyen est d'activer le ErP (vu que ca eteind tout, donc pas de mode eco bizarre) ou de voir apres les wake-on-lan etc


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Matériels & problèmes divers

  "Reveiller" un port de switch

 

Sujets relatifs
CM B550-F : Carte Son détecté uniquement sur port 16x ?!MSI B450 Gaming plus : Switch CG AMD 6900 HD / CG processeur AMD Ryzen
Passer de HDMI à display portradeon rx 570 seul le port hdmi fonctionne
Port PCIE de la carte Asus z170 Pro GamingSwitch tous mes périphériques
Remplacer boitier ONT Fibre Bouygues par switch SFPport usb 3.0 ne fonctionnent pas
alimentation port usb mag b550Branchement HDMI ou Display port
Plus de sujets relatifs à : "Reveiller" un port de switch


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR