Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1893 connectés 

  FORUM HardWare.fr
  Windows & Software
  Win 10

  Problème Windows 10 installation GPT MBR Blue screen

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème Windows 10 installation GPT MBR Blue screen

n°3371786
ayting69
Posté le 06-05-2020 à 12:10:02  profilanswer
 

Salut :)
 
Config :
 

Code :
  1. MB : AORUS B450 PRO
  2. DRIVE : NVME 1 To partionné. 1 partition "Games" 827 GO 1 partition  "OS" 125 Go  où Windows est installé
  3. CPU : RYZEN 5 2600


 
Chronologie :
 
1 : Windows 10 à un démarrage lent et étrange :  https://streamable.com/enmwtf
 
 
2 : Windows 10 est installé en MBR, je le réinstalle avec le secure boot en GPT selon un conseil d'un redditien
 
 
3 : Windows 10 démarre maintenant très rapidement (10 secondes contre 22 secondes avant) et plus de texte nvidia et autre, logo aorus > windows démarre
 
 
4 : J'optimise mon PC pour le gaming en suivant les tuto de CAPET et je désactive le secure boot pensant que mon PC pourra être plus rapide (connerie je sais)
 
 
5 : J'ai des problèmes en jeu, l'opti que j'ai fais m'a amené des bugs, je décide de réinstaller Windows 10.
 
 
6 :Je branche ma clef usb bootable et là : Blue screen. J'essaye de simplement démarrer Windows 10 :  Blue screen. Impossible de rédémarrer.
 
 
7 : Apparement ça serait dût au fait que j'ai desactiver le secure boot, une histoire de sécurité, je réintialise les "factory key" dans le menu "secure boot" du bios et je peux seulement rebooter sur la clef, mais pas sur windows qui est toujours en blue screen.

 
8 : Je réinstalle Windows 10 en formatant seulement la partition OS avec le secure boot desactivé.
 
 
9 : Maintenant Windows 10 démarre en 30  secondes, mais il ni y'a pas le texte nvidia, logo aorus > windows démarre
 
 
 
 
Mes questions :
 

  • Est ce que le démarrage rapide était dût au fait que j'avais installer Windows 10 avec le secure boot ? Par ailleurs j'ai l'impression que quand on installe Windows 10 avec le secure boot, on ne peut pas le réinstaller sans le désactiver ?


  • Pourquoi j'ai eu un blue screen permanent quand j'ai branché ma clef usb ?  


  • Est ce que je dois formater tout le nvme pour y installer Windows 10 sans problème ?


  • J'aimerais bien réinstaller Windows pour de nouveau avoir le démarrage ultra rapide que j'avais avant. Mais j'aimerais savoir si je dois vraiment l'installer  avec le secure boot qui a l'air de poser problème. Aussi j'aimerais connaître les précautions à avoir pour ne pas faire face à un nouveau BSOD si je l'installe en secure boot et qu'un jour je veuille encore réinstaller Windows pour X raison.


 
En vous remerciant d'avance.

Message cité 1 fois
Message édité par ayting69 le 06-05-2020 à 12:15:40
mood
Publicité
Posté le 06-05-2020 à 12:10:02  profilanswer
 

n°3371819
nex84
Dura lex, sed lex
Posté le 06-05-2020 à 16:05:22  profilanswer
 

ayting69 a écrit :


Mes questions :
 

  • Est ce que le démarrage rapide était dût au fait que j'avais installer Windows 10 avec le secure boot ? Par ailleurs j'ai l'impression que quand on installe Windows 10 avec le secure boot, on ne peut pas le réinstaller sans le désactiver ?


  • Pourquoi j'ai eu un blue screen permanent quand j'ai branché ma clef usb ?  


  • Est ce que je dois formater tout le nvme pour y installer Windows 10 sans problème ?


  • J'aimerais bien réinstaller Windows pour de nouveau avoir le démarrage ultra rapide que j'avais avant. Mais j'aimerais savoir si je dois vraiment l'installer  avec le secure boot qui a l'air de poser problème. Aussi j'aimerais connaître les précautions à avoir pour ne pas faire face à un nouveau BSOD si je l'installe en secure boot et qu'un jour je veuille encore réinstaller Windows pour X raison.


 
En vous remerciant d'avance.


1- De base, Windows 10 s'installe en GPT sur un PC moderne, et utilise le SecureBoot et le FastBoot de l'UEFI.  
Pourquoi ? Pour te faire booter plus vite et de manière plus sécurisée.
Le SecureBoot est là pour que le PC ne puisse pas booter sur un OS non validé (corrompu, indésirable, ...).
Par contre rien n'empèche de booter sur l'installeur de Windows qui est valide lui aussi.
 
2- Impossible à dire, il faudrait le détail du BSOD.
Ça peut venir d'une clé corrompue, d'un souci hardware, d'un problème de driver, etc ...
 
3- Quand on installe Windows, il faut retirer tous les disques sauf celui qui accueillera Windows.
Ensuite, il n'est pas nécessaire d'initialiser des partitions avant installation.
Dans le cas d'une réinstallation de zéro, il faut tout virer et l'installeur de Windows créera les partitions correctement (GPT) comme tu le souhaites (il y a un menu avancé si tu veux créer des partitions de tailles spécifiques.
 
4- Le SecureBoot ne pose aucun souci.
La cause de tous tes problèmes viennent plutôt des "optimisations" des tutos que tu as suivi.


---------------
#TeamNoBidouille || Come to the Dark Side, we have cookies || Mangez 5 fruits et légumes par an ! || Le digital, c'est les doigts
n°3371878
ayting69
Posté le 06-05-2020 à 21:53:12  profilanswer
 

1 - Ouais donc en faite sans secure boot c'est normal que le pc démarre plus lentement déjà tu m'éclaires sur ça merci.
Le soucis c'est que quand je l'active dans le bios il reste en inactive au niveau de son statut, je dois absolument réinstaller windows pour l'activer ?
 
 
2 -  Problème de drivers peut être si  le secure boot ne charge pas certains drivers et qu'une fois desactivé il les charge.
Ça aurait pu crée un conflit quand j'ai essayé de démarrer sur la clef bootable, j'en sais rien je dis peut être des inepties
 
 
3 - Le soucis c'est que je sais pas pourquoi, mais sans mon hdd et mon ssd sata branché à côté mon bios ne détecte pas mon NVME, et je comprend absolument pas pourquoi.  
Ca serait car le bios charge les drivers du nvme depuis un de ces disque où est installé Windows de ce que j'ai pu lire.  
Parce qu'en faite oui j'ai eu ce nvme après ces disque  donc j'ai jamais eu une situation ou j'ai du installer windows dessus sans un autre windows à côté.  
 
 
4 - Et oui, tu as raisons ces optimisations bidons et plus particulièrement celle d'avoir désactive le secure boot  puis d'avoir branché une clef usb bootable alors que les factory key étaient toujours installées.  
Je pense que c'est ça qui a tout fait foiré. Mais visiblement ça a pas l'air d'être un cas de figure connu..  
 
 
Bref avec tout ça je flippe de réinstaller Windows 10 dans les règles de l'art, déjà le fait que mon nvme soit detecté que avec ces 2 disques branchés je trouve ça flippant.  
Et surtout j'ai peur de brick mon bios ou que sais je encore..  
Alors oui je sais c'est pas la mort 30 secondes mais quand je sais que juste avant que je fasse le con il démarrait en 10, ça me frustre beaucoup !
 
 
Déjà si je crée la clef usb avec media creation tool, vu que je vais le faire depuis un système sans secure boot et que de ce que j'ai lu la création s'adapte au système en cours.  
Je pourrais pas booter dessus quand je vais essayer de démarrer avec le secure boot activé non ? Dans ce cas faut que j'utilise rufus ?


Message édité par ayting69 le 06-05-2020 à 21:58:09
n°3371914
nex84
Dura lex, sed lex
Posté le 07-05-2020 à 10:01:39  profilanswer
 

1- En fait c'est le FastBoot qui change la manière dont le système démarre :
https://lecrabeinfo.net/app/uploads/2019/11/demarrage-rapide-demarrage-a-froid-windows-5dcd4d37769ab.jpg
Sauf que normalement le FastBoot n'est disponible que si le SecureBoot est activé
 
2- Le FastBoot ne charge pas tous les drivers, et zappe certaines étapes du boot. Par exemple il boot directement sur l'OS sans permettre de booter en USB par exemple. Pour gagner du temps.  
Par contre le système une fois démarré va gérer le matériel et les drivers normalement.
 
3- le boot sur un SSD NVMe n'a pas besoin de drivers. C'est l'UEFI qui gère ça.
Il n'y a donc aucun rapport avec les disques ou le reste du système.
Par contre il faut que l'UEFI de la carte mère sache le gérer, et éventuellement le mettre à jour si nécessaire. Il faut aussi regarder dans les réglages pour voir si ce n'est pas simplement mal configuré.
En revanche ce qui peut arriver, c'est que le bootloader de Windows soit sur le mauvais disque. Ça arrive quand on installe Windows en laissant brancher tous les disques plutôt qu'en ne laissant branché que celui (le NVMe dans ton cas) qui accueillera l'OS.
Si c'est le cas, il faut forcément le disque ayant le bootloader ainsi que celui qui contient Windows pour pouvoir démarrer.
 
4- Malheureusement la grande majorité des des tutos qu'on trouve (surtout sur youtube) sont soit inutiles, soit dangereux, soit obsolètes.
 
Je te rassure tout de suite, il n'y a aucune raison de bricker ton BIOS UEFI.
 
Pour réinstaller Windows, le Media Creation Tool fonctionne très bien et permet de créer la clé d'installation USB qui va bien.
Elle sera "adaptée" à ton PC dans le sens où elle intègrera les drivers de ton matériel, en plus des drivers génériques.
Elle ne posera aucun problème pour le SecureBoot. Au pire si le boot USB ne se fait pas, tu peux lancer le setup.exe depuis Windows utiliser le menu pour aller dans le démarrage avancé.


---------------
#TeamNoBidouille || Come to the Dark Side, we have cookies || Mangez 5 fruits et légumes par an ! || Le digital, c'est les doigts
n°3371933
ayting69
Posté le 07-05-2020 à 13:25:56  profilanswer
 

1 - https://streamable.com/cwoqno Moi j'ai le fastboot que le démarrage sécurisé soit activé ou pas, mais je suis certains que le démarrage suit le premier schéma c'est à dire qu'il charge les drivers etc.  
Vu le temps que ça met par rapport à  avant c'est o-bli-gé, en plus y'a au moins 10 secondes d'écran noir avant que le logo windows s'affiche puis que le bureau s'affiche donc en faite l'option de fast boot que j'ai est bidon  
(ah et j'ai aussi une fonction ultra fastboot mais je l'utilise pas c'est beaucoup trop galère de rentrer dans le bios quand je l'active)
 
2 - Je peux démarrer en usb avec le fastboot activé, j'ai mis le paramètre usb en partial initial mais ça change rien au temps de boot.
 
 
3 - Bon j'ai  re testé et finalement ça marche, mais en faite quand j'avais essayé en débranchant les deux pour installer windows, dans le bios j'avais carrément plus le nom du nvme, il disparaissait, et quand je rebranchais les deux, il réapparaissait.  
Et ce avec la dernière version de mon bios installée, d'ailleurs j'aime pas du tout mettre mon bios à jour car ça je sais que ça peut vraiment brick la cm si le processus est interrompu pour x raison
 
J'ai essayé un truc, j'ai cherché comment activé le secure boot sans réinstaller, j'ai lu qu'il fallait check sur information système, que le système est bien installé en UEFI, et c'est mon cas.
Donc j'ai activé le secure boot et j'ai juste du faire une manip supplémentaire pour passer le truc en utilisateur, et le secure boot est passé en active
 
Mais ça n'a rien changé, du coup j'en conclue que pour que le "vrai" fastboot soit activé, j'dois absolument réinstaller Windows ? Activé le secureboot ne suffit pas ?
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Win 10

  Problème Windows 10 installation GPT MBR Blue screen

 

Sujets relatifs
Problème téléchargement fichiers (mp4, pps) avec Windows mailQuel lecteur vidéo utilisez-vous sous Windows 10?
Gros problème avec Acronis True Image 2020Probleme Msi Afterburner
Problème Explorateur WindowsProblème messagerie outlook avec fichier.ost
Windows 10 x64 DRIVERS nouveau PC(humour) optimiser windows
Plus de sujets relatifs à : Problème Windows 10 installation GPT MBR Blue screen


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR