Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2177 connectés 

  FORUM HardWare.fr
  Windows & Software

  (RESOLU) Routeur: pb de NAT (redirection des ports)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

(RESOLU) Routeur: pb de NAT (redirection des ports)

n°1743452
[grandpas]
by some called Strider
Posté le 02-10-2004 à 17:17:43  profilanswer
 

Salut,
 
J'ai une machine sur laquelle se trouve EasyPhP (serveur Apache/MySQL/PHP). Cette machine est connectée à internet (ADSL) via un routeur Zyxel Prestige 660. Ca donne qqchose comme ça:
Serveur local : 192.168.1.X
Routeur: 192.168.1.1 / 217.A.B.C (IP dynamique attribuée par le FAI)
 
Je tente de configurer le routeur afin de rediriger tout ce qui rentre sur le port 80 de 217.A.B.C vers l'IP locale 192.168.1.X ... mais rien à faire ... la redirection ne s'effectue pas: quand j'entre (sur une machine externe l'IP dynamique du routeur, je ne tombe jamais sur le serveur web mais sur la fenêtre d'identification pour l'administration du routeur.
J'ai fait des essais avec/sans firewall mais ça ne change rien. Un truc que j'ai oublié? Des pistes?
 
Merci
 
 
PS: si je connecte la machine avec le serveur web directement à internet (en passant par un modem ADSL et non plus par le routeur), ça fonctionne parfaitement .. cette simple précision pour indiquer qu'il n'y a pas de pb du côté de la machine serveur web (elle est bien à l'écoute de ce qui arrive sur le port 80); c'est bien côté routeur qu'il y a le pb.
 
 
comme le pensait com21, le "pb" venait du fait que le routeur interprétait les accès du réseau local comme des accès pour son administration ... le "pb" venait donc de moi


Message édité par [grandpas] le 05-10-2004 à 05:43:28

---------------
All that is gold does not glitter, not all those who wander are lost ... I am Aragorn, and those verses go with that name.
mood
Publicité
Posté le 02-10-2004 à 17:17:43  profilanswer
 

n°1743459
Prems
Just a lie
Posté le 02-10-2004 à 17:22:43  profilanswer
 

Es-tu sûr d'avoir bien fait tout ce qu'il fallait ? Est-ce que ça passe sur un autre port ?
 
Par exemple, tu rediriges le port 81 externe sur le port local 80.


---------------
Ratures - Cuisine
n°1743471
com21
Modérateur
real men don't click
Posté le 02-10-2004 à 17:44:01  profilanswer
 

"une machine externe" = ?
 
tu parle bien d'une machine possédant sa propre connexion internet (un ami, au boulot, etccc)
 


---------------
Cherche geekette | Traquez vos billets d'€ | Don du sang | Don de moelle osseuse
n°1743475
Mjules
Parle dans le vide
Posté le 02-10-2004 à 17:48:49  profilanswer
 

ya pas un truc du routeur qui écoutes sur le 80 côté public qu'il faudrait désactiver ?


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1743488
[grandpas]
by some called Strider
Posté le 02-10-2004 à 17:56:22  profilanswer
 

Prems a écrit :

Es-tu sûr d'avoir bien fait tout ce qu'il fallait ? Est-ce que ça passe sur un autre port ?
Par exemple, tu rediriges le port 81 externe sur le port local 80.


Pas essayé ça mais c'est un test à faire (faudra attendre un peu j'ai pas les machines sous la main là)
 
Et puis pas grave si je dois ajouter :81 au lien pour accéder au serveur :-)


---------------
All that is gold does not glitter, not all those who wander are lost ... I am Aragorn, and those verses go with that name.
n°1743490
[grandpas]
by some called Strider
Posté le 02-10-2004 à 17:56:54  profilanswer
 

com21 a écrit :

"une machine externe" = ?
tu parle bien d'une machine possédant sa propre connexion internet (un ami, au boulot, etccc)


oui; j'ai testé avec une machine se connectant par RTC


---------------
All that is gold does not glitter, not all those who wander are lost ... I am Aragorn, and those verses go with that name.
n°1743497
[grandpas]
by some called Strider
Posté le 02-10-2004 à 18:01:39  profilanswer
 

Mjules a écrit :

ya pas un truc du routeur qui écoutes sur le 80 côté public qu'il faudrait désactiver ?


J'ai pensé aussi à un truc comme ça: un truc qui prends le pas sur la redirection ... mais je n'ai pas trouvé d'option de ce genre dans les menus
 
PS: a noter que j'ai le dernier firmware (ça plantait avec l'ancien et la MAJ n'a rien changé). J'ai paramétré via l'interface WEB mais j'ai aussi essayé en paramétrant via telnet (paraît que parfois l'interface web ne fait pas bien son boulot)


Message édité par [grandpas] le 02-10-2004 à 18:02:45

---------------
All that is gold does not glitter, not all those who wander are lost ... I am Aragorn, and those verses go with that name.
n°1743500
Manaloup
Posté le 02-10-2004 à 18:02:27  profilanswer
 

Télécharger un firmware récent qui résouds ce bug ? Ou mettre l'interface du routeur sur un autre port ?
Désactiver le controle à distance (et donc l'écoute via le WAN) ?
Tu devrais avoir le même pb avec le telnet (23) ou ssh(20) , bcp de routeurs s'administrant par ce protocole également..

n°1743501
com21
Modérateur
real men don't click
Posté le 02-10-2004 à 18:02:48  profilanswer
 

il est etrange, que de base, tu accede à la config du routeur via l'exterieur.
 
Generalement c'est une option a activé (question de sécurité) et il faut parfois indiquer quels ip sont autorisés à s'y connecter.


---------------
Cherche geekette | Traquez vos billets d'€ | Don du sang | Don de moelle osseuse
n°1743508
Profil sup​primé
Posté le 02-10-2004 à 18:08:15  answer
 

com21 a écrit :

il est etrange, que de base, tu accede à la config du routeur via l'exterieur.
 
Generalement c'est une option a activé (question de sécurité) et il faut parfois indiquer quels ip sont autorisés à s'y connecter.


 
Il a du essayer de tester son serveur web en local, ca fait ca quand tu rentres l ip publique du routeur , il ouvre la page de config comme si tu mettais l ip locale :D

mood
Publicité
Posté le 02-10-2004 à 18:08:15  profilanswer
 

n°1743509
[grandpas]
by some called Strider
Posté le 02-10-2004 à 18:08:26  profilanswer
 

Télécharger un firmware récent qui résouds ce bug ?
ça n'a pas marché
 
Ou mettre l'interface du routeur sur un autre port ?
très bonne cette idée
 
Désactiver le controle à distance (et donc l'écoute via le WAN) ?
testé .. sans effet :-(
 
Tu devrais avoir le même pb avec le telnet (23) ou ssh(20)
exact mais c'est pas un pb majeur dans la mesure ou je ne suis intéressé que par du http (le serveur fait tourner une appli. nommé TimeCop et rien d'autre)


---------------
All that is gold does not glitter, not all those who wander are lost ... I am Aragorn, and those verses go with that name.
n°1743524
[grandpas]
by some called Strider
Posté le 02-10-2004 à 18:15:50  profilanswer
 

frank75 a raison: le login/pass d'administration apparaît en cas d'accès à partir de machines locales.


---------------
All that is gold does not glitter, not all those who wander are lost ... I am Aragorn, and those verses go with that name.
n°1743541
com21
Modérateur
real men don't click
Posté le 02-10-2004 à 18:25:50  profilanswer
 

franck75 a écrit :

Il a du essayer de tester son serveur web en local, ca fait ca quand tu rentres l ip publique du routeur , il ouvre la page de config comme si tu mettais l ip locale :D


 
non il vient de dire qu'il testait avec une connect en rtc....
 
(c'est aussi ce que j'avais pensé au début)


---------------
Cherche geekette | Traquez vos billets d'€ | Don du sang | Don de moelle osseuse
n°1743947
[grandpas]
by some called Strider
Posté le 03-10-2004 à 00:05:32  profilanswer
 

com21 a écrit :

non il vient de dire qu'il testait avec une connect en rtc....(c'est aussi ce que j'avais pensé au début)


J'ai testé avec une machine tierce en RTC lorsque le serveur était connecté via modem ADSL. Là, rien à signaler ça marche.
Tous les autres tests ont été fait à partir de machines du même réseau local dont la connection ADSL est établie au moyen du routeur. Dans ce cas:
- accès au serveur en entrant l'IP 192.168.1.X => ça marche
- accès au serveur en entrant l'IP dynamique => fenetre d'admin. du routeur, pas de routage vers le serveur
 
Le test se faisant à partir de machines du même réseau local (gérées par le routeur), je suis en train de me demander si le routeur n'interprète pas la commande "http://IP dynamique" comme étant une tentative d'administration et donc court-circuite le routage vers le serveur ...


---------------
All that is gold does not glitter, not all those who wander are lost ... I am Aragorn, and those verses go with that name.
n°1743978
com21
Modérateur
real men don't click
Posté le 03-10-2004 à 01:16:30  profilanswer
 

.....
 
vive la prise de tete pour des broutille.
 
quand tu est sur le reseau local, tu utilise l'adresse ip local.
Quand tu est sur une machine extérieur, tu utilise l'adresse ip net.
 
Tu ne peux PAS tester ton serveur local, depuis un poste de ton reseau local, en mettant l'adresse ip net.


---------------
Cherche geekette | Traquez vos billets d'€ | Don du sang | Don de moelle osseuse
n°1744079
[grandpas]
by some called Strider
Posté le 03-10-2004 à 09:45:38  profilanswer
 

com21 a écrit :

Tu ne peux PAS tester ton serveur local, depuis un poste de ton reseau local, en mettant l'adresse ip net.


sauf que j'ai récemment eu à tester une config. similaire et IP publique via machine locale ça marchait ... la seule nuance ... le routeur n'était pas un Prestige 660 (c'était un Zyxel mais je n'ai plus le modèle en tête)
 
Quoi qu'il en soit je ferais un test demain avec un poste isolé via RTC pour voir si change qqchose ... je croise les doigts ... si seulement tu pouvais avoir raison !!!


---------------
All that is gold does not glitter, not all those who wander are lost ... I am Aragorn, and those verses go with that name.
n°1744161
Profil sup​primé
Posté le 03-10-2004 à 10:52:26  answer
 

Tu peux tester ton serveur en passant par un proxy web public :D , mais ca devient lourd comme methode :)

n°1744205
com21
Modérateur
real men don't click
Posté le 03-10-2004 à 11:22:33  profilanswer
 

suffit d'avoir un ami ;)


---------------
Cherche geekette | Traquez vos billets d'€ | Don du sang | Don de moelle osseuse
n°1744425
[grandpas]
by some called Strider
Posté le 03-10-2004 à 14:07:53  profilanswer
 

franck75 a écrit :

Tu peux tester ton serveur en passant par un proxy web public :D , mais ca devient lourd comme methode :)


A une époque, je tenais une liste de proxies http et FTP ... mais ça fait un bail que je n'ai pas actualisé ... doit bien y'en avoir encore un ou deux qui tourne :-)
Ceci dit, j'ai suffisament de machines avec du RTC pour faire mon test ... mais je dois attendre d'être au boulot pour ça :-)


---------------
All that is gold does not glitter, not all those who wander are lost ... I am Aragorn, and those verses go with that name.

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software

  (RESOLU) Routeur: pb de NAT (redirection des ports)

 

Sujets relatifs
Routeur freeboxActiver la barre de lancement rapide par le registre [résolu]
echange de donnees par modem routeur speedtouch 750 .probleme de lecture power dvd en parti résolu
[resolu] Probleme icones inactives et les reaficher dans la barre!!Partage de connection wi-fi sur routeur USR8054
resolu => Look'n'stop, Partage connection internetjsuis perdu avec mon wifi et mon routeur...
un répertoire systeme de 18 Go ?? [résolu]comment configurer les ports sur routeur peabird switch 4port?
Plus de sujets relatifs à : (RESOLU) Routeur: pb de NAT (redirection des ports)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR