Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1072 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [EXCEL 2016] Ajouter une condition à plusieurs formules en meme temps

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[EXCEL 2016] Ajouter une condition à plusieurs formules en meme temps

n°3322869
Latiole
Posté le 22-10-2018 à 10:19:47  profilanswer
 

Bonjour,

 

j'ai un tableau avec environ 20 formules differentes. Le hic est que ce ne sont pas des formules que je peux reproduire en les copiant (differents facteurs les influencent).

 

En revanche, elles sont un point commun: si la cellule B6 contient 0, alors elles doivent rien afficher.

 

Je souhaiterai ajouter à toutes ces formules la condition =SI(B6=0;"";Formule existante) mais sans le faire individuellemt par cellule pour gagner du temps.

 

Y a t-il un moyen hors VBA de faire cela ?  :D

 

Merci :hello:


Message édité par Latiole le 22-10-2018 à 10:20:38
mood
Publicité
Posté le 22-10-2018 à 10:19:47  profilanswer
 

n°3322975
Benoit6363
Posté le 23-10-2018 à 09:31:13  profilanswer
 

Bonjour,
 
Tu peux le faire en utilisant la fonction REMPLACER (CTRL + H)
 
Imaginons qu'une des formules soit
 
=SOMME(B6;C6)
 
Tu remplaces = par SI(B6=0;"";
 
SI(B6=0;"";SOMME(B6;C6)
 
ensuite tu remplaces ) par ))
 
SI(B6=0;"";SOMME(B6;C6))
 
et enfin SI(B6=0 par =SI(B6=0
 
=SI(B6=0;"";SOMME(B6;C6))

n°3326544
Latiole
Posté le 25-10-2018 à 12:23:47  profilanswer
 

Merci, cela a fonctionné !


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [EXCEL 2016] Ajouter une condition à plusieurs formules en meme temps

 

Sujets relatifs
Comment ajouter des titres à des lignes dans un fichier M3U ?Automatisation sous Excel
tablette surface / lecture code barre dans ExcelAjouter une application portable dans le menu demarrer
[Win 7] Clic droit > Nouveau > Fichier Excelmots de passe Access sur plusieurs niveaux
Nouveau pc portable crash intempestif sur plusieurs jeuxConditions avec excel
Formile excel 
Plus de sujets relatifs à : [EXCEL 2016] Ajouter une condition à plusieurs formules en meme temps


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR