Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1005 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [VBS] Problème sur RUN

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[VBS] Problème sur RUN

n°1604679
nicotine33
Posté le 27-08-2007 à 17:54:58  profilanswer
 

Salut,
 
Voila je tombe sur un prb et je ne vois vraiment d'ou cela provient (config machine je penses mais j'en ai pas d'autre sous la main).
Mon code (en simplifié)
 

Code :
  1. Option Explicit
  2. dim oShell
  3. dim err
  4. set oShell =wscript.createobject("wscript.shell" )
  5. err=oShell.Run "ipconfig >C:\temp\toto.txt",0,true


 
J'obtiens un code erreur 800A0401 a la ligne 8 (fin d'instruction attendue) alors que je ne vois vraiment pas d'ou cela peut venir.
 
SVP, aider moi (je me suis pas mal pourris la dessus ...)
Merci

mood
Publicité
Posté le 27-08-2007 à 17:54:58  profilanswer
 

n°1608058
PaLoTTe
Posté le 04-09-2007 à 13:57:45  profilanswer
 

Slt !
 
Si tu veux faire passer le résultat de ta commande dans une variable comme c'est le cas, tu dois mettre des paranthèses après ton run :

err = oShell.Run ("ipconfig >C:\temp\toto.txt",0,true)

 
Sinon tu l'écris :
 
oShell.Run "ipconfig >C:\temp\toto.txt",0,true
 
++


Message édité par PaLoTTe le 04-09-2007 à 14:00:47

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [VBS] Problème sur RUN

 

Sujets relatifs
Probleme script d'ajout d'entrée dans une base mysqlProblème d'opération avec let
Probleme COOKIE site multi langue[RESOLU]Probleme Formula
[Résolu] Problème d'arborescence avec require_once( )Problème pour une mise en page sous forme de tableau
Problème avec swfObjectprobleme de structure
[SQL] Probleme avec ORDER BYProbleme de lien : ok en swf mais pas dans le navigateur
Plus de sujets relatifs à : [VBS] Problème sur RUN


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR