Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1691 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Probleme Formula

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme Formula

n°1603415
gyllou
Posté le 24-08-2007 à 10:43:53  profilanswer
 

Bjr a tous,
 
Voila mon ptit souci.
Dans une macro, apres effacement d'une zone, j'aimerais remettre en place les formules.
Pour cela, je pensais pouvoir passer la commande suivante :
Cells(Lig, Col).Formula = "=IF($T$5="S0200";A5*B5;C5*D5)"
 
or le probleme de " me bloque
 
Merci

mood
Publicité
Posté le 24-08-2007 à 10:43:53  profilanswer
 

n°1603436
jpcheck
Pioupiou
Posté le 24-08-2007 à 11:05:06  profilanswer
 

remplace " par """ ;)

n°1603448
gyllou
Posté le 24-08-2007 à 11:09:36  profilanswer
 

Super
 
j'avais tout essayé \", ...
Mais pas ca.  
 
Merci


Message édité par gyllou le 24-08-2007 à 11:11:16
n°1603491
kiki29
Posté le 24-08-2007 à 11:53:30  profilanswer
 

Et normalement même avec la réponse de jpcheck tu devrais avoir une erreur 1004 ?
Le séparateur de liste n'étant pas le bon


Message édité par kiki29 le 24-08-2007 à 11:54:12
n°1603753
gyllou
Posté le 24-08-2007 à 17:10:43  profilanswer
 

Comment faire alors ;-) ?

n°1603772
denis1979
Posté le 24-08-2007 à 17:46:33  profilanswer
 

puisque "S0200" contient déja une lettre, je crois que tu peux enlever les " carrément.
 
OU
 
mets le dans une variable type string ,et concatène les différentes parties :
sVar = "S0200"
Cells(Lig, Col).Formula = "=IF($T$5=" & sVar & ";A5*B5;C5*D5)"  
 
ca serait à tester.

n°1603777
kiki29
Posté le 24-08-2007 à 17:50:22  profilanswer
 

en US                Cells(lig, col).Formula = "=IF($T$5=""S0200"",A5*B5,C5*D5)"
en Langue Locale Cells(lig, col).FormulaLocal = "=SI($T$5=""S0200"";A5*B5;C5*D5)"


Message édité par kiki29 le 28-08-2007 à 09:08:53
n°1603803
gyllou
Posté le 24-08-2007 à 20:37:59  profilanswer
 

Avec Formulalocal; cela fonctionne Top.
 
Par contre quelqu'un aurait une idée pour mettre dans ma macro ce style de formule avec les accolades:  
{=((SUM(IF('A4'!$AH$5:$AH$1249="OK";'A4'!$D$10:$D$100;0)}


Message édité par gyllou le 24-08-2007 à 21:00:54
n°1604828
kiki29
Posté le 28-08-2007 à 09:02:30  profilanswer
 

Déjà tu continues avec la même erreur: séparateur de liste incorrect
pour une formulation US

Selection.FormulaArray = "=SUM(IF('A4'!$AH$5:$AH$1249=""OK"",'A4'!$D$10:$D$100,0))"


Message édité par kiki29 le 28-08-2007 à 09:03:07

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Probleme Formula

 

Sujets relatifs
[Résolu] Problème d'arborescence avec require_once( )Problème pour une mise en page sous forme de tableau
Problème avec swfObjectprobleme de structure
[SQL] Probleme avec ORDER BYProbleme de lien : ok en swf mais pas dans le navigateur
probleme avec creation de table sql mayadmin[RESOLU] Display None/Block
Problème de conditionInclude php et problème menu déroulant
Plus de sujets relatifs à : Probleme Formula


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR