Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1860 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  incrémentation auto vba excel en fonction de plusieurs cellules

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

incrémentation auto vba excel en fonction de plusieurs cellules

n°2318018
vbakho
Posté le 15-07-2018 à 20:53:04  profilanswer
 

Bonjour,
Je cherche a créer un code client sur excel qui se compose de: Num de ville et la prestation fournie et qui s’incrémente automatiquement  
j'ai 20 ville de (01a20) et 4 prestations (A,F,T,V)  
quand je change le num de ville ou la prestation je veux que mon code se remet a la valeur 001 et commence a compter
 
EX:01A001
   01A002
   01A003
 
 
   01V001
   01V002
   01V003
 
 
   02A001
   02A002
   02A003
 
 
   02V001
   02V002
   02V003
 
existe il une formule ou un code vba qui peut faie ça ???
Merci d'avance

mood
Publicité
Posté le 15-07-2018 à 20:53:04  profilanswer
 

n°2318086
Antac
..
Posté le 17-07-2018 à 19:08:01  profilanswer
 

En formule, tu peux faire ça si tu part du principe que la colonne A1 contient 01A par exemple :  
 
B1 : =SI(A1<>"";SI(ESTERREUR(RECHERCHEV(A1;$A$1:A1;1;FAUX));1;1);"" )
B2 et suivante (copie vers le bas) : =SI(A2<>"";SI(ESTERREUR(RECHERCHEV(A2;$A$1:A1;1;FAUX));1;B1+1);"" )


Message édité par Antac le 17-07-2018 à 19:08:49

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  incrémentation auto vba excel en fonction de plusieurs cellules

 

Sujets relatifs
Langage ExcelDéplacer plusieurs fichier en ajoutant la date
Suppression de ligne ExcelAffichage évènement de plusieurs jours sur un calendrier
[RESOLU] variable contenant plusieurs valeurs possiblesPB sur EXCEL
opimisation de la fonction soundexUtilisation d'une méthode de class en tant que fonction de callback
Excel 2016 - Inscription données saisie par formulaireComparer 4 colonnes entre 2 feuilles Excel
Plus de sujets relatifs à : incrémentation auto vba excel en fonction de plusieurs cellules


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR