Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
829 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Menu déroulant, Javascript & CSS, Fonctionne sur un max de nav.

 



 Mot :   Pseudo :  
 
 Page :   1  2  3
Page Précédente
Auteur Sujet :

Menu déroulant, Javascript & CSS, Fonctionne sur un max de nav.

n°502442
greut
Posté le 30-08-2003 à 16:23:59  profilanswer
 

Bonjour,
 
Bon premièrement je ne suis pas Greut. Greut c'est un pote qui m'a prêté son peusdo.
 
J'ai réalisé un menu déroulant et comme je vois que beaucoup de monde en demande ici je vous donne le lien sur le document.
 
http://www.magnin-sante.ch/journal/html/menu3/menu.htm
 
    * Navigation correcte avec IE 5 IE 5.5 et IE 6,
    * Navigation correcte avec Mozilla 1.5 et théoriquement sous tout navigateur Gecko,
    * Navigation correcte avec Opera 7 et Opera 6
    * Navigation correcte avec Safari,
    * Navigation correcte avec Konqueror 3.0.3,
    * Navigation passable avec MSIE 5.23
    * Ce menu ne fonctionne pas sous IE4 et NN4 ( faut pas croire au père noël ).
 
Menu sous Licence GPL.
 
http://www.magnin-sante.ch/journal/
 
Batiste Bieler :hello:  
Merci à tous :)


Message édité par greut le 02-09-2003 à 20:04:51
mood
Publicité
Posté le 30-08-2003 à 16:23:59  profilanswer
 

n°502462
Freekill
Electron libre…
Posté le 30-08-2003 à 16:47:59  profilanswer
 

C'est normal que je n'arrive pas à aller sur les sous-éléments ?
 
Dès que le curseur quitte l'élément principal, les sous-éléments se replient?


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502515
greut
Posté le 30-08-2003 à 17:48:10  profilanswer
 

:sweat:  
 
Avec quel navigateur ?
Sur quel OS ?
Tu peux me faire un screenshot ?

n°502516
Freekill
Electron libre…
Posté le 30-08-2003 à 17:50:19  profilanswer
 

IE 6 SP 1
Win2k
nan :D


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502519
greut
Posté le 30-08-2003 à 17:51:37  profilanswer
 

Je vais régler ça vite fait  :)

n°502523
greut
Posté le 30-08-2003 à 17:55:14  profilanswer
 

IE6
windows2000 sp2
 
www.chezmoicamarche.org  :??:

n°502541
greut
Posté le 30-08-2003 à 18:05:13  profilanswer
 

as tu testé les deux menus ?
 
tu pourrais me donner plus de détails ?


Message édité par greut le 30-08-2003 à 18:06:39
n°502547
Freekill
Electron libre…
Posté le 30-08-2003 à 18:09:31  profilanswer
 

greut a écrit :

as tu testé les deux menus ?
 
tu pourrais me donner plus de détails ?


 
Dès qu'on quite l'élément principal, le menu se replie


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502550
greut
Posté le 30-08-2003 à 18:12:31  profilanswer
 

:sweat:


Message édité par greut le 30-08-2003 à 18:14:31
n°502551
greut
Posté le 30-08-2003 à 18:13:56  profilanswer
 

:sweat:  
 
Et quand tu navigue dedans à coup de tab, que se passe-t-il ?
 
Pourrais tu me faire un screenshot ? j'en ai vraiment besoin.  
 
Tu me mets le menu horizontal avec un élément ouvert
 
Tu peux mailer : faden at altern dot org


Message édité par greut le 30-08-2003 à 18:15:52
mood
Publicité
Posté le 30-08-2003 à 18:13:56  profilanswer
 

n°502554
Freekill
Electron libre…
Posté le 30-08-2003 à 18:15:31  profilanswer
 

Pas besoin de screenshot? :heink:
 
Tu vas avec ta souris sur un élément, ça se déplie, tu bouge pour aller sur un sous-élément et avant que tu arrives dessus le bazar se replie?


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502556
greut
Posté le 30-08-2003 à 18:20:51  profilanswer
 

peux tu me donner la version exact de IE. Tout les ptits chiffre qui vont après, stp.
 
Pourtant ça marche chez moi et chez des amis aussi... Ca marche même avec la croute de Opera6 ... Je suis perplexe.
 
Ya aussi un IE mac assez spécifique sur lequel ça foire...


Message édité par greut le 30-08-2003 à 18:23:39
n°502563
Freekill
Electron libre…
Posté le 30-08-2003 à 18:29:51  profilanswer
 

6.0.2800.1106


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502565
greut
Posté le 30-08-2003 à 18:33:07  profilanswer
 

Quel idée bizzare de naviguer avec IE  ;)

n°502567
Freekill
Electron libre…
Posté le 30-08-2003 à 18:33:52  profilanswer
 

greut a écrit :

Quel idée bizzare de naviguer avec IE  ;)


 
Je pourrais te dire la même chose des autres navigateurs?  :sarcastic:  (et je les ai tous essayés)


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502574
greut
Posté le 30-08-2003 à 18:38:00  profilanswer
 

Freekill a écrit :


 
Je pourrais te dire la même chose des autres navigateurs?  :sarcastic:  (et je les ai tous essayés)


 
Ha bon ? Ouais j'aimerais bien que tu m'explique pourquoi tu pourrais dire la même chose. Moi je vais te dire pourquoi je ne navigue pas avec IE : c'est le plus mauvais navigateur d'entre tous.
 
bon en resumé ça donne ceçi  
 
6.0.2800.1106 -->bug
6.0.2600.0000 -->oki
 
J'ai besoin de plus de testeurs, viendez nombreux !


Message édité par greut le 30-08-2003 à 18:40:56
n°502576
Freekill
Electron libre…
Posté le 30-08-2003 à 18:40:17  profilanswer
 

greut a écrit :


 
Ha bon ? Ouais j'aimerais bien que tu m'explique pourquoi tu pourrais dire la même chose.
 
bon en resumé ça donne ceçi  
 
6.0.2800.1106 -->bug
6.0.2600.0000 -->oki


 
Opera : payant, foire sur plein de sites
Mozilla : trop lent à se lancer (même Firebird), j'aime pas le "feeling"


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502578
greut
Posté le 30-08-2003 à 18:44:15  profilanswer
 

Freekill a écrit :


 
Opera : payant, foire sur plein de sites
Mozilla : trop lent à se lancer (même Firebird), j'aime pas le "feeling"


 
Opera n'est pas forcement payant, y a juste une bannière  de pub. L'argument pour Mozilla me fait vraiment marrer... À moins que tu ait vraiment un toute vieille config cet argument vaut rien. Une fois que Moz est en mémoire il est très vite relancé, aussi vite que ton préééccieuuxx IE ... Compare donc ce qui est comparable.
 
Et les autres ? Tu les a pas tous essayés ?


Message édité par greut le 30-08-2003 à 18:45:24
n°502579
Freekill
Electron libre…
Posté le 30-08-2003 à 18:46:01  profilanswer
 

greut a écrit :


 
Opera n'est pas forcement payant, y a juste une bannière  de pub. L'argument pour Mozilla me fait vraiment marrer... À moins que tu ait vraiment un toute vieille config cet argument vaut rien. Une fois que Moz est en mémoire il est très vite relancé, aussi vite que ton préééccieuuxx IE ... Compare donc ce qui est comparable.
 
Et les autres ? Tu les a pas tous essayés ?


 
Les autres ? Des vieux brols ?  :D


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502584
greut
Posté le 30-08-2003 à 18:49:48  profilanswer
 

Freekill a écrit :


 
Les autres ? Des vieux brols ?  :D  


 
C'est quoi un Brols ?
 
pour les nav's oui il y en a plein d'autre  
 
http://openweb.eu.org/articles/nav [...] ternatifs/
 
Dans la rubrique "saine lecture" il y a aussi ceci  
 
http://oumph.free.fr/textes/penibles_du_net.html

n°502590
greut
Posté le 30-08-2003 à 18:54:56  profilanswer
 

j'aime pas le "feeling" = j'aime pas le changement
 
Quand on voit toute les choses géniales qu'il y a dans firebird on se demande encore pourquoi les gens qui le connaisse ne l'utilise pas.
 
http://frenchmozilla.sourceforge.n [...] /pourquoi/

n°502596
Freekill
Electron libre…
Posté le 30-08-2003 à 19:01:02  profilanswer
 

Sous win32 y'en a pas tant que ça?
 
Quand à firebird je me suis forcé à l'utiliser une ou deux semaines, mais je suis revenu à IE?  [:spamafote]  
 
PS : brol = stuut quoi :D


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502622
greut
Posté le 30-08-2003 à 19:16:35  profilanswer
 

"Quand à firebird je me suis forcé à l'utiliser une ou deux semaines, mais je suis revenu à IE"
 
Bha c'est pas grave  :) , c'est déjà bien de savoir que ça existe. Faut pas se forcer non plus, faut avoir envie. Firebird moi je le trouve vachement sexy ( même si c'est pas lui que j'utilise ).
 
Mais comment fait-tu sans la navigation par tab  :pt1cable:  ? c'est impossible de vivre sans  :??:  et puis tu a pas peur des virus ? Avec ce qui traine dans IE je me sentirais pas en securité.
 
Bon alors ou sont les autres testeurs  :wahoo:  ?

n°502630
Freekill
Electron libre…
Posté le 30-08-2003 à 19:19:48  profilanswer
 

J'aime pas trop les tabs en fait, je préfère avoir un barre des tâches super encombrée? [:ddr555]
 
Sinon pour les virus je n'ai jamais eu le moindre problème? (F-Secure qui tourne aussi)


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502661
greut
Posté le 30-08-2003 à 19:44:56  profilanswer
 

Je crois que les anti-virus ne peuvent pas faire grand chose contre les failles de IE. A cet heure il y a 22 failles de securité non patchées.
 
http://www.pivx.com/larholm/unpatched/

n°502680
Freekill
Electron libre…
Posté le 30-08-2003 à 19:53:38  profilanswer
 

greut a écrit :

Je crois que les anti-virus ne peuvent pas faire grand chose contre les failles de IE. A cet heure il y a 22 failles de securité non patchées.
 
http://www.pivx.com/larholm/unpatched/


 
Ah ouais, quand même? :/


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502772
Freekill
Electron libre…
Posté le 30-08-2003 à 21:17:20  profilanswer
 

Sinon ça fonctionne sans les images...


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502783
greut
Posté le 30-08-2003 à 21:25:06  profilanswer
 

Sans les images ?
 
Super, comment explique tu le bug ? Que dois-je faire pour y remédier ?
 
Merci FreeKill  :love:  
 :hello:

n°502785
samuelp
Posté le 30-08-2003 à 21:25:21  profilanswer
 

Je pourrais l'utiliser dans la version 0.1x d'un de mes projets GPL ?
[:thotho]

n°502788
greut
Posté le 30-08-2003 à 21:27:25  profilanswer
 

Bien sûre :) ça me ferait plaisir !
 
Mais si ça bug avec IE6 (~60% des ordinateurs ) ... c'est pas très utilisable...
 
Il me faut plus de tests ... moi je peux rien faire j'ai pas la bête sous la main.


Message édité par greut le 30-08-2003 à 21:28:51
n°502792
samuelp
Posté le 30-08-2003 à 21:30:09  profilanswer
 

greut a écrit :

Bien sûre :) ça me ferait plaisir !
 
Mais si ça bug avec IE6 (~60% des ordinateurs ) ... c'est pas très utilisable...
 
Il me faut plus de tests ... moi je peux rien faire j'ai pas la bête sous la main.


C'est une application Intranet livrée avec Mozilla :)  
Donc pas de pb.
Je vais garder ton site en référence, et je noterai dans les mes archives la provenance de ce menu (que je modifierai quelque peu car ce Menu sera généré en PHP)
 

n°502798
Flyman30
Posté le 30-08-2003 à 21:36:24  profilanswer
 

greut a écrit :


 
Ha bon ? Ouais j'aimerais bien que tu m'explique pourquoi tu pourrais dire la même chose. Moi je vais te dire pourquoi je ne navigue pas avec IE : c'est le plus mauvais navigateur d'entre tous.
 
bon en resumé ça donne ceçi  
 
6.0.2800.1106 -->bug
6.0.2600.0000 -->oki
 
J'ai besoin de plus de testeurs, viendez nombreux !


 
IE 6.0.2800.1106 avec windows 2000 sp4 ça fonctionne  :bounce:  
 
Quand on navigue dans les menus aussi bien vertical qu'horizontal il y a un temps mort désagréable ou les images n'apparaissent pas tout de suite  :sweat:

n°502808
Freekill
Electron libre…
Posté le 30-08-2003 à 21:40:28  profilanswer
 

flyman30 a écrit :


 
IE 6.0.2800.1106 avec windows 2000 sp4 ça fonctionne  :bounce:  
 
Quand on navigue dans les menus aussi bien vertical qu'horizontal il y a un temps mort désagréable ou les images n'apparaissent pas tout de suite  :sweat:  


 
Tu arrives à aller sur l'élément 2 du menu 1 dans le menu vertical ?  :heink: (par exemple)


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502812
greut
Posté le 30-08-2003 à 21:41:37  profilanswer
 

flyman30 a écrit :


 
IE 6.0.2800.1106 avec windows 2000 sp4 ça fonctionne  :bounce:  
 
Quand on navigue dans les menus aussi bien vertical qu'horizontal il y a un temps mort désagréable ou les images n'apparaissent pas tout de suite  :sweat:  


 
Ha ... mais d'ou viens donc le problème ... Killer pourrais-tu tester en supprimant le a:hover dans le fichier CSS ?
 
Pour le temps mort, c'est du au fait que IE télécharge à chaque fois l'image, mais je crois pouvoir régler ça.


Message édité par greut le 30-08-2003 à 21:46:00
n°502825
Freekill
Electron libre…
Posté le 30-08-2003 à 21:46:55  profilanswer
 

Mon pseudo c'est pas "killer"  :fou:  
 
Sinon ça change rien?


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502839
greut
Posté le 30-08-2003 à 21:52:50  profilanswer
 

Excuse moi FreeKil  :sweat:  
 
Et tu dit que sans les images ça marche ?
 
tu a  fait quoi au juste ? Juste supprimer les images ou enlever les styles CSS ?


Message édité par greut le 30-08-2003 à 21:53:50
n°502848
Freekill
Electron libre…
Posté le 30-08-2003 à 21:57:48  profilanswer
 

supprimer les images


---------------
Faux & usage de faux ¤ Machins roses ¤ ASCIImage ¤ HFR Enhance v0.8.6
n°502855
greut
Posté le 30-08-2003 à 21:59:37  profilanswer
 

"que je modifierai quelque peu car ce Menu sera généré en PHP"
 
Oui ben si jamais c'est juste une liste de lien... devrais pas avoir grand chose à modifier. Normalement tu devrais pouvoir t'en sortir juste en modifiant le fichier CSS.
 
Tien moi au courant si tu y apporte des améliorations
 
faden at altern.org

n°502858
greut
Posté le 30-08-2003 à 22:01:07  profilanswer
 

Freekill a écrit :

supprimer les images


 
Oki pourrais tu essayer maintenant enlevant les background images dans le fichier CSS ?
 
En essayant différentres syntaxes comme celle-ci :
 
background: url("mon_image" ) no-repeat;
 
Je t'en serais infiniment reconnaissant  :jap:


Message édité par greut le 30-08-2003 à 22:11:48
n°502882
antp
Super Administrateur
Champion des excuses bidons
Posté le 30-08-2003 à 22:09:00  profilanswer
 
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Menu déroulant, Javascript & CSS, Fonctionne sur un max de nav.

 

Sujets relatifs
Pb menu dynamique JS[javascript] soumission de formulaire & php
Infobulle javascript[CSS] Mettre en forme du code
[php] Upload d'une image qui fonctionne, mais Image tronquée!Positionnement avec CSS: Problème
Style Swticher creer 2 présentation differente CSS sur une page HTML[JS] Menus Déroulants Javascript à plusieurs niveaux
[CSS] probleme de couleurs resoluErreur ds formulaire de recherche javascript
Plus de sujets relatifs à : Menu déroulant, Javascript & CSS, Fonctionne sur un max de nav.


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR