Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1430 connectés 

  FORUM HardWare.fr
  Programmation
  Flash/ActionScript

  login/password en flash / php

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

login/password en flash / php

n°1937391
BBFUNK01
quand on veut on peut...
Posté le 03-11-2009 à 20:04:32  profilanswer
 

Bonjour à tous, je me tourne vers car vous êtes beaucoup plus expérimentés que moi et j'espère que vous pourrez m'aider à comprendre où mon code n'est pas bon.
Voilà : je veux faire un système d'identification login/password en flash + php. Le but c'est que chaque couple login/password, une fois entré, soit envoyé à une page php qui vérifie si le login et le password sont exacts, et permette la redirection vers une page privée différente pour chaque utilisateur disposant d'identifiants (attribués par moi au préalable). Seulement, c'est que je n'arrive même pas à obtenir un ok lorsque je teste avec des identifiants (je n'ai pas encore attaqué la partie du code "redirection" vu que je n'ai pas encore réussi la partie "identification" ).
Voici donc mon code actionscript2 dans flash :
 
- sur le calque de saisie des textes login et password :
 
txt_login = ""
txt_password = ""
 
- sur le calque du bouton :
 
on (release) {
// On teste si les champs sont remplis
if ((txt_login = "" ) && (txt_password = "" )) {
// Envoi simplement des données à la page flash.php
loadVariablesNum ("flash.php", 0, "POST" );
} else {
messErreur = "IDENTIFIANTS INCORRECTS !";  
}
}
 
- et voici mon script php :
 
<?php
$login = $_POST["login"];
$password = $_POST["password"];
 
$goodlogin == "bob";
$goodpassword == "toto";
 
if ($login == $goodlogin == "bob" && $password == $goodpassword == "toto" ) {
echo "ok";  
} else {
echo "refused";
}
 
if ($login == $goodLogin == "jo" && $password == $goodPassword == "titi" ) {
echo "ok";  
} else {
echo "refused";
}
?>
 
Lorsque je teste l'appli., le résultat est le retour en erreur de l'identification et donc l'affichage du message : "IDENTIFIANTS INCORRECTS !"
Je présume que c'est mon script php qui n'est pas correct mais de là à savoir pourquoi et où cela coince...
Merci infiniment d'avance si vous avez la gentillesse de m'aider.
 
BBFUNK01

mood
Publicité
Posté le 03-11-2009 à 20:04:32  profilanswer
 

n°1938181
abais
Posté le 05-11-2009 à 23:42:33  profilanswer
 

D'après ton code, tu exécutes le loadVariablesNum() QUE si les champs sont vides... c'est déjà bizarre non ?


---------------
Le membre ci-contre n'est pas responsable du message ci-dessus.

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Flash/ActionScript

  login/password en flash / php

 

Sujets relatifs
Problème lecture vidéo flash FirefoxChanger dynamiquement le wmode des flash
[SQL Server 2008] Messages d'erreurs loginFlash & 3D
Iphone et flash enfin une realitéFlash ASRécupérer position souris quand elle sort trop vite du cadre ?
utiliser une variable d'un combobox FlashFlash/Flex/ActionScript, petite explication
[resolu] IE6 object flash et <!--[ if IE]> 
Plus de sujets relatifs à : login/password en flash / php


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR