Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
933 connectés 

  FORUM HardWare.fr
  Programmation
  Divers

   Probleme avec CVS et Savannah : qqn peut m'aider ?

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme avec CVS et Savannah : qqn peut m'aider ?

n°515896
samuelp
Posté le 16-09-2003 à 17:59:16  profilanswer
 

J'aimerai mettre dans mon CVS de savannah les fichiers de mon projet.
 
Pour ce faire j'ai lu quelque peu la donc de savannah et de http://ftp.cvshome.org/release/sta [...] 1.11.6.pdf
 
Helas cela ne fonctionne pas.
 
Je me connecte en tant que administrateur du projet :
export CVSROOT=samuelp@subversions.gnu.org:/cvsroot
export CVS_RSH=ssh
cvs -z3 -d samuelp@subversions.gnu.org:/cvsroot/worm co worm
 
pour l'instant tout va bien, j'ai mon projet qui est mis a jour
 
Me trouvant chez moi à la racine de mon projet je fais un :
cvs add *
Et j'obtient le message d'erreur :
 
Cannot access /worm/CVSROOT
No such file or directory
 
 
Bizard non ?
Je regarde le CVS de mon projet :
http://savannah.nongnu.org/cgi-bin/viewcvs/worm/
 
J'ai bien en regardant l'URL CVSROOT qui se trouve dans le repertoire worm a partir de ma connexion
 
Un specialiste de savannah ou CVS pourrait m'aider ?

mood
Publicité
Posté le 16-09-2003 à 17:59:16  profilanswer
 

n°516273
samuelp
Posté le 17-09-2003 à 09:02:57  profilanswer
 

:bounce:

n°516333
Kristoph
Posté le 17-09-2003 à 10:22:35  profilanswer
 

Faut toujours commencer par un "cvs import" pour ajouter les premiers fichiers sur une base CVS. C'est utilisé pour créer le module CVS et après "cvs add" sert à ajouter des fichiers dans un module existant.

n°516591
samuelp
Posté le 17-09-2003 à 15:46:11  profilanswer
 

Kristoph a écrit :

Faut toujours commencer par un "cvs import" pour ajouter les premiers fichiers sur une base CVS. C'est utilisé pour créer le module CVS et après "cvs add" sert à ajouter des fichiers dans un module existant.


J'ai essayé  
cvs import -m "Imported Source" worm WORM START
 
Et cela me fait le meme message d'erreur :/
Une idee ?

n°516599
Kristoph
Posté le 17-09-2003 à 15:54:01  profilanswer
 

Je pense qu'il y a un / de trop dans ta commande cvs import/add . La tu essaye d'accéder à un répertoire worm situé à la racine.
 
PS : desactive les smileys la prochaine fois.
 
Edit : li le manuel de Savannah la prochaine fois, le CVSROOT à utiliser c'est ça : "cvs -z3 -duser@subversions.gnu.org: /cvsroot/project co project"


Message édité par Kristoph le 17-09-2003 à 15:55:23
n°516694
samuelp
Posté le 17-09-2003 à 17:55:50  profilanswer
 

Kristoph a écrit :

Je pense qu'il y a un / de trop dans ta commande cvs import/add . La tu essaye d'accéder à un répertoire worm situé à la racine.
 
PS : desactive les smileys la prochaine fois.
 
Edit : li le manuel de Savannah la prochaine fois, le CVSROOT à utiliser c'est ça : "cvs -z3 -duser@subversions.gnu.org: /cvsroot/project co project"


 
J'ai bien lu la doc Savannah mais il y a un truc que je comprend pas :
-> Je peux y acceder bien sur et quand je met ta commande ça fonctionne.
 
Par contre quand je lance une commande CVS il m'envoie paitre :/
 
Y a un truc que je capt e pas là

n°516707
Kristoph
Posté le 17-09-2003 à 18:18:41  profilanswer
 

Je pense qu'il faut que tu te trouves un bon tutorial cvs. C'est pas très simple à expliquer mais je vais essayer quand même.
 
Comment fait cvs pour retrouver le serveur :
 
- Il utilise le fichier CVS/Root si celui-ci existe. En général, une fois le "cvs checkout" fait, c'est comme ça que ça fonctionne
- Il utilise le flag -d sur la ligne de commande
- Il utilise la variable CVSROOT


Message édité par Kristoph le 17-09-2003 à 18:19:01
n°516750
samuelp
Posté le 17-09-2003 à 20:48:58  profilanswer
 

Kristoph a écrit :

Je pense qu'il faut que tu te trouves un bon tutorial cvs. C'est pas très simple à expliquer mais je vais essayer quand même.
 
Comment fait cvs pour retrouver le serveur :
 
- Il utilise le fichier CVS/Root si celui-ci existe. En général, une fois le "cvs checkout" fait, c'est comme ça que ça fonctionne
- Il utilise le flag -d sur la ligne de commande
- Il utilise la variable CVSROOT
 


 
J'en conclu que mon CVSROOT (variable d'environnement) est erroné.
Parce que quand j'essaye n'importe quelle commande CVS il me fait un :
cannot access worm/CVSROOT
 
Je veux bien comprendre que les utilisateurs de savannah ne doivent pas etre des tanches mais ils auraient pu mettre dans leur FAQ la valeur de la variable CVSROOT a affecter. Ce n'est quand meme pas à l'utilisateur de le deviner...

n°516762
Kristoph
Posté le 17-09-2003 à 21:33:19  profilanswer
 

samuelp a écrit :


 
J'en conclu que mon CVSROOT (variable d'environnement) est erroné.
Parce que quand j'essaye n'importe quelle commande CVS il me fait un :
cannot access worm/CVSROOT
 
Je veux bien comprendre que les utilisateurs de savannah ne doivent pas etre des tanches mais ils auraient pu mettre dans leur FAQ la valeur de la variable CVSROOT a affecter. Ce n'est quand meme pas à l'utilisateur de le deviner...


 
En fait, tu n'as pas vraiment besoin d'affecter une valeur a CVSROOT. Moi je ne l'utilises jamais. En effet, une fois que tu as fait un "cvs checkout", les commandes cvs marchent toutes seules si tu es dans un répertoire créé par cvs.
 
Le CVSROOT ne sert que quand tu veux faire un checkout ou un import, et à ce moment là, autant le remplacer par -d

n°516887
samuelp
Posté le 18-09-2003 à 09:13:58  profilanswer
 

merci pour cette info, je vais essayer ;)

mood
Publicité
Posté le 18-09-2003 à 09:13:58  profilanswer
 

n°518252
samuelp
Posté le 19-09-2003 à 15:07:24  profilanswer
 

Ptain ça commence à m'enerver Savannah :fou:


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Divers

   Probleme avec CVS et Savannah : qqn peut m'aider ?

 

Sujets relatifs
[C/C++] probleme de dependance de librairieKylix 3 Open C++ : Problème de compilation, voilà le log
Kylix C++ Builder : problème avec time.h !probleme de liste deroulante
[Java] Problème de classpath avec un fichier Jar[Delphi] Problème de transparence d'images
Probleme avec le russephpBB2 : problème de frame
[HTML] Problème de bordure avec une image...Problème de marge
Plus de sujets relatifs à : Probleme avec CVS et Savannah : qqn peut m'aider ?


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR