Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
829 connectés 

  FORUM HardWare.fr
  Programmation
  Divers

  [EXCEL] utiliser SI avec ET et OU

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[EXCEL] utiliser SI avec ET et OU

n°1979161
bigbru
Posté le 30-03-2010 à 19:23:27  profilanswer
 

Bonjour,
 
Je suis actuellement en train de travailler sur EXCEL pour mon boulot et j'aimerai crée une fonction multipliant une valeur en fonction de critères.
 
 
3 colonnes nous intéressent :
-Objectif du congé
-Nombre de jour de congés demandés
-Nombre de jours de congés accordés
 
 
La première colonne est en format "TEXTE" pouvant être "CFA", "Formation" et "Autres"
La seconde colonne est une colonne numéraire (nombre allant de 1 à 1000)  
La 3ème colonne est celle de la formule.
Nous les nommerons donc les colonnes A, B et C.
 
 
 
Donc la formule souhaitée :
 
Si B>130 alors +10%
Si A="CFA" alors +20% seulement si B>65
Si A="Formation" alors +50% seulement si B>10
 
 
 
En sachant que c'est soit "CFA" ou "FORMATION" et que ceux-ci peuvent se cumuler avec le +10% de B.
 
Les pourcentages ont pour base B, pas exemple dans le cas où B=200 et A="CFA" nous auront donc 200x1.1x1.2.
 
J'ai pour le moment seulement la formule pour B>130 mais je n'arrive pas à y insérer les cas de figure pour "CFA" et "Formation".
 
la voici : "=SI(L32>=130,02;L32*1,1;L32)"
 
Je sais c'est peu mais ça fait longtemps que je n'ai plus touchés à EXCEL.
 
 
Donc si des masochistes d'EXCEL voient ce post, pourriez vous m'aider à finir cette formule ?
 
Merci d'avance à ceux qui se pencherons sur ce problème,
 
Bonne soirée
 

mood
Publicité
Posté le 30-03-2010 à 19:23:27  profilanswer
 

n°1980010
dje69r
Arme de distraction massive
Posté le 01-04-2010 à 14:51:45  profilanswer
 

Hello
 
Pour les formules "complexes", le mieux c'est, dans un premier temps, de décomposer ton calcul.
 

  • Si A="CFA" alors +20% seulement si B>65  

SI(ET(A2="CFA";B2>65);1,2;   (Le sinon sera la suite)
 

  • Sinon


  • Si A="Formation" alors +50% seulement si B>10

SI(ET(A2="Formation";B2>10);1,5;
 

  • Sinon

On met 1, la multiplication par 1 ne fera donc pas d'augmentation
SI(ET(A2="CFA";B2>65);1,2;SI(ET(A2="Formation";B2>10);1,5;1))
 

  • Le tout multiplié par : Si B>130 alors +10% sinon 1

*SI(B2>130;1,1;1)
 

  • Formule globale pour avoir le pourcentage d'augmentation

=SI(ET(A2="CFA";B2>65);1,2;SI(ET(A2="Formation";B2>10);1,5;1))*SI(B2>130;1,1;1)
 

  • Donc

=B2*SI(ET(A2="CFA";B2>65);1,2;SI(ET(A2="Formation";B2>10);1,5;1))*SI(B2>130;1,1;1)
 
Cordialement
 
Et non je ne suis pas un maso d'excel !  :kaola:


Message édité par dje69r le 01-04-2010 à 14:53:05

---------------
Plus tu pédales moins vite, moins tu avances plus vite — SuperLoustic ! La radio des Loustics !

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Divers

  [EXCEL] utiliser SI avec ET et OU

 

Sujets relatifs
Utiliser des fonctions C# pour Excelvba excel : utiliser la proprièté name d'une cellule
[EXCEL] utiliser fonction excel dans VBAC# créer DLL et l'utiliser sous Excel
Utiliser des CheckBox sur une feuille excelVBA Excel : utiliser une Locale spécifique dans une macro
Excel, quelle fonction/macro utiliser ?Faire un programme en C ou C++ et l'utiliser sous excel ou Ooo
Utiliser Excel avec VB sur poste sans ExcelUtiliser un autre compte mail que celui par défaut avec VBA sous Excel
Plus de sujets relatifs à : [EXCEL] utiliser SI avec ET et OU


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR