Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
2097 connectés 

  FORUM HardWare.fr
  Programmation
  ASP

  Help ! pige pas... [résolu]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Help ! pige pas... [résolu]

n°530483
DJERO
Yoooup...merde ça marche pas..
Posté le 03-10-2003 à 17:29:33  profilanswer
 

Salut à tous,
 
Bon voila mon pb j'ai une variable "recup_action" qui détermine le type de requete SQL je dois executer.
Voici Mon code:
 

Code :
  1. if recup_action="" then
  2. SQLDESACPROD="UPDATE produits SET ACTION='SUPPR', Actif_prod=false WHERE id_prod= "&numprod&" "
  3. SQLATT="INSERT INTO Intervention (id_prod_inter,titre_prod_inter,client_inter,action_inter) VALUES ("&numprod&",'"&Titre_prod&"','"&USER&"','SUPPR')"
  4. elseif recup_action="AJOUT" then
  5. SQLDESACPROD="DELETE * FROM produits WHERE  id_prod= "&numprod&" "
  6. SQLATT="DELETE * FROM Intervention WHERE  id_prod_inter= "&numprod&" "
  7. elseif recup_action="MODIF" then
  8. SQLDESACPROD="UPDATE produits SET ACTION='SUPPR', Actif_prod=false WHERE id_prod= "&numprod&" "
  9. SQLATT="UPDATE Intervention SET action_inter='SUPPR' WHERE id_prod_inter= "&numprod&" "
  10. end if
  11. connAbo.Execute(SQLDESACPROD)
  12. Conn.Execute(SQLATT)


 
Bon,  
si ma variable recup_action="MODIF" : aucun pb
si ma variable recup_action="AJOUT" : aucun pb
mais
si ma variable recup_action="" : GROS PB
 
Voila ce que me retourne le navigateur:

Code :
  1. Type d'erreur :
  2. Microsoft OLE DB Provider for ODBC Drivers (0x80040E0C)
  3. Aucun texte de commande n'a été défini pour l'objet de commande.


 
Je n'ai jamais eu ce type de problème avant.
Quelqu'un aurait-il une ID ??
 
Merci à vous ;)


Message édité par DJERO le 03-10-2003 à 18:46:22
mood
Publicité
Posté le 03-10-2003 à 17:29:33  profilanswer
 

n°530506
DJERO
Yoooup...merde ça marche pas..
Posté le 03-10-2003 à 18:19:55  profilanswer
 

Ah oui, j'oubliais, c'est en base Access et la connection s'effectue en DNS-LESS:
 
Set conn = Server.CreateObject("ADODB.Connection" )
connstring="DRIVER={Microsoft Access Driver (*.mdb)}; " & "DBQ=" & Server.Mappath("../database/validation.mdb" )  
conn.Open connstring  
 
Set connAbo = Server.CreateObject("ADODB.Connection" )
connstringAbo="DRIVER={Microsoft Access Driver (*.mdb)}; " & "DBQ=" & Server.Mappath("../database/"&bdd&"" )  
connAbo.Open connstringAbo

n°530524
DJERO
Yoooup...merde ça marche pas..
Posté le 03-10-2003 à 18:44:40  profilanswer
 

Bon, j'ai trouvé la soluce,
en fait, j'avais pb sur ma variable recup_action. Pour je ne sais quelle raison elle n'est jamais vide (???) mais bon, j'ai juste déclaré mes variables:

Code :
  1. SQLDESACPROD="UPDATE produits SET ACTION='SUPPR', Actif_prod=false WHERE id_prod= "&numprod&" "
  2. SQLATT="INSERT INTO Intervention (id_prod_inter,titre_prod_inter,client_inter,action_inter) VALUES ("&numprod&",'"&Titre_prod&"','"&USER&"','SUPPR')"


par defaut et j'entame le test de la variable recup_action apres et seulement sur AJOUT et modif.
 
Voili.


Message édité par DJERO le 03-10-2003 à 18:45:33

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  ASP

  Help ! pige pas... [résolu]

 

Sujets relatifs
[resolu] syntaxe en couleurPassage de variable ne marche plus ?? HELP
[cookie]helpOutil de programmation.... Help!!
Help pour une macro Excel[Help] Pb PHP exec( ) et java
[debutant][Resolu]Passer la page suivante ?[Algo] Rollercoaster part II [presque resolu le prob voir en bas]
[debutant][Resolu] Attraper les Erreurs SQL[RESOLU] euh pkoi ca marche pas cette image??
Plus de sujets relatifs à : Help ! pige pas... [résolu]


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR