Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
717 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Ubuntu serveur et disque réseau

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Ubuntu serveur et disque réseau

n°1261022
zered
Posté le 16-01-2011 à 10:43:29  profilanswer
 

Bonjour,
 
maintenant que j'ai de nouveau accès à mon serveur je peux continuer sa configuration...
 
Je dispose d'un disque réseau MyBook accessible par mes machines sous Vista, Seven et Ubuntu.
 
J'aimerais que mon serveur (Ubuntu Server) puisse y accéder aussi. J'ai recopier mes fichiers auto.master et auto.nfs dessus mais ça ne monte rien. Sous linux je dois utiliser des signets pour initier le montage mais comment faire avec un serveur ?
 
Merci d'avance.
 
PS : j'ai un accès en ssh et via webmin.


Message édité par zered le 24-06-2012 à 11:37:16
mood
Publicité
Posté le 16-01-2011 à 10:43:29  profilanswer
 

n°1261025
bardiel
Debian powa !
Posté le 16-01-2011 à 10:58:53  profilanswer
 

Bêtement je dirais de faire un montage avec mount ou dans le fstab :/
 
Par exemple dans le fstab tu peux mettre :

Code :
  1. 192.168.1.4:/PARTAGE /media/nas nfs defaults 0 0


(suivi d'un mount -a ou d'un redémarrage de la machine)
Pour monter un partage en NFS d'un nas situé à l'adresse 192.168.1.4, ayant un dossier PARTAGE, au point de montage (que tu as crée) /media/nas
 
Tu peux faire la même chose en SMBFS ou CIFS suivant ce qui est disponible (le NFS étant le plus adapté à du monde Linux). Tu peux lire ceci pour t'aider.


Message édité par bardiel le 16-01-2011 à 10:59:28

---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°1261026
zered
Posté le 16-01-2011 à 11:01:29  profilanswer
 

Merci pour votre réponse rapide.
 
J'avais utilisé fstab au début et je trouvais la vitesse de transfert assez lente (même sous NFS d'ailleurs...) mais je crains surtout qu'il soit en activité en permanence. Je me trompe ?
 
Je vais lire votre lien.
 
Merci.

n°1261034
bardiel
Debian powa !
Posté le 16-01-2011 à 12:20:56  profilanswer
 

Quand je regarde les logs du NAS (un netgear) à mon boulot, le serveur ne se connecte que quand il a besoin :/
Pour la vitesse de transfert, qu'appelez vous "lent" ?

 

Ensuite pour les accès disques, apparemment en modifiant le MyBook on peut éviter d'avoir trop d'accès, mais je ne connais pas suffisamment le produit pour vous dire si la manip est efficace ou pas.


Message édité par bardiel le 16-01-2011 à 12:22:17

---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°1261042
zered
Posté le 16-01-2011 à 15:08:34  profilanswer
 

Ben je vais donc tester un montage avec fstab.
 
Je vous tiens au courant.
 
Merci de vos conseils.
 
PS : mes accès sont extrêmement rapide avec windows et ils tombent très vite sous linux (quelques ko/s voire quelques o/s !!!).

n°1314841
zered
Posté le 24-06-2012 à 10:44:55  profilanswer
 

Bonjour,
 
j'avais promis de vous tenir au courant... (vieux motard que jamais disait l'autre...).
 
Bref, j'ai toujours ce problème de vitesse. Afin de donner le plus d'informations aux spécialistes du forum voici ma configuration :
 
Ubuntu voyager 12.04 en 64 bits
Installation propre (formatage de TOUT le disque, home compris)
Ligne dans fstab (c'est la même configuration pour tous les répertoires du NAS):
 
//192.168.x.xx/download      /media/MyBook/download cifs rw,uid=1000,credentials=/root/.smbcredentials 0 0
 
Je pense que le soucis vient des options sur la ligne de fstab. Ou alors je fais trop de montages (7 répertoires sur ce NAS).
 
Merci de votre intérêt pour ce "problème".
 
@ +


Message édité par zered le 24-06-2012 à 10:45:35

---------------
Nous sommes des morts en sursis...
n°1315040
roscocoltr​an
L'enfer c'est les utilisateurs
Posté le 27-06-2012 à 01:29:30  profilanswer
 

vérifie ton câble
 
vérifie ton fichier smb.conf, spécialement les options telles que TCP_NODELAY
vérifie aussi la résolution des noms netbios


---------------
"Your god is too small", Giordano Bruno, 1548 - 1600
n°1315242
zered
Posté le 29-06-2012 à 18:33:36  profilanswer
 

Bonsoir,
merci pour ces conseils. Cependant je ne suis pas un technicien et même si je comprends de quoi on parle je ne sais pas ce que je dois vérifier ? Que devrais je trouver ?
En attendant je vous mettrais en ligne le contenu de smb.conf.
Merci.

n°1315305
e_esprit
Posté le 01-07-2012 à 14:13:19  profilanswer
 

Si ton disque réseau propose du NFS, fais le montage en NFS plutot qu'en samba entre ton serveur et ton disque réseau.


---------------
Ce n'est point ma façon de penser qui a fait mon malheur, c'est celle des autres.
n°1315685
zered
Posté le 07-07-2012 à 17:20:00  profilanswer
 

Bonjour,
 
j'avais déjà essayé le NFS sans amélioration. Mais je reste persuadé que je n'ai pas configuré comme il faut... Un comble, je préfère faire mes mouvements de fichiers sur ce disque... sous windows !
 
Pour préciser l'ampleur du soucis (enfin, relativisons !) lorsque j'ouvre une autre fenêtre sur un répertoire, pendant une copie, ça freeze le système quelques secondes, la fenêtre s'ouvre... puis se rempli après quelques instants. Et je ne vois pas de suractivité du processeur.
 
Mais les copies sont un poil plus rapide. J'ai activé certaines options dans le smb.conf (celles conseillées dans les commentaire du fichier).
 
Merci.
 

mood
Publicité
Posté le 07-07-2012 à 17:20:00  profilanswer
 

n°1315687
roscocoltr​an
L'enfer c'est les utilisateurs
Posté le 07-07-2012 à 17:53:32  profilanswer
 

tu n'as pas précisé la mesure de la vitesse de transfert.


---------------
"Your god is too small", Giordano Bruno, 1548 - 1600
n°1315690
zered
Posté le 07-07-2012 à 19:09:07  profilanswer
 

Je suis sous Voyager (XFCE) et les transferts ne précisent pas la vitesse. Mais plusieurs minutes pour déplacer un fichier de quelques Mo alors que ça prends quelques secondes sous windows.
 
merci.

n°1315696
bardiel
Debian powa !
Posté le 07-07-2012 à 22:47:36  profilanswer
 

zered a écrit :

Pour préciser l'ampleur du soucis (enfin, relativisons !) lorsque j'ouvre une autre fenêtre sur un répertoire, pendant une copie, ça freeze le système quelques secondes, la fenêtre s'ouvre... puis se rempli après quelques instants. Et je ne vois pas de suractivité du processeur.


Je dirais qu'il s'agit plus d'un problème avec Voyager que Samba :/


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Ubuntu serveur et disque réseau

 

Sujets relatifs
ubuntu 64 bits: gain sous Matlab[Ubuntu 10.04 Server] Mise en veille problématique.
[Résolu] Ubuntu/Sony Vaio : touchpad inactif[ubuntu 10.10 & Catalyst] - Multi desktop : 2 bureaux indépendants
Imprimante entièrement compatible UbuntuServeur NAS et standby mode
Récuperation données réussie sur disque en ext4Problème de dépendances sous Ubuntu
Probleme de firewall et serveur openvpn 
Plus de sujets relatifs à : Ubuntu serveur et disque réseau


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR