Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1733 connectés 

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

bridge + wifi

n°542242
maxpower44
Posté le 18-08-2004 à 14:39:16  profilanswer
 

Voila j'ai qq que soucis à faire marcher un bridge avec un module wifi usb.  
D'abord la config réseaux
La machine A qui sert de passerelle sous WinXp
La machine B où le bridge doit être configurer (Linux FC2)
La machine C (WinXP | RH9)
 
B et C sont reliées en ethernet 100 T
A et B sont relié en Wifi (b)
 
les modules Wifi sont des clés usb wifi Peabird. sous linux j'utilise les drivers at76c503a.
 
les ip :
Machine A 192.168.0.1
Machine B 192.168.0.2
Machine C 192.168.0.3
 
Pour la machine B, je fais :

Code :
  1. ifconfig eth0 0.0.0.0
  2. ifconfig wlan0 0.0.0.0
  3. iwconfig wlan0 essid test channel 1
  4. brctl addif br0 eth0
  5. brctl addif br0 wlan0
  6. ifconfig br0 192.168.0.2 netmask 255.255.255.0 up
  7. route add -net default gw 192.168.0.1 netmask 0.0.0.0


Resultat :
de la machine A:  
ping 192.168.0.2 OK
ping 192.168.0.3 marche pas
ping www.google.fr OK (encore heureux !)
 
de la machine B:  
ping 192.168.0.1 OK
ping 192.168.0.2 OK
ping www.google.fr OK
 
de la machine C:  
ping 192.168.0.2 OK
ping 192.168.0.1 marche pas
ping www.google.fr marche pas
 
Si qq a une idée ?


Message édité par maxpower44 le 18-08-2004 à 14:59:20
mood
Publicité
Posté le 18-08-2004 à 14:39:16  profilanswer
 

n°542243
farib
Posté le 18-08-2004 à 14:41:08  profilanswer
 

on pourrait avoir la conf rézal plus détaillée de la machine B  ?


---------------
Bitcoin, Magical Thinking, and Political Ideology
n°542245
maxpower44
Posté le 18-08-2004 à 14:43:08  profilanswer
 

mm pas le temps de corrigé mes fautes que deja une réponse  ;)  
 
j'y connais pas trop en reseaux sous linux tu peux être plus précis ...

n°542247
farib
Posté le 18-08-2004 à 14:44:31  profilanswer
 

maxpower44 a écrit :

mm pas le temps de corrigé mes fautes que deja une réponse  ;)  
 
j'y connais pas trop en reseaux sous linux tu peux être plus précis ...


bein c "physiquement" ( wifi et ethernet" )
A & C  sont reliés, il faut que logiquement, les configurations de routage/bridge soient correctes pour que A & C puissent communiquer.


---------------
Bitcoin, Magical Thinking, and Political Ideology
n°542252
maxpower44
Posté le 18-08-2004 à 14:52:02  profilanswer
 

farib a écrit :

bein c "physiquement" ( wifi et ethernet" )


physiquement B et C sont relié en ethernet et A et B en wifi (module usb)

Citation :

A & C  sont reliés, il faut que logiquement, les configurations de routage/bridge soient correctes pour que A & C puissent communiquer.


A et C sont relié par l'intemediaire de B (normalement) mais le pont n'a pas l'air de faire son travail de hub cad que quand une requete arrive à B via le wifi il devrait le renvoyé a C et inversement non ?


Message édité par maxpower44 le 18-08-2004 à 14:59:56
n°542264
ZeBib
4tus
Posté le 18-08-2004 à 15:02:15  profilanswer
 

Question : tu mets une IP sur ton bridge pour faire quoi ? L'administrer à distance ou juste comme ça ?

n°542266
maxpower44
Posté le 18-08-2004 à 15:03:48  profilanswer
 

J'ai un serveur cvs dessus

n°542268
ZeBib
4tus
Posté le 18-08-2004 à 15:04:20  profilanswer
 

maxpower44 a écrit :

physiquement B et C sont relié en ethernet et A et B en wifi (module usb)

Citation :

A & C  sont reliés, il faut que logiquement, les configurations de routage/bridge soient correctes pour que A & C puissent communiquer.


A et C sont relié par l'intemediaire de B (normalement) mais le pont n'a pas l'air de faire son travail de hub cad que quand une requete arrive à B via le wifi il devrait le renvoyé a C et inversement non ?


 
Attention le brdige (niveau 2) n'est pas un hub (niveau 1).

n°542277
maxpower44
Posté le 18-08-2004 à 15:08:43  profilanswer
 

Zebib a écrit :

Attention le brdige (niveau 2) n'est pas un hub (niveau 1).


Je veux dire par la que j'ai pas de filtres dessus et que tous paquets arrivant sur un periphérique du bridge est renvoyé sur tous les autres peripheriques réseaux
 
sur la faq de bridge, il y a ceci :

Citation :

It doesn't work with my Wireless card!
This is a known problem, and it is not caused by the bridge code. Many wireless cards don't allow spoofing of the source address. It is a firmware restriction with some chipsets. You might find some information in the bridge mailing list archives to help.


c'est quoi deja le spoofing ? (je devait surement dormir pdt les cours réseaux :) ) il y a un moyen de contourné le probleme ?


Message édité par maxpower44 le 18-08-2004 à 15:11:23
n°542279
ZeBib
4tus
Posté le 18-08-2004 à 15:10:41  profilanswer
 

Bon sinon pour bien conpremdre, je vais t'indiquer comment j'aurais configuré ta machine B :
 

  • chargement du module 802.1d
  • configuration de l'interface br0
  • installation des utilitaires (debian pour moi) bridge-utils
  • affectation des interfaces eth0 et wlan0 dans br0


Faut penser à désactiver le SPT si tu n'as pas de chemins redondants (à priori non).
 
Il faut voir aussi les @MAC de tes interfaces, pour voir làquelle prend br0.
 
Est-ce que tes interfaces (eth0 wlan0) sont en mode promiscuous ?


Message édité par ZeBib le 18-08-2004 à 15:12:22
mood
Publicité
Posté le 18-08-2004 à 15:10:41  profilanswer
 

n°542282
ZeBib
4tus
Posté le 18-08-2004 à 15:13:33  profilanswer
 

maxpower44 a écrit :


c'est quoi deja le spoofing ? (je devait surement dormir pdt les cours réseaux :) ) il y a un moyen de contourné le probleme ?


 
http://www.commentcamarche.net/attaques/spoofing.php3

n°542290
maxpower44
Posté le 18-08-2004 à 15:16:47  profilanswer
 

Zebib a écrit :

Bon sinon pour bien conpremdre, je vais t'indiquer comment j'aurais configuré ta machine B :
 

  • chargement du module 802.1d
  • configuration de l'interface br0
  • installation des utilitaires (debian pour moi) bridge-utils
  • affectation des interfaces eth0 et wlan0 dans br0



c'est ce que j'ai fais (sauf que j'ai fais le 3 avant le 2 :) )

Citation :


Faut penser à désactiver le SPT si tu n'as pas de chemins redondants (à priori non).

je crois que SPT est desactivé mais faut que je verifie (pour le moment c'est la machine C sous XP qui fait le pont sinon j'ai pas acces au forum :( )

Citation :


Il faut voir aussi les @MAC de tes interfaces, pour voir làquelle prend br0.

je te dis ca tout de suite

Citation :

Est-ce que tes interfaces (eth0 wlan0) sont en mode promiscuous ?

pour eth0 oui il me le dit quand je l'ajoute au bridge et pour wlan0 je sais pas. comment je regarde sa ? et qu'est ce que cela signifie ?
 
Merci pour ton aide

n°542299
ZeBib
4tus
Posté le 18-08-2004 à 15:21:56  profilanswer
 

Le mode promiscuous c'est pour capturer toutes les trames arrivant sur ton interface.

n°542302
ZeBib
4tus
Posté le 18-08-2004 à 15:26:58  profilanswer
 

Les infos qu'il nous faudrait seraient :
 

  • dmesg de tes cartes réseaux pour vérifier la bonne détection
  • @MAC de tes cartes réseaux
  • listing des commandes que tu as passées (si différent de ton premier post)
  • les infos de /var/log/syslog suite au redémarrage de ton réseau


 
 :)

n°542321
maxpower44
Posté le 18-08-2004 à 15:59:05  profilanswer
 

Zebib a écrit :

Les infos qu'il nous faudrait seraient :
 

  • dmesg de tes cartes réseaux pour vérifier la bonne détection

divert: allocating divert_blk for eth0

eth0: RealTek RTL8139 at 0xdc00, 00:50:22:82:53:a0, IRQ 11
eth0:  Identified 8139 chip type 'RTL-8139C'
ip_tables: (C) 2000-2002 Netfilter core team
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
parport0: PC-style at 0x3bc (0x7bc) [PCSPP,TRISTATE]
parport_pc: Via 686A parallel port: io=0x3BC
lp0: using parport0 (polling).
lp0: console ready
NET: Registered protocol family 10
Disabled Privacy Extensions on device 022db720(lo)
IPv6 over IPv4 tunneling driver
divert: not allocating divert_blk for non-ethernet device sit0
eth0: no IPv6 routers present
usb 1-1: USB disconnect, address 2
/usr/local/src/at76c503a/at76c503-fw_skel.c: wlan0 disconnecting
divert: freeing divert_blk for wlan0
/usr/local/src/at76c503a/at76c503-fw_skel.c: at76c505-rfmd2958 disconnected
usb 1-1: new full speed USB device using address 4
/usr/local/src/at76c503a/at76c503-fw_skel.c: using compiled-in firmware
/usr/local/src/at76c503a/at76c503.c: $Id: at76c503.c,v 1.64 2004/08/13 00:17:22 jal2 Exp $ compiled Aug 13 2004 11:44:34
/usr/local/src/at76c503a/at76c503.c: firmware version 1.101.0 #86 (fcs_len 4)
/usr/local/src/at76c503a/at76c503.c: device's MAC 00:40:f4:81:84:d2, regulatory domain ETSI (Europe - (Spain+France) (id 48)
divert: allocating divert_blk for wlan0
/usr/local/src/at76c503a/at76c503.c: registered wlan0

Citation :

  • @MAC de tes cartes réseaux

br0       Lien encap:Ethernet  HWaddr 00:40:F4:81:84:D2  

         inet adr:192.168.0.2  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::240:f4ff:fe81:84d2/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:152 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0  
          RX bytes:19104 (18.6 Kb)  TX bytes:3169 (3.0 Kb)
 
eth0      Lien encap:Ethernet  HWaddr 00:50:22:82:53:A0  
          adr inet6: fe80::250:22ff:fe82:53a0/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:268 errors:0 dropped:0 overruns:0 frame:0
          TX packets:125 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000  
          RX bytes:16745 (16.3 Kb)  TX bytes:21377 (20.8 Kb)
          Interruption:11 Adresse de base:0xdc00  
 
lo        Lien encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:30 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0  
          RX bytes:2604 (2.5 Kb)  TX bytes:2604 (2.5 Kb)
 
wlan0     Lien encap:Ethernet  HWaddr 00:40:F4:81:84:D2  
          adr inet6: fe80::240:f4ff:fe81:84d2/64 Scope:Lien
          UP BROADCAST  MTU:1500  Metric:1
          RX packets:37 errors:0 dropped:0 overruns:0 frame:0
          TX packets:124 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000  
          RX bytes:15146 (14.7 Kb)  TX bytes:7614 (7.4 Kb)
 
A priori l'adresse Mac du bridge est celle de wlan

Citation :

  • listing des commandes que tu as passées (si différent de ton premier post)

ifconfig eth0 0.0.0.0

ifconfig wlan0 0.0.0.0
iwconfig wlan0 essid test channel 1
brctl addbr br0
brctl addif br0 eth0
brctl addif br0 wlan0
ifconfig br0 192.168.0.2 netmask 255.255.255.0 up
route add -net default gw 192.168.0.1 netmask 0.0.0.0

Citation :

  • les infos de /var/log/syslog suite au redémarrage de ton réseau

Aug 18 15:49:58 XineBox kernel: Bridge firewalling registered

Aug 18 15:49:58 XineBox kernel: eth0: Promiscuous mode enabled.
Aug 18 15:49:58 XineBox kernel: device eth0 entered promiscuous mode
Aug 18 15:49:59 XineBox kernel: device wlan0 entered promiscuous mode
Aug 18 15:49:59 XineBox kernel: /usr/local/src/at76c503a/at76c503.c: wlan0: KEVENT_SET_PROMISC
Aug 18 15:49:59 XineBox kernel: br0: port 2(wlan0) entering learning state
Aug 18 15:49:59 XineBox kernel: br0: port 1(eth0) entering learning state
Aug 18 15:50:00 XineBox kernel: /usr/local/src/at76c503a/at76c503.c: /usr/local/src/at76c503a/at76c503.c:2482 assertion dev->istate == INIT failed
Aug 18 15:50:14 XineBox kernel: br0: topology change detected, propgating
Aug 18 15:50:14 XineBox kernel: br0: port 2(wlan0) entering forwarding state
Aug 18 15:50:14 XineBox kernel: br0: topology change detected, propgating
Aug 18 15:50:14 XineBox kernel: br0: port 1(eth0) entering forwarding state
 
J'ai une erreur sur at76c503a qui ne m'enpeche pas de pinguer la machine a ... ?

n°542335
ZeBib
4tus
Posté le 18-08-2004 à 16:30:40  profilanswer
 

Ca semble pas mal à première vue...
 
Et çà ne fonctionne pas.... il faudrait que tu regardes ce que deviennent les paquets sur la machine B avec ethereal si tu as X d'installé ou tcpdump en mode console.
 
Il faudrait vérifier que les paquets de C arrivent bien sur eth0 et ensuite regarder si çà sort de wlan0 ou non.
 
T'as testé le sens machine A vers C ?

n°542361
maxpower44
Posté le 18-08-2004 à 17:15:50  profilanswer
 

Zebib a écrit :

T'as testé le sens machine A vers C ?

oui et ca marche pa mieux.
J'ai fais les tcpdump lors d'un ping de A vers C et inversement et bizarement le resultat n'est pas "symetrique" mais je ne sais pas les interpreté.
 
Ping de la machine C vers A (192.168.0.11 vers 192.168.0.1):
-eth0

Citation :

17:10:02.954210 IP 192.168.0.11 > 192.168.0.1: icmp 40: echo request seq 33280
17:10:08.025522 IP 192.168.0.11 > 192.168.0.1: icmp 40: echo request seq 33536
17:10:13.525540 IP 192.168.0.11 > 192.168.0.1: icmp 40: echo request seq 33792
17:10:19.025519 IP 192.168.0.11 > 192.168.0.1: icmp 40: echo request seq 34048


-wlan0

Citation :

17:10:02.954406 IP 192.168.0.11 > 192.168.0.1: icmp 40: echo request seq 33280
17:10:08.025545 IP 192.168.0.11 > 192.168.0.1: icmp 40: echo request seq 33536
17:10:13.525553 IP 192.168.0.11 > 192.168.0.1: icmp 40: echo request seq 33792
17:10:19.025534 IP 192.168.0.11 > 192.168.0.1: icmp 40: echo request seq 34048


 
Ping de la machine A vers C:
-wlan0

Citation :

17:09:04.005055 arp who-has 192.168.0.11 tell 192.168.0.1
17:09:04.005206 arp reply 192.168.0.11 is-at 02:0c:6e:6e:9f:5e
17:09:09.427635 arp who-has 192.168.0.11 tell 192.168.0.1
17:09:09.427808 arp reply 192.168.0.11 is-at 02:0c:6e:6e:9f:5e
17:09:14.432802 arp who-has 192.168.0.11 tell 192.168.0.1
17:09:14.432976 arp reply 192.168.0.11 is-at 02:0c:6e:6e:9f:5e
17:09:19.438930 arp who-has 192.168.0.11 tell 192.168.0.1
17:09:19.439130 arp reply 192.168.0.11 is-at 02:0c:6e:6e:9f:5e


-eth0

Citation :

17:09:04.004781 arp who-has 192.168.0.11 tell 192.168.0.1
17:09:04.004988 arp reply 192.168.0.11 is-at 02:0c:6e:6e:9f:5e
17:09:09.427578 arp who-has 192.168.0.11 tell 192.168.0.1
17:09:09.427814 arp reply 192.168.0.11 is-at 02:0c:6e:6e:9f:5e
17:09:14.432746 arp who-has 192.168.0.11 tell 192.168.0.1
17:09:14.432982 arp reply 192.168.0.11 is-at 02:0c:6e:6e:9f:5e
17:09:19.438908 arp who-has 192.168.0.11 tell 192.168.0.1
17:09:19.439136 arp reply 192.168.0.11 is-at 02:0c:6e:6e:9f:5e


 
 
J'espere que ca te parle plus qu'a moi ;)

n°542404
maxpower44
Posté le 18-08-2004 à 18:39:45  profilanswer
 

je viens de refaire le tcpdump sur le wlan0 losque je ping de la machine C vers A

Citation :

18:35:24.719903 IP 192.168.0.3 > sci-jmsfx.mshome.net: icmp 40: echo request seq 49920
18:35:24.721773 IP 192.168.0.2.32782 > sci-jmsfx.mshome.net.domain:  30131+ PTR? 1.0.168.192.in-addr.arpa. (42)
18:35:24.725756 IP sci-jmsfx.mshome.net.domain > 192.168.0.2.32782:  30131- 1/0/0 (100)
18:35:24.726243 IP 192.168.0.2.32782 > sci-jmsfx.mshome.net.domain:  30132+ PTR? 11.0.168.192.in-addr.arpa. (43)
18:35:24.794687 IP sci-jmsfx.mshome.net.domain > 192.168.0.2.32782:  30132 NXDomain* 0/1/0 (106)
18:35:24.795124 IP 192.168.0.2.32782 > sci-jmsfx.mshome.net.domain:  30133+ PTR? 2.0.168.192.in-addr.arpa. (42)
18:35:24.866676 IP sci-jmsfx.mshome.net.domain > 192.168.0.2.32782:  30133 NXDomain* 0/1/0 (105)
18:35:27.805236 IP sci-jmsfx.mshome.net.domain > 192.168.0.2.32782:  30132 NXDomain* 0/1/0 (106)
18:35:27.805310 IP 192.168.0.2 > sci-jmsfx.mshome.net: icmp 142: 192.168.0.2 udp port 32782 unreachable
18:35:27.866177 IP sci-jmsfx.mshome.net.domain > 192.168.0.2.32782:  30133 NXDomain* 0/1/0 (105)
18:35:27.866257 IP 192.168.0.2 > sci-jmsfx.mshome.net: icmp 141: 192.168.0.2 udp port 32782 unreachable
18:35:29.720367 arp who-has sci-jmsfx.mshome.net tell 192.168.0.2
18:35:29.723864 arp reply sci-jmsfx.mshome.net is-at 00:40:f4:81:82:56
18:35:29.864865 IP 192.168.0.3 > sci-jmsfx.mshome.net: icmp 40: echo request seq 50176
18:35:30.793686 IP sci-jmsfx.mshome.net.domain > 192.168.0.2.32782:  30132 NXDomain* 0/1/0 (106)
18:35:30.793761 IP 192.168.0.2 > sci-jmsfx.mshome.net: icmp 142: 192.168.0.2 udp port 32782 unreachable
18:35:30.866676 IP sci-jmsfx.mshome.net.domain > 192.168.0.2.32782:  30133 NXDomain* 0/1/0 (105)
18:35:30.866750 IP 192.168.0.2 > sci-jmsfx.mshome.net: icmp 141: 192.168.0.2 udp port 32782 unreachable
18:35:33.793188 IP sci-jmsfx.mshome.net.domain > 192.168.0.2.32782:  30132 NXDomain* 0/1/0 (106)
18:35:33.793277 IP 192.168.0.2 > sci-jmsfx.mshome.net: icmp 142: 192.168.0.2 udp port 32782 unreachable
18:35:33.864177 IP sci-jmsfx.mshome.net.domain > 192.168.0.2.32782:  30133 NXDomain* 0/1/0 (105)
18:35:33.864249 IP 192.168.0.2 > sci-jmsfx.mshome.net: icmp 141: 192.168.0.2 udp port 32782 unreachable
18:35:35.364838 IP 192.168.0.3 > sci-jmsfx.mshome.net: icmp 40: echo request seq 50432
18:35:40.864791 IP 192.168.0.3 > sci-jmsfx.mshome.net: icmp 40: echo request seq 50688


la machine A est "sci-jmsfx.mshome.net". ce qui est bizard c'est "sci-jmsfx.mshome.net.domain"

n°542419
ZeBib
4tus
Posté le 18-08-2004 à 19:40:46  profilanswer
 

J'ai un doute sur le mode promiscuous de ta carte wifi...
 
edit : pas certain en fait...
 
C'est con que je ne sois pas avec toi c'est le genre de problème que j'adore résoudre mais comme ça sur le forum, le déclic ne vient pas...
 
Bon manifestement ton bridge fonctionne vu les logs mais ne machines n'arrivent pas à dialoguer......
 
kernel: br0: port 2(wlan0) entering learning state
kernel: br0: port 1(eth0) entering learning state
kernel: br0: topology change detected, propgating
kernel: br0: port 2(wlan0) entering forwarding state
kernel: br0: topology change detected, propgating
kernel: br0: port 1(eth0) entering forwarding state
 
les deux interfaces forwardent les paquets, on le voit avec tcpdump mais  les machines A et C ne dialoguent pas....A voir.


Message édité par ZeBib le 18-08-2004 à 19:58:49
n°547654
maxpower44
Posté le 28-08-2004 à 11:19:49  profilanswer
 

Bon, j'ai toujours pas résolu mon problème. si quelqu'un d'autres a une idée ...
 

ZeBib a écrit :

C'est con que je ne sois pas avec toi c'est le genre de problème que j'adore résoudre mais comme ça sur le forum, le déclic ne vient pas...


C'est surtout con de perdre du temps sur de l'administration réseau. J'ai du developpement à faire et la je suis coincé  :fou:

n°547658
[Albator]
MDK un jour, MDK toujours !
Posté le 28-08-2004 à 11:28:57  profilanswer
 

N'y aurait-il pas des règles de filtrage iptables qui foutent le boxon ?

n°547659
maxpower44
Posté le 28-08-2004 à 11:31:51  profilanswer
 

Possible mais je ne sais pas du tout comment iptable fonctionne. je ne crois pas qu'il soit chargé.

n°547694
maxpower44
Posté le 28-08-2004 à 13:02:10  profilanswer
 

effectivement j'ai verifié, je n'ai aucune chaine dans iptable (qui n'est pas chargé d'ailleurs)

n°547766
ZeBib
4tus
Posté le 28-08-2004 à 16:32:19  profilanswer
 

J'ai un peu laché ton affaire depuis le temps  :(  
 
Est-ce que tes interfaces sont toutes UP ? (ip link set <iface> up)

n°547796
Nis+
Posté le 28-08-2004 à 17:36:56  profilanswer
 

si tu rajoute "promisc" au 2 premiers ifconfig ca aide pas ?
 

Code :
  1. ifconfig eth0 0.0.0.0 promisc
  2. ifconfig wlan0 0.0.0.0 promisc

n°547807
maxpower44
Posté le 28-08-2004 à 17:57:01  profilanswer
 

Merci pour votre aide
[quote}Est-ce que tes interfaces sont toutes UP ? (ip link set <iface> up)[/quote]Je suppose que oui puisque je pense que le fait de faire un up sur le bridge doit faire un up sur toutes ces interfaces. et le ping de la machine B ne marcherais pas vers C ou A.
J'ai qd mm essayer à tout hazard, mais ca ne change rien.
 

Citation :

ifconfig eth0 0.0.0.0 promisc  
ifconfig wlan0 0.0.0.0 promisc


Ca non plus ca ne change rien :(

n°547820
fute77
Life Is Short ! Have Fun !
Posté le 28-08-2004 à 18:18:37  profilanswer
 

dis moi,comment ta machine au centre fait pour savoir à quel interface elle doit relayer un paquet ?
les deux interfaces sont sur le meme réseaux 192.168.0.x


---------------
"Si il y avait un impot sur la connerie, l'Etat s'autofinancerai" J Yanne
n°547823
maxpower44
Posté le 28-08-2004 à 18:23:29  profilanswer
 

fute77 a écrit :

dis moi,comment ta machine au centre fait pour savoir à quel interface elle doit relayer un paquet ?
les deux interfaces sont sur le meme réseaux 192.168.0.x


C'est bien l'interêt d'un pont reseau. le pont reseau permet de joindre deux reseaux physique en un seul reseau logique de manière completement transparente et indetectable. Je suppose que qd le pont recoit un paquet d'une interface, il le renvoie sur toutes les autres interfaces du pont.


Message édité par maxpower44 le 28-08-2004 à 18:24:42
n°547834
fute77
Life Is Short ! Have Fun !
Posté le 28-08-2004 à 18:49:45  profilanswer
 

Pourquoi ne pas commencer par le plus simple :
1 reseau en 192.168.0.x
1 reseau en 192.168.1.x
 
et ta machine B elle appartient au deux
 
en suite tu mets au point ton petit scrip iptables
et vala, 2 minutes de travail, et c'est plus logique


---------------
"Si il y avait un impot sur la connerie, l'Etat s'autofinancerai" J Yanne
n°547835
fute77
Life Is Short ! Have Fun !
Posté le 28-08-2004 à 18:50:30  profilanswer
 

sinon, ta machine B ne doit pas etre visible sur le resau pour faire ce que tu veux faire (ou si peut etre pas une 3eme interface réseau)


---------------
"Si il y avait un impot sur la connerie, l'Etat s'autofinancerai" J Yanne
n°547839
maxpower44
Posté le 28-08-2004 à 19:01:56  profilanswer
 

fute77 a écrit :

Pourquoi ne pas commencer par le plus simple :
1 reseau en 192.168.0.x
1 reseau en 192.168.1.x
 
et ta machine B elle appartient au deux
 
en suite tu mets au point ton petit scrip iptables
et vala, 2 minutes de travail, et c'est plus logique

le pb c'est iptable et moi ... ca fais 2 :) et le bridge "avait l'air plus simple a mettre en oeuvre

n°547854
fute77
Life Is Short ! Have Fun !
Posté le 28-08-2004 à 19:16:59  profilanswer
 

iptables c'est pas si sorcier que ca tu sais
j'ai toujours fais mes scripts à moi


---------------
"Si il y avait un impot sur la connerie, l'Etat s'autofinancerai" J Yanne
n°547877
Nis+
Posté le 28-08-2004 à 19:43:01  profilanswer
 

l'interet du bridge est de reunir 2 reseaux entre eux de facon totalement transparante pour les 2 parties et avec des ips dans le même reseau. (pour moi ca m'a permit de faire un partage windows fonctionnel entre les deux bouts du reseau alors qu'avec un "pont" par iptables c'etait pas top du tout)
 
sinon question bête le module "bridge" (ou quelque chose dans le genre, j'ai pas la machine où je l'ai fait sous la main) est bien  chargé ?


Message édité par Nis+ le 28-08-2004 à 19:43:27
n°547892
maxpower44
Posté le 28-08-2004 à 20:10:49  profilanswer
 

oui, il est chargé d'ailleurs si il n'était pas chargé je devrais pas pouvoir faire de ping sur le pont (?). C'est le pont qui a une adresse IP pas les intefaces (dans mon cas)

n°547934
ZeBib
4tus
Posté le 28-08-2004 à 21:01:16  profilanswer
 

fute77 a écrit :

Pourquoi ne pas commencer par le plus simple :
1 reseau en 192.168.0.x
1 reseau en 192.168.1.x
 
et ta machine B elle appartient au deux
 
en suite tu mets au point ton petit scrip iptables
et vala, 2 minutes de travail, et c'est plus logique


 
dans ce cas il fait ou routeur et non un bridge.
 
Deux solutions différentes.

n°618392
Azum
Posté le 11-01-2005 à 01:10:51  profilanswer
 

Bonjour tout le monde !!
Je sais que le post est un peut vieux mais il m'a bien servi dans mes recherches. Voila ce que je peux dire:
J'avais le meme probleme : un gateway sur la freebox , mon pc perso (sous Sarge 2.6 )relie au gateway en lan et une carte Wifi , plus un portable en wifi aussi. Je voulais bridger le wifi (wlan0) et mon ethernet (eth0) sur mon pc perso.
Le problème (et j'ai mis du temps a le comprendre....) c'est que j'utilise Ndiswrapper comme driver pour le wifi et celui-ci ne supporte pas le promisc mode (capter tout ce qui arrive sur l'interface)....
Donc j'ai abandonné le bridge et je suis retourné au bon vieux IP forwarding avec un dhcpd sur wlan0 . Grossomodo :
 
dhcpd wlan0
iptables -A FORWARD -i $if_net -o $if_lan -j ACCEPT
iptables -A FORWARD -o $if_lan -i $if_net -j ACCEPT
 
 
Voila...si ca peut aider qq1...
P.S. : j'ai eu des problemes avec cette methode et ndsiwrapper si ca peu aider qq1 aussi :  
Je suis oblige de mettre iwconfig wlan0 mode Ad-Hoc a chaque boot... pas tres propre. Si quelqu'un voit une solution plus propre..
++

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
 

Sujets relatifs
Config wifi MSI PC54G2 sur mdk10: ça marche mais...WiFi en PCMIA et Mandrake 10.0 ?
Sécuriser les communications wifi [SSH/tunneling][WiFi] problème ESSID
bridge linuxproblème création résaux wifi et cablé
[WIFI] problème de ping avec réponse aléatoireProblème: reseau wifi, modem ethernet netgear dm602
[wifi] adresse macet oui encore le wifi :(, cmt faire marcher ?
Plus de sujets relatifs à : bridge + wifi


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR