Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1537 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  [Debian && Apt] Dist-upgrade déconne grave!!!

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Debian && Apt] Dist-upgrade déconne grave!!!

n°581059
falconn
Posté le 27-10-2004 à 21:35:37  profilanswer
 

Bonjour à tous!
Il m'arrive de temps en temps de faire un apt-get upgrade qui met à jour certains paquets... Cependant depuis aujourdhui, il ne se contente plus de faire une mise à jour, mais il fait aussi le grand ménage!  
Il me propose de supprimer tout ca  ( à vrai dire preske tout ce qui est installé sur mon ordi!!). C'est quoi ce délire? quelqu'un peut-il m'aider à résoudre le problème?  
 
 
apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront ENLEVÉS :
  amsn ark at-spi autoconf automake1.4 bb bug-buddy capplets capplets-data
  cupsys dia-common dia-gnome docbook docbook-dsssl docbook-xml docker
  ed2k-gtk-gui eog evolution evolution-data-server file-roller frozen-bubble
  gaim gcalctool gcombust gconf-editor gconf2 gdesklets gdm gdm-themes gedit
  gedit-common gftp gftp-gtk gkrellm gksu gnome-about gnome-alsamixer
  gnome-applets gnome-applets-data gnome-control-center gnome-core
  gnome-cpufreq-applet gnome-cups-manager gnome-desktop-environment
  gnome-doc-tools gnome-games gnome-gv gnome-keyring gnome-media gnome-network
  gnome-panel gnome-panel-data gnome-session gnome-system-monitor
  gnome-terminal gnome-themes gnome-themes-extras gnome-utils
  gnome2-user-guide gnomemeeting gpdf gs gs-common gs-esp gs-gpl
  gstreamer0.8-misc gthumb gtk-engines-pixmap gtk2-engines-crux
  gtk2-engines-industrial gtk2-engines-lighthouseblue gtk2-engines-pixbuf
  gtk2-engines-smooth gtk2-engines-spherecrystal gtk2-engines-thinice
  gtkglarea5 gtkhtml3.0 gtkhtml3.2 gtoaster gucharmap gxine jumpnbump k3b
  k3blibs kcontrol kdebase-bin kdevelop3 kdevelop3-data kdevelop3-plugins
  kmess lesstif2 libatspi1.0-0 libbonoboui2-0 libcairo1 libcvsservice0
  libebook8 libecal6 libedata-book1 libedata-cal5 libedataserver3 libeel2-2
  libegroupwise6 libgail-common libgail17 libgal2.0-6 libgal2.0-common
  libgal2.2-1 libgal2.2-common libgconf2-4 libgdkcardimage0 libgksu1.2-0
  libgksuui1.0-0 libglade-gnome0 libglade0 libglade2-0 libglib-perl
  libgnome-desktop-2 libgnome-keyring0 libgnome-pilot2 libgnome2-0
  libgnome2-canvas-perl libgnome2-common libgnome2-perl libgnome2-vfs-perl
  libgnomecanvas2-0 libgnomecupsui1.0-1 libgnomeprint-bin libgnomeprint2.2-0
  libgnomeprintui2.2-0 libgnomeui-0 libgnomevfs2-0 libgnomevfs2-common
  libgsf-gnome-1 libgstreamer-gconf0.8-0 libgtk2-perl libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libgtkhtml2-0 libgtkhtml3.0-4
  libgtkhtml3.2-11 libgtksourceview1.0-0 libgtkspell0 libgucharmap4
  libmetacity0 libnautilus2-2 libodbcinstq1 libpanel-applet2-0 libpango1.0-0
  libpango1.0-common librsvg2-2 librsvg2-common libsdl-perl libvte4 libwnck4
  libzvt2.0-0 magicdev metacity metacity-themes mozilla mozilla-browser
  mozilla-firefox mozilla-mailnews mozilla-psm mozilla-thunderbird nautilus
  nautilus-cd-burner nautilus-data nautilus-media openjade openssl
  python-glade-1.2 python-glade2 python-gnome2 python-gtk2 python2.3-glade2
  python2.3-gnome2 python2.3-gtk2 rdesktop rep-gtk sawfish scrollkeeper
  sgml-base sgml-data sodipodi sound-juicer tk8.3 unixodbc-bin wine
  winesetuptk x-window-system-core xchat xchat-common xml-core xpdf
  xpdf-reader xscreensaver xterm yelp zenity

mood
Publicité
Posté le 27-10-2004 à 21:35:37  profilanswer
 

n°581066
chaced
Posté le 27-10-2004 à 21:39:41  profilanswer
 

falconn a écrit :

Bonjour à tous!
Il m'arrive de temps en temps de faire un apt-get upgrade qui met à jour certains paquets... Cependant depuis aujourdhui, il ne se contente plus de faire une mise à jour, mais il fait aussi le grand ménage!  
Il me propose de supprimer tout ca  ( à vrai dire preske tout ce qui est installé sur mon ordi!!). C'est quoi ce délire? quelqu'un peut-il m'aider à résoudre le problème?  
 
 
apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront ENLEVÉS :
  amsn ark at-spi autoconf automake1.4 bb bug-buddy capplets capplets-data
  cupsys dia-common dia-gnome docbook docbook-dsssl docbook-xml docker
  ed2k-gtk-gui eog evolution evolution-data-server file-roller frozen-bubble
  gaim gcalctool gcombust gconf-editor gconf2 gdesklets gdm gdm-themes gedit
  gedit-common gftp gftp-gtk gkrellm gksu gnome-about gnome-alsamixer
  gnome-applets gnome-applets-data gnome-control-center gnome-core
  gnome-cpufreq-applet gnome-cups-manager gnome-desktop-environment
  gnome-doc-tools gnome-games gnome-gv gnome-keyring gnome-media gnome-network
  gnome-panel gnome-panel-data gnome-session gnome-system-monitor
  gnome-terminal gnome-themes gnome-themes-extras gnome-utils
  gnome2-user-guide gnomemeeting gpdf gs gs-common gs-esp gs-gpl
  gstreamer0.8-misc gthumb gtk-engines-pixmap gtk2-engines-crux
  gtk2-engines-industrial gtk2-engines-lighthouseblue gtk2-engines-pixbuf
  gtk2-engines-smooth gtk2-engines-spherecrystal gtk2-engines-thinice
  gtkglarea5 gtkhtml3.0 gtkhtml3.2 gtoaster gucharmap gxine jumpnbump k3b
  k3blibs kcontrol kdebase-bin kdevelop3 kdevelop3-data kdevelop3-plugins
  kmess lesstif2 libatspi1.0-0 libbonoboui2-0 libcairo1 libcvsservice0
  libebook8 libecal6 libedata-book1 libedata-cal5 libedataserver3 libeel2-2
  libegroupwise6 libgail-common libgail17 libgal2.0-6 libgal2.0-common
  libgal2.2-1 libgal2.2-common libgconf2-4 libgdkcardimage0 libgksu1.2-0
  libgksuui1.0-0 libglade-gnome0 libglade0 libglade2-0 libglib-perl
  libgnome-desktop-2 libgnome-keyring0 libgnome-pilot2 libgnome2-0
  libgnome2-canvas-perl libgnome2-common libgnome2-perl libgnome2-vfs-perl
  libgnomecanvas2-0 libgnomecupsui1.0-1 libgnomeprint-bin libgnomeprint2.2-0
  libgnomeprintui2.2-0 libgnomeui-0 libgnomevfs2-0 libgnomevfs2-common
  libgsf-gnome-1 libgstreamer-gconf0.8-0 libgtk2-perl libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libgtkhtml2-0 libgtkhtml3.0-4
  libgtkhtml3.2-11 libgtksourceview1.0-0 libgtkspell0 libgucharmap4
  libmetacity0 libnautilus2-2 libodbcinstq1 libpanel-applet2-0 libpango1.0-0
  libpango1.0-common librsvg2-2 librsvg2-common libsdl-perl libvte4 libwnck4
  libzvt2.0-0 magicdev metacity metacity-themes mozilla mozilla-browser
  mozilla-firefox mozilla-mailnews mozilla-psm mozilla-thunderbird nautilus
  nautilus-cd-burner nautilus-data nautilus-media openjade openssl
  python-glade-1.2 python-glade2 python-gnome2 python-gtk2 python2.3-glade2
  python2.3-gnome2 python2.3-gtk2 rdesktop rep-gtk sawfish scrollkeeper
  sgml-base sgml-data sodipodi sound-juicer tk8.3 unixodbc-bin wine
  winesetuptk x-window-system-core xchat xchat-common xml-core xpdf
  xpdf-reader xscreensaver xterm yelp zenity


 
Verifi ton fichier source.list, utilise un mirroir si il est ok et refait un update.


---------------
Mes bd
n°581101
falconn
Posté le 27-10-2004 à 22:08:40  profilanswer
 

merci chaced pour ta réponse, mais le problème reste le même. J'ai un deuxieme ordi avec les mêmes sources et je n'ai pas ce bug!

n°581115
qdm
Posté le 27-10-2004 à 22:21:56  profilanswer
 

Qu'est ce qu'il te propose d'installer avec toutes ces suppressions. Et quelle est la différence entre un apt-get upgrade et un apt-get dist-upgrade (bien entendu update toutes tes sources et vérifie si le problème persiste).
 
C'est probablement dû à l'arrivée dans la base d'un paquet qui a besoin de dépendances récents pas encore disponible.

n°581198
Profil sup​primé
Posté le 28-10-2004 à 07:06:02  answer
 

il est temps de passer à une vraie distribution : gentoo.
ok, on est pas encore vendredi, je sors ;)

n°581294
chaced
Posté le 28-10-2004 à 11:07:11  profilanswer
 

Le Sot Zi a écrit :

il est temps de passer à une vraie distribution : gentoo.
ok, on est pas encore vendredi, je sors ;)


 
:lol:
 
Ps : Faut quand meme avoir du tmp pour gentoo, l'avantage de debian, c'est facile a mettre en place ;)


---------------
Mes bd
n°581835
falconn
Posté le 28-10-2004 à 23:59:50  profilanswer
 

Voila ce qu'il me propose d'installer :  
 

Code :
  1. alsa-base dpkg dselect gettext gettext-base groff-base imagemagick  libfribidi0 libiw27 libmagick6 libselinux1 libsmbclient python-numeric
  2.   python2.3-numeric samba-common smbclient smbfs usbutils wireless-tools zsh


 
La différence entre l'apt-distupgrade et l'apt-upgrade c'est que le premier me propose de supprimer 600 mo de packages. Les deux me proposent les mêmes mises à jour pour les autres paquets...
 
Edit: ah et pis un update des sources aujourdhui n'a rien changé...


Message édité par falconn le 29-10-2004 à 00:01:04
n°581860
AsTro
Posté le 29-10-2004 à 00:58:22  profilanswer
 

C'est une woody?
Si oui c'est peut-etre pour ca :
http://www.debian.org/News/2004/20041026
 
C'est le passage en revision 3 du 26 octobre 2004 ;)

n°582031
falconn
Posté le 29-10-2004 à 12:07:50  profilanswer
 

nan c'est une sid  :pfff:   mais merci pour ta réponse  ;)

n°582383
qdm
Posté le 29-10-2004 à 23:10:51  profilanswer
 

Ben fais déja un apt-get upgrade. Et après donne nous l'output complet de apt-get dist-upgrade

mood
Publicité
Posté le 29-10-2004 à 23:10:51  profilanswer
 

n°582408
halucard
Souriez à plein dent
Posté le 30-10-2004 à 00:11:12  profilanswer
 

Si ca marche toujours pas, il reste toujours le bon vieux reflexe ... de formatage à la windows ;-).
 
--------->[    ]

n°582433
eL_Shaman_​__
Plop.
Posté le 30-10-2004 à 01:41:16  profilanswer
 

Utilise «apt-get upgrade» pour traiter les paquets que tu peux mettre à jour sans avoir à en supprimer un paquet.
 
Ensuite, tu peux faire «apt-get install un_paquet» pour trouver celui ou ceux qui clochent.
 
 
Il y a des problèmes de dépendances visiblement, ce n'est pas toi qui va les régler, mais les mainteneurs. Tu ne peux qu'attendre de nouvelles versions ou signaler un bug s'il y en a éventuellement un.

n°582571
qdm
Posté le 30-10-2004 à 13:01:36  profilanswer
 

Ouais tu fais bien de sortir Halucard  :D

n°582791
falconn
Posté le 30-10-2004 à 20:49:24  profilanswer
 

merci pour votre aide mais c'est bon j'ai trouvé. Lorsque je lance apt-get update et que aptlist-bugs trouve des bugs dans les paquets à installer, je les met en "hold" (commande p). Ca me crée un fichier /etc/apt/preferences qui me fou le souk quand je fais apt-get dist-upgrade. Quand je supprime ce fichier j'ai pu de problème. Quelqu'un peut-il m'éclairer?

n°582910
cgo2
Dum spiro spero
Posté le 31-10-2004 à 00:24:59  profilanswer
 

j'avais le même problème, du coup j'ai viré apt-listbugs (et maintenant j'utilise aptitude pour faire des mises à jour)

n°582926
falconn
Posté le 31-10-2004 à 01:54:31  profilanswer
 

cgo2 > il gere les bugs des paquets aptitude?

n°583029
cgo2
Dum spiro spero
Posté le 31-10-2004 à 14:01:15  profilanswer
 

non mais il gère très bien les problèmes de dépendances lors des upgrade
pour les bugs des paquets j'ai laissé tomber : je met à jour sans m'en soucier et je n'ai jamais eu de gros problème.

n°583194
qdm
Posté le 31-10-2004 à 20:47:00  profilanswer
 

Je regarde les bugreports et je décide en fonction. Mais 9 fois sur 10 c'est des bugreports de crash qui concernent la version que j'ai déja installée et qui tourne sans souci. Les deux fois où j'ai eu un bug bloquant une MAJ, ben j'ai été le premier à les reporter :cry:


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  [Debian && Apt] Dist-upgrade déconne grave!!!

 

Sujets relatifs
Comment monter ses disques automatiquement sous debian?[Debian] Serveur X ne se lance pas ou...
Partitionnement pour installation XP + DebianActiver la librairie GD sur Debian Woody
[Debian Sid] comment passer de devfs à udev[Debian Woody] installation sur un disque dur Serial ATA
xawdecode-plugin (debian)[Debian WoOdy] support en dur ???
[Debian] Pourquoi unrar ne veut pas decompresser ?debian sarge : petites questions ... (gnome)
Plus de sujets relatifs à : [Debian && Apt] Dist-upgrade déconne grave!!!


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR