Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1711 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  gros bugs sous linux apres compilation du noyau

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

gros bugs sous linux apres compilation du noyau

n°398667
neg'gwada
rafix 971
Posté le 30-01-2004 à 15:35:03  profilanswer
 

voila je suis sous linux 9.1 et tout est dans le titre :)


Message édité par neg'gwada le 01-02-2004 à 14:34:29

---------------
--- WinSplit Revolution ---
mood
Publicité
Posté le 30-01-2004 à 15:35:03  profilanswer
 

n°398670
AirbaT
Connection timed out
Posté le 30-01-2004 à 15:49:13  profilanswer
 

un post-it sur l'écran, ou /etc/hostname.

n°398684
Dark_Schne​ider
Close the World, Open the Net
Posté le 30-01-2004 à 16:06:45  profilanswer
 

linux 9.1 ... tu veux dire mdk 9.1 ?
 
dans les outils mdk ...
 
ou /etc/sysconfig/network


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°398731
neg'gwada
rafix 971
Posté le 30-01-2004 à 17:45:06  profilanswer
 

ok merci mais entre temps je crois que j'ai niqué mon linux :(


---------------
--- WinSplit Revolution ---
n°398733
Profil sup​primé
Posté le 30-01-2004 à 17:48:00  answer
 

neg'gwada a écrit :

ok merci mais entre temps je crois que j'ai niqué mon linux :(


 
qu ' est ce qui se passe ?  :heink:

n°398736
black_lord
Modérateur
Truth speaks from peacefulness
Posté le 30-01-2004 à 17:49:26  profilanswer
 

le lecteur de disquettes en peut plus :D
 
ok je sors :)

n°398768
neg'gwada
rafix 971
Posté le 30-01-2004 à 18:27:23  profilanswer
 

voila, j'ai voulu compiler mon noyaux pour retirer les modules qui ne me servaient pas comme le raid scsi pcmcia joystik...
apres je reviens dessus je vois bien que mon noyaux est compilé (les modules en question ne sont pas chargé mais j'ai perdu des trucs:
-il ne reconnais pas mes cartes reseaux et je n'arrive meme pas le faire
(linux sans internet c'est tres cho surtout lorsqu'on debute)
-les drivers audio et video ont sauté
-je ne vois plus mes paritions windows et fat32
et ca ce n'est qu'a premiere vu je n'ai pas encore pris le temps de tout regarder.
mais il y a un truc qui me chagrine, c'est qu'au demarrage je vois mes eth0 et eth1 et dans drakeconnect ils n'y sont pas.
enfin bon, si il y a des idées pour que je retrouve un linux qui marche je suis preneur
ps: je suis une grosse bite en linux


Message édité par neg'gwada le 30-01-2004 à 18:28:21

---------------
--- WinSplit Revolution ---
n°399621
vanilla
datoune's revival
Posté le 01-02-2004 à 12:22:42  profilanswer
 

- Tu as tapé quoi pour recompiler ton noyau ?
- as tu bien copié le bzImage dans /boot ?
- as tu fais une sauvegarde de l'ancien noyau qui marchait ?
- peux tu donner le résultat d'un lsmod ?


---------------
Membre du Front de Libération de Datoune | Soutenez le FLD | A Tribute To Datoune
n°399702
neg'gwada
rafix 971
Posté le 01-02-2004 à 13:57:05  profilanswer
 

vanilla a écrit :

- Tu as tapé quoi pour recompiler ton noyau ?
- as tu bien copié le bzImage dans /boot ?
- as tu fais une sauvegarde de l'ancien noyau qui marchait ?
- peux tu donner le résultat d'un lsmod ?

- Tu as tapé quoi pour recompiler ton noyau ?
j'ai suivi un truc voici les commandes:

cd /lib/modules
mv 2.x.x 2.x.x.old
cd /usr/src/linux
make mrproper
cd /boot
cp config-ide-2.x.x /usr/src/linux/.config
cd /usr/src/linux
make xconfig
enleve les options que tu ne veux pas et ajoutes celles que tu veux en dur ou module
make dep clean bzImage modules modules_install
puis copier le kernel et System.map etc....


pour la procedure de sauvegarde j'ai fais:

cd /usr/src/linux
cp arch/i386/boot/bzImage /boot/vmlinuz.2xx (ex : vmlinuz.261)
cp System.map /boot/System.map-2xx
cd /boot
rm System.map
ln -s /boot/System.map-2xx /boot/System.map


- as tu fais une sauvegarde de l'ancien noyau qui marchait ?
ben j'ai suivi cette procedure et je ne sais pas si ca a effacé l'ancien noyau.
- peux tu donner le résultat d'un lsmod ?
je vais testé ca tout a l'heure.


Message édité par neg'gwada le 01-02-2004 à 13:57:38

---------------
--- WinSplit Revolution ---
n°399708
farib
Posté le 01-02-2004 à 14:03:45  profilanswer
 

neg'gwada a écrit :

ok merci mais entre temps je crois que j'ai niqué mon linux :(


Tu as utilisé une protection, au moins, j'espère ?

mood
Publicité
Posté le 01-02-2004 à 14:03:45  profilanswer
 

n°399731
vanilla
datoune's revival
Posté le 01-02-2004 à 14:23:54  profilanswer
 


Et pdt que tu y es, le résultat de la commande "uname -a"
Puis donne nous la version du kernel que tu avais et celle que tu souhaitais mettre (parce que là je sais pas du tout)


Message édité par vanilla le 01-02-2004 à 14:26:41

---------------
Membre du Front de Libération de Datoune | Soutenez le FLD | A Tribute To Datoune
n°399739
neg'gwada
rafix 971
Posté le 01-02-2004 à 14:33:21  profilanswer
 

je regarde ca de suite et je repond entre temps j'edite le titre de mon topic parce que ce n'est pas adapté a la situation.


---------------
--- WinSplit Revolution ---
n°399753
neg'gwada
rafix 971
Posté le 01-02-2004 à 14:47:55  profilanswer
 

voila, je suis de retour:
le lsmod me renvoi:

Modules size used bu trained : P
nvidia 1765632 4 (autoclean)


ensuite le unme -a

linux localhost 2.4.21-0.27mdk #1 wed jan 7 03:44:18 MST 2004 i686 unknown unknown GNU/linux

[:spamafote]  
je ne sais c'est quoi tout ca.
en fait j'etais sur le noyau d'oriine de linux c'etai un truc du genre 2.4.21-0.10mdk puis je suis passé a 2.4.21-0.27mdk, enfin je voulais compilé por retirer les trucs inutiles et voila ou j'en suis [:w3c compliant]


Message édité par neg'gwada le 01-02-2004 à 14:51:43

---------------
--- WinSplit Revolution ---
n°399761
vanilla
datoune's revival
Posté le 01-02-2004 à 15:01:48  profilanswer
 

L'est bizarre ton lsmod, tu as juste le module nvidia !?
 
Faut que tu recompiles ton kernel en mettant en module ta carte réseau, etc !


---------------
Membre du Front de Libération de Datoune | Soutenez le FLD | A Tribute To Datoune
n°399763
Mjules
Modérateur
Parle dans le vide
Posté le 01-02-2004 à 15:03:34  profilanswer
 

t'aurais pas oublier l'option permettant de gérer les modules ?


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°399764
neg'gwada
rafix 971
Posté le 01-02-2004 à 15:03:55  profilanswer
 

je vais tester ca, mais pour le son je fais comment parce que les pilotes sont la, alsa aussi et pourtant pas de sons...


---------------
--- WinSplit Revolution ---
n°399766
vanilla
datoune's revival
Posté le 01-02-2004 à 15:05:08  profilanswer
 

Alsa se sert des modules aussi.


---------------
Membre du Front de Libération de Datoune | Soutenez le FLD | A Tribute To Datoune
n°399770
lucaramel
Posté le 01-02-2004 à 15:10:29  profilanswer
 

En même temps, si tu admets que tu ne connais rien à Linux, pourquoi est-ce que tu as voulu modifier un kernel qui marchait très bien pour tout faire foirer ?

n°399775
vanilla
datoune's revival
Posté le 01-02-2004 à 15:15:40  profilanswer
 

Sûrement par curiosité mais la curiosité est un vilain défaut. ;)


---------------
Membre du Front de Libération de Datoune | Soutenez le FLD | A Tribute To Datoune
n°399813
o'gure
Modérateur
Multi grognon de B_L
Posté le 01-02-2004 à 16:22:10  profilanswer
 

lucaramel a écrit :

En même temps, si tu admets que tu ne connais rien à Linux, pourquoi est-ce que tu as voulu modifier un kernel qui marchait très bien pour tout faire foirer ?


comment veux tu qu il apprenne quelque chose a linux si il  ne fait pas de chose risqué dessus... Moi je dis la curiosité c est tres bien... faut l encourager

n°399894
neg'gwada
rafix 971
Posté le 01-02-2004 à 18:19:38  profilanswer
 

vanilla a écrit :

Sûrement par curiosité mais la curiosité est un vilain défaut. ;)

effectivement c'est par curieusité :)  mais c'est en se plantant qu'on apprend c'est comme les maths  ;).
sinon si je passe au kernel 2.6 ca ne va pas regler mon probleme? [:spamafote]


Message édité par neg'gwada le 01-02-2004 à 18:21:21

---------------
--- WinSplit Revolution ---
n°399923
vanilla
datoune's revival
Posté le 01-02-2004 à 18:38:42  profilanswer
 

neg'gwada a écrit :

effectivement c'est par curieusité :)  mais c'est en se plantant qu'on apprend c'est comme les maths  ;).
sinon si je passe au kernel 2.6 ca ne va pas regler mon probleme? [:spamafote]  

:D  
 
Bin si tu compiles ton noyau proprement cad passer du temps à mettre les bons modules qui correspondent à ta carte réseau, à tes filesystems, à tes périphériques, etc et que tu enlèves pas n'importe quoi, ça peut très bien marcher.
 
Qui ne tente rien n'a rien :jap:  
 
http://frlinux.net/?section=systeme&article=110
http://forum.hardware.fr/forum2.ph [...] 55#t386604


---------------
Membre du Front de Libération de Datoune | Soutenez le FLD | A Tribute To Datoune
n°399962
neg'gwada
rafix 971
Posté le 01-02-2004 à 18:54:08  profilanswer
 

ok ce soir je vais me lancer a nouveau de toute facon je n'ai rien a perdre [:spamafote]


Message édité par neg'gwada le 01-02-2004 à 18:54:38

---------------
--- WinSplit Revolution ---
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  gros bugs sous linux apres compilation du noyau

 

Sujets relatifs
un souci sous linux ou unix[ C++ ] Et pourquoi pas de l'objet dans nos chers kernel Linux ?
Noyau Mandrake patché Open Mosix ...Compilation de Programme
Gros problème de rsh : permission denied !Ati remote wonder sous linux
Cygwin et prise de main linux par winXP, ça ne marche pas :(Système SMP sous Linux : vos conseils
compilation de noyau 
Plus de sujets relatifs à : gros bugs sous linux apres compilation du noyau


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR