Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
780 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [TUTO][RESOLU]VMWare Server/debian lenny 2.6.26-1-amd64

 


Sujet(s) à lire :
 

Ce tutorial vous a t'il aidé




Attention si vous cliquez sur "voir les résultats" vous ne pourrez plus voter
Les invités peuvent voter

 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[TUTO][RESOLU]VMWare Server/debian lenny 2.6.26-1-amd64

n°1076843
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 15:34:48  profilanswer
 

[TUTO]
 
Installer Vmware Server 1.0.6 sur une Debian Lenny 2.6.26-1-amd64.
 
AVANT D'INSTALLER VMWARE
 
Avant d’installer VMWare Server, certains paquets doivent être installés sur la machine.
Ces paquets permettent de compiler les modules vmware sans erreur, et donc de faire tourner correctement VMWare Server.  
Ces paquets sont :  
· Make (permet de compiler les modules vmware)
· Gcc  (compilateur c), doit être identique à la version du compilateur du noyau. Dans notre cas, la version était la 4.1.3 (version compatible 4.1). Si vous ne connaissez pas la version à utiliser, installez gcc, et lors de la configuration de vmware, celui-ci vous dira quelle est la version à utiliser.
· Linux-headers-2.6.26-1-amd64 si vous ne connaissez pas votre version de linux, faites un ‘uname –sr’ ensuite il suffira de récupérer les headers correspondants.
· Ia32-libs. Ces librairies sont nécessaires uniquement dans le cas d’un linux 64 bits, comme c’est le cas ici.
 
Voici les commandes réalisées :  

aptitude install make
aptitude install gcc-4.1.
aptitude install linux-headers-2.6.26-1-amd64
aptitude install ia32-libs


Pour gcc-4.1 il s'agit de la version correspondante au compilateur de mon kernel linux. veuillez télécharger la version qui correspond à VOTRE kernel.
 
INSTALLATION BASIQUE
Afin d’installer VMWare server 1.0.6-91891, il faut tout d’abord le télécharger.
Il est disponible au lien suivant : http://download3.vmware.com/softwa [...] 891.tar.gz
Le placer dans un répertoire de travail. Dans notre cas, il à été placé dans le répertoire /home/virt/INSTALLVMWARE/  
 
Voici les commandes à réaliser pour l’installation :

cd /home/virt/INSTALLVMWARE/ ; tar -zxvf VMware-server-1.0.6-91891.tar.gz
cd vmware-server-distrib/ ; ./vmware-install.pl


 
L’installation se lance et plusieurs questions sont posées. Dans notre cas, l’installation par défaut à été faite.

In which directory do you want to install the binary files?
[/usr/bin]
What is the directory that contains the init directories (rc0.d/ to rc6.d/)?
[/etc]
What is the directory that contains the init scripts?
[/etc/init.d]
In which directory do you want to install the daemon files?
[/usr/sbin]
In which directory do you want to install the library files?
[/usr/lib/vmware]
The path "/usr/lib/vmware" does not exist currently. This program is going to
create it, including needed parent directories. Is this what you want?
[yes]
In which directory do you want to install the manual files?
[/usr/share/man]
In which directory do you want to install the documentation files?
[/usr/share/doc/vmware]
The path "/usr/share/doc/vmware" does not exist currently. This program is
going to create it, including needed parent directories. Is this what you want?
[yes]
Before running VMware Server for the first time, you need to configure it by
invoking the following command: "/usr/bin/vmware-config.pl". Do you want this
program to invoke the command for you now? [yes] no


Il faut bien répondre ‘no’ à la dernière question de l’installation. Cela ne servirait à rien de répondre oui car la configuration planterait. Il faut avant patcher les modules vmmon et vmnet.
 
MISE A JOUR VMMON ET VMNET
Plusieurs solutions sont disponible sur Internet pour mettre à jour l’installation de VMWare Server et ainsi compiler sans erreur la configuration. Cependant elles ne fonctionnent pas toutes, notemment la solution d’utiliser les patchs update-any-any-xxx qui permettent de compiler correctement, mais qui empêchent de changer l’état d’une machine virtuelle. Ainsi on ne peut pas démarrer les machines virtuelles, donc rendent l’hyperviseur inutile. La solution trouvée a été de patcher vmmon et vmnet à la main. Pour ce faire, il faut d’abord récupérer les fichiers de patch disponibles aux liens suivants :  
http://www.le-vert.net/divers/VMwa [...] 26-1.patch
http://www.le-vert.net/divers/VMwa [...] 26-1.patch
 
Une fois ces liens téléchargés il faut les placer dans un répertoire de travail. Dans notre cas, nous avons gardé le répertoire /home/virt/INSTALLVMWARE/.
Il faut ensuite récupérer les modules dans le répertoire source de vmware puis les patcher.
Voici les commandes à utiliser.
 
Copier les modules dans le répertoire de travail :

cd /home/virt/INSTALLVMWARE/
cp /usr/lib/vmware/modules/source/vm*.tar ./.


 
Cette commande est valable uniquement si vous avez placé les fichiers de librairie de vmware dans /usr/lib/vmware. Sinon il faudra spécifier le bon répertoire.
 
Ensuite il faut décompresser les modules puis les renommer en backup, afin d’avoir toujours un original au cas où :

tar xvf vmmon.tar; tar xvf vmnet.tar ; mv vmmon.tar vmmon.tar.backup;mv vmnet.tar vmnet.tar.backup


 
Ensuite on peut patcher le module vmmon :  

cd vmmon-only;patch -p1 <../VMware-server-vmmon-1.0.6-91891-2.6.26-1.patch ; cd ..


Le résultat suivant devrait apparaitre :

Citation :

patching file linux/driver.c


 
Puis le module vmnet :  

cd vmnet-only;patch -p1 < ../VMware-server-vmnet-1.0.6-91891-2.6.26-1.patch;cd ..


Le résultat suivant devrait apparaitre :

Citation :

patching file bridge.c
patching file procfs.c
patching file vmnetInt.h


 
Une fois les deux modules patchés, il faut les recompresser au format tar puis les replacer dans le répertoire source de vmware server :

tar cvf vmmon.tar vmmon-only; tar cvf vmnet.tar vmnet-only ; cp -f *.tar /usr/lib/vmware/modules/source/


De la même manière, le repertoire des sources est dans notre cas celui par défaut. Il faut donc spécifier le bon répertoire dans le cas ou les sources sont installées dans un autre répertoire.
 
Les patchs sont maintenant appliqués, on peut donc lancer la configure de VMWare server.
 
 
CONFIGURATION DE VMWARE SERVER
 
Pour lancer la configuration il faut lancer la commande :

vmware-config.pl


 
Tout d’abord, le configurateur demande d’accepter le texte de licence d’utilisateur final. il faut donc appuyer sur <enter> pour l’afficher.
Afin de gagner du temps, on peut taper ‘q’ pour quitter la lecture du document. Le configurateur demande alors si on accepte la licence. répondre ‘yes’.
 
Ensuite plusieurs questions sont posées. Dans notre cas, l’installation par défaut à été faite :

In which directory do you want to install the mime type icons?
[/usr/share/icons]
What directory contains your desktop menu entry files? These files have a
.desktop file extension. [/usr/share/applications]
In which directory do you want to install the application's icon?
[/usr/share/pixmaps]


 
Lors de la configuration, VMWare va essayer de détecter un module précompilé, qui n’existe pas encore. Il va donc avoir besoin d’un compilateur pour en créer un. C’est à cet endroit que le package gcc est sollicité. Il faudra surement definir l’emplacement de gcc à la main.
 

Trying to find a suitable vmmon module for your running kernel.
 
None of the pre-built vmmon modules for VMware Server is suitable for your
running kernel.  Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]
 
Setup is unable to find the "gcc" program on your machine.  Please make sure it
is installed.  Do you want to specify the location of this program by hand?
[yes]
 
What is the location of the "gcc" program on your machine? /usr/bin/gcc-4.1


 
Le configurateur demande ensuite les emplacement des librairies avant de pouvoir compiler :
 

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.26-1-amd64/build/include]


 
Le résultat suivant devrait apparaitre (compilation de vmmon) :
 

Citation :

Building the vmmon module.
 
Using 2.6.x kernel build system.
make: entrant dans le répertoire « /tmp/vmware-config0/vmmon-only »
make -C /lib/modules/2.6.26-1-amd64/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. mod                ules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.26-1-amd64 »
  CC [M]  /tmp/vmware-config0/vmmon-only/linux/driver.o
  CC [M]  /tmp/vmware-config0/vmmon-only/linux/hostif.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/cpuid.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/hash.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/memtrack.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/phystrack.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/task.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/vmx86.o
  CC [M]  /tmp/vmware-config0/vmmon-only/vmcore/moduleloop.o
  LD [M]  /tmp/vmware-config0/vmmon-only/vmmon.o
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: modpost: missing MODULE_LICENSE() in /tmp/vmware-config0/vmmon-only/vmmon.o
see include/linux/module.h for more information
  CC      /tmp/vmware-config0/vmmon-only/vmmon.mod.o
  LD [M]  /tmp/vmware-config0/vmmon-only/vmmon.ko
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.26-1-amd64 »
cp -f vmmon.ko ./../vmmon.o
make: quittant le répertoire « /tmp/vmware-config0/vmmon-only »
The module loads perfectly in the running kernel.


 
Après compilation, le configurateur demande des informations sur les machines virtuelles. La configuration à été faite par défaut :
 

Do you want networking for your virtual machines? (yes/no/help) [yes]
 
Configuring a bridged network for vmnet0.
 
Your computer has multiple ethernet network interfaces available: eth0, eth1.
Which one do you want to bridge to vmnet0? [eth0]
 
The following bridged networks have been defined:
 
. vmnet0 is bridged to eth0
 
Do you wish to configure another bridged network? (yes/no) [no]
 
Do you want to be able to use NAT networking in your virtual machines? (yes/no)
[yes]
 
Configuring a NAT network for vmnet8.
 
Do you want this program to probe for an unused private subnet? (yes/no/help)
[yes]
 
Probing for an unused private subnet (this can take some time)...
 
The subnet 172.16.83.0/255.255.255.0 appears to be unused.
 
The following NAT networks have been defined:
 
. vmnet8 is a NAT network on private subnet 172.16.83.0.
 
Do you wish to configure another NAT network? (yes/no) [no]
 
Do you want to be able to use host-only networking in your virtual machines?
[yes]
 
Configuring a host-only network for vmnet1.
 
Do you want this program to probe for an unused private subnet? (yes/no/help)
[yes]
 
Probing for an unused private subnet (this can take some time)...
 
 
The subnet 192.168.124.0/255.255.255.0 appears to be unused.
 
The following host-only networks have been defined:
 
. vmnet1 is a host-only network on private subnet 192.168.124.0.
 
Do you wish to configure another host-only network? (yes/no) [no]


 
Le résultat suivant devrait apparaitre (compilation de vmnet) :

Citation :

Extracting the sources of the vmnet module.
 
Building the vmnet module.
 
Using 2.6.x kernel build system.
make: entrant dans le répertoire « /tmp/vmware-config0/vmnet-only »
make -C /lib/modules/2.6.26-1-amd64/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.26-1-amd64 »
  CC [M]  /tmp/vmware-config0/vmnet-only/driver.o
  CC [M]  /tmp/vmware-config0/vmnet-only/hub.o
  CC [M]  /tmp/vmware-config0/vmnet-only/userif.o
  CC [M]  /tmp/vmware-config0/vmnet-only/netif.o
  CC [M]  /tmp/vmware-config0/vmnet-only/bridge.o
  CC [M]  /tmp/vmware-config0/vmnet-only/procfs.o
  CC [M]  /tmp/vmware-config0/vmnet-only/smac_compat.o
  SHIPPED /tmp/vmware-config0/vmnet-only/smac_linux.x86_64.o
  LD [M]  /tmp/vmware-config0/vmnet-only/vmnet.o
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: modpost: missing MODULE_LICENSE() in /tmp/vmware-config0/vmnet-only/vmnet.o
see include/linux/module.h for more information
  CC      /tmp/vmware-config0/vmnet-only/vmnet.mod.o
  LD [M]  /tmp/vmware-config0/vmnet-only/vmnet.ko
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.26-1-amd64 »
cp -f vmnet.ko ./../vmnet.o
make: quittant le répertoire « /tmp/vmware-config0/vmnet-only »
The module loads perfectly in the running kernel.


 
Après ça, le configurateur tente de configurer vmPerl, dont nous n’avons pas besoin.
néanmoins des questions sont posées :  
 

Please specify a port for remote console connections to use [902]


 
Le résultat suivant doit apparaitre :  
 

Citation :

Configuring the VMware VmPerl Scripting API.
 
Building the VMware VmPerl Scripting API.
 
Using compiler "/usr/bin/gcc-4.1". Use environment variable CC to override.
 
Unable to compile the VMware VmPerl Scripting API.
 
********
The VMware VmPerl Scripting API was not installed.  Errors encountered during
compilation and installation of the module can be found here:
/tmp/vmware-config0
 
You will not be able to use the "vmware-cmd" program.
 
Errors can be found in the log file:
'/tmp/vmware-config0/control-only/make.log'
********
 
Hit enter to continue.


 
Enfin, le configurateur pose encore quelques questions avant de se terminer :
 

In which directory do you want to keep your virtual machine files?
[/var/lib/vmware/Virtual Machines]
 
The path "/var/lib/vmware/Virtual Machines" does not exist currently. This
program is going to create it, including needed parent directories. Is this
what you want? [yes]
 
Please enter your 20-character serial number.
 
Type XXXXX-XXXXX-XXXXX-XXXXX or 'Enter' to cancel:


 
Une fois la clé insérée, le résultat suivant apparait, puis le configurateur se termine :

Citation :

Starting VMware services:
   Virtual machine monitor                                             done
   Virtual ethernet                                                    done
   Bridged networking on /dev/vmnet0                                   done
   Host-only networking on /dev/vmnet1 (background)                    done
   Host-only networking on /dev/vmnet8 (background)                    done
   NAT service on /dev/vmnet8                                          done
 
The configuration of VMware Server 1.0.6 build-91891 for Linux for this running
kernel completed successfully.


 
Ces résultats montrent que les services se sont bien lancés, et donc que VMWare Server est opérationnel.
 
Merci à M300A pour l'aide fournie.
 
En espérant que ce petit tuto vous aura satisfait (répondez au sondage ^^)
 
 
 
 
 
 
MESSAGE ORIGINAL
Bonjour,
 
J'ai installé un VMWare server sur un serveur Linux Debian lenny 2.6.26-1-amd64 :  
voir sujet correspondant : Sujet créé précédemment
 
Aujourd'hui la version de vmware server est une 1.0.6-91891, et avant de lancer le script de config de vmware (vmware-config.pl) et ai suivi la procédure dispo sur netou  
en gros :  

  • Install de vmware server sans lancer le fichier de config.
  • Récupération de vmmon.tar et vmnet.tar depuis /usr/lib/vmware/modules/source/ dans un repertoire temp
  • tar xvf vmmon.tar; tar xvf vmnet.tar
  • Récupération des patchs depuis le site de paldo : Patch Vmmon pour kernel 2.6.26 et Patch Vmnet pour kernel 2.6.26
  • application des patchs :  patch -p1 < ../VMware-server-vmmon-1.0.6-91891-2.6.26-1.patch (j'ai eu tout bon)
  • patch -p1 < ../VMware-server-vmnet-1.0.6-91891-2.6.26-1.patch et la j'ai eu des erreurs :  

patching file bridge.c
Hunk #1 FAILED at 274.
1 out of 1 hunk FAILED -- saving rejects to file bridge.c.rej
patching file procfs.c
patching file vmnetInt.h
Hunk #1 FAILED at 63.
Hunk #2 FAILED at 89.
2 out of 2 hunks FAILED -- saving rejects to file vmnetInt.h.rej


 
Du coup après recréation des archives, réinjection dans /usr/lib/vmware/modules/source/ et lancement du vmware-config.pl : j'ai le problème de compilation présent ici.
 
Donc j'ai appliqué le patch-any-any-117d ça compile tout bien, et je peux lancer VMWare Server. Sauf que :  
 
Aujourd'hui j'ai créé une machine de test, elle se crée correctement, mais je ne peux pas changer l'état de la machine. Donc ne peux pas la démarrer.
 
voici le message d'erreur que j'ai :  
http://www.imagefreehost.com/files/25092008/zg1248484567.jpeg
 
Dans le doute je suis allé voir les logs, et voici l'erreur en question :  

Sep 25 15:14:35: vmx| Log for VMware Server pid=6481 version=1.0.6 build=build-91891 option=Release
Sep 25 15:14:35: vmx| Command line: "/usr/lib/vmware/bin/vmware-vmx" "-C" "-@" """" "/tmp/test/Windows XP Professional.vmx"
Sep 25 15:14:35: vmx| vmxvmdb: Index name being generated from config file
Sep 25 15:14:35: vmx| VMXVmdbConnectServerd - Trying to discover serverd
Sep 25 15:14:35: vmx| MStat: Creating Stat system.cpuusage
Sep 25 15:14:35: vmx| MStat: Creating Stat system.ram
Sep 25 15:14:35: vmx| MStat: Creating Stat system.uptime
Sep 25 15:14:35: vmx| MStat: Creating Stat system.load
Sep 25 15:14:35: vmx| Msg_Post: Error
Sep 25 15:14:35: vmx| [msg.vmmonPosix.badVersion] Version mismatch with vmmon module: expecting 138.0, got 168.0.
Sep 25 15:14:35: vmx| [msg.vmmonPosix.badDriver] You have an incorrect version of the `vmmon' kernel module.
Sep 25 15:14:35: vmx| Try reinstalling VMware Server.
Sep 25 15:14:35: vmx| ----------------------------------------
Sep 25 15:14:35: vmx| POST(no connection): Version mismatch with vmmon module: expecting 138.0, got 168.0.
Sep 25 15:14:35: vmx| You have an incorrect version of the `vmmon' kernel module.
Sep 25 15:14:35: vmx| Try reinstalling VMware Server.
Sep 25 15:14:35: vmx|
Sep 25 15:14:35: vmx| Msg_Post: Error
Sep 25 15:14:35: vmx| [msg.vmmonPosix.initFailed] Failed to initialize monitor device.
Sep 25 15:14:35: vmx| ----------------------------------------
Sep 25 15:14:35: vmx| POST(no connection): Failed to initialize monitor device.
Sep 25 15:14:35: vmx|
Sep 25 15:14:35: vmx| Module VMMon initialization failed.
Sep 25 15:14:35: vmx| Flushing VMX VMDB connections
Sep 25 15:14:35: vmx| Failed to initialize VM.


 
Les lignes les plus intéressantes sont bien entendu :  

[msg.vmmonPosix.badDriver] You have an incorrect version of the `vmmon' kernel module.
POST(no connection): Version mismatch with vmmon module: expecting 138.0, got 168.0.
You have an incorrect version of the `vmmon' kernel module.


Globalement c'est ce qui m'a permis de faire mes recherches avec google mon ami.
 
En cherchant sur gougueule les erreurs correspondantes, ça me ramène toujours à la solution tentée précédemment qui merde avec le vmnet.  
Bref en règle générale il faut pas lancer le patch any any ça fait merder le truc.
 
Je suis donc toujours bloqué ...
 
Des idées ?
 
Cordialement,
 
Nicolas.


Message édité par nixnbk le 29-09-2008 à 11:11:33

---------------
I'll feed your skin snacks to my cockatiel!
mood
Publicité
Posté le 25-09-2008 à 15:34:48  profilanswer
 

n°1076846
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 25-09-2008 à 15:42:06  profilanswer
 

vmware-any-any foireux.

n°1076848
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 15:46:42  profilanswer
 

oui apparemment, sauf que pour l'instant y a que avec ça que j'arrive à compiler vmmon. :o


---------------
I'll feed your skin snacks to my cockatiel!
n°1076849
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 25-09-2008 à 15:47:13  profilanswer
 

Oé mais il est foireux, cherche en un autre :D

n°1076850
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 25-09-2008 à 15:50:14  profilanswer
 

Allez je suis sympa
http://www.le-vert.net/divers/VMwa [...] 26-1.patch
http://www.le-vert.net/divers/VMwa [...] 26-1.patch
 
Les patches la marchent bien, mais faut aller trouver les vmmon.tar et vmnet.tar, les patcher avec ça, puis recréer le tarbal et lancer vmware-config.pl standard.

n°1076853
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 15:56:14  profilanswer
 

essayé le vmware-any-any-116-josemaX.tar.gz => compile pas
 
vais tenter d'autres...


---------------
I'll feed your skin snacks to my cockatiel!
n°1076856
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 16:00:16  profilanswer
 

M300A a écrit :

Allez je suis sympa
http://www.le-vert.net/divers/VMwa [...] 26-1.patch
http://www.le-vert.net/divers/VMwa [...] 26-1.patch
 
Les patches la marchent bien, mais faut aller trouver les vmmon.tar et vmnet.tar, les patcher avec ça, puis recréer le tarbal et lancer vmware-config.pl standard.


 
Déja essayé :  
quand je patch le vmnet j'ai ça :  

patch -p1 < ../VMware-server-vmnet-1.0.6-91891-2.6.26-1.patch
 
 
patching file bridge.c
Hunk #1 FAILED at 274.
1 out of 1 hunk FAILED -- saving rejects to file bridge.c.rej
patching file procfs.c
patching file vmnetInt.h
Hunk #1 FAILED at 63.
Hunk #2 FAILED at 89.
2 out of 2 hunks FAILED -- saving rejects to file vmnetInt.h.rej



---------------
I'll feed your skin snacks to my cockatiel!
n°1076857
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 25-09-2008 à 16:00:27  profilanswer
 

Tu as vu ce que j'ai dit quand même ? :D

n°1076858
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 16:00:52  profilanswer
 

ou alors la commande patch -p1 n'est pas correcte :/


---------------
I'll feed your skin snacks to my cockatiel!
n°1076859
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 25-09-2008 à 16:01:06  profilanswer
 

Parce que tu essaye de patcher quelque chose qui a deja été patcher par vmware-any-any.
 
Supprime complètement vmware (vmware-uninstall) puis réinstalle.

mood
Publicité
Posté le 25-09-2008 à 16:01:06  profilanswer
 

n°1076861
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 16:02:05  profilanswer
 

M300A a écrit :

Tu as vu ce que j'ai dit quand même ? :D


oui oui
 
Chuis allé récupéré les tar dans /usr/lib/vmware/modules/source/  
detar  
go dans le sousrep vmmon-only => patch
go dans le sousrep vmnet-only => patch => bug :/


---------------
I'll feed your skin snacks to my cockatiel!
n°1076863
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 16:10:16  profilanswer
 

Marrant :
J'étais sur que j'avais patché le vmmon non updaté avec le any-any.
Pourtant cette fois-ci pas d'erreur au patch et compil OK au config.
 
On va voir pour la suite ^^
 
Je ferai un petit tuto au cas ou ^^
 
Merci pour l'aide encore une fois M300A :D


---------------
I'll feed your skin snacks to my cockatiel!
n°1076867
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 16:27:37  profilanswer
 

Bon ça me fait plus d'erreur, mais à priori quand je démarre une machine virtuelle ça me plombe littéralement le serveur :/

 

Obligé de reboot. (reflexe windows désolé :/)


Message édité par nixnbk le 25-09-2008 à 16:27:52

---------------
I'll feed your skin snacks to my cockatiel!
n°1076871
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 25-09-2008 à 16:56:11  profilanswer
 

Hum. Tu aurais pas Xen, KVM ou un autre truc de virtualisation chargé ?

n°1076873
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 17:07:12  profilanswer
 

AAAH... Ya des chances que KVM tourne également.


---------------
I'll feed your skin snacks to my cockatiel!
n°1076880
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 17:16:42  profilanswer
 

YES

 

C'était ça :)

 

Problème résolu ;)

 

Merci encore.

 

Je fais un tuto en premier post et je termine le topak.


Message édité par nixnbk le 25-09-2008 à 17:17:04

---------------
I'll feed your skin snacks to my cockatiel!
n°1076887
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 25-09-2008 à 17:30:20  profilanswer
 

module kvm + module vmware = problèmes :(

n°1076902
nixnbk
Strip the flesh salt the wound
Posté le 25-09-2008 à 17:50:22  profilanswer
 

c'est bien dommage... Premier post à jour ^^
 
Répondu à mon sondage, voté oui, puisque je l'ai rédigé :D


Message édité par nixnbk le 25-09-2008 à 17:55:04

---------------
I'll feed your skin snacks to my cockatiel!
n°1077374
fighting_f​alcon
Posté le 27-09-2008 à 13:13:26  profilanswer
 

[:drap]
 
Merci beaucoup, je sens que ça va me servir très bientôt ...

n°1077644
nixnbk
Strip the flesh salt the wound
Posté le 29-09-2008 à 11:12:16  profilanswer
 

j'ai mis à jour le tuto pour qu'il soit plus clair.


---------------
I'll feed your skin snacks to my cockatiel!
n°1083377
fighting_f​alcon
Posté le 21-10-2008 à 23:46:57  profilanswer
 

salut,
 
je viens de suivre ton tuto
et comme je suis un peu fou, surtout à cette heure avancée, je me suis dis que j'allais lancé la config sans meme patcher ...
 
résultat, je n'ai "que" ça :

Citation :


  CC [M]  /tmp/vmware-config0/vmmon-only/common/vmx86.o
/tmp/vmware-config0/vmmon-only/common/vmx86.c: In function ‘Vmx86_GetkHzEstimate’:
/tmp/vmware-config0/vmmon-only/common/vmx86.c:1899: warning: passing argument 4 of ‘Div643264’ from incompatible pointer type
/tmp/vmware-config0/vmmon-only/common/vmx86.c:1908: warning: passing argument 4 of ‘Div643232’ from incompatible pointer type


 
j'ai pas encore testé si ça marche, j'éditerai en fonction. Par contre, peux tu expliquer pour tu as patcher tes modules vmware ?

n°1083378
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 21-10-2008 à 23:55:57  profilanswer
 

T'as un kernel plus vieux et les sources de vmware marchent dessus c'est tout :D

n°1083389
fighting_f​alcon
Posté le 22-10-2008 à 07:49:32  profilanswer
 

M300A a écrit :

T'as un kernel plus vieux et les sources de vmware marchent dessus c'est tout :D


 
2.6.24-etchnhalf.1-686  :pt1cable:  
 
Comme je disais ... "en cette heure avancée" ...
pô tapé, merci ...

n°1093569
faty35
Posté le 28-11-2008 à 14:28:03  profilanswer
 

Bonjour à tous (et toutes ?)
 
Je viens de suivre la procédure sur ma machine : debian 2.6.26-1-686
Mais en respectant la version de gcc de l'article.
 
Tout semble bien ... mais quand je lance vmware (via mon terminal car j'ai pas de raccouric sur mon bureau) et que je choisi local host et ouvrir une machine virtuel
 et que l'interface suivante il me demande de choisir la localisation du fichier.
 
Les messages suivants apparaît:
 

Citation :

"Le contenu du dossier ne peut être affiché.  VFS Error:  Paramètres non valides"


 
et en terminal :
 

Citation :


(vmware:4230): libgnomevfs-CRITICAL **: gnome_vfs_uri_to_string: assertion `uri != NULL' failed
 
(vmware:4230): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri != NULL' failed
 
(vmware:4230): libgnomevfs-CRITICAL **: gnome_vfs_uri_to_string: assertion `uri != NULL' failed
 
(vmware:4230): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))
 
(vmware:4230): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))
 
(vmware:4230): libgnomevfs-CRITICAL **: gnome_vfs_uri_to_string: assertion `uri != NULL' failed
 
(vmware:4230): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri != NULL' failed


 
 
Pouvez-vous m'aider ?
Merci
 
 
 

n°1093625
fighting_f​alcon
Posté le 28-11-2008 à 17:03:30  profilanswer
 

si tu n'as pas changer les chemins d'install par défaut, le binaire vmware est dans /usr/bin
 
renommé le vmware.real et crée un script shell vmware avec ce contenu :

Citation :


#!/bin/bash
 
VMWARE_USE_SHIPPED_GTK=yes LD_PRELOAD=/usr/lib/libglib-2.0.so.0 vmware.real $@
 
exit $?

n°1094721
faty35
Posté le 03-12-2008 à 11:00:53  profilanswer
 

Bonjour,
 
Je te remercie d'aider. Malgré le script shell vmware et après l'avoir rendu "executable" (chmod +x vmware)
 
Voici ce que j'obtiens ...  
 
NB: J'avais bien gardé les chameins d'isnall par défaut pourtant...
 
 
/usr/bin# vmware
 
/usr/share/themes/Industrial/gtk-2.0/gtkrc:38: error: unexpected character `@', expected string constant
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb6f7c767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb6f7c8b1]
#2 /usr/lib/libX11.so.6(_XReply+0x254) [0xb7dc0c44]
#3 /usr/lib/vmware/lib/libXrender.so.1/libXrender.so.1(XRenderQueryFormats+0x109) [0xb7cac969]
#4 /usr/lib/vmware/lib/libXrender.so.1/libXrender.so.1(XRenderFindFormat+0x4c) [0xb7cacf4c]
#5 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xb7b7e180]
#6 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xb7b7ed2c]
#7 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0xb7b4ec14]
#8 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xb7b5b24f]
#9 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0xb7b4ec14]
#10 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_pixbuf_render_pixmap_and_mask_for_colormap+0x255) [0xb7b5ab34]
#11 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xb7a5f298]
#12 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xb7a5f586]
#13 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xb7a6177e]
#14 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0xd1) [0xb7c75459]
#15 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0 [0xb7c5d3a1]
#16 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_closure_invoke+0x1b1) [0xb7c5d076]
#17 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0 [0xb7c746eb]
#18 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_signal_emit_valist+0x91e) [0xb7c73d46]
#19 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_signal_emit+0x38) [0xb7c740b8]
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb6f7c767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb6f7c81e]
#2 /usr/lib/libX11.so.6 [0xb7dbfde9]
#3 /usr/lib/libX11.so.6(XAddExtension+0x2c) [0xb7da229c]
#4 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2(_XftDisplayInfoGet+0x77) [0xb7ca4ed7]
#5 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2 [0xb7ca38b1]
#6 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2 [0xb7ca3d39]
#7 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2(XftDrawPicture+0x10) [0xb7ca3ec0]
#8 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xb7b7c9b6]
#9 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xb7b7ed75]
#10 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0xb7b4ec14]
#11 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xb7b5b24f]
#12 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0xb7b4ec14]
#13 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_pixbuf_render_pixmap_and_mask_for_colormap+0x255) [0xb7b5ab34]
#14 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xb7a5f298]
#15 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xb7a5f586]
#16 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xb7a6177e]
#17 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0xd1) [0xb7c75459]
#18 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0 [0xb7c5d3a1]
#19 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_closure_invoke+0x1b1) [0xb7c5d076]
vmware: ../../src/xcb_lock.c:77: _XGetXCBBuffer:  l'assertion « ((int) ((xcb_req) - (dpy->request)) >= 0) » a échoué.
 
 
 
Bien à toi,

n°1094762
fighting_f​alcon
Posté le 03-12-2008 à 14:06:44  profilanswer
 

méfie toi que c'est un script bash, donc il faut pas de CRLF en fin de ligne, mais seulement des LF
 
si tu as fais un copier / coller de ton truc, je serai toi, je le re-taperai caractère par caractère, parce que y'a du y avoir une merde. J'ai re-vérifié et c'est bien ce que j'ai sur mon poste et ça marche nickel (Debian Etch à jour, noyau etch'n'half)

n°1094867
nixnbk
Strip the flesh salt the wound
Posté le 03-12-2008 à 21:25:55  profilanswer
 

En même temps partir de mon tuto prévu pour une lenny en 2.6.26, et l'adapter sur une etch en 2.6.24 :crazy: ...
 
Faut pas s'étonner que ça marche pas. :o
 
Si tu patchs vmmon et vmnet faudrait prendre les fichiers de patch adapté non ?
 
Je répète je suis pas spécialiste linux du tout, donc ça se trouve mon post sert a rien :o (pas mon tuto hein, il marche testé et approuvé sur deux serveurs :o)
 


---------------
I'll feed your skin snacks to my cockatiel!
n°1094905
fighting_f​alcon
Posté le 04-12-2008 à 07:58:17  profilanswer
 

nixnbk > j'ai également suivi ton tuto, et en fait quand on essaie de patcher sur un noyau 2.6.24, ça marche pas (erreurs, fichiers correspondent pas, ...) donc perso me suis dis "on s'en fous, on continue (et on verra bien)" et ça marche tout seul ...
 
donc 2.6.24 => pas besoin de patcher
 
 
Et je précise d'ailleurs que le problème de faty35 n'apparait qu'une fois qu'il a lancer VMWare serveur, donc toute l'install est ok et fonctionne.
C'est juste un pb à la con, connu puisque la soluce je ne l'ai pas pondue moi même mais trouvée par Google sur les forums VMWare

Message cité 1 fois
Message édité par fighting_falcon le 04-12-2008 à 07:59:28
n°1094939
nixnbk
Strip the flesh salt the wound
Posté le 04-12-2008 à 10:21:11  profilanswer
 

fighting_falcon a écrit :

nixnbk > j'ai également suivi ton tuto, et en fait quand on essaie de patcher sur un noyau 2.6.24, ça marche pas (erreurs, fichiers correspondent pas, ...) donc perso me suis dis "on s'en fous, on continue (et on verra bien)" et ça marche tout seul ...
 
donc 2.6.24 => pas besoin de patcher
 
 
Et je précise d'ailleurs que le problème de faty35 n'apparait qu'une fois qu'il a lancer VMWare serveur, donc toute l'install est ok et fonctionne.
C'est juste un pb à la con, connu puisque la soluce je ne l'ai pas pondue moi même mais trouvée par Google sur les forums VMWare


 
Ah OK.
 
Parce qu'en fait (et c'est pas marqué dans mon tuto), quand j'ai installé VMWare j'avais trouvé d'autres patches/solutions pour installer VMWare sans erreurs, Vmware se lançait correctement, mais impossible de changer l'état d'une machine.
 
C'est pour ça, me suis dit que ça pouvait provenir d'un problème de patch qu'était pas adapté pour son noyau.
 
Mais bon si le problème est connu et résolu :).
 
Faty ce qui serait bien, c'est que tu m'indique la solution que tu as utilisée et qui fonctionne pour toi, si possible en détaillant comme mon tuto, que je puisse l'intégrer dans le premier post... :)
 


---------------
I'll feed your skin snacks to my cockatiel!
n°1184381
Conty
Posté le 07-12-2009 à 17:10:54  profilanswer
 

Bonjour, j'ai suivi votre tutoriel d'installation avec les patches, cependant j'ai une erreur affichée :
 
1 concernant la version de mon Gcc
2 lors de la configuration.
 
 
Merci de votre aide.
 
ScreenShot ici : http://img81.imageshack.us/img81/7694/aideaide.jpg

n°1184404
nixnbk
Strip the flesh salt the wound
Posté le 07-12-2009 à 19:01:53  profilanswer
 

a priori ton problème de gcc correspond à cette ligne au début de mon premier post :  
Pour gcc-4.1 il s'agit de la version correspondante au compilateur de mon kernel linux. veuillez télécharger la version qui correspond à VOTRE kernel.  
 
En gros ton noyau a été compilé avec un gcc 4.1.3 or tu cherches à compiler vmware server avec un gcc 4.3.2 => Il faut que tu désinstalle gcc 4.3.2 et que tu réinstalle gcc 4.1.3 => normalement tu n'auras plus l'erreur.
 
Il ya des chances que ton problème de conf derrière soit lié a ton problème de gcc.
 


---------------
I'll feed your skin snacks to my cockatiel!
n°1184600
Conty
Posté le 08-12-2009 à 14:15:09  profilanswer
 

Merci de la réponse.
 
Cependant, j'avais résolu le problème avant de voir le post.
 
J'ai désinstallé gcc-4.3
apt-get remove gcc-4.3
 
Puis ça a fonctionné.
 
PS:ne pas désinstaller gcc-4.3-base !!!!!
 
En fait, il voulait utiliser seulement gcc-4.3 pour la compilation ... malgré que j'eusse gcc-4.1 déjà installer. Je ne pouvais pas choisir le compilateur que je désirai.
 
 
Au passage, tuto NIQUEL !
 
 
 
J'ai installé VMware Server 2.0.2 ; Je n'ai pas eu a patché quoi que ce soit ; ma version étant Linux 2.6.26-2-686 Lenny 5.0 stable.


Message édité par Conty le 08-12-2009 à 14:17:34
n°1184712
nixnbk
Strip the flesh salt the wound
Posté le 08-12-2009 à 19:06:31  profilanswer
 

merci :jap: :)
 
Oui ya des chance qu'il n'y ait pas de patch a faire sur les dernières versions, après tout ce tuto à 1 an ;)


---------------
I'll feed your skin snacks to my cockatiel!
n°1192998
sierramike
Posté le 17-01-2010 à 13:45:18  profilanswer
 

Je vais apporter ma petite contribution : j'ai suivi ce tuto avec succès sur une Debian Lenny 5.0.3 32bits, kernel 2.6.26-2-686 avec un VMware 1.0.10-203137 (la dernière version de la série 1 à ce jour), les patchs fonctionnent, ça compile, ça démarre et on peut changer l'état des machines virtuelles (allumer/éteindre).
 
Ceci dit, pour Conty, j'ai deux petits points à apporter :
1) pas besoin de désinstaller gcc-4.3, il suffit de faire un export CC=gcc-4.1 avant d'appeler le script vmware-config.pl (ou avant de lancer l'installation d'ailleurs ;) ), et le script utilisera la bonne version de gcc (il y a une variante dans certains tutos où ils suppriment le link "gcc" pour en créer un nouveau (ln -s) qui pointe vers gcc-4.1, ça marche aussi, l'ennui c'est qu'il faut penser à remettre le bon lien après, alors qu'avec l'export le script sait lui même quoi faire ...
 
2) VMware Server 2.0.2 est effectivement très bien, mais dans mon cas sur un kernel 2.6.26-2-686, j'ai tout de même eu un patch à appliquer pour que ça compile le module vsock, et j'ai un énorme problème : impossible de stocker les VM (ou plutôt un datastore) sur une autre partition que la partition principale "/", sinon ça fait planter le webaccess. J'ai aussi été obligé d'upgrader le jre qui est fourni avec le webaccess pour éviter une montagne d'erreurs "http 0" ...
 
Donc dans mon cas, au moins la version 1 fonctionne en mettant les VM sur une autre partition, mais il manque une fonction qui a été ajoutée à la version 2 : la possibilité de faire un "suspend" sur les VM lors du reboot de l'hôte, ici on n'a le choix qu'entre une extenction bestiale et une extinction "polie" demandée à l'OS invité ...
 
Bref merci pour ce tuto excellent et qui fonctionne ! Mais moi je reste sur ma faim concernant VMware sous Linux ...

n°1193067
nixnbk
Strip the flesh salt the wound
Posté le 17-01-2010 à 20:32:21  profilanswer
 

toutes façons sur linux je pense qu'il vaut mieux faire tourner du xen que du VMWare. Ou alors abandonner l'idée d'un tux et mettre directement un ESXi en bare metal. c'est encore la meilleure solution.


---------------
I'll feed your skin snacks to my cockatiel!
n°1193117
sierramike
Posté le 18-01-2010 à 00:34:07  profilanswer
 

C'est pas faux, mais d'un côté j'ai déjà plusieurs machines qui fonctionnent avec VMware et j'aimerais rester sur la même techno pour le côté pratique de pouvoir déplacer/copier facilement une VM d'une machine à une autre ...
 
Quant à ESXi, c'est très séduisant sur le papier, mais d'une part ça fait maintenant 2 serveurs IBM sur lesquels l'installation d'ESXi se bloque en plein milieu sans explications (j'ai dû céder à l'install d'un W2K3 server car c'était urgent), et en l'occurence dans le cas présent il s'agit de recycler un vieux PC avec 512Mo de ram pour en faire un NAS avec du RAID5 soft (hors grosse entreprise qui a les moyens je ne veux plus entendre parler de RAID hard, trop d'emmerdes en cas de crash contrôleur), et juste pouvoir monter une petite VM dessus pour des besoins ponctuels ...
 
Mais il est clair que pour moi, en environnement professionnel, VMware sur Linux je ne me risquerai jamais à faire ça ...

n°1193288
nixnbk
Strip the flesh salt the wound
Posté le 18-01-2010 à 16:33:53  profilanswer
 

sierramike a écrit :

C'est pas faux, mais d'un côté j'ai déjà plusieurs machines qui fonctionnent avec VMware et j'aimerais rester sur la même techno pour le côté pratique de pouvoir déplacer/copier facilement une VM d'une machine à une autre ...
 
Quant à ESXi, c'est très séduisant sur le papier, mais d'une part ça fait maintenant 2 serveurs IBM sur lesquels l'installation d'ESXi se bloque en plein milieu sans explications (j'ai dû céder à l'install d'un W2K3 server car c'était urgent), et en l'occurence dans le cas présent il s'agit de recycler un vieux PC avec 512Mo de ram pour en faire un NAS avec du RAID5 soft (hors grosse entreprise qui a les moyens je ne veux plus entendre parler de RAID hard, trop d'emmerdes en cas de crash contrôleur), et juste pouvoir monter une petite VM dessus pour des besoins ponctuels ...
 
Mais il est clair que pour moi, en environnement professionnel, VMware sur Linux je ne me risquerai jamais à faire ça ...


pour l'install d'esxi ça m'étonne qu'a moitié, ils disent que ça marche sur de la blackbox mais ils fournissent quand même la liste des matériels supportés.


---------------
I'll feed your skin snacks to my cockatiel!
n°1193328
sierramike
Posté le 18-01-2010 à 18:16:23  profilanswer
 

C'est pas faux. Ceci dit, un VMware Server 1.0 en l'occurence m'irait tout aussi bien dans la situation qui me préoccupe, la seule chose qui me gêne est l'impossibilité de paramétrer un "suspend" des VM au moment de rebooter (ou éteintre) l'hôte. N'aurais-tu pas une idée de petit script bash pour lancer des suspend "à la main" qu'il suffirait de placer dans le bon /etc/rcX.d pour que ça comble cette lacune ?

n°1193419
sierramike
Posté le 19-01-2010 à 02:10:12  profilanswer
 

Je me réponds à moi même : j'ai placé sur mon post initial la soluce que j'ai trouvée, pour scripter l'état "suspend" en cas de reboot ou shutdown de l'hôte :
http://forum.hardware.fr/hfr/OSAlt [...] m#t1193418
 
En espérant que ça puisse servir à quelqu'un !

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [TUTO][RESOLU]VMWare Server/debian lenny 2.6.26-1-amd64

 

Sujets relatifs
Réseau Wifi non détecté sous Debian Lennysamba + windows server 2003
Configuration du firewall sous DebianDual Boot Vista - Debian
[RESOLU]install VmWare server sur debian lenny 2.6.26-1-amd64 
Plus de sujets relatifs à : [TUTO][RESOLU]VMWare Server/debian lenny 2.6.26-1-amd64


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR