Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1706 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Proftpd] Problème à l'installation

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Proftpd] Problème à l'installation

n°485142
benj63
Posté le 24-05-2004 à 10:40:07  profilanswer
 

Bonjour,
 
Je suis en train d'essayer d'installer ProFTPd sur un serveur sous RedHat 9.
 
J'ai téléchargé la dernière version de ProFTPd sur leur site, et lorsque je tente de faire rpm -i proftpd-1.2.9-1.9.i386.rpm, j'obtiens :
 

error: failed dependencies:
        libc.so.6(GLIBC_2.3)   is needed by proftpd-1.2.9-1.9
        libcrypto.so.4   is needed by proftpd-1.2.9-1.9
        libssl.so.4   is needed by proftpd-1.2.9-1.9


 
J'ai regardé avec un rpm -qa, mes librairies semblent être installées (les fichiers se trouvent dans le répertoire /lib).  :sweat: Que faire ??
 
Merci par avance...

mood
Publicité
Posté le 24-05-2004 à 10:40:07  profilanswer
 

n°485492
benj63
Posté le 24-05-2004 à 18:03:37  profilanswer
 

:bounce:

n°485493
bobuse
Posté le 24-05-2004 à 18:07:06  profilanswer
 

t'es sur ?
ça donne quoi ça :
rpm -qa | grep -E "glibc|libopenssl"

n°485898
benj63
Posté le 25-05-2004 à 08:30:26  profilanswer
 

ça me donne ça :
 

glibc-2.2.5-39
glibc-devel-2.2.5-39
glibc-kernheaders-2.4-7.16
compat-glibc-6.2-2.1.3.2
glibc-common-2.2.5-39


 
Est-ce qu'il manque des choses ?
 
Je précise, je suis assez newbie en Linux...

n°485904
VenerZen
M - D - M
Posté le 25-05-2004 à 09:02:42  profilanswer
 

la glib en 2.3 et pas en 2.2.5 peut-être ?
Tes problèmes semblent venir du fait que les paquets que tu as installé sont trop anciens pour satisfaire les dépendances de proftp.

n°485906
benj63
Posté le 25-05-2004 à 09:04:17  profilanswer
 

J'utilise d'autres logiciels avec ces librairies, pensez-vous que ce soit génant si je mets la 2.3 ? Ou tout va planter ?

n°485908
bobuse
Posté le 25-05-2004 à 09:07:27  profilanswer
 

non mais attends, il y a bien un rpm de proftpd qui est fourni avec la RedHat 9 !!
C'est celui là qu'il te faut :)
Ca sert à ça une distrib !
Si tu essaies d'installer un rpm plus récent que la distrib, c'est clair que tu as un risque d'obslescence de tes libs !

n°485910
VenerZen
M - D - M
Posté le 25-05-2004 à 09:09:05  profilanswer
 

Non je dirai, mais je dois avouer que je ne m'étais jamais posé cette question.  
Il n'y a pas un apt-get pour redhat ? tu te ferais moin chié avec les dépendances.

n°486853
benj63
Posté le 26-05-2004 à 09:55:53  profilanswer
 

:sweat: Bon finalement c'était beaucoup plus simple qu'il n'y paraissait...
 
 
J'ai fait un :
 

cat /etc/redhat-release


 
...pour connaître ma distribution de Linux : RedHat 7.3
 
J'ai téléchargé la version correspondante de ProFTP... et ça semble marcher.
 
 
Pour info, le ProFTPd de RedHat 7.3 :
 
http://ftp.freshrpms.net/pub/fresh [...] 3/proftpd/
 
 
Merci pour vos conseils !


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Proftpd] Problème à l'installation

 

Sujets relatifs
installation XPVMInstallation Debian : erreur fatale a cause d'apt-utils
Installation en GRP de la GentooProbleme boot sur Win avec lilo...
[OpenOffice] Problème de correction orthographique....Installation Bewans ADSL ST sous Debian
d-link g604T + ethernet (travelmate)+ MDK 10 problème de DNSProbleme LINUX (Knoppix)
probleme codec mplayer?Probléme avec Squid
Plus de sujets relatifs à : [Proftpd] Problème à l'installation


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR