Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2500 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [(pas)RESOLU]Comment installer compiz sur debian testing ?

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[(pas)RESOLU]Comment installer compiz sur debian testing ?

n°1100289
l0g4n
Proxmox&Beer
Posté le 27-12-2008 à 11:35:27  profilanswer
 

Bonjour,
Alors, vu comme sa, forcément, on pense à un n00b, mais non.
Ou si, peut être...
Enfin, tout en est que je cherche à installer Compiz fusion sur ma debian testing netinstall ( donc quasiment rien d'installer, Xorg, openbox, pypanel, iceweasel toussa )
bah oui mais, au lancement, compiz me dit ( je cite : ) Checking for Xgl: not present.  :fou:  et X se coupe.
Bon, bah on install Xgl.... ;)  
Ah :??: il est pas dans les dépots ?
Bon, on trouve un dépots communiste de l'ex-URSS avec xgl dedans ( autistici en locurence ), on relance compiz et la, même problème, Checking for Xgl: not present. et X qui se coupe.
Mon Xorg.conf :

Code :
  1. # xorg.conf (X.Org X Window System server configuration file)
  2. #
  3. # This file was generated by dexconf, the Debian X Configuration tool, using
  4. # values from the debconf database.
  5. #
  6. # Edit this file with caution, and see the xorg.conf manual page.
  7. # (Type "man xorg.conf" at the shell prompt.)
  8. #
  9. # This file is automatically updated on xserver-xorg package upgrades *only*
  10. # if it has not been modified since the last upgrade of the xserver-xorg
  11. # package.
  12. #
  13. # If you have edited this file but would like it to be automatically updated
  14. # again, run the following command:
  15. #   sudo dpkg-reconfigure -phigh xserver-xorg
  16. Section "InputDevice"
  17.    Identifier   "Generic Keyboard"
  18.    Driver      "kbd"
  19.    Option      "XkbRules"   "xorg"
  20.    Option      "XkbModel"   "pc105"
  21.    Option      "XkbLayout"   "fr"
  22.    Option      "XkbVariant"   "latin9"
  23.    Option      "XkbOptions"   "lv3:ralt_switch"
  24. EndSection
  25. Section "InputDevice"
  26.    Identifier   "Configured Mouse"
  27.    Driver      "mouse"
  28. EndSection
  29. Section "Device"
  30.    Identifier   "Configured Video Device"
  31. EndSection
  32. Section "Monitor"
  33.    Identifier   "Configured Monitor"
  34. EndSection
  35. Section "Screen"
  36.    Identifier   "Default Screen"
  37.    Monitor      "Configured Monitor"
  38. EndSection


 
Voila, donc si quelqu'un sait comment faire fonctionner Xgl et compiz, je précise que j'ai une carte intel ( gma950 ) et que le direct rendering est activé


Message édité par l0g4n le 28-12-2008 à 14:43:29

---------------
Le mieux n'est pas de savoir, c'est que les autres pensent que tu saches, après tu peux enfin apprendre !
mood
Publicité
Posté le 27-12-2008 à 11:35:27  profilanswer
 

n°1100291
roll68
Posté le 27-12-2008 à 12:03:14  profilanswer
 

euh il n'y a pas une autre erreur? parce que c'est normal qu'il dise ça de toute façon t'as pas besoin de Xgl, vire ça tout de suite  :o

n°1100292
l0g4n
Proxmox&Beer
Posté le 27-12-2008 à 12:12:28  profilanswer
 

Bah oui, mais c'est le seul message d'erreur explicite, après X se coupe, donc bon, je veux bien virer Xgl m'enfin, il lui faut quoi à compiz-fusion pour tourner ? ( a part les dépendances ? )
Histoire de faire un truc complet, compiz me sort ( et tue X juste après ) :

Code :
  1. Checking for Xgl: not present.
  2. Detected PCI ID for VGA: 00:02.0 0300: 8086:27a2 (rev 03) (prog-if 00 [VGA controller])
  3. Checking for texture_from_pixmap: not present.
  4. Trying again with indirect rendering:
  5. Checking for texture_from_pixmap: present.
  6. Checking for non power of two support: present.
  7. Checking for Composite extension: present.
  8. Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
  9. Checking for nVidia: not present.
  10. Checking for FBConfig: present.
  11. Checking for Xgl: not present.


EDIT : si je lance compiz en root, sa marcherar ptete mieux non ?  :??:


Message édité par l0g4n le 27-12-2008 à 12:33:16
n°1100298
l0g4n
Proxmox&Beer
Posté le 27-12-2008 à 13:13:52  profilanswer
 

Re-post, après lecture de http://www.numerama.com/forum/inde [...] opic=84487, j'ai mis le dépots kivabien, puis installé le dernier compiz ( 0.7.9 ou un truc du genre ) mais toujours le même problème : X se coupe et je me retrouve en ligne de commandes. :fou:  
Je suis en train de faire une mise à jour ( 200mo, j'avait pas vu  :whistle:  ) on verra si sa viens de là.
Je crois vraiment qu'un tuto pour installer compiz sur testing ne serait pas inutile ( le plus récent date de 2006  :pt1cable: )


---------------
Le mieux n'est pas de savoir, c'est que les autres pensent que tu saches, après tu peux enfin apprendre !
n°1100309
roll68
Posté le 27-12-2008 à 14:10:48  profilanswer
 

non ne le lance pas en root.

 

Si tu veux un message d'erreur plus complet va voir dans /var/log/Xorg.0.log. les erreurs commencent par (EE).

 

EDIT: en plus compiz étant dans les dépôts officiels, je vois pas pourquoi tu es obligé d'en rajouter (à par pour le plaisir d'avoir la dernière version mais bon ...).


Message édité par roll68 le 27-12-2008 à 14:13:09
n°1100311
l0g4n
Proxmox&Beer
Posté le 27-12-2008 à 14:53:07  profilanswer
 

Emerald demandais la version 0.7.9, je ne disposait que de la 0.7.x ( avec x<9) donc plutot que de jouer avec dpkg...
Bon, le Xorg.0.log ne contient aucune ligne commençant par (EE)... :sol:  
Je termine ma mise à jour, et je retente, en espérant avoir une erreur dans le log de X.
J'ai l'impression que compiz demande à Xorg de se fermer  :pt1cable:  


---------------
Le mieux n'est pas de savoir, c'est que les autres pensent que tu saches, après tu peux enfin apprendre !
n°1100340
l0g4n
Proxmox&Beer
Posté le 27-12-2008 à 18:53:48  profilanswer
 

Je Up :
alors, mises à jours faites, plus d'erreurs de compiz, ni de Xorg, tout est normal...
Sauf que, quand je lance "compiz", il m'indique " There is already the openbox win manager running, you should use the --replace option to override it"
Bon, d'accord, compiz --replace
Et la, X se ferme ?! je me retrouve sur tty1...

n°1100447
roll68
Posté le 28-12-2008 à 11:27:29  profilanswer
 

Ah d'accord tout s'explique  :o  
 
Compiz et Openbox ça va pas ensemble.

n°1100450
lebibi
Notre torture c'est la tourtel
Posté le 28-12-2008 à 11:56:00  profilanswer
 

Compiz est fait pour fonctionner avec Gnome et KDE à ma connaissance.


---------------

n°1100473
roll68
Posté le 28-12-2008 à 13:05:29  profilanswer
 

et XFCE  :jap:

mood
Publicité
Posté le 28-12-2008 à 13:05:29  profilanswer
 

n°1100474
Fork Bomb
Obsédé textuel
Posté le 28-12-2008 à 13:23:06  profilanswer
 

lebibi a écrit :

Compiz est fait pour fonctionner avec Gnome et KDE à ma connaissance.


le driver proprio  [:aloy]  
Pour Intel, je ne sais pas.


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1100489
l0g4n
Proxmox&Beer
Posté le 28-12-2008 à 14:42:01  profilanswer
 

Bon, ben, je suis bon pour abandonner...
Le driver développé pour Intel est libre et dans les dépots...
Je croit que la solution est la : compiz ne fonctionne qu'avec XFCE, Gnome et KDE...
Tant pis...


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [(pas)RESOLU]Comment installer compiz sur debian testing ?

 

Sujets relatifs
[Résolu]Samba/WebDAV + LDAP[RESOLU] Compte hotmail sur thunderbird
installer un prog sur linux sur aspire one[Resolu] ]Raid 1 soft (mdadm) 2 * 1To = 871Go ?
Installation Carte Réseau Netgear Fa311 Debian (lspci non reconnu)[Résolu] Besoin d'aide : récupérer fichier sur un serveur
[RESOLU] J'ai perdu les liens symboliques /dev/cdrom et /dev/dvdkitchensync KDE 4 ne veut plus s'installer {Gentoo} [Résolu]
problème VPN PPTP sur Debian 
Plus de sujets relatifs à : [(pas)RESOLU]Comment installer compiz sur debian testing ?


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR