Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2181 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [RESOLU] Putty problèmes affichage caractères

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[RESOLU] Putty problèmes affichage caractères

n°960886
Drix75
Posté le 05-10-2007 à 10:35:07  profilanswer
 

Bonjour à tous, j'ai un petit problème d'affichage de caractères entre un serveur redhat et putty ..
Cela concerne les caractères avec les accents.Sur le serveur je suis en UTF8 :  
[root@mamachine root]# locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
[root@mamachine root]#
 
Lorsque je séléctionne le character set UTF8 dans putty j'ai ceci :  
[root@mamachine root]#ls -alrt
-rw-------    1 root     root        16260 oct  5 10:17 .bash_history
-rw-r--r--    1 root     root           31 oct  5 10:20 test_avec_accents_éàèê.txt
[root@mamachine root]# cat test_avec_accents_éàèê.txt
▒▒▒▒▒▒▒
▒▒▒▒▒▒▒
▒▒▒▒▒▒▒
 
 :heink:  
 
Par contre lorsque je selectionne le character set ISO-8859-1 dans putty (celui par défault) j'obtiens cela :  
[root@mamachine root]#ls -alrt
-rw-r--r--    1 root     root           31 oct  5 10:20 test_avec_accents_éà èê.txt
drwxr-x---   16 root     root         4096 oct  5 10:26 .
 
[root@mamachine root]# cat test_avec_accents_éà èê.txt
ééééééé
ààààààà
êêêêêêê
 
Donc ça fonctionne bof comme vous pouvez le voir ...
Je précise qu'en me connectant sur la console du serveur tout fonctionne correctement,je n'ai pas pas problèmes avec le ls ni avec le cat ..
 
Si quelqu'un a une idée elle est la bienvenue  :)


Message édité par Drix75 le 05-10-2007 à 10:52:51
mood
Publicité
Posté le 05-10-2007 à 10:35:07  profilanswer
 

n°960887
o'gure
Modérateur
Multi grognon de B_L
Posté le 05-10-2007 à 10:39:47  profilanswer
 

A mon avis ton fichier test_avec_accents_éàèê.txt  n'est pas en UTF-8.
utilise iconv pour le convertir
 
Sinon c'est toi ce topic ou non ?  Si oui, faut éviter de faire des doublons...


---------------
Ton Antoine commence à me les briser menus !
n°960888
Drix75
Posté le 05-10-2007 à 10:43:43  profilanswer
 

o'gure a écrit :

A mon avis ton fichier test_avec_accents_éàèê.txt  n'est pas en UTF-8.
utilise iconv pour le convertir
 
Sinon c'est toi ce topic ou non ?  Si oui, faut éviter de faire des doublons...


 
 :sarcastic:  
Et non ce n'est pas moi ...


Message édité par Drix75 le 05-10-2007 à 10:43:56
n°960889
o'gure
Modérateur
Multi grognon de B_L
Posté le 05-10-2007 à 10:47:58  profilanswer
 

Bref...
La conversion résoud le problème ?


---------------
Ton Antoine commence à me les briser menus !
n°960890
Drix75
Posté le 05-10-2007 à 10:49:52  profilanswer
 

OK je pense que tu a raison :  
[root@mamachine root]# iconv -t UTF8 test_avec_accents_éàèê.txt
iconv -t UTF8 test_avec_accents_éàèê.txt
iconv: Séquence d'échappement illégale à la position 0
 
Par contre j'ai crée un nouveau fichier test_avec_accent.txt que j'ai rempli de caractères à,é et ê sous vi et le cat les a affichés correctement  ;)  
Et comme le premier fichier a été crée sous windows et transféré ensuite sur cette machine je comprend pourquoi ça ne fonctionnait pas bien !
Merci  :hello:


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [RESOLU] Putty problèmes affichage caractères

 

Sujets relatifs
[Résolu] Configuration pour UbuntuResolu - Partition EXT3 morte?
[Résolu] Problème ipcop & urlfilter[resolu] freemind: version ?
[resolu][mandriva] peertv gcc++[Resolu] Multiboot avec Vista... quelqu'un à essayer ?
[RESOLU] My Epson 480 SXU & USB2.0 on Feisty Suxx !lspci mais pour périphériques ISA ? [Résolu]
[RESOLU] Connexion SMB (CIFS) possible uniquement en root ???? (FC6)[zsh] lire une réponse au clavier ? [Résolu]
Plus de sujets relatifs à : [RESOLU] Putty problèmes affichage caractères


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR