Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1667 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Debian] dpkg-buildpackage Erreur 63

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Debian] dpkg-buildpackage Erreur 63

n°965634
ffluff
Challenge Everything
Posté le 18-10-2007 à 10:47:03  profilanswer
 

Bonjour,
 
ca fait longtemps que j'essaye de compiler mail-notifiaction-evolution avec le support ssl (à la debian)
 


# apt-get build-dep mail-notification-evolution
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances        
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 16 non mis à jour.
 
$ apt-get source mail-notification-evolution
 
$ dpkg-buildpackage -us -uc -rfakeroot


 
en faisant comme ca marche pas j'ai une erreur post-patches 63 (je precise que je n'ai rien modifié meme pas debian/rules pour activer le mode ssl)
Alors qu'en faisant un ./configure, make et make install j'ai aucune erreur.
 
 
Quelqu'un sait d'ou ca pourrait venir ?
 


$ dpkg-buildpackage -us -uc -rfakeroot
dpkg-buildpackage: source package mail-notification
dpkg-buildpackage: source version 4.1.dfsg.1-4
dpkg-buildpackage: source changed by Pascal Giard <pascal@debian.org>
dpkg-buildpackage: host architecture i386
 fakeroot debian/rules clean
test -x debian/rules
test "`id -u`" = 0
/usr/bin/make -f debian/rules reverse-config
make[1]: entrant dans le répertoire « /home/paul/download/mail-notification-4.1.dfsg.1 »
for i in ./config.guess ./config.sub  ; do \
                if test -e $i.cdbs-orig ; then \
                        mv $i.cdbs-orig $i ; \
                fi ; \
        done
make[1]: quittant le répertoire « /home/paul/download/mail-notification-4.1.dfsg.1 »
if [ "reverse-patches" = "reverse-patches" ]; then rm -f debian/stamp-patched; fi
patches: debian/patches/01-gmail.png_has_been_replaced-AUTHORS.diff debian/patches/02-per_user_autostart-01.diff debian/patches/02-per_user_autostart-02.diff debian/patches/04-fixed_polish_sent.diff debian/patches/05-add_french_autostart.diff debian/patches/06-fix_evolution_plugin_check.diff debian/patches/07-fix_API_change.diff debian/patches/08-freedesktop.org_specs_compliance.diff
Patch debian/patches/08-freedesktop.org_specs_compliance.diff is not applied.
Patch debian/patches/07-fix_API_change.diff is not applied.
Patch debian/patches/06-fix_evolution_plugin_check.diff is not applied.
Patch debian/patches/05-add_french_autostart.diff is not applied.
Patch debian/patches/04-fixed_polish_sent.diff is not applied.
Patch debian/patches/02-per_user_autostart-02.diff is not applied.
Patch debian/patches/02-per_user_autostart-01.diff is not applied.
Patch debian/patches/01-gmail.png_has_been_replaced-AUTHORS.diff is not applied.
if [ "reverse-patches" != "reverse-patches" ]; then touch debian/stamp-patched; fi
if [ "reverse-patches" != "reverse-patches" ] ; then \
                /usr/bin/make -f debian/rules update-config ; \
        fi
for dir in debian/patches ; do \
            rm -f $dir/*.log ; \
        done
for i in ./config.guess ./config.sub  ; do \
                if test -e $i.cdbs-orig ; then \
                        mv $i.cdbs-orig $i ; \
                fi ; \
        done
dh_clean  
GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 /usr/bin/make -C . -k distclean
make[1]: entrant dans le répertoire « /home/paul/download/mail-notification-4.1.dfsg.1 »
make[1]: *** Pas de règle pour fabriquer la cible « distclean ».
make[1]: quittant le répertoire « /home/paul/download/mail-notification-4.1.dfsg.1 »
make: [makefile-clean] Erreur 2 (ignorée)
rm -f debian/stamp-makefile-build
rm -f debian/stamp-autotools-files
cd . && \
          rm -f intltool-extract intltool-merge intltool-update po/.intltool-merge-cache; \
          if test -d doc; then find doc -name '*.omf.out' -exec rm -f \{\} \; ; fi; \
          if test -d help; then find help -name '*.omf.out' -exec rm -f \{\} \; ; fi
[ ! -f Makefile ] || /usr/bin/make distclean
rm -f config.log
rm -f help/C/*.omf.out
rm -f po/POTFILES po/*.gmo
# We regenerate them with gob2, see patch 02
rm -f src/mn-properties-dialog-private.h
rm -f src/mn-properties-dialog-private.c
rm -f src/mn-properties-dialog.c
rm -f src/mn-properties-dialog.h
# We regenerate them in post-patches
rm -f po/Makefile.in.in
rm -f config.sub* config.guess*
rm -f missing mkinstalldirs depcomp install-sh ltmain.sh
rm -f intltool-merge.in intltool-extract.in intltool-update.in
 dpkg-source -b mail-notification-4.1.dfsg.1
dpkg-source : construction de mail-notification à partir de mail-notification_4.1.dfsg.1.orig.tar.gz
dpkg-source : construction de mail-notification dans mail-notification_4.1.dfsg.1-4.diff.gz
dpkg-source : avertissement : suppression du fichier po/Makefile.in.in ignorée
dpkg-source : avertissement : suppression du fichier src/mn-properties-dialog.c ignorée
dpkg-source : avertissement : suppression du fichier src/mn-properties-dialog.h ignorée
dpkg-source : avertissement : suppression du fichier src/mn-properties-dialog-private.h ignorée
dpkg-source : avertissement : suppression du fichier depcomp ignorée
dpkg-source : avertissement : suppression du fichier intltool-extract.in ignorée
dpkg-source : avertissement : suppression du fichier ltmain.sh ignorée
dpkg-source : avertissement : suppression du fichier intltool-update.in ignorée
dpkg-source : avertissement : suppression du fichier config.guess ignorée
dpkg-source : avertissement : suppression du fichier install-sh ignorée
dpkg-source : avertissement : suppression du fichier config.sub ignorée
dpkg-source : avertissement : suppression du fichier missing ignorée
dpkg-source : avertissement : suppression du fichier mkinstalldirs ignorée
dpkg-source : avertissement : suppression du fichier intltool-merge.in ignorée
dpkg-source : construction de mail-notification dans mail-notification_4.1.dfsg.1-4.dsc
 debian/rules build
test -x debian/rules
mkdir -p "."
/usr/bin/make -f debian/rules reverse-config
make[1]: entrant dans le répertoire « /home/paul/download/mail-notification-4.1.dfsg.1 »
make[1]: Rien à faire pour « reverse-config ».
make[1]: quittant le répertoire « /home/paul/download/mail-notification-4.1.dfsg.1 »
if [ "debian/stamp-patched" = "reverse-patches" ]; then rm -f debian/stamp-patched; fi
patches: debian/patches/01-gmail.png_has_been_replaced-AUTHORS.diff debian/patches/02-per_user_autostart-01.diff debian/patches/02-per_user_autostart-02.diff debian/patches/04-fixed_polish_sent.diff debian/patches/05-add_french_autostart.diff debian/patches/06-fix_evolution_plugin_check.diff debian/patches/07-fix_API_change.diff debian/patches/08-freedesktop.org_specs_compliance.diff
Trying patch debian/patches/01-gmail.png_has_been_replaced-AUTHORS.diff at level 1 ... 0 ... success.
Trying patch debian/patches/02-per_user_autostart-01.diff at level 1 ... 0 ... success.
Trying patch debian/patches/02-per_user_autostart-02.diff at level 1 ... 0 ... success.
Trying patch debian/patches/04-fixed_polish_sent.diff at level 1 ... 0 ... success.
Trying patch debian/patches/05-add_french_autostart.diff at level 1 ... 0 ... success.
Trying patch debian/patches/06-fix_evolution_plugin_check.diff at level 1 ... success.
Trying patch debian/patches/07-fix_API_change.diff at level 1 ... success.
Trying patch debian/patches/08-freedesktop.org_specs_compliance.diff at level 1 ... 0 ... success.
if [ "debian/stamp-patched" != "reverse-patches" ]; then touch debian/stamp-patched; fi
if [ "debian/stamp-patched" != "reverse-patches" ] ; then \
                /usr/bin/make -f debian/rules update-config ; \
        fi
make[1]: entrant dans le répertoire « /home/paul/download/mail-notification-4.1.dfsg.1 »
make[1]: Rien à faire pour « update-config ».
make[1]: quittant le répertoire « /home/paul/download/mail-notification-4.1.dfsg.1 »
libtoolize --force
intltoolize --force
You should update your 'aclocal.m4' by running aclocal.
ln -sf /usr/share/automake-1.10/mkinstalldirs mkinstalldirs
aclocal-1.10 -I m4
/usr/share/aclocal/libmcrypt.m4:17: warning: underquoted definition of AM_PATH_LIBMCRYPT
/usr/share/aclocal/libmcrypt.m4:17:   run info '(automake)Extending aclocal'
/usr/share/aclocal/libmcrypt.m4:17:   or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
autoheader
autoconf
automake --add-missing --force-missing
configure.ac:34: version mismatch.  This is Automake 1.9.6,
configure.ac:34: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:34: comes from Automake 1.10.  You should recreate
configure.ac:34: aclocal.m4 with aclocal and run automake again.
configure.ac: installing `./install-sh'
configure.ac: installing `./missing'
src/Makefile.am: installing `./compile'
src/Makefile.am: installing `./depcomp'
make: *** [post-patches] Erreur 63
dpkg-buildpackage : échec : debian/rules build a produit une erreur de sortie de type 2

mood
Publicité
Posté le 18-10-2007 à 10:47:03  profilanswer
 

n°965642
Riot
Buy me a riot
Posté le 18-10-2007 à 10:54:37  profilanswer
 

Citation :

configure.ac:34: version mismatch.  This is Automake 1.9.6,
configure.ac:34: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:34: comes from Automake 1.10.  You should recreate
configure.ac:34: aclocal.m4 with aclocal and run automake again.


 
T'as pas moyen de passer à automake 1.10 ?


---------------
Be the one with the flames.
n°965680
ffluff
Challenge Everything
Posté le 18-10-2007 à 11:22:07  profilanswer
 

effectivement sur ma debian j'avais automake 1.9.6 et 1.10 et /usr/bin/automake pointé sur /etc/alternatives/automake ...
en le faisant pointé su automake-1.10 ca marche effectivement

 

La question est maintenant pourquoi automake pointé sur la 1.9 ...

 

PS: apt-get remove automake1.9 && apt-get install automake1.10 --reinstall a corrigé le probleme de facon plus clean ;)

 

Merci.

Message cité 1 fois
Message édité par ffluff le 18-10-2007 à 11:23:43
n°965684
Riot
Buy me a riot
Posté le 18-10-2007 à 11:24:10  profilanswer
 

Relax, take it easy [:ocolor]


---------------
Be the one with the flames.
n°966372
Riot
Buy me a riot
Posté le 19-10-2007 à 10:48:12  profilanswer
 

ffluff a écrit :

effectivement sur ma debian j'avais automake 1.9.6 et 1.10 et /usr/bin/automake pointé sur /etc/alternatives/automake ...
en le faisant pointé su automake-1.10 ca marche effectivement
 
La question est maintenant pourquoi automake pointé sur la 1.9 ...
 
PS: apt-get remove automake1.9 && apt-get install automake1.10 --reinstall a corrigé le probleme de facon plus clean ;)
 
Merci.


Maintenant que j'y pense, un truc vraiment clean aurait été de faire un update-alternative.
M'enfin ...


---------------
Be the one with the flames.

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Debian] dpkg-buildpackage Erreur 63

 

Sujets relatifs
debian, forcer l'installation d'un paquet "stable"[debian Etch] pas de resolution wide avec intel
Installation Mandriva Spring 2007 64bits=erreurnut sous une debian 64
Espace disque sur debianErreur lors de la compilation du noyau
Debian & Intel 2200BGinstallation xen sous debian lenny
[Dualboot] Installation de Windows après DebianCréer son cd de Debian
Plus de sujets relatifs à : [Debian] dpkg-buildpackage Erreur 63


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR