Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1938 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  debian, forcer l'installation d'un paquet "stable"

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

debian, forcer l'installation d'un paquet "stable"

n°964273
dams78
développateur
Posté le 15-10-2007 à 19:14:41  profilanswer
 

bonsoir,
j'utilise vlc pour mon freeplayer or depuis peu il ne fonctionne plus en unstable
donc en attandant que le bug soit réparé je voudrai utilisé le paquet stable de vlc (qui lui marche je le sais)
mais j'arrive pas à la faire...
j'ai essayé avec le fichier /etc/apt/preferences et les options de aptitude
 
merci de votre aide


---------------
dam's (debianer), ma galerie Flickr
mood
Publicité
Posté le 15-10-2007 à 19:14:41  profilanswer
 

n°964275
-Opera-
mago spé électricité
Posté le 15-10-2007 à 19:16:32  profilanswer
 

Tu as mis quoi dans le fichier préférences ? Etrange que ça ne fonctionne pas...


---------------
You get so used to things the way they are. And I've always been alone. I guess that makes me lonely.
n°964279
dams78
développateur
Posté le 15-10-2007 à 19:23:57  profilanswer
 

j'ai essayé ca


Package: vlc
Pin: release a=stable
Pin-priority: 1001


et ca


Package: vlc
Pin: version 0.8.6*
Pin-priority: 1001


le probleme avec le dernier c'est que la version stable et unstable ont le même numéro (c'est aprés que ca change)


Message édité par dams78 le 15-10-2007 à 19:24:21

---------------
dam's (debianer), ma galerie Flickr
n°964313
THRAK
- THR4K -
Posté le 15-10-2007 à 23:13:24  profilanswer
 

Une solution simple, rapide et efficace :
 
- Dans /var/cache/apt/archives/ regarde s'il n'y a pas de disponible une version de VLC antérieure à celle qui est bugguée avec le Freeplayer (typiquement ce répertoire contient toutes les versions des paquets installés lors des upgrades effectués, à moins d'utiliser la directive autoclean ou clean avec apt-get ou aptitude).
 
Au cas où tu en trouves une, installe-là simplement en faisant un dpkg -i ancienne-version-de-vlc.deb
 
 
- Une autre solution est de directement télécharger le .deb d'une version précédente, et de l'installer manuellement avec dpkg comme précédemment.
 
 
- Autrement, tu as aussi la possibilité de passer par l'archive snapshot.debian.net
 


Message édité par THRAK le 15-10-2007 à 23:15:20

---------------
THRAK (def.) : 1) A sudden and precise impact moving from intention, direction and commitment, in service of an aim. 2) 117 guitars almost striking the same chord simultaneously.
n°964979
dams78
développateur
Posté le 16-10-2007 à 19:20:10  profilanswer
 

j'avais essayé d'installer la version téléchargé mais ya trop de dépendance...
je vais voir le lien que tu m'as donné


---------------
dam's (debianer), ma galerie Flickr

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  debian, forcer l'installation d'un paquet "stable"

 

Sujets relatifs
[Linux Mandrake] installation modem SagemInstallation de Mandriva+ubuntu
[debian Etch] pas de resolution wide avec intelInstallation Mandriva Spring 2007 64bits=erreur
installation Ubuntu 7.04 Feisty Fawn infinie (résolu)Installation windows XP impossible (?)
nut sous une debian 64Pb installation mandriva2008 free - XFDrake - autre soucis help :(
Installation d'un serveur sous linux depuis pc portable 
Plus de sujets relatifs à : debian, forcer l'installation d'un paquet "stable"


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR