Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
725 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Problème XFree avec NVidia TNT2 M64

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème XFree avec NVidia TNT2 M64

n°204169
Olivier51
Posté le 22-12-2002 à 15:01:48  profilanswer
 

Je pense avoir suivi le tutorial du site Léa pour l'installation du driver de Nvidia, comme je le dis dans le titre j'ai une carte graphique NVidia TNT2 M64.
 
Quand je lance le serveur XFree par la commande startX, l'écran clignote plusieurs fois, puis revient à la ligne de commande.
Je vais vous montrer quelques lignes des fichiers qui me semblent nécessaire au fonctionnement du serveur X.
 
Un petit ls dans les drivers vidéo pour le noyau

Code :
  1. total 1092
  2. -rw-rw-r--    1 root     root      1112996 Dec 22 12:57 NVdriver


 
Un petit lsmod après le lancement du serveur X

Code :
  1. Module                  Size  Used by    Tainted: P 
  2. NVdriver              988096   0  (autoclean)


 
Une petite partie du fichier /etc/modules.conf

Code :
  1. alias cipher-17  rc5
  2. alias char-major-195 NVdriver
  3. ### update-modules: end processing /etc/modutils/aliases


 
Une petite partie des logs de XFree

Code :
  1. (II) Loading sub module "vgahw"
  2. (II) LoadModule: "vgahw"
  3. (II) Loading /usr/X11R6/lib/modules/libvgahw.a
  4. (II) Module vgahw: vendor="The XFree86 Project"
  5. compiled for 4.1.0.1, module version = 0.1.0
  6. ABI class: XFree86 Video Driver, version 0.4
  7. (**) NVIDIA(0): Depth 16, (--) framebuffer bpp 16
  8. (==) NVIDIA(0): RGB weight 565
  9. (==) NVIDIA(0): Default visual is TrueColor
  10. (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
  11. (--) NVIDIA(0): Linear framebuffer at 0xCA000000
  12. (--) NVIDIA(0): MMIO registers at 0xCE000000
  13. (EE) NVIDIA(0): Failed to initialize the NVdriver kernel module!
  14. (EE) NVIDIA(0):  *** Aborting ***
  15. (II) UnloadModule: "nvidia"
  16. (II) UnloadModule: "vgahw"
  17. (II) Unloading /usr/X11R6/lib/modules/libvgahw.a
  18. (EE) Screen(s) found, but none have a usable configuration.
  19. Fatal server error:
  20. no screens found


 
Une ptite partie du fichier XF86Config-4

Code :
  1. Section "Module"
  2. # Load "GLcore"
  3. # Load "bitmap"
  4. Load "dbe"
  5. # Load "ddc"
  6. # Load "dri"
  7. Load "extmod"
  8. Load "freetype"
  9. # Load "glx"
  10. # Load "int10"
  11. # Load "pex5"
  12. # Load "record"
  13. # Load "speedo"
  14. Load "type1"
  15. # Load "vbe"
  16. # Load "xie"
  17. EndSection
  18. Section "Device"
  19. Identifier "NVidia TNT2 M64"
  20. # Driver  "nv"
  21. Driver   "nvidia"
  22. # VideoRam 32000
  23. EndSection
  24. Section "Screen"
  25. Identifier "Default Screen"
  26. Device  "NVidia TNT2 M64"
  27. Monitor  "TVM AS6S"
  28. DefaultDepth 16
  29. SubSection "Display"
  30.  Depth  1
  31.  Modes  "1024x768" "800x600" "640x480"
  32. EndSubSection
  33. SubSection "Display"
  34.  Depth  4
  35.  Modes  "1024x768" "800x600" "640x480"
  36. EndSubSection
  37. SubSection "Display"
  38.  Depth  8
  39.  Modes  "1024x768" "800x600" "640x480"
  40. EndSubSection
  41. SubSection "Display"
  42.  Depth  15
  43.  Modes  "1024x768" "800x600" "640x480"
  44. EndSubSection
  45. SubSection "Display"
  46.  Depth  16
  47.  Modes  "1024x768" "800x600" "640x480"
  48. EndSubSection
  49. SubSection "Display"
  50.  Depth  24
  51.  Modes  "1024x768" "800x600" "640x480"
  52. EndSubSection
  53. EndSection

mood
Publicité
Posté le 22-12-2002 à 15:01:48  profilanswer
 

n°204219
lucaramel
Posté le 22-12-2002 à 16:25:49  profilanswer
 

Quelle distribution ?

n°204227
Olivier51
Posté le 22-12-2002 à 16:33:50  profilanswer
 

Debian, mais je vois pas trop le rapport ...

n°204307
lucaramel
Posté le 22-12-2002 à 20:02:02  profilanswer
 

Pour savoir comment tu as installé les drivers ?
Pour te dire une méthode qui marche si tu t'es planté ?
Pour savoir si tu as utilisé les outils de ta distrib ?
Pour savoir s'il ne te manque pas des paquets ?

n°204321
Olivier51
Posté le 22-12-2002 à 20:18:23  profilanswer
 

Je pense avoir suivi mot pour mot le tutoriel du site Léa, disponible ici :
http://lea-linux.org/hardware/nvidia.php3

n°204365
lucaramel
Posté le 22-12-2002 à 22:48:59  profilanswer
 

Ce tutoriel est :
- très vieux et dépassé
- inadapté pour plein de distribs
 
Donc précise ta distrib, et je te dirai comment l'installer si tu as une Debian ou une Mandrake...

n°204368
Olivier51
Posté le 22-12-2002 à 22:57:06  profilanswer
 

Debian (voir 3ème message), si tu pouvais m'aider j'en serais très reconnaissant, parce que là je tourne sous windows depuis cette après-midi et je voudrais bien retrouver mes données ...

n°204381
eL_Shaman_​__
Plop.
Posté le 22-12-2002 à 23:49:04  profilanswer
 

J'avais expliqué 2 ou 3 trucs pour l'install des drivers nVIDIA sur une Debian, dans le topic:
 
"[important] --== MESSAGE POUR LES DEBUTANTS ==--"
 
À la dernière page, il me semble.
 
 
 
 
PS: les drivers 41.91 déconnent avec GNOME2 (=grosses lenteurs).

n°204415
Olivier51
Posté le 23-12-2002 à 01:52:19  profilanswer
 

Non ça y est j'ai trouvé d'où venait l'erreur, cela venait de la configuration du BIOS, merci de m'avoir aidé comme même ...


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Problème XFree avec NVidia TNT2 M64

 

Sujets relatifs
probleme de XF86config sous slackware 8.1[MDK9.0 + appache ] Probleme de police
probleme lors du demarage de linuxProblème K3b
Mise en veille portable MAJ [Problème à moitié résolu !][nvidia] Comment virer l'anti aliasing pour une Geforce4 sous linux
[hum ... ptit problème smtp conflit inside][freebsd] probleme sendmail / config reseau
Probleme boot Linux suite à modif [resolu][Drivers NVIDIA] Les derniers sont tout pourri !!
Plus de sujets relatifs à : Problème XFree avec NVidia TNT2 M64


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR