Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1333 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [freebsd] probleme sendmail / config reseau

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[freebsd] probleme sendmail / config reseau

n°203565
--greg--
Posté le 20-12-2002 à 00:07:02  profilanswer
 

Hop,
 
Plusieurs heures/soirs que je rame, je pige quedz
 
Bon, voici ce que je retrouve dans le /var/log/maillog

Citation :

Dec 20 00:00:41 mabebete sendmail[26918]: gBJN0flc026918: from=greg, size=61, class=0, nrcpts=1, msgid=<200212192300.gBJN0flc026918@mabebete.lan>, relay=greg@localhost
Dec 20 00:00:41 mabebete sendmail[26918]: gBJN0flc026918: to=greg, ctladdr=greg (1000/1001), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30024, relay=localhost.lan., dsn=4.0.0, stat=Deferred: Operation timed out with localhost.lan.


quand je suis loggé en tant que greg (ou n'importe quel user)  
et que je    mail greg     (ou n'importe quel user)
 
ce qui est étrange c'est le .lan ajouté derriere le localhost ..... :??:
 
sinon au niveau du reste de la config

Citation :

-bash-2.05b$ hostname
mabebete.lan
-bash-2.05b$ domainname
lan


la machine à une ipfixe, y'a un alcatel STP derriere, dont le dns a "lan" comme nom de domaine ... euh si autres questions, posez, posez :D
 
un autre truc louche:
quand je fais mailq
ça me repond que la queue est vide, par contre dans le maillog je trouve ça

Citation :

Dec 19 23:35:26 mabebete sendmail[26721]: gethostbyaddr(IPv6:::1) failed: 1


 
si vous avez des idées.... merci  :hello:


---------------
#19b | Mardi 18 Février 2003 - nous fêtons les Bernadette | contre le fleur icq!
mood
Publicité
Posté le 20-12-2002 à 00:07:02  profilanswer
 

n°203686
_Evangelio​n_
Posté le 20-12-2002 à 15:30:08  profilanswer
 

1) sendmail ca pue
2) /etc/hosts ?
3) sendmail ca pue
4) ton etc/resolv.conf pointe ou?
5 sendmail ca pue
 
 :D

n°203687
--greg--
Posté le 20-12-2002 à 15:34:39  profilanswer
 

_Evangelion_ a écrit :

1) sendmail ca pue
2) /etc/hosts ?
3) sendmail ca pue
4) ton etc/resolv.conf pointe ou?
5 sendmail ca pue
 
 :D  


1) je sais :D
2) euh par coeur je vais avoir du mal (firewall au boulot :cry:) mais ça ressemble à ça:  

Citation :

127.0.0.1 localhost
10.0.0.1 mabebete
10.0.0.1 mabebete.lan


3) je sais :D
4) 10.0.0.138 , l'ip du speedtouch (me rappelle pas exactement, je pense que c'est nameserver=10.0.0.138  et rien d'autre dans de fichier... ?)
5) je sais :D
 
Cela dit, pour 1,3,5 quand bien meme je veux bien être d'accord, ça ne marchait pas mieux quand j'ai essayé avec postfix il me semble... et manifestement c'est plus un probleme de config reseau que de sendmail nan?  
(A propos de postfix d'ailleurs j'ai pas du tout aimé la maniere dont il s'est installé... ses executables s'appellaient "sendmail", au lieu d'utiliser le mailer.conf qui sert justement a wrapper un mailer en utilisant d'autres noms :pfff:)
 
Merci de repondre ;)


---------------
#19b | Mardi 18 Février 2003 - nous fêtons les Bernadette | contre le fleur icq!
n°203705
_Evangelio​n_
Posté le 20-12-2002 à 17:21:46  profilanswer
 

oui oui clairement un pb de conf reseau la, mais ca n'enleve rien au fait que sendmail ca pue  :D  
 
Well.. le hosts en général c'est  
ip host.domaine.tld host
ca donne en clair et sans decodeur
::1                     localhost.lan localhost
127.0.0.1               localhost.lan localhost
10.0.0.1                mabebete.lan mabebete
 
Ensuite ca serait bien de voir ou pointe ton resolv.conf
Et pour finir postfix install son "sendmail" mais dans un autre rep  :D  
il ecrase donc pas le vrai sendmail.
tu dois confondre /usr/sbin avec /usr/local/sbin
 
cat /etc/mail/mailer.conf
#
# Execute the Postfix sendmail program, named /usr/local/sbin/sendmail
#
sendmail       /usr/local/sbin/sendmail
send-mail      /usr/local/sbin/sendmail
mailq          /usr/local/sbin/sendmail
newaliases     /usr/local/sbin/sendmail
 
ll /usr/sbin/sendmail  
lrwxr-xr-x  1 root  wheel  21 Jul 16 01:44 /usr/sbin/sendmail@ -> /usr/sbin/mailwrapper
 
ll /usr/local/sbin/sendmail  
-rwxr-xr-x  1 root  wheel  104511 May 17  2002 /usr/local/sbin/sendmail*
 
Le "sendmail" postfix est dans /local/  :D


Message édité par _Evangelion_ le 20-12-2002 à 17:22:44
n°203709
--greg--
Posté le 20-12-2002 à 17:26:02  profilanswer
 

_Evangelion_ a écrit :

oui oui clairement un pb de conf reseau la, mais ca n'enleve rien au fait que sendmail ca pue  :D

certes :D

_Evangelion_ a écrit :


 
Well.. le hosts en général c'est  
ip host.domaine.tld host
ca donne en clair et sans decodeur
::1                     localhost.lan localhost
127.0.0.1               localhost.lan localhost
10.0.0.1                mabebete.lan mabebete

:??: localhost.lan :??: HA BON? ok :o ... ensuite euh ::1 ça veut dire quoi? :/

_Evangelion_ a écrit :


Ensuite ca serait bien de voir ou pointe ton resolv.conf

je te confirme ça se soir :)

_Evangelion_ a écrit :


Et pour finir postfix install son "sendmail" mais dans un autre rep  :D  
il ecrase donc pas le vrai sendmail.
tu dois confondre /usr/sbin avec /usr/local/sbin
 
cat /etc/mail/mailer.conf
#
# Execute the Postfix sendmail program, named /usr/local/sbin/sendmail
#
sendmail       /usr/local/sbin/sendmail
send-mail      /usr/local/sbin/sendmail
mailq          /usr/local/sbin/sendmail
newaliases     /usr/local/sbin/sendmail
 
ll /usr/sbin/sendmail  
lrwxr-xr-x  1 root  wheel  21 Jul 16 01:44 /usr/sbin/sendmail@ -> /usr/sbin/mailwrapper
 
ll /usr/local/sbin/sendmail  
-rwxr-xr-x  1 root  wheel  104511 May 17  2002 /usr/local/sbin/sendmail*
 
Le "sendmail" postfix est dans /local/  :D

euh okie mais bon tu avoueras que la confusion est facile :D il aurait pu mettre explicitement "postfix" comme nom quoi :o
 
 
merci pour tout [:prosterne2]


---------------
#19b | Mardi 18 Février 2003 - nous fêtons les Bernadette | contre le fleur icq!
n°203716
_Evangelio​n_
Posté le 20-12-2002 à 17:37:06  profilanswer
 

::1 c'est le 127.0.0.1 mais version Ipv6, or en lisant ton 1er post, je vois à la fin qui tu as du v6..
 
Dec 19 23:35:26 mabebete sendmail[26721]: gethostbyaddr(IPv6:::1) failed: 1
 
Simple constatation.

n°203718
--greg--
Posté le 20-12-2002 à 17:41:19  profilanswer
 

_Evangelion_ a écrit :

::1 c'est le 127.0.0.1 mais version Ipv6, or en lisant ton 1er post, je vois à la fin qui tu as du v6..
 
Dec 19 23:35:26 mabebete sendmail[26721]: gethostbyaddr(IPv6:::1) failed: 1
 
Simple constatation.

certes mais justement en installant freebsd il me semblait avoir mis "non" pour l'ipv6 :/
merci pour l'info sinon :D


Message édité par --greg-- le 20-12-2002 à 17:42:22

---------------
#19b | Mardi 18 Février 2003 - nous fêtons les Bernadette | contre le fleur icq!
n°203756
--greg--
Posté le 20-12-2002 à 20:28:51  profilanswer
 

alors, mon /etc/resolv.conf:

Citation :

nameserver      10.0.0.138


y'avait une autre ligne que j'ai virée y'a qques jours  :ange: (je sais plus ce que c'était mais ça me paraissait redondant avec le dns du modem)
... donc 10.0.0.138 c'est bien l'ip de mon STP
 
mon /etc/hosts:

Citation :

127.0.0.1               localhost
10.0.0.1                mabebete  
10.0.0.1                mabebete.lan


... que je vais modifier comme tu m'as dit...
 
pour mettre le système a jour apres ces modifs je fais ifconfig ed0 down puis ifconfig ed0 up ?
 
je fais les modifs et je tiens au courant ;)
merci :hello:


---------------
#19b | Mardi 18 Février 2003 - nous fêtons les Bernadette | contre le fleur icq!
n°203759
--greg--
Posté le 20-12-2002 à 20:34:48  profilanswer
 

ça maaaarche !!!  
 
 [:prosterne]_Evangelion_ [:prosterne2]


---------------
#19b | Mardi 18 Février 2003 - nous fêtons les Bernadette | contre le fleur icq!
n°203791
linuxois
Posté le 20-12-2002 à 22:06:28  profilanswer
 

_Evangelion_ a écrit :

oui oui clairement un pb de conf reseau la, mais ca n'enleve rien au fait que sendmail ca pue  :D  
 
Well.. le hosts en général c'est  
ip host.domaine.tld host
ca donne en clair et sans decodeur
::1                     localhost.lan localhost
127.0.0.1               localhost.lan localhost
10.0.0.1                mabebete.lan mabebete
 
Ensuite ca serait bien de voir ou pointe ton resolv.conf
Et pour finir postfix install son "sendmail" mais dans un autre rep  :D  
il ecrase donc pas le vrai sendmail.
tu dois confondre /usr/sbin avec /usr/local/sbin
 
cat /etc/mail/mailer.conf
#
# Execute the Postfix sendmail program, named /usr/local/sbin/sendmail
#
sendmail       /usr/local/sbin/sendmail
send-mail      /usr/local/sbin/sendmail
mailq          /usr/local/sbin/sendmail
newaliases     /usr/local/sbin/sendmail
 
ll /usr/sbin/sendmail  
lrwxr-xr-x  1 root  wheel  21 Jul 16 01:44 /usr/sbin/sendmail@ -> /usr/sbin/mailwrapper
 
ll /usr/local/sbin/sendmail  
-rwxr-xr-x  1 root  wheel  104511 May 17  2002 /usr/local/sbin/sendmail*
 
Le "sendmail" postfix est dans /local/  :D


 
Salut,
 
Pourquoi ne pas utiliser postfix qui mille fois plus facile à configurer. Je peux t'aider en t'envoyant mes fichiers config par mail.

mood
Publicité
Posté le 20-12-2002 à 22:06:28  profilanswer
 

n°203797
--greg--
Posté le 20-12-2002 à 22:17:10  profilanswer
 

linuxois a écrit :


 
Salut,
 
Pourquoi ne pas utiliser postfix qui mille fois plus facile à configurer. Je peux t'aider en t'envoyant mes fichiers config par mail.

allons allons :)
lis bien le topic, tu verras qu'il s'agit d'un pb de config reso et non de sendmail directement. j'ai pas touché a la config de sendmail et mtnt ça marche ([:prosterne]_Evangelion_ [:prosterne2]).
 
certes, je changerai sans doute un jour, postfix ou exim, mais en attendant ça marche et c tout ce que je demande (pour les mails de cron tfaçons hein...)
 
et puis c'est pas ton pseudo qui va mettre en confiance... BSD RULEZ :fou:
:D


---------------
#19b | Mardi 18 Février 2003 - nous fêtons les Bernadette | contre le fleur icq!
n°203803
linuxois
Posté le 20-12-2002 à 22:26:23  profilanswer
 

--greg-- a écrit :

allons allons :)
lis bien le topic, tu verras qu'il s'agit d'un pb de config reso et non de sendmail directement. j'ai pas touché a la config de sendmail et mtnt ça marche ([:prosterne]_Evangelion_ [:prosterne2]).
 
certes, je changerai sans doute un jour, postfix ou exim, mais en attendant ça marche et c tout ce que je demande (pour les mails de cron tfaçons hein...)
 
et puis c'est pas ton pseudo qui va mettre en confiance... BSD RULEZ :fou:
:D


 
Pourquoi es tu si agressif avec moi? je voulais juste t'aider. Quand à mon pseudo (linuxois) je l'ai choisi non pas pretention mais plutot pour signifier que desormais j'appartien a cette belle communauté qui s'est formée depuis un certain nombre d'annee autour de ce formidable OS qu'est Linux.

n°203822
--greg--
Posté le 20-12-2002 à 22:56:22  profilanswer
 

linuxois a écrit :


 
Pourquoi es tu si agressif avec moi? je voulais juste t'aider. Quand à mon pseudo (linuxois) je l'ai choisi non pas pretention mais plutot pour signifier que desormais j'appartien a cette belle communauté qui s'est formée depuis un certain nombre d'annee autour de ce formidable OS qu'est Linux.

":D" j'ai dit ;)
stépourire quoi :/


---------------
#19b | Mardi 18 Février 2003 - nous fêtons les Bernadette | contre le fleur icq!
n°203825
linuxois
Posté le 20-12-2002 à 23:04:04  profilanswer
 

--greg-- a écrit :

":D" j'ai dit ;)
stépourire quoi :/


 
C'est d'accord!
 
Bonnes fêtes de fin d'années. :)

n°203826
--greg--
Posté le 20-12-2002 à 23:06:01  profilanswer
 

linuxois a écrit :


 
C'est d'accord!
 
Bonnes fêtes de fin d'années. :)  

pareillement :)


---------------
#19b | Mardi 18 Février 2003 - nous fêtons les Bernadette | contre le fleur icq!

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [freebsd] probleme sendmail / config reseau

 

Sujets relatifs
config apache sur linuxConfig Apache + Php
Probleme boot Linux suite à modif [resolu]Aidez moi !!! probleme de FAT !!! Linux inside !!!
Problème au démarrage de mysql sous debianproftpd : problème de login
Un prog de backup pour un hp 12/24 dds-3 sous FreeBSD 4.7 mode textReiser FS & Apache ... problème ?
probleme de partage de fichier sous 2000Problème de connexion modem Trust 56k V92 PCI sous Linux [résolu]
Plus de sujets relatifs à : [freebsd] probleme sendmail / config reseau


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR