Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1850 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  probleme avec mon installation debian 6

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

probleme avec mon installation debian 6

n°1323884
joe dalton
Posté le 05-11-2012 à 18:29:07  profilanswer
 

bonjour, j'ai quelques probleme avec ma debian.
j'ai un C2D E8600 avec 4 go de ram et un ssd ocz vertex 2 60go.
 
 
j'ai 3 problemes:  
 
- de temps en temps mon ordi se bloque le clavier clignote et j'ai plus jamais la main, forcé de rebooter l'ecran reste sur le dernier affichage avant plantage.
- je n'arrive pas a installer d'application en 64bts tel que blender 3D par exemple.
- iceweasel se lance mais plante systématiquement pas moyen de surfer avec lui.
 
 
pour mon 1er probleme je ne sais pas quoi vous dire de plus.
 
pour le 2eme:
lorsque je fais un "uname -a" j'obtiens:
Linux debian 2.6.32-5-amd64 #1 SMP Sun Sep 23 11:00:33 UTC 2012 x86_64 GNU/Linux
donc je devrais bien pouvoir installer blender 3D 64bits... mais ca veux pas il me dit rien et refuse de se lancer. la version 32bits marche trés bien. par contre d'autre programme me dise que ma version de linux n'est pas 64bits....
 
est ce que pour les problemes 1 et 3 le ssd peut en etre la cause?
 
merci d'avance pour vos reponses.
 

mood
Publicité
Posté le 05-11-2012 à 18:29:07  profilanswer
 

n°1323889
joe dalton
Posté le 05-11-2012 à 18:44:37  profilanswer
 

pour iceweasel j'ai: Mozilla/5.0 (X11; U; Linux i686 (x86_64); fr; rv:1.9.1.16) Gecko/20121020 Iceweasel/3.5.16 (like Firefox/3.5.16)


---------------
Blog
n°1323951
FranceDenB​as
1 dépense = 1 socialiss' :o
Posté le 06-11-2012 à 10:11:10  profilanswer
 

Postes sur le topic Debian, tu auras plus de chances de réponses : http://forum.hardware.fr/hfr/OSAlt [...] 2264_1.htm


---------------
"Il a inventé le bougisme : je bouge donc je suis" :sol: - Dupont-Aignan à propos de Son Altesse Sérénissime Sarkal 1er. Merci Handsome Devil et Meriadeck.
n°1324009
THRAK
- THR4K -
Posté le 06-11-2012 à 16:11:20  profilanswer
 

Bonjour,

 

D'après ce que tu décris, j'ai l'impression que tu utilises un noyau 64bits mixé avec un userland 32bits.
En gros, l'architecture de ton processeur est 64bits et le noyau fonctionne dans ce mode, mais ton installation Debian (userland) est en 32bits.

 

Ce qui explique pourquoi les programmes 64 bits ne se lancent pas (car toutes tes lib système & co sont 32 bits) contrairement aux programmes 32bits (ton noyau 64bits dispose d'un mode de compatibilité qui permet de les exécuter).

 

Du point de vue théorique, une installation mixant noyau 64bits et userland 32bits est censée fonctionner, mais en pratique cela peut poser des problèmes et ce n'est pas vraiment recommandé. D'autant que les versions stables actuelles de Debian ne gèrent pas le multilib (c'est à dire la possiblité d'installer en parallèle des bibliothèques 32 et 64bits et donc de mixer indifféremment des applis dans ces 2 modes).
Donc, pour faire simple :
-> tu disposes d'une architecture 64bits, tu n'utilises plus du tout d'applis 32bits : noyau + userland en full 64bits
-> tu disposes d'une architecture 64bits, tu utilises ponctuellement des applis 32bits : noyau + userland en full 64bits + ia32-libs
-> tu disposes d'une architecture 64bits, tu as besoin d'une pleine compatibilité 32bits : noyau + userland en full 32bits
-> tu disposes d'une architecture 32bits, et bien tu n'as pas d'autre choix  :D

 

Peut-être que ton problème de plantage (système et/ou Iceweasel) est donc lié au fait que tu utilises ce type d'installation.
Dans un premier temps, je te conseillerai d'effectuer un backup de tes données et de tout réinstaller proprement suivant tes besoins et ce que j'ai indiqué ci-dessus.
Le lien suivant te permet de télécharger l'ISO d'installation minimale Debian 6.0 en 32 ou 64bits (au choix lors du boot de l'install -i386=32bits et amd64=64bits ; dans tous les cas utilises le noyau proposé par défaut, il correspondra automatiquement au type d'install sélectionné) :
   ---> http://cdimage.debian.org/debian-c [...] etinst.iso

 

Si, pendant l'install ou après, tes problèmes de plantages perdurent, alors il faudra sans doute envisager un problème matériel et vérifier le bon fonctionnement -cas le plus probable- de la mémoire (cf. memtest) ou du disque dur SSD (cf. smartmontools, fsck, etc.) voire -cas le moins probable- le bon fonctionnement du CPU (cf. cpuburn, attention au pb de surchauffe). Après un plantage, vérifie également les erreurs enregistrées dans /var/log/messages et /var/log/kern.log (noyau), dans /var/log/user.log et ~/.xsession-errors (applis) ça peut grandement aider pour déterminer l'origine d'un problème.

Message cité 1 fois
Message édité par THRAK le 06-11-2012 à 16:12:42

---------------
THRAK (def.) : 1) A sudden and precise impact moving from intention, direction and commitment, in service of an aim. 2) 117 guitars almost striking the same chord simultaneously.
n°1324023
joe dalton
Posté le 06-11-2012 à 17:32:30  profilanswer
 

THRAK a écrit :

Bonjour,
 
D'après ce que tu décris, j'ai l'impression que tu utilises un noyau 64bits mixé avec un userland 32bits.
En gros, l'architecture de ton processeur est 64bits et le noyau fonctionne dans ce mode, mais ton installation Debian (userland) est en 32bits.
 
Ce qui explique pourquoi les programmes 64 bits ne se lancent pas (car toutes tes lib système & co sont 32 bits) contrairement aux programmes 32bits (ton noyau 64bits dispose d'un mode de compatibilité qui permet de les exécuter).
 
Du point de vue théorique, une installation mixant noyau 64bits et userland 32bits est censée fonctionner, mais en pratique cela peut poser des problèmes et ce n'est pas vraiment recommandé. D'autant que les versions stables actuelles de Debian ne gèrent pas le multilib (c'est à dire la possiblité d'installer en parallèle des bibliothèques 32 et 64bits et donc de mixer indifféremment des applis dans ces 2 modes).
Donc, pour faire simple :
-> tu disposes d'une architecture 64bits, tu n'utilises plus du tout d'applis 32bits : noyau + userland en full 64bits
-> tu disposes d'une architecture 64bits, tu utilises ponctuellement des applis 32bits : noyau + userland en full 64bits + ia32-libs
-> tu disposes d'une architecture 64bits, tu as besoin d'une pleine compatibilité 32bits : noyau + userland en full 32bits
-> tu disposes d'une architecture 32bits, et bien tu n'as pas d'autre choix  :D  
 
Peut-être que ton problème de plantage (système et/ou Iceweasel) est donc lié au fait que tu utilises ce type d'installation.
Dans un premier temps, je te conseillerai d'effectuer un backup de tes données et de tout réinstaller proprement suivant tes besoins et ce que j'ai indiqué ci-dessus.
Le lien suivant te permet de télécharger l'ISO d'installation minimale Debian 6.0 en 32 ou 64bits (au choix lors du boot de l'install -i386=32bits et amd64=64bits ; dans tous les cas utilises le noyau proposé par défaut, il correspondra automatiquement au type d'install sélectionné) :
   ---> http://cdimage.debian.org/debian-c [...] etinst.iso
 
Si, pendant l'install ou après, tes problèmes de plantages perdurent, alors il faudra sans doute envisager un problème matériel et vérifier le bon fonctionnement -cas le plus probable- de la mémoire (cf. memtest) ou du disque dur SSD (cf. smartmontools, fsck, etc.) voire -cas le moins probable- le bon fonctionnement du CPU (cf. cpuburn, attention au pb de surchauffe). Après un plantage, vérifie également les erreurs enregistrées dans /var/log/messages et /var/log/kern.log (noyau), dans /var/log/user.log et ~/.xsession-errors (applis) ça peut grandement aider pour déterminer l'origine d'un problème.


 
 
merci pour ces info, comment puis je vois le type d'userland?
autre chose étrange c'est que j'arrive a installer certaine application en 64bits quand meme telque virtualbox grace a apt-get. cela veux il dire que certaines applications ne s'occupent pas du userland? que seul le noyau compte pour elles?
normalement j'ai télécharger au depart les iso 64bits donc ça me parait étrange qu'il soit en 32bits après installation.
mais bon je vais reesayer en téléchargeant une nouvelle image.


---------------
Blog
n°1324026
joe dalton
Posté le 06-11-2012 à 17:35:41  profilanswer
 

je suis entrain de télécharger
http://cdimage.debian.org/debian-c [...] -DVD-1.iso
ça devrais etre bon?


Message édité par joe dalton le 06-11-2012 à 17:36:21

---------------
Blog

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  probleme avec mon installation debian 6

 

Sujets relatifs
probleme d'installation debian sur RAID LSI[DEBIAN] Problème installation ISPconfig3
problème installation carte son debian lenny 5.0Probleme d'installation Horde3/IMP4 sur Debian 5
Problème à l'installation de DEBIAN 4[Debian] Problème d'installation (Serveur X et Disque dur SATA)
[WIFI] Problème d'installation de dongle usb Sagem Livebox sur Debian[DEBIAN]Problème installation debian + carte réseau
[DEBIAN] Probleme installation et startx 
Plus de sujets relatifs à : probleme avec mon installation debian 6


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR