Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1275 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [Open GL]installation de la 3D

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

[Open GL]installation de la 3D

n°701069
coolben
http://www.starbusiness.fr
Posté le 01-07-2005 à 20:02:12  profilanswer
 

Bonjour a tous
 
La 3D ne marche pas chez moi.
Je ne sais pas quoi faire et je n'ai plus d'idée.
Comment savoir quel est le probleme ?
J'ai une debian sarge sous gnome
 
merci pour votre aide
 

Citation :

coolben@sempron:~$
coolben@sempron:~$ tuxracer
Tux Racer 0.61 -- a Sunspire Studios Production (http://www.sunspirestudios.com)
(c) 1999-2000 Jasmin F. Patry <jfpatry@sunspirestudios.com>
"Tux Racer" is a trademark of Jasmin F. Patry
Tux Racer comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions.
See http://www.gnu.org/copyleft/gpl.html for details.
 
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
*** tuxracer error: Couldn't initialize video: Couldn't find matching GLX visual (Success)
coolben@sempron:~$
coolben@sempron:~$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
 
   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Erreur de segmentation
coolben@sempron:~$ glxgears
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
coolben@sempron:~$
 

mood
Publicité
Posté le 01-07-2005 à 20:02:12  profilanswer
 

n°701071
Dark_Schne​ider
Close the World, Open the Net
Posté le 01-07-2005 à 20:24:53  profilanswer
 

1. carte graphique
 
2. distribution


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°701073
Jar Jar
Intaigriste
Posté le 01-07-2005 à 20:29:04  profilanswer
 

Xlib:  extension "GLX" missing on display ":0.0".  
 
Ça c'est le serveur X qui est mal configuré.

n°701084
dr-freuder​ick
Asymétrie Cognitive.
Posté le 01-07-2005 à 21:01:54  profilanswer
 

Ya des réponses j'ai l'impression sur google.

n°701085
Jar Jar
Intaigriste
Posté le 01-07-2005 à 21:02:46  profilanswer
 

Bah c'est pas sorcier, faut juste activer l'extension GLX dans la configuration du serveur X.

n°701086
dr-freuder​ick
Asymétrie Cognitive.
Posté le 01-07-2005 à 21:05:06  profilanswer
 

oué je crois bien.

n°701184
Dark_Schne​ider
Close the World, Open the Net
Posté le 02-07-2005 à 04:23:43  profilanswer
 

mais bon en même temps si le pilotre ne supporte pas l'OpenGL.
 
 
Load "glx" dans ton fichier de conf de Xfree/Xorg dans al section "Module"


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°701197
Jar Jar
Intaigriste
Posté le 02-07-2005 à 09:45:18  profilanswer
 

Dark_Schneider a écrit :

mais bon en même temps si le pilotre ne supporte pas l'OpenGL.

Quand bien même, l'extension GLX permet alors d'utiliser Mesa.

n°701234
coolben
http://www.starbusiness.fr
Posté le 02-07-2005 à 12:26:52  profilanswer
 

salut et merci pour vos reponses
 
j'ai deja cette ligne dans mon fichier XF86Config-4 :

Citation :

Section "Module"
 Load "GLcore"
 Load "bitmap"
 Load "dbe"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "record"
 Load "speedo"
 Load "type1"
 Load "vbe"
EndSection


 
donc a ce niveau je pense que c'est bon.
ma carte graphique est un Geforce 2 GTS en AGP.
 
J'ai deja chercher sur Google mais j'ai rien trouvé d'intéréssant.
 
J'aimerai surtout savoir quel est le problème précisément pour savoir ou cherché.
Es ce une librairie manquante, mon drivers de ma carte garphique ma configurer, mauvaise config de mon serveur X , ...
Voila je suis un peu debutant et j'aimerai avoir la 3D pour jouer
 
merci

n°701236
dr-freuder​ick
Asymétrie Cognitive.
Posté le 02-07-2005 à 12:30:35  profilanswer
 

et si tu fais ça ?
 
export DISPLAY=localhost:0.0
 


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
mood
Publicité
Posté le 02-07-2005 à 12:30:35  profilanswer
 

n°701237
miminou
Posté le 02-07-2005 à 12:30:54  profilanswer
 

tout le monde a oublié de te dire d'installer les derniers drivers nvidia...
 
http://www.nvidia.com/object/unix.html


Message édité par miminou le 02-07-2005 à 12:31:49
n°701342
the_fireba​ll
I have fucking failed
Posté le 02-07-2005 à 17:10:02  profilanswer
 

pas de bol il parait que les nouveaux drivers nvidia ne supportent plus les geforce2


---------------
Two thousand years of misery, of torture in my name, hypocrisy made paramount, paranoia the law, my name is called religion, sadistic, sacred whore.
n°701346
orson
Posté le 02-07-2005 à 17:19:26  profilanswer
 

Si, ils supportent sans pb les GeForce 2; j'en ai une générique sur un PC avec Mandriva 10.2, aucun problème pour l'installation qui doit être effectuée comme décrit sur le site nvidia (ou dans le fichier readme de l'archive) S'assurer par contre après que le fichier xorg.conf est bien libellé (sous root, remplacer dans ce fichier driver "nv" par "nvidia".
Cordialement.

n°701351
the_fireba​ll
I have fucking failed
Posté le 02-07-2005 à 17:33:35  profilanswer
 

raté, extrait du fichier ftp://download.nvidia.com/XFree86 [...] README.txt
 
Below are the legacy GPUs that are no longer supported in the unified driver.
These GPUs will continue to be maintained through the special legacy NVIDIA
GPU driver releases.
 
 
    NVIDIA chip name                   Device PCI ID
    -------------------------------    -------------------------------
    RIVA TNT                           0x0020
    RIVA TNT2/TNT2 Pro                 0x0028
    RIVA TNT2 Ultra                    0x0029
    Vanta/Vanta LT                     0x002C
    RIVA TNT2 Model 64/Model 64 Pro    0x002D
    Aladdin TNT2                       0x00A0
    GeForce 256                        0x0100
    GeForce DDR                        0x0101
    Quadro                             0x0103
    GeForce2 GTS/GeForce2 Pro          0x0150
    GeForce2 Ti                        0x0151
    GeForce2 Ultra                     0x0152
    Quadro2 Pro                        0x0153


---------------
Two thousand years of misery, of torture in my name, hypocrisy made paramount, paranoia the law, my name is called religion, sadistic, sacred whore.
n°701802
coolben
http://www.starbusiness.fr
Posté le 04-07-2005 à 10:05:09  profilanswer
 

Mais comment peut on savoir que les drivers sont bon ou pas ?
J'ai deja essayé de les installer et j'avais eu de probleme de source de kernel.
ce qui m'etonne aussi fortement c'est que je viens d'installer une debian sarge sur mon portable (un autre pc) et que la 3D marche alors que je n'ai rien fais de plus.

Citation :

export DISPLAY=localhost:0.0


je remercie que l'on me conseille ca mais ca me dit pas grand chose. Es ce une command ou un ligne a rajouter dans XF86Config-4 ou dans un autre fichier ?
j'espere que google me le dira.
 
merci encore

n°701868
coolben
http://www.starbusiness.fr
Posté le 04-07-2005 à 13:13:54  profilanswer
 

apres quelques petits recherches j'ai essayer ca mais j'ai l'impression que c'est pire
 
 

Citation :

sempron:/home/coolben# export DISPLAY=localhost:0.0
sempron:/home/coolben# glxinfo
Error: unable to open display (null)
sempron:/home/coolben#


n°701929
Dark_Schne​ider
Close the World, Open the Net
Posté le 04-07-2005 à 14:59:06  profilanswer
 

coolben> quelle distro utilises tu ?


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°701978
_darkalt3_
Proctopathe
Posté le 04-07-2005 à 15:39:58  profilanswer
 

coolben a écrit :

J'ai une debian sarge sous gnome



---------------
Töp of the plöp
n°701987
miminou
Posté le 04-07-2005 à 15:52:04  profilanswer
 

dis donc , on va faire combien de page pour avoir le XF86Config
ou que tu te decide a installer/reinstaller les drivers... !!  :heink:

n°702080
coolben
http://www.starbusiness.fr
Posté le 04-07-2005 à 18:41:42  profilanswer
 

Je viens de telecharger le driver de chez nvidia.
voici ce que j'ai fait :
#init 3
ALT+CTRL+SUPPR
cd mon_repertoire
sh NVIDIA...
 
la une interface sur fond bleu se lance.
il me demande si je veux un noyeau precompilé.
je dit oui
il me dit qu'il n'en a pas qui convient
il essaye d'en construire un et voila le message d'erreur qu'il me retourne :

Citation :


ERROR: enable to load the kernel module 'nvidia.ko' this is most likely because the kernel module was built using the wrong kernel source file. Please make sur you have installed the kernel source files for your kernel; on Red Hat Linux systems, fo example, be sure you have the 'kernel-source' rpm installed. If you know the correct kernel source files are installed, you may specify the kernelsource path with the '--kernel-source-path' commandline option


 
voila mon probleme pour le kernel

n°702082
Dark_Schne​ider
Close the World, Open the Net
Posté le 04-07-2005 à 18:42:59  profilanswer
 

installe les source du noyau.
 
apt-get kernel-source


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°702085
coolben
http://www.starbusiness.fr
Posté le 04-07-2005 à 18:50:07  profilanswer
 

c'est deja fait pourtant

n°702093
Dark_Schne​ider
Close the World, Open the Net
Posté le 04-07-2005 à 19:10:45  profilanswer
 

uname -r   <- cela te donne la version de ton noyau
 
maintenant vas dans /usr/src et regarde les répertoires qui s'y trouve, tu dois en avoir un qui a le même numéro de version que ton noyau


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°702107
Jar Jar
Intaigriste
Posté le 04-07-2005 à 19:59:01  profilanswer
 

Arrrrrrg mais arrêtez avec les drivers nvidia... Il faut installer le paquet Debian, pas la version du site de nvidia.

n°702131
coolben
http://www.starbusiness.fr
Posté le 04-07-2005 à 21:07:59  profilanswer
 

il me semble avoir deja installer le paquet debian de nvidia mais la je suis pas sure
je vais voir la correspondance des version de mes sources et du uname mais il me semble que ce sont les memes

n°702134
coolben
http://www.starbusiness.fr
Posté le 04-07-2005 à 21:11:07  profilanswer
 

voila :

Citation :

sempron:/usr/src# uname -r
2.6.8-1-386
sempron:/usr/src# ls -l
total 52884
-rw-r--r--   1 root src   7484948 2005-04-26 20:02 kernel-image-2.6.8.050426_2.6.8_i386.deb
-rw-r--r--   1 root src  11715186 2005-04-24 19:37 kernel-image-2.6.8_2.6.8-1ben_i386.deb
drwxr-xr-x   3 root root     4096 2005-04-24 17:14 kernel-kbuild-2.6-3
drwxr-xr-x  20 root root     4096 2005-04-26 20:02 kernel-source-2.6.8
-rw-r--r--   1 root root 34867542 2005-05-19 12:53 kernel-source-2.6.8.tar.bz2
lrwxrwxrwx   1 root src        19 2005-04-24 17:30 linux -> kernel-source-2.6.8
lrwxrwxrwx   1 root src        26 2005-04-24 17:11 linux-OLDVERSION.1114355672 -> kernel-headers-2.6.8-1-386
lrwxrwxrwx   1 root src        26 2005-04-24 17:14 linux-OLDVERSION.1114355846 -> kernel-headers-2.6.8-1-386
sempron:/usr/src#


j'ai un kernel 2.6.8-1-.386 mais mes sources sont 2-6-8
es ce problèmatique ?

n°702143
Jar Jar
Intaigriste
Posté le 04-07-2005 à 21:31:41  profilanswer
 

Putain mais y'a pas besoin des sources pour compiler un module ! Il faut faire pointer le lien linux vers kernel-headers-2.6.8-1-386.

n°702146
_darkalt3_
Proctopathe
Posté le 04-07-2005 à 21:38:55  profilanswer
 

bon allez je donne la soluce:
http://trustonme.net/didactels/120.html


---------------
Töp of the plöp
n°702183
Jar Jar
Intaigriste
Posté le 05-07-2005 à 00:40:19  profilanswer
 

Il commence mal ton dictaticiel, il est faux.

n°702209
_darkalt3_
Proctopathe
Posté le 05-07-2005 à 07:49:10  profilanswer
 

c'est pas le mien :o
 
explique !


---------------
Töp of the plöp
n°702292
coolben
http://www.starbusiness.fr
Posté le 05-07-2005 à 13:25:50  profilanswer
 

es ce que cela pourrais arranger les chose d'installer cela :  
kernel-headers-2.6.8-2-386  
 
ou doit je trouver une version du type :
kernel-headers-2.6.8-1-386
 
puisque :
sempron:/usr/src# uname -r
2.6.8-1-386
 
?


Message édité par coolben le 05-07-2005 à 16:47:47
n°702376
Dark_Schne​ider
Close the World, Open the Net
Posté le 05-07-2005 à 15:29:33  profilanswer
 

apt-get kernel-2.6.8-2


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°702428
coolben
http://www.starbusiness.fr
Posté le 05-07-2005 à 16:47:29  profilanswer
 

j'adore les réponses tres claires ...
mais je te remercie quand meme
 :)

n°702439
coolben
http://www.starbusiness.fr
Posté le 05-07-2005 à 17:27:11  profilanswer
 

bon j'ai essayé en mettant les entetes du kernel 2.6.8-2-386 et cela a marché
 
j'ai maintenant la 3D
 
je vous remercie a tous
 
PS j'ai utilisé le driver NVIDIA-linux-x86-7174

n°702441
Shingo93
Posté le 05-07-2005 à 17:28:22  profilanswer
 

j'ai un peu le même problème mais sous quake3 :/
 
Il me Xlib : extension "XFree86-DRI" missing on display "0:0"
GL_RENDERER.
 
Je suis sous gentoo et ma cg et une ATI radeon mobility 9700
J'ai installé les drivers, fait fglrxconfig plusieurs fois :/
Xorgconfig idem :/
un update opengl ATI
 
MESA n'est pas installé, et quand je veux l'installer, il est en "masked".

n°702539
Dark_Schne​ider
Close the World, Open the Net
Posté le 05-07-2005 à 20:38:35  profilanswer
 

Shingo93> lis la doc ATI, ajoute Load "dri"


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°702801
Shingo93
Posté le 05-07-2005 à 23:04:18  profilanswer
 

c'est déja ajouté :/
 
voilà ce que ça me met quand je lance q3 :
 
GL_Renderer : MESA GLX indirect
 
You are using software MESA (no hardware acceleration)
Drivers DLL used : libGL.so.1
 
et MESA toujours pas installer :/
 
 

n°703262
Dark_Schne​ider
Close the World, Open the Net
Posté le 06-07-2005 à 18:45:39  profilanswer
 

que donne glxinfo


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°705277
coolben
http://www.starbusiness.fr
Posté le 11-07-2005 à 23:18:50  profilanswer
 

hello me re-voila
 
j'ai maintenant une nouvelle carte graphique :
une ati radeon 9550
 
j'ai installé le driver et lancé fglrxconfig.
Cela ma créé un nouveau ficher de config de X (XF86Config-4) mais il ne marche pas.
Je ne comprend pas pourquoi je dois lancer fglrxconfig alors que ca reconfigure tout (souris,...) alors que mise a part la carte graphique rien a changé.
bref c'est pas grave j'ai repris mon ancien et je l'ai un peu adapté.
J'arrive a lancer gdm mais j'ai n'est pas la 3D :
 

Citation :

coolben@sempron:~$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
 
   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
coolben@sempron:~$ glxgears
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
coolben@sempron:~$


je n'ai plus trop d'idée
 
merci pour votre aide

n°705479
Dark_Schne​ider
Close the World, Open the Net
Posté le 12-07-2005 à 13:21:18  profilanswer
 

quelle version de XFree as tu ?
 
si tu as une Radeon 9550, tu dois installer et conf correctement XFree. tu dois aussi chargé le module pour le support de ton chipset AGP.
 
un bon moyen est de regarder les logs/journaux de XFree : /var/log/XFree86.0.log


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [Open GL]installation de la 3D

 

Sujets relatifs
installation RAID sous debianComment créé une installation???
[MDK 10.1] Problème d'installation d'un pilote...Heeeeelp!! Installation Debian : blocage
installation mandrake - pb 2eme DD - mbr ?[Debian Installation] Ecran noir
Avenir de Qt et KDE par rapport a l'open sourceprobleme installation mandrake
problème d'installation de FEDORA 4probleme installation mandrake 10.1
Plus de sujets relatifs à : [Open GL]installation de la 3D


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR