Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1067 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [résolu] Impossible de démarrer Windows après installation d'Ubuntu

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[résolu] Impossible de démarrer Windows après installation d'Ubuntu

n°1430848
ress p
Posté le 05-03-2019 à 13:55:16  profilanswer
 

Bonjour à tous  :hello:  
 
Je viens d'installer Ubuntu 18.04 sur un SSD, et depuis, impossible de booter sur mon autre SSD avec Windows 10  :sweat:  
 
 
J'ai des connaissances relativement limitées dans le domaine, mais je vais essayer de faire comprendre au mieux la situation en vulgarisant ma problématique.
 
 
SITUATION DE DEPART (sans problème) :
 
SSD1 : Windows 10
SSD2 : Ubuntu 16.04
 
Windows boot de manière prioritaire, et si je veux lancer Ubuntu, je fais juste un petit coup de F11 au démarrage afin de lancer le boot-menu et sélectionner le SSD Ubuntu en UEFI.
 
-------------------------------------------------------------------------------------------
CHANGEMENT EFFECTUE :
SSD1 déconnecté : Windows 10  (pour sécuriser la manip)
SSD2 : formatage et installation de Ubuntu 18.04
 
-------------------------------------------------------------------------------------------
SITUATION FINALE (avec problème) :
SSD1 reconnecté : Windows 10  
SSD2 : Ubuntu 18.04
 
Ubuntu boot de manière prioritaire (à l'inverse de la situation de départ donc), et se lance parfaitement. Par contre, si je veux lancer Windows 10 via le boot menu, impossible.
Le message suivant s'écrit au démarrage ==> "error file '/boot/grub 'i386-pc/normal.mod' not found"
 
 
 
 
Je pense savoir d’où viens le souci, mais je ne sais pas comment le résoudre.
Avant, dans les paramètres de boot de la carte mère, chacun de mes SSD apparaissait 2 fois (1 fois en UEFI et 1 fois en non-UEFI).
Mais depuis l'installation d'Ubuntu 18.04, le SSD de Windows n'apparait plus en version UEFI mais seulement en version non-UEFI
Et si auparavant je faisais l'erreur de booter sur la version non-UEFI, j'avais bien le même message qui s'inscrivait (error file '/boot/grub 'i386-pc/normal.mod' not found)
 
 
J'imagine que lors du boot, le SSD de Windows ne charge plus les infos nécessaires pour être reconnu de manière adéquat par le système de démarrage.
Mais pourquoi un tel changement alors que tout la manœuvre d'installation d'Ubuntu 18.04 s'est faite avec le SSD de Windows 10 deconnecté ?
 
A noter, que le SSD de Windows en question et très bien reconnu par Ubuntu, je peux même accéder aux fichier/dossiers.
 
 
Merci d'avance pour votre aide  :jap:


Message édité par ress p le 05-03-2019 à 14:26:30
mood
Publicité
Posté le 05-03-2019 à 13:55:16  profilanswer
 

n°1430849
ress p
Posté le 05-03-2019 à 14:17:49  profilanswer
 

Évidemment, je trouve la solution 10 minutes après  :pfff:  
 
Dans les paramètres de boot priority ma carte mère, en bas du listing du tous les périphériques, il y'a un autre menu déroulant spécialement dédié à la partie UEFI.
J'ai déroulé ce menu, et j'ai pu réactiver une option du genre Windows Manager System afin qu'elle apparaisse par la suite sur le boot menu.
 
Le fait d'avoir déconnecte le SSD Windows durant la manœuvre avait simplement désactivé la reconnaissance.
 
Bon bah voilà, je peux rebooter sur mes 2 systèmes  :bounce:  
 
 
Merci bien les amis  :D

n°1430851
kaari
Fuck Yeah !
Posté le 05-03-2019 à 15:20:39  profilanswer
 

Sinon grub peut booter ton Windows dans avoir à choisir au boot. D'ailleurs je croyais que sur Ubuntu il y avait d'office os-prober d'installé...


---------------
Mon topic ventes ;)
n°1430860
Trit'
Posté le 05-03-2019 à 17:46:08  profilanswer
 

kaari a écrit :

Sinon grub peut booter ton Windows dans avoir à choisir au boot. D'ailleurs je croyais que sur Ubuntu il y avait d'office os-prober d'installé...


Mais os-prober ne peut pas détecter un OS présent sur un disque non branché à l’installation… Et comme il ne va pas se relancer de lui-même par la suite, il le détectera pas non plus aux démarrages suivants.
 
En fait, il faudrait forcer une réinstallation de GRUB sur lui-même (donc, savoir dans quel /dev/sd× il est logé), avec un « sudo grub-install /dev/sd× » (remplacer × par la lettre associée au disque où est installé Ubuntu). Tu as la procédure détaillée ici (point 8.5).
 

Spoiler :

J’allais mettre « la lettre de lecteur », ce qui, vu qu’on parle du manipulation à faire sur un Linux, aurait été pour le moins cocasse… mais pas complètement faux non plus ! :whistle:


Message édité par Trit' le 05-03-2019 à 17:49:05
n°1430861
kaari
Fuck Yeah !
Posté le 05-03-2019 à 18:38:12  profilanswer
 

Re-installer grub ne changera rien il est déja installé et rien ne changera...
Os-prober n'as juste pas repéré le disque windows a l'install comme tu le dis, a la prochaine update kernel il verra windows, ou tu peux actualiser la config avec grub-mkconfig -o /boot/grub/grub.cfg (a modifier en fonction de la distro).
Et si tu ne vois pas que l'outil de conf a repéré windows, c'est qu'il manque os-prober.


---------------
Mon topic ventes ;)
n°1430874
ress p
Posté le 05-03-2019 à 23:45:16  profilanswer
 

Si je comprends bien, dans le cas ou j'aurais installé Ubuntu avec le SSD Windows connecté, il aurait de lui même bien configuré les paramètres de boot ?
 
Je me doute bien que de faire une installation en déconnectant les autres SSD/HDD n'est pas forcément la meilleure solution, mais me connaissant, je préfère prendre mes précautions  :D  
 
Toujours est-il que tout est bien rentré dans l'ordre.
Et concernant ma méthode de boot, ce n'est peut-être pas la plus optimale, mais y étant habitué depuis plusieurs années, elle me va bien.
 
Aucune action => démarrage W10
F11(boot menu) + choix du SSD Ubuntu => démarrage Ubuntu
 
Par contre, impossible d’accéder à mes HDD (internes) sous Ubuntu suite à une session Windows que je n'aurai pas quitté via la ligne de commande "shutdown /p"
Si je démarrage Ubuntu après avoir quitté Windows de manière classique, les HDD (ainsi que le SSD Windows) ne peuvent pas être montés.

n°1430876
Trit'
Posté le 06-03-2019 à 01:22:23  profilanswer
 

ress p a écrit :

Par contre, impossible d’accéder à mes HDD (internes) sous Ubuntu suite à une session Windows que je n'aurai pas quitté via la ligne de commande "shutdown /p"
Si je démarrage Ubuntu après avoir quitté Windows de manière classique, les HDD (ainsi que le SSD Windows) ne peuvent pas être montés.


C’est parce que la mise en veille prolongée que provoque le système de « démarrage rapide » de Windows verrouille l’accès à sa partition système.
 
Pour régler ça, il faut donc désactiver le démarrage rapide dans les options d’alimentation de Windows (Panneau de configuration classique).
 
Et accessoirement, pour accéder à ta partition Linux depuis Windows, tu as l’outil Ext2fsd qui te permettra d’affecter une lettre de volume à tes partitions Ext2-4 (le montage sera ensuite automatique à chaque démarrage de l’outil et restera effectif jusqu’à l’arrêt de Windows).


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [résolu] Impossible de démarrer Windows après installation d'Ubuntu

 

Sujets relatifs
Antivirus pour Ubuntu 16.04Impossible d'installer Mongodb sous Ubuntu 18.04
Démarrer le serveur automatiquement au reboot de la machine.[ubuntu 16.04 LTS] apt-get update erreur 404
Problème démarrage Ubuntu suite MàJ ZentyalServeur Ubuntu KVM + Kimchi VPS innaccessible en SSH de l'exterieur
Thunderbolt entre Windows et Linuxprobleme apres instalation de ubuntu 14.04
Plus de sujets relatifs à : [résolu] Impossible de démarrer Windows après installation d'Ubuntu


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR