Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2336 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  *Failed* Passer de kubuntu edgy à debian etch, proprement

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

*Failed* Passer de kubuntu edgy à debian etch, proprement

n°928869
Jeddo
A nice place to live
Posté le 30-06-2007 à 15:34:36  profilanswer
 

Bonjour à tous :hello:  
 
Je voudrais migrer ma kubuntu edgy vers une debian etch sans passer par la case reinstall.
Mon petit doigt me dit que c'est possible mais délicat.
 
Dans ce post, zecrazytux m'expliquait plus ou moins comment faire, mais je préfère créer un topic pour les détails manquant.
Mon idée est la suivante :
 - changer les repositories de /etc/apt/sources.list
 - faire un dist-upgrade
Dites-moi si je me plante complètement.
 
En attendant, je vais quand même sauvegarder sur un DVD :D
 
(une petite recherche google me donne un beau topic à troll sur le forum d'ubuntu : http://forum.ubuntu-fr.org/viewtopic.php?id=104808)


Message édité par Jeddo le 01-07-2007 à 20:07:45

---------------
FREE DATOUNE
mood
Publicité
Posté le 30-06-2007 à 15:34:36  profilanswer
 

n°928893
Jeddo
A nice place to live
Posté le 30-06-2007 à 19:14:44  profilanswer
 

Un petit up.
 
En fait j'ai lutté pour faire ma sauvegarde, je sais pas pourquoi  [:cerveau skyzor]


---------------
FREE DATOUNE
n°928897
Chocolay
Posté le 30-06-2007 à 20:00:17  profilanswer
 

perso, je ferais sauvegarde et je passerai par la case reinstall  
sauf si t'es du genre casse-cou :D

n°928899
Jeddo
A nice place to live
Posté le 30-06-2007 à 20:22:17  profilanswer
 

Je vais tenter le "casse-cou" :D
De toute façon, j'ai fait une sauvegarde.
 
J'ai modifié mon sources.list comme ceci (j'ai une sauvegarde de l'ancien sources.list) :
 

# dépôts officiels
deb http://ftp2.fr.debian.org/debian/ etch main contrib non-free
deb-src http://ftp2.fr.debian.org/debian/ etch main contrib non-free
 
# dépôts security
deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free


 
J'ai une erreur gpg quand j'update :
 

jeddo@jlaptop:/etc/apt$ sudo apt-get update
Réception de : 1 http://ftp2.fr.debian.org etch Release.gpg [378B]
Ign http://ftp2.fr.debian.org etch/main Translation-fr
Ign http://ftp2.fr.debian.org etch/contrib Translation-fr
Ign http://ftp2.fr.debian.org etch/non-free Translation-fr
Réception de : 2 http://ftp2.fr.debian.org etch Release [58,2kB]
Réception de : 3 http://security.debian.org etch/updates Release.gpg [189B]
Ign http://security.debian.org etch/updates/main Translation-fr
Ign http://security.debian.org etch/updates/contrib Translation-fr
Ign http://security.debian.org etch/updates/non-free Translation-fr
Réception de : 4 http://security.debian.org etch/updates Release [22,5kB]
Ign http://ftp2.fr.debian.org etch Release
Ign http://security.debian.org etch/updates Release
Réception de : 5 http://security.debian.org etch/updates/main Packages [92,7kB]
Réception de : 6 http://ftp2.fr.debian.org etch/main Packages [4295kB]
Réception de : 7 http://security.debian.org etch/updates/contrib Packages [14B]
Réception de : 8 http://security.debian.org etch/updates/non-free Packages [14B]
Réception de : 9 http://security.debian.org etch/updates/main Sources [13,8kB]
Réception de : 10 http://security.debian.org etch/updates/contrib Sources [14B]
Réception de : 11 http://security.debian.org etch/updates/non-free Sources [14B]
Réception de : 12 http://ftp2.fr.debian.org etch/contrib Packages [60,0kB]
Réception de : 13 http://ftp2.fr.debian.org etch/non-free Packages [83,6kB]
Réception de : 14 http://ftp2.fr.debian.org etch/main Sources [1214kB]
Réception de : 15 http://ftp2.fr.debian.org etch/contrib Sources [18,4kB]
Réception de : 16 http://ftp2.fr.debian.org etch/non-free Sources [28,1kB]
5887ko réceptionnés en 8s (720ko/s)
Lecture des listes de paquets... Fait
W: GPG error: http://ftp2.fr.debian.org etch Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY A70DAF536070D3A1 NO_PUBKEY B5D0C804ADB11277
W: GPG error: http://security.debian.org etch/updates Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY A70DAF536070D3A1
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.


 
Malgré quelques pistes glanées sur des forums je n'ai pas solutionné ça.
Si je passe outre et fait un dist-upgrade :
 

jeddo@jlaptop:/etc/apt$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront ENLEVÉS :
  adept-batch apt-index-watcher fglrx-control kaffeine-xine language-selector-qt openoffice.org-style-crystal openoffice.org-style-default
  python-apt startup-tasks synaptic system-services ubuntu-minimal upstart upstart-compat-sysv upstart-logd xorg xorg-driver-fglrx
  xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-elographics xserver-xorg-input-evdev xserver-xorg-input-kbd
  xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-apm
  xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-cyrix
  xserver-xorg-video-dummy xserver-xorg-video-fbdev xserver-xorg-video-glint xserver-xorg-video-i128 xserver-xorg-video-i740
  xserver-xorg-video-i810 xserver-xorg-video-imstt xserver-xorg-video-mga xserver-xorg-video-neomagic xserver-xorg-video-newport
  xserver-xorg-video-nsc xserver-xorg-video-nv xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge
  xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx
  xserver-xorg-video-tga xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-v4l xserver-xorg-video-vesa
  xserver-xorg-video-vga xserver-xorg-video-via xserver-xorg-video-vmware xserver-xorg-video-voodoo
Les NOUVEAUX paquets suivants seront installés :
  apache2-mpm-prefork apache2.2-common busybox debian-archive-keyring gcc-3.4-base genisoimage gpgv gstreamer0.10-alsa gstreamer0.10-ffmpeg
  gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gtk-qt-engine hwdata iceape-browser icedax icedove
  icedove-locale-en-gb icedove-locale-fr iceweasel iceweasel-l10n-en-gb iceweasel-l10n-fr lapack3 libapache2-mod-php4 libapr1 libaprutil1
  libcaca0 libcucul0 libdb4.2 libdirectfb-0.9-25 libdns22 libexiv2-0.10 libg2c0 libgail17 libgalago1.0-cil libgalago2 libgnokii3
  libgraphicsmagick1 libicu36 libiec61883-0 libjack0.100.0-0 libjaxp1.3-java libkbanking1 libneon26 libnspr4-0d libnss3-0d liboil0.3
  libopenobex1 libpoppler0c2 libpoppler0c2-qt libsasl2-2 libshout3 libsidplay1 libssp0 libsvga1 libufsparse libvolume-id0 libwv-1.2-3
  lshw-common menu menu-xdg modconf openbsd-inetd openhackware perl-doc proll refblas3 svgalibg1 sysvinit sysvinit-utils update-inetd wodim
Les paquets suivants ont été conservés :
  belocs-locales-bin kde-guidance-powermanager kmymoney2 libk3b2
Les paquets suivants seront mis à jour :
  ...
866 mis à jour, 72 nouvellement installés, 62 à enlever et 4 non mis à jour.
Il est nécessaire de prendre 823Mo dans les archives.
Après dépaquetage, 158Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?


 
Puis :
 

ATTENTION : les paquets suivants n'ont pas été authentifiés.
  ...
Faut-il installer ces paquets sans vérification (o/N) ?
E: Certains paquets n'ont pas pu être authentifiés


 
Bref, pas de dist-upgrade possible. Je pense que l'erreur GPG est solutionnable et devrait permettre de faire l'upgrade.
 
Une idée ?
 


---------------
FREE DATOUNE
n°928902
vanfannel_​94
Posté le 30-06-2007 à 20:34:27  profilanswer
 

Je sais pas si ca peut t aider => http://www.coriolys.org/index.php? [...] gpg-debian
 
J ai pas ma debian a dispo pour tester.

n°928903
Jeddo
A nice place to live
Posté le 30-06-2007 à 20:47:28  profilanswer
 

:jap:
 
Avec ce tip, je n'ai plus de Warning :
 

jeddo@jlaptop:/etc/apt$ gpg --keyserver keyring.debian.org --recv-keys A70DAF536070D3A1
gpg: requête de la clé 6070D3A1 du serveur hkp keyring.debian.org
gpg: clé 6070D3A1: « Debian Archive Automatic Signing Key (4.0/etch) <ftpmaster@debian.org> » n'a pas changé
gpg: Quantité totale traitée: 1
gpg:              inchangée: 1
jeddo@jlaptop:/etc/apt$ gpg --armor --export A70DAF536070D3A1 | sudo apt-key add -
OK
jeddo@jlaptop:/etc/apt$ gpg --keyserver pgp.mit.edu --recv-keys B5D0C804ADB11277
gpg: requête de la clé ADB11277 du serveur hkp pgp.mit.edu
gpg: clé ADB11277: « Etch Stable Release Key <debian-release@lists.debian.org> » n'a pas changé
gpg: Quantité totale traitée: 1
gpg:              inchangée: 1
jeddo@jlaptop:/etc/apt$ gpg --armor --export B5D0C804ADB11277 | sudo apt-key add -
OK
jeddo@jlaptop:/etc/apt$ sudo apt-get update
Réception de : 1 http://ftp2.fr.debian.org etch Release.gpg [378B]
Ign http://ftp2.fr.debian.org etch/main Translation-fr
Ign http://ftp2.fr.debian.org etch/contrib Translation-fr
Ign http://ftp2.fr.debian.org etch/non-free Translation-fr
Atteint http://ftp2.fr.debian.org etch Release
Réception de : 2 http://security.debian.org etch/updates Release.gpg [189B]
Ign http://security.debian.org etch/updates/main Translation-fr
Ign http://security.debian.org etch/updates/contrib Translation-fr
Ign http://security.debian.org etch/updates/non-free Translation-fr
Atteint http://security.debian.org etch/updates Release
Atteint http://ftp2.fr.debian.org etch/main Packages
Atteint http://ftp2.fr.debian.org etch/contrib Packages
Atteint http://ftp2.fr.debian.org etch/non-free Packages
Atteint http://security.debian.org etch/updates/main Packages
Atteint http://security.debian.org etch/updates/contrib Packages
Atteint http://security.debian.org etch/updates/non-free Packages
Atteint http://security.debian.org etch/updates/main Sources
Atteint http://security.debian.org etch/updates/contrib Sources
Atteint http://ftp2.fr.debian.org etch/main Sources
Atteint http://ftp2.fr.debian.org etch/contrib Sources
Atteint http://ftp2.fr.debian.org etch/non-free Sources
Atteint http://security.debian.org etch/updates/non-free Sources
567o réceptionnés en 0s (897o/s)
Lecture des listes de paquets... Fait


---------------
FREE DATOUNE
n°928904
ttys
Posté le 30-06-2007 à 20:48:04  profilanswer
 

L’erreur GPG c’est juste parce que tu n’as pas les clés qu’il faut pour vérifier les signatures des paquets, mais ce n’est pas ça qui empêche l’upgrade (si tu réponds « oui » il t’installera/désinstallera les paquets, la signature c’est pour s’assurer que ce sont bien des développeurs debian qui ont fait les paquets). Par contre ce que je trouve plus gênant c’est qu’il veut supprimer le serveur X, tu peux toujours essayer de passer en mode console avant de faire la mise à jour et demander à le réinstaller après, mais c’est pas sûr que ça marche... Il faudrait trouver quel conflit provoque sa suppression.
 
PS : Il vaut mieux utiliser aptitude qu’apt-get.

n°928905
Jeddo
A nice place to live
Posté le 30-06-2007 à 20:48:54  profilanswer
 

Trop tard, je viens de lancer dist-upgrade [:alph-one]


---------------
FREE DATOUNE
n°928907
Jeddo
A nice place to live
Posté le 30-06-2007 à 20:55:00  profilanswer
 

Bon j'ai interrompu l'upgrade rapidement, je pense qu'il n'y a pas de souci pour l'instant car je n'ai téléchargé que quelques paquets, aucune mise à jour n'a été faite.
 
En utilisant aptitude dist-upgrade, j'ai le message suivant :
 

jeddo@jlaptop:/etc/apt$ sudo aptitude dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état... Fait
Initialisation de l'état des paquets... Fait
Construction de la base de données des étiquettes... Fait
Les paquets suivants sont CASSÉS :
  adept-batch fglrx-control language-pack-en-base language-pack-fr-base language-pack-kde-en-base language-pack-kde-fr-base libc6
  libflac++5c2 libvte4 openoffice.org-style-crystal openoffice.org-style-default python-apt xserver-xorg-video-all
Les NOUVEAUX paquets suivants vont être automatiquement installés :
  aqbanking16-qt-wizard belocs-locales-data busybox exiv2 gcc-3.4-base genisoimage gpgv gstreamer0.10-alsa gstreamer0.10-ffmpeg
  gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gstreamer0.10-x gtk-qt-engine hwdata iceape-browser
  iceape-gnome-support icedax icedove icedove-locale-en-gb icedove-locale-fr iceweasel iceweasel-l10n-en-gb iceweasel-l10n-fr iproute-doc
  jackd lapack3 latex-beamer libapr1 libaprutil1 libcaca0 libclass-accessor-perl libcucul0 libdb4.2 libdirectfb-0.9-25 libdns22
  libexiv2-0.10 libflac++5 libg2c0 libgail17 libgalago1.0-cil libgalago2 libgcj7-awt libgnokii3 libgraphicsmagick1 libhtml-parser-perl
  libhtml-tagset-perl libhtml-template-perl libicu36 libiec61883-0 libio-string-perl libjack0.100.0-0 libjaxp1.3-java libkbanking1
  libneon26 libnspr4-0d libnss3-0d libofx3 liboil0.3 libopenobex1 libparse-debianchangelog-perl libpoppler0c2 libpoppler0c2-qt libsasl2-2
  libshout3 libsidplay1 libssp0 libsvga1 libtimedate-perl libufsparse liburi-perl libvolume-id0 libwv-1.2-3 libxml-libxml-common-perl
  libxml-libxml-perl libxml-namespacesupport-perl libxml-sax-perl libxml-simple-perl lshw-common menu menu-xdg modconf openbsd-inetd
  openhackware oss-compat p7zip-full perl-doc proll python-pylibacl python-pyxattr refblas3 svgalibg1 sysvinit-utils texinfo update-inetd
  wodim
Les paquets suivants seront automatiquement ENLEVÉS :
  apt-index-watcher kaffeine-xine klaptopdaemon libofx2c2a locales xorg-driver-fglrx xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-ati xserver-xorg-video-fbdev xserver-xorg-video-glint xserver-xorg-video-mga xserver-xorg-video-newport
  xserver-xorg-video-nsc xserver-xorg-video-nv xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-tdfx xserver-xorg-video-tga xserver-xorg-video-trident
  xserver-xorg-video-v4l xserver-xorg-video-vesa xserver-xorg-video-vga xserver-xorg-video-via xserver-xorg-video-voodoo
Les NOUVEAUX paquets suivants vont être installés :
  aqbanking16-qt-wizard belocs-locales-data busybox exiv2 gcc-3.4-base genisoimage gpgv gstreamer0.10-alsa gstreamer0.10-ffmpeg
  gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gstreamer0.10-x gtk-qt-engine hwdata iceape-browser
  iceape-gnome-support icedax icedove icedove-locale-en-gb icedove-locale-fr iceweasel iceweasel-l10n-en-gb iceweasel-l10n-fr iproute-doc
  jackd lapack3 latex-beamer libapr1 libaprutil1 libcaca0 libclass-accessor-perl libcucul0 libdb4.2 libdirectfb-0.9-25 libdns22
  libexiv2-0.10 libflac++5 libg2c0 libgail17 libgalago1.0-cil libgalago2 libgcj7-awt libgnokii3 libgraphicsmagick1 libhtml-parser-perl
  libhtml-tagset-perl libhtml-template-perl libicu36 libiec61883-0 libio-string-perl libjack0.100.0-0 libjaxp1.3-java libkbanking1
  libneon26 libnspr4-0d libnss3-0d libofx3 liboil0.3 libopenobex1 libparse-debianchangelog-perl libpoppler0c2 libpoppler0c2-qt libsasl2-2
  libshout3 libsidplay1 libssp0 libsvga1 libtimedate-perl libufsparse liburi-perl libvolume-id0 libwv-1.2-3 libxml-libxml-common-perl
  libxml-libxml-perl libxml-namespacesupport-perl libxml-sax-perl libxml-simple-perl lshw-common menu menu-xdg modconf openbsd-inetd
  openhackware oss-compat p7zip-full perl-doc proll python-pylibacl python-pyxattr refblas3 svgalibg1 sysvinit-utils texinfo update-inetd
  wodim
Les paquets suivants seront ENLEVÉS :
  apt-index-watcher kaffeine-xine klaptopdaemon libofx2c2a locales xorg-driver-fglrx xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-ati xserver-xorg-video-fbdev xserver-xorg-video-glint xserver-xorg-video-mga xserver-xorg-video-newport
  xserver-xorg-video-nsc xserver-xorg-video-nv xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-tdfx xserver-xorg-video-tga xserver-xorg-video-trident
  xserver-xorg-video-v4l xserver-xorg-video-vesa xserver-xorg-video-vga xserver-xorg-video-via xserver-xorg-video-voodoo
Les paquets suivants seront mis à jour :
  ...
890 paquets mis à jour, 97 nouvellement installés, 28 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 755Mo/845Mo d'archives. Après dépaquetage, 200Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  openoffice.org-style-default: Dépend: openoffice.org-common (= 2.0.4-0ubuntu5) mais 2.0.4.dfsg.2-7etch1 doit être installé
  language-pack-en-base: Dépend: locales (>= 2.3.6) mais il n'est pas installable
  xserver-xorg-video-all: Dépend: xserver-xorg-video-apm mais il n'est pas installable
                          Dépend: xserver-xorg-video-ark mais il n'est pas installable
                          Dépend: xserver-xorg-video-ati mais il n'est pas installable
                          Dépend: xserver-xorg-video-fbdev mais il n'est pas installable
                          Dépend: xserver-xorg-video-glint mais il n'est pas installable
                          Dépend: xserver-xorg-video-mga mais il n'est pas installable
                          Dépend: xserver-xorg-video-newport mais il n'est pas installable
                          Dépend: xserver-xorg-video-nsc mais il n'est pas installable
                          Dépend: xserver-xorg-video-nv mais il n'est pas installable
                          Dépend: xserver-xorg-video-rendition mais il n'est pas installable
                          Dépend: xserver-xorg-video-s3 mais il n'est pas installable
                          Dépend: xserver-xorg-video-s3virge mais il n'est pas installable
                          Dépend: xserver-xorg-video-siliconmotion mais il n'est pas installable
                          Dépend: xserver-xorg-video-sis mais il n'est pas installable
                          Dépend: xserver-xorg-video-tdfx mais il n'est pas installable
                          Dépend: xserver-xorg-video-tga mais il n'est pas installable
                          Dépend: xserver-xorg-video-trident mais il n'est pas installable
                          Dépend: xserver-xorg-video-vesa mais il n'est pas installable
                          Dépend: xserver-xorg-video-vga mais il n'est pas installable
                          Dépend: xserver-xorg-video-via mais il n'est pas installable
                          Dépend: xserver-xorg-video-voodoo mais il n'est pas installable
                          Dépend: xserver-xorg-video-v4l mais il n'est pas installable
  libflac++5c2: Est en conflit avec: libflac++5 mais 1.1.2-6 doit être installé
  python-apt: Dépend: libapt-inst-libc6.4-6-1.1 qui est un paquet virtuel
              Dépend: libapt-pkg-libc6.4-6-3.51 qui est un paquet virtuel
  adept-batch: Dépend: libapt-pkg-libc6.4-6-3.51 qui est un paquet virtuel
  language-pack-kde-en-base: Dépend: locales (>= 2.3.6) mais il n'est pas installable
  language-pack-fr-base: Dépend: locales (>= 2.3.6) mais il n'est pas installable
  fglrx-control: Dépend: xorg-driver-fglrx mais il n'est pas installable
  libvte4: Dépend: libvte-common (= 1:0.12.2-5) mais 1:0.14.1-0ubuntu1 est installé
  openoffice.org-style-crystal: Dépend: openoffice.org-common (= 2.0.4-0ubuntu5) mais 2.0.4.dfsg.2-7etch1 doit être installé
  language-pack-kde-fr-base: Dépend: locales (>= 2.3.6) mais il n'est pas installable
  libc6: Dépend: locales (>= 2.3.11) mais il n'est pas installable
Resolving dependencies...
Les actions suivantes permettront de résoudre ces dépendances :
 
Supprimer les paquets suivants :
adept-batch
openoffice.org-style-crystal
openoffice.org-style-default
synaptic
xserver-xorg-video-all
 
Conserver les paquets suivants dans leur version actuelle :
belocs-locales-bin [2.4-1ubuntu6 (now)]
belocs-locales-data [Non installé]
discover1-data [1.2006.01.14ubuntu2 (now)]
kscreensaver [4:3.5.5-0ubuntu1 (now)]
ksmserver [4:3.5.5-0ubuntu3.4 (now)]
libflac++5 [Non installé]
libk3b2 [0.12.17-1ubuntu3 (now)]
libvte4 [Non installé]
locales [2.3.22 (now)]
qemu [0.8.2-0ubuntu1 (now)]
 
éinstaller à une version antérieure les paquets suivants :
fglrx-control [8.28.8+2.6.17.8-11.2 (now) -> 8.28.8-4 (stable)]
python-apt [0.6.19ubuntu9.1 (now) -> 0.6.19 (stable)]
xserver-xorg [1:7.1.1ubuntu6.2 (now) -> 1:7.1.0-16 (stable)]
 
Laisser les dépendances suivantes non satisfaites :
xserver-xorg recommande xserver-xorg-video-all
Le score est de -2433
 
Accepter cette solution ? [Y/n/q/?]


---------------
FREE DATOUNE
n°928908
Jeddo
A nice place to live
Posté le 30-06-2007 à 20:58:03  profilanswer
 

Ce que je peux faire par exemple, c'est une maintenance à la main avant, en supprimant les paquets qui posent problème avec apt-get remove.


---------------
FREE DATOUNE
mood
Publicité
Posté le 30-06-2007 à 20:58:03  profilanswer
 

n°928909
Xavier_OM
Pas de slips radioactifs !
Posté le 30-06-2007 à 21:01:14  profilanswer
 

plutôt avec aptitude et beaucoup de courage :o


---------------
https://www.baba-patrimoine.fr/  pour tout comprendre sur l'art et le patrimoine
n°928913
zecrazytux
Posté le 30-06-2007 à 21:10:30  profilanswer
 

coucou keupaing :)
alors oui le coup du warning GPG, ons 'en fou, c'est juste pour etre sur que quand t'installe un package, ça vienne bien de debian (ta confiance en la distro qui va pas foutre un keylogger ou une backdoor par exemple, mais beaucoup moins dans un repository sorti de nulle part...)
 
apt-get ou aptitude c'est aussi pas aml pour un bon troll... j'utilise apt-get et j'en suis pleinement satisfait. la gestion des dépendances est DIFFERENTE entre apt et aptitude, mais IMHO, n'est pas SUPERIEURE
 
ainsi a toi de tester et d'utiliser celui que tu preferera...
 
comment se passe ta migration ?
tu as bien mis "installer la version du packager/maintainer" a chaque question posé ? :)


---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°928915
Jeddo
A nice place to live
Posté le 30-06-2007 à 21:12:39  profilanswer
 

On m'a pas encore posé la question :/


---------------
FREE DATOUNE
n°928916
zecrazytux
Posté le 30-06-2007 à 21:14:39  profilanswer
 

tien je viens d'avoir une idée :)
 
dpkg -l, ça te met quoi en version ? ta pas version-ubuntu ?
si c'est le cas, tu pourrai virer tous les packages -ubuntu avant :)


---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°928918
ttys
Posté le 30-06-2007 à 21:15:53  profilanswer
 

La version de xorg d'etch est plus vieille que celle d'edgy, et la version de « locales » d'etch est 2.3.6.ds1-13 alors que la libc6 veut >=2.3.11... Peut-être qu’en essayant la testing ça passerait mieux ?  
Pour faire des essais tu peux utiliser l’option « -s » (--simulate) avec aptitude (valable pour apt-get aussi), comme ça tu peux tester différents cas sans risques. Tu peux même lancer aptitude avec cette option sans être root pour encore moins risquer de faire des conneries (marche pas avec apt-get par contre).

n°928920
zecrazytux
Posté le 30-06-2007 à 21:18:42  profilanswer
 

chinon tu pete tout et tu recommenche :)
 
t'enelve pas mal de packages d'ubuntu, ensuite tu fais un coup de tasksel et tu choisis "environnement graphique" un truc du genre


---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°928921
Xavier_OM
Pas de slips radioactifs !
Posté le 30-06-2007 à 21:20:54  profilanswer
 

zecrazytux a écrit :

coucou keupaing :)
alors oui le coup du warning GPG, ons 'en fou, c'est juste pour etre sur que quand t'installe un package, ça vienne bien de debian (ta confiance en la distro qui va pas foutre un keylogger ou une backdoor par exemple, mais beaucoup moins dans un repository sorti de nulle part...)
 
apt-get ou aptitude c'est aussi pas aml pour un bon troll... j'utilise apt-get et j'en suis pleinement satisfait. la gestion des dépendances est DIFFERENTE entre apt et aptitude, mais IMHO, n'est pas SUPERIEURE
 
ainsi a toi de tester et d'utiliser celui que tu preferera...
 
comment se passe ta migration ?
tu as bien mis "installer la version du packager/maintainer" a chaque question posé ? :)


 
dépendances inverses sparien :o


---------------
https://www.baba-patrimoine.fr/  pour tout comprendre sur l'art et le patrimoine
n°928922
Jeddo
A nice place to live
Posté le 30-06-2007 à 21:21:13  profilanswer
 

zecrazytux a écrit :

tien je viens d'avoir une idée :)
 
dpkg -l, ça te met quoi en version ? ta pas version-ubuntu ?
si c'est le cas, tu pourrai virer tous les packages -ubuntu avant :)


 
"dpkg -l" me renvoie la liste de tous les paquets, la plupart ont le tag ubuntu.
Tu es sûr de l'option '-l' ?
 

ttys a écrit :

La version de xorg d'etch est plus vieille que celle d'edgy, et la version de « locales » d'etch est 2.3.6.ds1-13 alors que la libc6 veut >=2.3.11... Peut-être qu’en essayant la testing ça passerait mieux ?  
Pour faire des essais tu peux utiliser l’option « -s » (--simulate) avec aptitude (valable pour apt-get aussi), comme ça tu peux tester différents cas sans risques. Tu peux même lancer aptitude avec cette option sans être root pour encore moins risquer de faire des conneries (marche pas avec apt-get par contre).


 
Avec '-s' il me dit simplement qu'il va télécharger/installer/supprimer quelques paquets.


---------------
FREE DATOUNE
n°928923
Jeddo
A nice place to live
Posté le 30-06-2007 à 21:22:53  profilanswer
 

Dans le pire des cas, j'ai toujours un dvd de debian etch... mais ça me permet d'expérimenter ce genre de migration risquée ;)


---------------
FREE DATOUNE
n°928924
zecrazytux
Posté le 30-06-2007 à 21:23:08  profilanswer
 

Xavier_OM a écrit :

dépendances inverses sparien :o


ouai poursa caybÿen
je désinstalle rarement :D


---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°928925
Skateinmar​s
Posté le 30-06-2007 à 21:23:42  profilanswer
 

A ta place j'aurais desinstallé Xorg et sa clique avant de tenter une pareille expérience :)

n°928927
zecrazytux
Posté le 30-06-2007 à 21:24:37  profilanswer
 

Jeddo a écrit :

"dpkg -l" me renvoie la liste de tous les paquets, la plupart ont le tag ubuntu.
Tu es sûr de l'option '-l' ?
 
 
 
Avec '-s' il me dit simplement qu'il va télécharger/installer/supprimer quelques paquets.


 
 
ben i, justement, si tu veux virer tous les packages dont la version est {numericversion}-ubuntu, suffit de faire un dpkg -l avec des cut et des sed qui vont bieng :)
 
edit: par contre si libc6 c'est version-ubuntu, tu vas prendre cher :D

Message cité 1 fois
Message édité par zecrazytux le 30-06-2007 à 21:25:03

---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°928930
Jeddo
A nice place to live
Posté le 30-06-2007 à 21:53:09  profilanswer
 

Skateinmars a écrit :

A ta place j'aurais desinstallé Xorg et sa clique avant de tenter une pareille expérience :)


 
Je peux encore le faire et passer en console.
 

zecrazytux a écrit :

ben i, justement, si tu veux virer tous les packages dont la version est {numericversion}-ubuntu, suffit de faire un dpkg -l avec des cut et des sed qui vont bieng :)
 
edit: par contre si libc6 c'est version-ubuntu, tu vas prendre cher :D


 
C'est bien ubuntu... :(


---------------
FREE DATOUNE
n°928935
Jeddo
A nice place to live
Posté le 30-06-2007 à 22:27:54  profilanswer
 

Je suis allé au bout de l'upgrade, on ne m'a jamais rien demandé pour les fichiers de config.
À la fin, j'ai ça :

Errors were encountered while processing:
 adept-notifier
 netbase
 adept-updater
 debtags
 adept-installer
 aptitude
 python-apt
 apt-utils
 adept-common


 
Pendant le process, un message revient souvent :

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C" ).


 
J'ai fait des screenshots pendant l'exécution. Au début, l'interface de ksnapshot était en français, ça a fini en anglais :D !
 
On configure ça où les locale dans debian ?


---------------
FREE DATOUNE
n°928938
zecrazytux
Posté le 30-06-2007 à 22:43:17  profilanswer
 

dpkg-reconfigure locales, luke


---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°928942
Jeddo
A nice place to live
Posté le 30-06-2007 à 22:53:17  profilanswer
 

C'est en très très mauvaise voie !
 

Dépaquetage de sysvinit-utils (à partir de .../sysvinit-utils_2.86.ds1-38_i386.deb) ...
dpkg : erreur de traitement de /var/cache/apt/archives/sysvinit-utils_2.86.ds1-38_i386.deb (--unpack) :
 tentative de remplacement de « /usr/share/man/man1/mesg.1.gz », qui appartient aussi au paquet sysvutils
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/sysvinit-utils_2.86.ds1-38_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


 
Insoluble...


---------------
FREE DATOUNE
n°928943
zecrazytux
Posté le 30-06-2007 à 22:55:47  profilanswer
 

meuh non... :D
 
dpkg --force-all est ton amis, luke :D


---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°928945
Chocolay
Posté le 30-06-2007 à 22:57:14  profilanswer
 

barbare :D

n°928957
Jeddo
A nice place to live
Posté le 01-07-2007 à 00:43:09  profilanswer
 

zecrazytux a écrit :

meuh non... :D
 
dpkg --force-all est ton amis, luke :D


 
Tu penses à quoi exactement, un configure, un remove, ... ???


---------------
FREE DATOUNE
n°928959
Jeddo
A nice place to live
Posté le 01-07-2007 à 00:49:46  profilanswer
 

Dernière news :
 

jeddo@jlaptop:/etc/apt$ sudo aptitude dist-upgrade
Construction de l'arbre des dépendances... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Construction de la base de données des étiquettes... Fait
Les paquets suivants sont CASSÉS :
  acpi-support kdelibs4c2a kdm language-pack-en-base language-pack-kde-en-base language-pack-kde-fr-base libc6 xorg xserver-xorg
Les NOUVEAUX paquets suivants vont être automatiquement installés :
  belocs-locales-data
Les paquets suivants seront automatiquement ENLEVÉS :
  locales
Les NOUVEAUX paquets suivants vont être installés :
  belocs-locales-data
Les paquets suivants seront ENLEVÉS :
  locales
Les paquets suivants seront mis à jour :
  belocs-locales-bin
1 paquets mis à jour, 1 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 4196ko d'archives. Après dépaquetage, 2904ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  xserver-xorg: Dépend: xbase-clients mais il n'est pas installable
  kdelibs4c2a: Dépend: xbase-clients mais il n'est pas installable
  language-pack-en-base: Dépend: locales (>= 2.3.6) mais il n'est pas installable
  language-pack-kde-en-base: Dépend: locales (>= 2.3.6) mais il n'est pas installable
  kdm: Dépend: xbase-clients mais il n'est pas installable
  acpi-support: Dépend: xbase-clients mais il n'est pas installable
  language-pack-kde-fr-base: Dépend: locales (>= 2.3.6) mais il n'est pas installable
  xorg: Dépend: xbase-clients (>= 1:1.0.1-1) mais il n'est pas installable
  libc6: Dépend: locales (>= 2.3.11) mais il n'est pas installable
Resolving dependencies...
ouverts : 5218 ; fermés : 4973 ; reportés : 0 ; en conflit : 6                                                                      .Aucune solution n'a été trouvée dans le temps alloué. Faut-il poursuivre la recherche ? [Y/n]


 
Y'a un souci avec le paquet xbase-clients en gros, mais je ne trouve pas de solution pour l'instant.


---------------
FREE DATOUNE
n°929051
Jeddo
A nice place to live
Posté le 01-07-2007 à 20:13:12  profilanswer
 

J'ai fini par installer debian avec les dvd :D
 
Ultime tentative que j'avais faite, c'était de passer en testing et de faire le dist-upgrade, mais ça n'a pas tout résolu (je me suis arrêté sur un conflit apparemment entre tetex et texlive). Je ne sais pas si passer en unstable aurait fonctionné : à tester si vous avez du temps à perdre.
 
Pour l'instant je ne suis pas encore emballé par ma nouvelle configuration car je sens qu'il va falloir mettre les mains dans le cambouis (pour le wifi par exemple) et ça ne m'enchante pas trop.
 
Merci à ceux qui ont tenté de m'aider.
 
A+


---------------
FREE DATOUNE
n°929163
Taz
bisounours-codeur
Posté le 02-07-2007 à 10:00:45  profilanswer
 

si t'as ton /home sur une partoche, l'install va aller très vite.

n°929178
zecrazytux
Posté le 02-07-2007 à 10:27:41  profilanswer
 

pour le wifi dans contrib  || non-free y a les kernel modules


---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°929477
gee
Bon ben hon
Posté le 02-07-2007 à 19:53:55  profilanswer
 

j'aurais testé SID/Lenny plutôt qu'Etch moi vu qu'Ubuntu est un mixe de Testing et Unstable.


---------------
"Phildar t'es vraiment une pute pas finie toi! Et Manu le gros porc arrete de t'marrer!"
n°929486
Jeddo
A nice place to live
Posté le 02-07-2007 à 20:18:22  profilanswer
 

Le but de la manoeuvre était de conserver certains fichiers de configurations, pour le réseau notamment.
En fait, debian n'a pas affecté les interface ethX de la même manière que kubuntu.
Désormais j'ai un système fonctionnel, même si beaucoup de choses doivent être reconfigurées (je suis même passé en testing sous les conseils d'un ami cet après-midi car certains paquets dont j'avais besoin n'étaient pas en stable). Pour le wifi, a priori c'est bon mais je n'ai pas encore testé.
Il y a quand même une bonne communauté debian et pas mal de tutoriels dispatchés sur le Web.


---------------
FREE DATOUNE
n°929488
Jeddo
A nice place to live
Posté le 02-07-2007 à 20:19:10  profilanswer
 

Je me posais une ultime question : après avoir upgradé en unstable ou testing, est-ce qu'on peut toujours downgradé en stable ?


---------------
FREE DATOUNE
n°929540
ttys
Posté le 02-07-2007 à 21:41:40  profilanswer
 

Jeddo a écrit :

Je me posais une ultime question : après avoir upgradé en unstable ou testing, est-ce qu'on peut toujours downgradé en stable ?


Il n’y a pas de façon simple et sûre de le faire comme pour une upgrade, le plus sûr pour passer de testing à stable c’est d’attendre que la testing devienne stable (c’est pas pour tout de suite là...), sinon une recherche google sur downgrade debian te donnera plusieurs tutos sur le sujet.

n°929542
Jeddo
A nice place to live
Posté le 02-07-2007 à 21:45:49  profilanswer
 

Merci pour cette réponse.
Pour l'instant le down n'est pas au programme (ni le up). Je préfère rester en testing avec un peu plus de paquets et un environnement relativement stable :)


---------------
FREE DATOUNE
n°929543
gee
Bon ben hon
Posté le 02-07-2007 à 21:46:47  profilanswer
 

Faut passer en expérimental pour vraiment s'amuser je trouve :ange:


---------------
"Phildar t'es vraiment une pute pas finie toi! Et Manu le gros porc arrete de t'marrer!"
n°929547
Jeddo
A nice place to live
Posté le 02-07-2007 à 21:54:17  profilanswer
 

J'ai pas envie de m'amuser :fou:


Message édité par Jeddo le 02-07-2007 à 21:54:45

---------------
FREE DATOUNE
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  *Failed* Passer de kubuntu edgy à debian etch, proprement

 

Sujets relatifs
[Debian Etch/2.6.18] Problème de make menuconfigAlias sous debian
[debian etch] Pb d'écriture sur une clé USBRecherche fichier status pour dpkg
[Debian] Problème avec NTPDATE (no servers can be used)souris USB saccadé sous debian testing
[Debian] Problème avec les groupes et les permissions[KDE] Plasma 5.23, KDE Frameworks 5.87 et KDE Gear 21.08
Plus de sujets relatifs à : *Failed* Passer de kubuntu edgy à debian etch, proprement


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR