Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
772 connectés 

 


 

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  12  13  14  ..  98  99  100  101  102  103
Auteur Sujet :

[Topic Unique] Seagate Dockstar, le plug computer pas cher !

n°1231750
azrael24
PàN, dans les dents !
Posté le 06-08-2010 à 21:55:18  profilanswer
 

Reprise du message précédent :
Le routeur ne reste pas activé une fois la freebox debranchée ?

mood
Publicité
Posté le 06-08-2010 à 21:55:18  profilanswer
 

n°1231751
thana54
made in concept
Posté le 06-08-2010 à 22:19:26  profilanswer
 

Non, le chenilard tourne non stop.
 
En insistant un peu j'ai réussi à trouver la bête avec un  

Code :
  1. nmap -sP -PE -PA21,23,80,3389 169.254.0.0/16


J'ai crée le fichier /etc/hosts, je doute aller plus loin ce soir :whistle:

n°1231755
thana54
made in concept
Posté le 06-08-2010 à 23:03:13  profilanswer
 

uboot mis à jour sur mtd3 (je commence petit oui :o )
Installation de lenny sur clef nouessbay [:wark0]
 
J'ai sommeil...

n°1231756
azrael24
PàN, dans les dents !
Posté le 06-08-2010 à 23:06:41  profilanswer
 

Bon, j'ai un petit problème dont je n'arrive à pas trouver de solution.

 

Avec le script de reboot de monsieur, on passe par l'uboot de Jeff Doozan, du coup si on a branché un disque usb de données pour faire un serveur fichier y'a une chance sur 2 que le DS essaye de booter sur le DD et pas sur la clé, j'ai bien l'impression que du coup il se bloque et on ne peut rien y faire (à distance du moins).

Message cité 2 fois
Message édité par azrael24 le 06-08-2010 à 23:09:12
n°1231757
clood
Posté le 06-08-2010 à 23:11:01  profilanswer
 

Dockstar commandé sur topachat mais j'ai recu à la place un Go Dock sans port usb, prise ethernet   :fou:  
Et moi qui pensait m'amuser un peu avec, c'est raté.
 
Première et dernière commande sur ce site  :pfff:

n°1231758
mirtouf
Light is right !
Posté le 06-08-2010 à 23:13:17  profilanswer
 

mauvais référence, retour produit.


---------------
-~- Libérez Datoune ! -~- Camarade, toi aussi rejoins le FLD pour que la flamme de la Révolution ne s'éteigne pas ! -~- A VENDRE
n°1231759
clood
Posté le 06-08-2010 à 23:15:40  profilanswer
 

Je vais leur retourner le produit pour un remboursement et en commander un sur cdiscount. Il leur en reste en stock à priori.

n°1231760
thana54
made in concept
Posté le 06-08-2010 à 23:16:13  profilanswer
 

C'est bizarre ce boot, un coup sur 2 je me prend pogo  [:tristou:4]
Demain j'attaque mtd0 na !

 

aptitude  [:cerveau kryten]


Message édité par thana54 le 06-08-2010 à 23:17:32
n°1231764
monsieur
Posté le 06-08-2010 à 23:39:37  profilanswer
 

azrael24 a écrit :

Bon, j'ai un petit problème dont je n'arrive à pas trouver de solution.  
 
Avec le script de reboot de monsieur, on passe par l'uboot de Jeff Doozan, du coup si on a branché un disque usb de données pour faire un serveur fichier y'a une chance sur 2 que le DS essaye de booter sur le DD et pas sur la clé, j'ai bien l'impression que du coup il se bloque et on ne peut rien y faire (à distance du moins).


 
Je me suis posé la question dans un post dès la 1ere page, mais ça n'a pas semblé interpeler grand monde.
 
Comment la machine peut savoir ou décide-t-elle sur quelle clef ou HDD booter si on en a plusieurs de branchés?
Comment décidera-t-elle que /dev/sda est sur tel ou tel port USB et pas sur un autre?
 
Dans le cas où l'on ait branché plusieurs clefs ou HDD:
- Si la DS scanne tous les media USB branchés à la recherche d'une clef ou d'un HDD avec un kernel, dans ce cas il faut préciser dans la séquence du boot de Debian ainsi que dans le fstab de ne pas utiliser comme références /dev/sda... mais les ID des partitons (voir la doc explicative pour Ubuntu).
- Si la DS se contente d'essayer de booter uniquement sur le 1er media USB trouvé, il faudra alors brancher nos media USB dans un certain ordre matériel: port USB1 = system, ports USB2,3,4 = simple stockage.
 
Je pense que pour l'instant tout le monde s'en fout car on est dans une phase où chacun teste et installe son système avec 1 seul media USB, mais ce problème surgira quand petit à petit plus de gens utiliseront leur Dockstar en production et commenceront à y brancher plus de choses dessus en USB.

Message cité 2 fois
Message édité par monsieur le 06-08-2010 à 23:41:54

---------------
mon feedback H/V
n°1231766
azrael24
PàN, dans les dents !
Posté le 07-08-2010 à 00:07:51  profilanswer
 

monsieur a écrit :


 
Dans le cas où l'on ait branché plusieurs clefs ou HDD:
- Si la DS scanne tous les media USB branchés à la recherche d'une clef ou d'un HDD avec un kernel, dans ce cas il faut préciser dans la séquence du boot de Debian ainsi que dans le fstab de ne pas utiliser comme références /dev/sda... mais les ID des partitons (voir la doc explicative pour Ubuntu).


 
C'est une supposition ou une solution ? Car je n'ai pas de kernel sur mon disque et il n'est même pas flagué boot donc je doute que le bootloader soit si logique dans son fonctionnement. ;)

mood
Publicité
Posté le 07-08-2010 à 00:07:51  profilanswer
 

n°1231769
bohwaz
$bwz++
Posté le 07-08-2010 à 01:02:52  profilanswer
 

deK a écrit :

Ce ne sont pas des partitions au sens classique (PC) du terme, fdisk ne fonctionne pas là-dessus.


 
Chezmoiçamarche.  :bounce:


---------------
Suivi et archivage des offres LIDL, Aldi et Norma
n°1231770
deK
watching for beerz on the wing
Posté le 07-08-2010 à 01:08:09  profilanswer
 

monsieur a écrit :


 
Je me suis posé la question dans un post dès la 1ere page, mais ça n'a pas semblé interpeler grand monde.
 
Comment la machine peut savoir ou décide-t-elle sur quelle clef ou HDD booter si on en a plusieurs de branchés?
Comment décidera-t-elle que /dev/sda est sur tel ou tel port USB et pas sur un autre?
 
Dans le cas où l'on ait branché plusieurs clefs ou HDD:
- Si la DS scanne tous les media USB branchés à la recherche d'une clef ou d'un HDD avec un kernel, dans ce cas il faut préciser dans la séquence du boot de Debian ainsi que dans le fstab de ne pas utiliser comme références /dev/sda... mais les ID des partitons (voir la doc explicative pour Ubuntu).
- Si la DS se contente d'essayer de booter uniquement sur le 1er media USB trouvé, il faudra alors brancher nos media USB dans un certain ordre matériel: port USB1 = system, ports USB2,3,4 = simple stockage.
 
Je pense que pour l'instant tout le monde s'en fout car on est dans une phase où chacun teste et installe son système avec 1 seul media USB, mais ce problème surgira quand petit à petit plus de gens utiliseront leur Dockstar en production et commenceront à y brancher plus de choses dessus en USB.


 
Sur le forum Plugapps (si je ne confonds pas), il y a un topic là-dessus : en gros c'est au petit bonheur la chance pour l'instant, en attendant un bootloader plus évolué.
A priori ça peut booter sur n'importe lequel au hasard.
 
Chez moi j'avais testé avec 2 clés USB bootables sur le DS, ça a booté sur celle branchée sur le port immédiatement à côté de l'ethernet.
 

bohwaz a écrit :


 
Chezmoiçamarche.  :bounce:


 
Au temps pour moi alors  :jap:


---------------
Feed HA/V          
n°1231775
monsieur
Posté le 07-08-2010 à 02:53:10  profilanswer
 

azrael24 a écrit :

C'est une supposition ou une solution ?


 
Vu qu'on navigue dans l'inconnu pour l'instant à ce sujet, je ne fais que des suppositions.


---------------
mon feedback H/V
n°1231778
cactus
Posté le 07-08-2010 à 08:18:21  profilanswer
 

Pour le boot sur l'usb, je miserai un jeton sur l'ordre de détection des médias : le plus rapide à répondre au kernel a gagné le droit d'être en sda !
Vivement que la communauté nous ponde un bootloader plus évolué... au fait, il ne serait pas possible de chainer uBoot avec un grub (ou autre bootloader plus familier) ? ça permettrait de définir tranquillou l'UUID ! ;)


Message édité par cactus le 07-08-2010 à 08:18:41
n°1231779
VisualC++
J'va y penser ...
Posté le 07-08-2010 à 09:09:28  profilanswer
 

azrael24 a écrit :

Bon, j'ai un petit problème dont je n'arrive à pas trouver de solution.  
 
Avec le script de reboot de monsieur, on passe par l'uboot de Jeff Doozan, du coup si on a branché un disque usb de données pour faire un serveur fichier y'a une chance sur 2 que le DS essaye de booter sur le DD et pas sur la clé, j'ai bien l'impression que du coup il se bloque et on ne peut rien y faire (à distance du moins).


 
Perso sur la debian que j'ai monté, apr_s une petite googlelisation et suivi des liens donnés en première page, je suis arriivé à cela. Un petit coup de udev et avec cela le disque attaché est toujours identifié de la même façon qqsoit le port utilisé. Et on rajoute le automount des partitions c'est encore plus simple.
 
Pour le serial du disque (perso j'utilise un de mes freeagent go cela tombe bien :)


root~# udevinfo -a -p $(udevinfo -q path -n /dev/sdb)| egrep "serial"



root~# cat /etc/udev/rules.d/local.rules
BUS=="usb", KERNEL=="sd*", SYSFS{serial}=="2GE4F9EM", NAME="%k", SYMLINK+="freeagent%n"
RUN+="/bin/mount /mnt/disk_%n"



root~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
none           /dev/pts        devpts  defaults          0       0
none           /dev/shm        tmpfs   nodev,nosuid      0       0
/dev/sda1      /               ext3    errors=remount-ro 0       1
/dev/sda2      none            swap    sw                0       0
/dev/freeagent1 /mnt/disk_1    ntfs-3g   rw,user,gid=1000,uid=1000,umask=022,locale=fr_FR.utf8 0  0
/dev/freeagent2 /mnt/disk_2    ntfs-3g   rw,user,gid=1000,uid=1000,umask=022,locale=fr_FR.utf8 0  0


De plus pour ceux intéressés par mettre leur disque en idle (ca fait tj qq watts de gagnés) car j'ai pas trouvé autre chose qui fonctionne. Par contre la pour le moment pas trouvé comment faire avec /dev/XXX utilisé dans udev.


root~# cat /etc/init.d/spindow_seagate
#!/bin/sh
 
[ -z "$FORK" ] && { FORK=1 $0 "$@" & exit; }
 
disk=sdb
interval=600
 
state=`grep " $disk " /proc/diskstats`
count=$interval
up=1
log=1
 
while [ true ]; do
   sleep 10
   count=$(($count-10))
   newstate=`grep " $disk " /proc/diskstats`
   if [ "$state" = "$newstate" ]; then
      if [ $count -lt 0 ]; then
         count=$interval
         if [ $up = 1 ]; then
            logger $disk spin-down
            sync
            state=`grep " $disk " /proc/diskstats`
            sdparm --command=stop /dev/sdb
            up=0
            log=1
         fi
      fi
   else
      if [ $log = 1 ]; then
         logger $disk drive is up
         log=0
      fi
      count=$interval
      state="$newstate"
      up=1
   fi
done


avec dans  le rc.local


~# cat /etc/rc.local
#!/bin/sh -e
#
# rc.local
#
#.....
#
 
/etc/init.d/spindow_seagate
 
exit 0


 
Edit: et l'OS est sur USB 2Go tranquillement.

Message cité 2 fois
Message édité par VisualC++ le 07-08-2010 à 09:11:56
n°1231781
thana54
made in concept
Posté le 07-08-2010 à 09:51:50  profilanswer
 

Mais c'est de la loterie le boot [:mlc]
 
Ca fait 1h que je tente de comprendre la chose. Je pensais au début que c'était ma clef usb qui n'avait pas aimer l'update en testing [:transparency]

n°1231782
azrael24
PàN, dans les dents !
Posté le 07-08-2010 à 10:52:53  profilanswer
 

VisualC++ a écrit :


 
 

Code :
  1. root~# cat /etc/udev/rules.d/local.rules
  2. BUS=="usb", KERNEL=="sd*", SYSFS{serial}=="2GE4F9EM", NAME="%k", SYMLINK+="freeagent%n"
  3. RUN+="/bin/mount /mnt/disk_%n"


Code :
  1. root~# cat /etc/fstab
  2. # /etc/fstab: static file system information.
  3. #
  4. # <file system> <mount point>   <type>  <options>       <dump>  <pass>
  5. none           /dev/pts        devpts  defaults          0       0
  6. none           /dev/shm        tmpfs   nodev,nosuid      0       0
  7. /dev/sda1      /               ext3    errors=remount-ro 0       1
  8. /dev/sda2      none            swap    sw                0       0
  9. /dev/freeagent1 /mnt/disk_1    ntfs-3g   rw,user,gid=1000,uid=1000,umask=022,locale=fr_FR.utf8 0  0
  10. /dev/freeagent2 /mnt/disk_2    ntfs-3g   rw,user,gid=1000,uid=1000,umask=022,locale=fr_FR.utf8 0  0




 
C'est pas redondant de le faire monter dans udev ET dans fstab ?
En tout cas de mon coté je pédale dans la choucroute pour arriver à faire monter mon disque  :fou:


Message édité par azrael24 le 07-08-2010 à 10:55:42
n°1231783
thana54
made in concept
Posté le 07-08-2010 à 10:55:59  profilanswer
 

Pourtant pas dur :o
http://wiki.archlinux.org/index.ph [...] 3B_ntfs-3g

 

ne reprenez pas bêtement ce code, il se peut qu'il devienne obsolète, allez plutôt voir le lien au dessus

Code :
  1. File: /etc/udev/rules.d/10-my-media-automount.rules
  2. # vim:enc=utf-8:nu:ai:si:et:ts=4:sw=4:ft=udevrules:
  3. #
  4. # /etc/udev/rules.d/10-my-media-automount.rules
  5. # start at sdb to ignore the system hard drive
  6. KERNEL!="sd[b-z]*", GOTO="my_media_automount_end"
  7. ACTION=="add", PROGRAM!="/sbin/blkid %N", GOTO="my_media_automount_end"
  8. # import some useful filesystem info as variables
  9. IMPORT{program}="/sbin/blkid -o udev -p %N"
  10. # get the label if present, otherwise assign one based on device/partition
  11. ENV{ID_FS_LABEL}!="", ENV{dir_name}="%E{ID_FS_LABEL}"
  12. ENV{ID_FS_LABEL}=="", ENV{dir_name}="usbhd-%k"
  13. # create the dir in /media and symlink it to /mnt
  14. ACTION=="add", RUN+="/bin/mkdir -p '/media/%E{dir_name}'"
  15. # global mount options
  16. ACTION=="add", ENV{mount_options}="relatime"
  17. # filesystem-specific mount options (777/666 dir/file perms for ntfs/vfat)
  18. ACTION=="add", ENV{ID_FS_TYPE}=="vfat|ntfs", ENV{mount_options}="$env{mount_options},gid=100,dmask=000,fmask=111,utf8"
  19. # automount ntfs filesystems using ntfs-3g driver
  20. ACTION=="add", ENV{ID_FS_TYPE}=="ntfs", RUN+="/bin/mount -t ntfs-3g -o %E{mount_options} /dev/%k '/media/%E{dir_name}'"
  21. # automount all other filesystems
  22. ACTION=="add", ENV{ID_FS_TYPE}!="ntfs", RUN+="/bin/mount -t auto -o %E{mount_options} /dev/%k '/media/%E{dir_name}'"
  23. # clean up after device removal
  24. ACTION=="remove", ENV{dir_name}!="", RUN+="/bin/umount -l '/media/%E{dir_name}'", RUN+="/bin/rmdir '/media/%E{dir_name}'"
  25. # exit
  26. LABEL="my_media_automount_end"
 

Mon FreeAgent viens de se monter tout seul comme un grand.
Au pire, penser à relancer udev et rebrancher le disque.
(biensur il faut avoir ntfs-3g)

Message cité 1 fois
Message édité par thana54 le 07-08-2010 à 10:56:34
n°1231784
azrael24
PàN, dans les dents !
Posté le 07-08-2010 à 11:04:35  profilanswer
 

J'ai essayé d'aller au plus simple vu que je n'ai qu'un disque dur usb à automonter.
 
 

debian:~# cat /etc/udev/rules.d/10-local.rules
# Disque Dur USB 320Go
BUS=="usb", KERNEL=="sd?1", SYSFS{serial}=="5E4B8FFFFFFF", SYMLINK+="DD_USB", RUN+="/bin/mount -t vfat -o rw,user,gid=1000,uid=1000,umask=7 /home/User/DD_USB"


 

debian:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
none           /dev/pts        devpts  defaults          0       0
none           /dev/shm        tmpfs   nodev,nosuid      0       0
/dev/sda1      /               ext2    errors=remount-ro 0       1
/dev/sda2      none            swap    sw                0       0
/dev/DD_USB    /home/User/DD_USB vfat rw,user,gid=1000,uid=1000,umask=7,locale=fr_FR.utf8 0  0


 
Et ben ça marche pas  :cry:

n°1231786
bigstef
Posté le 07-08-2010 à 11:14:56  profilanswer
 

Bonjour
 
J'ai commandé deux dock chez rueducommerce.
Et j'ai recu deux Godock  :??:  
Suis je le seul à avoir ce probleme?

n°1231787
azrael24
PàN, dans les dents !
Posté le 07-08-2010 à 11:19:23  profilanswer
 

Non clood à le même problème, regarde un peu plus haut sur cette page.  
Par contre faites vous rembourser si c'est pas le bon produit, y'a pas de raison de vous laisser faire.  :non:

n°1231791
thana54
made in concept
Posté le 07-08-2010 à 11:34:14  profilanswer
 

azrael24 a écrit :

J'ai essayé d'aller au plus simple vu que je n'ai qu'un disque dur usb à automonter.

 


debian:~# cat /etc/udev/rules.d/10-local.rules
# Disque Dur USB 320Go
BUS=="usb", KERNEL=="sd?1", SYSFS{serial}=="5E4B8FFFFFFF", SYMLINK+="DD_USB", RUN+="/bin/mount -t vfat -o rw,user,gid=1000,uid=1000,umask=7 /home/User/DD_USB"

 

debian:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
none           /dev/pts        devpts  defaults          0       0
none           /dev/shm        tmpfs   nodev,nosuid      0       0
/dev/sda1      /               ext2    errors=remount-ro 0       1
/dev/sda2      none            swap    sw                0       0
/dev/DD_USB    /home/User/DD_USB vfat rw,user,gid=1000,uid=1000,umask=7,locale=fr_FR.utf8 0  0

 

Et ben ça marche pas  :cry:


pourtant il y a bien la ligne dans fstab, donc que udev à bien fait son boulot jusque là.
ca donne quoi un df ? un mount ?

 

De mon coté, je patine un peu avec pure-ftpd, je ne vois pas ce que j'ai pu oublier.
J'ai fais un copier coller des fichiers de conf, reconfigure pure-ftpd-common, converti mon user local en user virtuel, mis un passw et quelques droits/restrictions à ce user.
Toujours connexion refusée, alors que si je tente le ftp sur le fixe il me demande login/pass [:toyonos:1]


Message édité par thana54 le 07-08-2010 à 11:36:10
n°1231793
azrael24
PàN, dans les dents !
Posté le 07-08-2010 à 11:36:44  profilanswer
 

Un mount manuel au même point de montage marche parfaitement.

 

debian:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda1              1344016    583640    692104  46% /
tmpfs                    61824         0     61824   0% /lib/init/rw
udev                     10240       684      9556   7% /dev
tmpfs                    61824         0     61824   0% /dev/shm
none                     61824         0     61824   0% /dev/shm

 

Concernant purftpd, je l'ai installé via Webmin, j'ai crée "User" appartenant a je sais plus quel groupe, et refusé les connexions root, ça marche alors je ne suis pas allé plus loin.

 

Tout ça sur le serveur par défaut par contre. C'est basique mais je m'en fout, je n'ai pas d'autres user

Message cité 1 fois
Message édité par azrael24 le 07-08-2010 à 11:42:01
n°1231799
deK
watching for beerz on the wing
Posté le 07-08-2010 à 12:01:03  profilanswer
 

Pinout du JTag du DS : http://plugapps.com/index.php5?tit [...] r_JTAG.png

 

Ça va permettre de développer des uBoot sans risque de brickage :)
http://plugapps.com/forum/viewtopi [...] 2&start=40


Message édité par deK le 07-08-2010 à 12:02:10

---------------
Feed HA/V          
n°1231800
thana54
made in concept
Posté le 07-08-2010 à 12:02:56  profilanswer
 

Trouvé mon erreur :whistle:

Code :
  1. Aug  7 11:40:41 wonderland pure-ftpd: (?@?) [ERROR] Sorry, but that file doesn't exist: [/etc/ssl/private/pure-ftpd.pem]


Ah bah oui en comparant les paquets installés sur le DS avec le fixe, manque openssl, et vu que j'utilise TLS, faut un certificat. Donc hop copier coller via scp.
 
Résultat dans /var/log/syslog:

Code :
  1. Aug  7 11:59:11 wonderland pure-ftpd: (?@?) [ERROR] Unable to find the 'ftp' account
  2. Aug  7 11:59:41 wonderland pure-ftpd: (?@192.168.0.5) [INFO] New connection from 192.168.0.5
  3. Aug  7 11:59:41 wonderland pure-ftpd: (?@192.168.0.5) [DEBUG] Command [feat] []
  4. Aug  7 11:59:47 wonderland pure-ftpd: (?@192.168.0.5) [DEBUG] Command [user] [alice]
  5. Aug  7 11:59:47 wonderland pure-ftpd: (?@192.168.0.5) [DEBUG] Command [pass] [<*>]
  6. Aug  7 11:59:47 wonderland pure-ftpd: (?@192.168.0.5) [INFO] alice is now logged in
  7. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [type] [I]
  8. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [opts] [UTF8 ON]
  9. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [syst] []
  10. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [pwd] []
  11. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [cwd] [/]
  12. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [pasv] []
  13. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [list] [-a]
  14. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [cwd] [/media]
  15. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [pasv] []
  16. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [list] [-a]
  17. Aug  7 11:59:47 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [cwd] [/media/]
  18. Aug  7 11:59:54 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [cwd] [/media/]
  19. Aug  7 11:59:56 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [cwd] [/media/]
  20. Aug  7 11:59:56 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [cwd] [/media]
  21. Aug  7 11:59:56 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [pasv] []
  22. Aug  7 11:59:56 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [list] [-a]
  23. Aug  7 11:59:58 wonderland pure-ftpd: (alice@192.168.0.5) [DEBUG] Command [cwd] [/media/FreeAgent_Drive]


[:volta]

n°1231801
thana54
made in concept
Posté le 07-08-2010 à 12:05:40  profilanswer
 

azrael24 a écrit :

Un mount manuel au même point de montage marche parfaitement.
 

debian:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda1              1344016    583640    692104  46% /
tmpfs                    61824         0     61824   0% /lib/init/rw
udev                     10240       684      9556   7% /dev
tmpfs                    61824         0     61824   0% /dev/shm
none                     61824         0     61824   0% /dev/shm




Tu peux peut être avoir la cause du problème en activant le debug d'udev (modifier /etc/udev/udev.conf et remplacer "err" par "info", ne pas oublier de remettre ca comme c'était avant de reboot, me suis pris des kernel panic sans savoir pourquoi :whistle: )
 
A la rigueur, est-ce que le code que j'utilise au dessus marche ?

n°1231805
deK
watching for beerz on the wing
Posté le 07-08-2010 à 12:18:28  profilanswer
 

Tentative de compil de kernel sur la bête, sans swap  [:joce]
(oui, le swap sur NFS c'est tellement déconseillé que par défaut, le kernel t'interdit de le faire :o)

 

Au pire si ça passe pas, je mettrais un HDD externe et une swapfile dessus.

Message cité 1 fois
Message édité par deK le 07-08-2010 à 12:18:41

---------------
Feed HA/V          
n°1231806
thana54
made in concept
Posté le 07-08-2010 à 12:20:23  profilanswer
 

Hmm, on peut bien streamer une vidéo par ftp, non ?

Code :
  1. Playing ftp://alice@192.168.0.4/media/Fre [...] _h264.mov.
  2. Connecting to server 192.168.0.4[192.168.0.4]: 21...
  3. [ftp] command 'PASS no@spam' failed: 530 Login authentication failed
  4. Failed to open ftp://alice@192.168.0.4/media/Fre [...] _h264.mov.

n°1231808
azrael24
PàN, dans les dents !
Posté le 07-08-2010 à 12:24:03  profilanswer
 

thana54 a écrit :

Hmm, on peut bien streamer une vidéo par ftp, non ?

Code :
  1. Playing ftp://alice@192.168.0.4/media/Fre [...] _h264.mov.
  2. Connecting to server 192.168.0.4[192.168.0.4]: 21...
  3. [ftp] command 'PASS no@spam' failed: 530 Login authentication failed
  4. Failed to open ftp://alice@192.168.0.4/media/Fre [...] _h264.mov.



 
Oui.
 
ftp://User:MotDePasse@ip_serveur/ [...] e/film.mov
 
 
Sinon je laisse tomber l'automount, ça plus apt-get qui ne veut pas m'installer Deluge en Webui, c'est trop de frustration pour aujourd'hui. Linux c'est khakha  [:bidoo-one kenobi]  
 

n°1231809
VisualC++
J'va y penser ...
Posté le 07-08-2010 à 12:35:46  profilanswer
 

voila petite modification pour mettre le disque en veille et ce qqsoit le sd*  


#!/bin/sh
 
[ -z "$FORK" ] && { FORK=1 $0 "$@" & exit; }
 
disk=`ls -l /dev | egrep "freeagent ->" | awk '{print $11}'`
# 1800 : 30 min
interval=1800
 
state=`grep " $disk " /proc/diskstats`
count=$interval
up=1
log=1
 
while [ true ]; do
   sleep 10
   count=$(($count-10))
   newstate=`grep " $disk " /proc/diskstats`
   if [ "$state" = "$newstate" ]; then
      if [ $count -lt 0 ]; then
         count=$interval
         if [ $up = 1 ]; then
            logger $disk spin-down
            sync
            state=`grep " $disk " /proc/diskstats`
            sdparm --command=stop /dev/$disk
            up=0
            log=1
         fi
      fi
   else
      if [ $log = 1 ]; then
         logger $disk drive is up
         log=0
      fi
      count=$interval
      state="$newstate"
      up=1
   fi
done


freeagent à adapter suivant le nom utilisé

Message cité 1 fois
Message édité par VisualC++ le 07-08-2010 à 12:36:31
n°1231810
thana54
made in concept
Posté le 07-08-2010 à 12:41:08  profilanswer
 

azrael24 a écrit :


 
Oui.
 
ftp://User:MotDePasse@ip_serveur/ [...] e/film.mov
 
 
Sinon je laisse tomber l'automount, ça plus apt-get qui ne veut pas m'installer Deluge en Webui, c'est trop de frustration pour aujourd'hui. Linux c'est khakha  [:bidoo-one kenobi]  
 


Trompé de caractère entre user et pass [:prozac]
Ca marche mieux maintenant \o/

n°1231812
xinux4d
HFR spirit
Posté le 07-08-2010 à 12:43:30  profilanswer
 

azrael24 a écrit :


 
 
Sinon je laisse tomber l'automount, ça plus apt-get qui ne veut pas m'installer Deluge en Webui, c'est trop de frustration pour aujourd'hui. Linux c'est khakha  [:bidoo-one kenobi]  
 


 
 
passe sous arch, compile yaourt et c'est bonheur :o


---------------
blog voyages/4x4  https://www.pumbaoverland.com
n°1231813
monsieur
Posté le 07-08-2010 à 12:53:29  profilanswer
 

VisualC++ a écrit :

De plus pour ceux intéressés par mettre leur disque en idle (ca fait tj qq watts de gagnés)


Moi ça serait plutôt le contraire, j'y ai collé un WD Caviar Green de 1.5To dans un boitier USB, il parque les têtes toutes les 8 secondes, mon disque ne va même pas tenir 1 an à ce rythme.... :ouch: On dirait une horloge au ralenti ce tic-tac, quelle horreur.
 

thana54 a écrit :

Mon FreeAgent viens de se monter tout seul comme un grand.


La question qui me vient à l'esprit pour avoir confirmation: il est branché sur le port mini USB prévu pour les FreeAgent Go?
 
J'en avais trop marre du paquarge incessant des têtes du WDC Green, j'ai donc fait une copie de la partition système sur un petit HDD 2.5".
Ce HDD est auto-alimenté (avec un seul port USB) sans problème sur mes laptops, sur le décodeur de la 9box, sur la 9box, même sur un pauvre décodeur TNT à 20€... mais sur les ports USB (de taille standard) de la Dockstar: pas assez de jus!!!! Du coup je me demande si je ne devrais pas utiliser le port mini-USB via un adaptateur.
 

azrael24 a écrit :

ça plus apt-get qui ne veut pas m'installer Deluge en Webui, c'est trop de frustration pour aujourd'hui. Linux c'est khakha  [:bidoo-one kenobi]


Squeeze est en freeze :D :D
Bientôt un Debian 6 en stable

Message cité 1 fois
Message édité par monsieur le 07-08-2010 à 12:56:54

---------------
mon feedback H/V
n°1231814
thana54
made in concept
Posté le 07-08-2010 à 13:10:38  profilanswer
 

monsieur a écrit :


La question qui me vient à l'esprit pour avoir confirmation: il est branché sur le port mini USB prévu pour les FreeAgent Go?
 
J'en avais trop marre du paquarge incessant des têtes du WDC Green, j'ai donc fait une copie de la partition système sur un petit HDD 2.5".
Ce HDD est auto-alimenté (avec un seul port USB) sans problème sur mes laptops, sur le décodeur de la 9box, sur la 9box, même sur un pauvre décodeur TNT à 20€... mais sur les ports USB (de taille standard) de la Dockstar: pas assez de jus!!!! Du coup je me demande si je ne devrais pas utiliser le port mini-USB via un adaptateur.
 


Oui sur le dock
 
http://www.pixelz.fr/2/c/d/48333e43f05ae180a8b4e18d53d23.jpg

monsieur a écrit :


Squeeze est en freeze :D :D
Bientôt un Debian 6 en stable


Bientôt, bientôt, je dirais bien noël moi :o

n°1231815
VisualC++
J'va y penser ...
Posté le 07-08-2010 à 13:12:20  profilanswer
 

Idem, sur le dock.

n°1231818
LeKeiser
Appelez moi Marcel. J+10 :)
Posté le 07-08-2010 à 13:47:44  profilanswer
 

recu le mien hier
amusage je pense demain, ou dans l'apres midi :)
j'ai la tete engourdie ( ;) ), comment je peux le tester juste pour m'assurer qu'il est A-OK?


---------------
"I intend to live the first half of my life.I don't care about the rest."Errol Flynn."The difference between genius and stupidity is that genius has its limits."Albert Einstein
n°1231820
monsieur
Posté le 07-08-2010 à 14:05:45  profilanswer
 

LeKeiser a écrit :

comment je peux le tester juste pour m'assurer qu'il est A-OK?


Tu le branches sur ton routeur (en coupant l'accès à l'internet pour ne pas qu'il mette à jour son firmware), sur le routeur tu repères son adresse IP puis tu tentes une connexion ssh:
ssh root@adresseip
mot de passe stxadmin
 
Si t'as le courage, tu peux tenter de faire la manip du fichier /etc/hosts (décrite en 1er page) pour désactiver les adresses de mise à jour, comme ça tu seras tranquille et tu n'auras plus besoin de couper le net.
 
Puis tu peux le ranger pour te pencher dessus plus tard la tête sereine.
 


 
Cool  :)  
 

thana54 a écrit :


Bientôt, bientôt, je dirais bien noël moi :o


 
Avec Debian, "it comes when it's ready". :D

Message cité 1 fois
Message édité par monsieur le 07-08-2010 à 14:09:04

---------------
mon feedback H/V
n°1231822
thana54
made in concept
Posté le 07-08-2010 à 14:30:36  profilanswer
 

LeKeiser a écrit :

recu le mien hier
amusage je pense demain, ou dans l'apres midi :)
j'ai la tete engourdie ( ;) ), comment je peux le tester juste pour m'assurer qu'il est A-OK?


 

monsieur a écrit :


Tu le branches sur ton routeur (en coupant l'accès à l'internet pour ne pas qu'il mette à jour son firmware), sur le routeur tu repères son adresse IP puis tu tentes une connexion ssh


Pas besoin de le brancher au routeur/switch, un simple cable réseau suffit pour relier le pc au DS. Je n'arrivais pas à trouver l'ip du DS en passant par le switch (ou alors je ne laissais pas assez de temps à nmap). Au moins de cette façon, y a pas un gêneur qui va te prendre une ip.
 
Trouvé ici:

Citation :

connect the DockStar with a network cable directly to a computer running Linux which doesn't route or offers DHCP. Plug in the power cable of the DockStar and wait until the LED is steadily orange. Because the device won't get an IP from an DHCP server, it will use an automatic generated IP between 169.254.1.0 and 169.254.254.255 (see RFC 3927).
 
To find out the IP the device uses we are scanning this range. You might have luck and this quick scan may find the IP:

Code :
  1. root@host ~ # ifconfig eth0 169.254.1.0
  2. root@host ~ # nmap -e eth0 -sP 169.254.185.0/24




http://ahsoftware.de/dockstar/

n°1231824
monsieur
Posté le 07-08-2010 à 14:38:33  profilanswer
 

Heu juste une question

Citation :

ifconfig eth0 169.254.1.0


Cette commande ne fait pas merdouiller network-manager pour ceux qui l'utilisent avec Gnome?
Car, de souvenir, network-manager aime bien avoir la main complète sur la gestion réseau et n'aime pas trop qu'on configure autrement qu'en automatique.


Message édité par monsieur le 07-08-2010 à 14:39:05

---------------
mon feedback H/V
n°1231826
anapivirtu​a
Boh.
Posté le 07-08-2010 à 15:05:47  profilanswer
 

Plus moyen d'en trouver à moins de 20€ ?...
Je m'en serais bien acheté 4-5


---------------
Si vis pacem, para bellum.
n°1231829
thana54
made in concept
Posté le 07-08-2010 à 15:21:21  profilanswer
 
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  12  13  14  ..  98  99  100  101  102  103

Aller à :
Ajouter une réponse
 

Sujets relatifs
Le topic vert - gestion d'énergie sous LinuxTopic netbook originaux pour barbu
[ Topic Unique ] Problème de connexion à InternetSquid par authentification unique
[Topic Unique] Google Chrome OSUbuntu 9.04 sur portable : forcer l'utilisation unique du second écran
Plus de sujets relatifs à : [Topic Unique] Seagate Dockstar, le plug computer pas cher !


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR