Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
556 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  nouveau driver nforce : hw mixing

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

nouveau driver nforce : hw mixing

n°540032
mean
Posté le 14-08-2004 à 11:25:26  profilanswer
 

hw mixing, ac3 pass through, une petite appli de configuration
Ca a l'air de bien marcher
 
J'ai aussi l'impression que l'encodage en AC3 est activé
http://www.nvidia.com/object/linux_nforce_1.0-0283

mood
Publicité
Posté le 14-08-2004 à 11:25:26  profilanswer
 

n°540038
jeep05
Posté le 14-08-2004 à 11:37:53  profilanswer
 

Added support for 2.6 series kernels
 
 :love:  :love:


---------------
"Finalement, quand on est riche, ça ne s'arrête jamais ? - Rassurez-vous, c'est pareil quand on est pauvre !" -Film "Ah ! si j'étais riche, 2002"
n°540075
mean
Posté le 14-08-2004 à 12:54:40  profilanswer
 

Sont pas hyper stable

n°540077
jeep05
Posté le 14-08-2004 à 12:57:00  profilanswer
 

ca ne met pas le bordel dans Linux au niveau des drivers ? comment se passe la migration ?
 
Peux tu en dire plus sur la stabilité ?


---------------
"Finalement, quand on est riche, ça ne s'arrête jamais ? - Rassurez-vous, c'est pareil quand on est pauvre !" -Film "Ah ! si j'étais riche, 2002"
n°540082
udok
La racaille des barbus ©clémen
Posté le 14-08-2004 à 13:13:26  profilanswer
 

mean a écrit :

Sont pas hyper stable


 
dommage parce que là y-avait tout ce qu'il manquait :/
 
EDIT : quand je vois le temps qu'il leur a fallu pour pondre ça franchement, le temps que ça soit stabilisé j'aurais acheter un autre pc moi :/
y-a des chances que ça passe dans le module libre d'alsa ?


Message édité par udok le 14-08-2004 à 13:14:23

---------------
Non au projet de loi DADVSI ! (droits d'auteurs)
n°540083
mean
Posté le 14-08-2004 à 13:14:03  profilanswer
 

- fait ramer mplayer
- il y a un delai notable avec xine
- au bout de quelques essais plus de son du tout
 
Dommage ca le son est bon et la sortie DD un plus certain

n°540084
Dark_Schne​ider
Close the World, Open the Net
Posté le 14-08-2004 à 13:16:49  profilanswer
 

faites les rapports de bugs et ils amélioront les pilotes pour la prochaines releases comme ce fut le cas pour les pilotes graphiques.


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°540087
udok
La racaille des barbus ©clémen
Posté le 14-08-2004 à 13:17:34  profilanswer
 

Dark_Schneider > [:romf]
mean, tu t'en occupes ?  :ange:  (j'ai pas testé moi :o)


---------------
Non au projet de loi DADVSI ! (droits d'auteurs)
n°540088
mean
Posté le 14-08-2004 à 13:22:46  profilanswer
 

J'ai fait un post sur nvnews

n°540092
fl0ups
東京 - パリ - SLP
Posté le 14-08-2004 à 13:36:47  profilanswer
 

Added support for SoundStorm (Hardware Mixing supported)
 
Mais y a que le soundstorm qui fait l'hardware mixing :heink: :??:
Moi j'ai la version cheap du nforce2 qui a bien l'APU mais pas le soundstorm (Abit nf7), et il me semble qu'elle supporte quand meme le hw mixing meme si elle a pas les trucs genre dolby surround machin truc.

mood
Publicité
Posté le 14-08-2004 à 13:36:47  profilanswer
 

n°540093
jeep05
Posté le 14-08-2004 à 13:43:30  profilanswer
 

j'ai pas eu autant de chance car le son ne marche pas.
 
 
Pour la carte réseau, dans le Harddrake, il m'affiche l'ancien pilote et pas 'nvnet'. Il ne l'a pas pris en compte ? Comment le vérifier ?
 
Mon /etc/modprobes.conf  
 

Citation :

alias eth0 nvnet
alias eth1 3c59x
alias ieee1394-controller ohci1394
#alias sound-slot-0 snd-intel8x0
alias sound-slot-0 nvsound
 
install usb-interface /sbin/modprobe usb-ohci; /sbin/modprobe ehci-hcd; /bin/true
 
alias tty-ldisc-3 ppp_async
alias tty-ldisc-13 n_hdlc
alias tty-ldisc-14 ppp_synctty
alias char-major-108 ppp_generic


D'ailleurs, je ne sais pas à quoi correspondent les 4 derniers alias (tty)
 
Je suis en noyau 2.6.8 (Mandrake Cooker) - Carte mère Asus A7n8x Dlx)
 
Mon /etc/modules.conf

Citation :

probeall usb-interface usb-ohci ehci-hcd
#alias eth0 forcedeth
alias eth0 nvnet
alias eth1 3c59x
#alias eth2 3c59x
alias ieee1394-controller ohci1394
#above snd-intel8x0 snd-pcm-oss
#alias sound-slot-0 snd-intel8x0
alias sound-slot-0 nvsound


 
Si le noyau 2.6 utilise  /etc/modprobes.conf  pourquoi y a t-il toujours  /etc/modules.conf ? Faut-il quand même éditer modules.conf de la même manière que modprobes ?


Message édité par jeep05 le 08-04-2005 à 11:29:49

---------------
"Finalement, quand on est riche, ça ne s'arrête jamais ? - Rassurez-vous, c'est pareil quand on est pauvre !" -Film "Ah ! si j'étais riche, 2002"
n°540096
Threep
I'm a mighty pirate!
Posté le 14-08-2004 à 13:51:49  profilanswer
 

Rha, c'est un driver oss pour l'audio nan ? Bon déjà, j'arrive pas à le faire marcher, je peux pas lancer alsamixer, et le module se trouve dans la section oss. Bref tout porte à croire que...
 
Si c'est le cas, rhaaaaaa! Sont relous, depuis le temps ils auraient pu se mettre à page. Moi j'ai tout qui marche en alsa chez ouam. Bref, jsuis reparti pour mon pauv' snd-intel8x0, même si je commence à en avoir marre-marre-marre de pas avoir de mix HW.

n°540111
udok
La racaille des barbus ©clémen
Posté le 14-08-2004 à 14:35:15  profilanswer
 

mean : tu as le soundstorm ou pas ? le hw mixing marche chez toi ?


Message édité par udok le 14-08-2004 à 14:50:10

---------------
Non au projet de loi DADVSI ! (droits d'auteurs)
n°540116
[Albator]
MDK un jour, MDK toujours !
Posté le 14-08-2004 à 14:50:27  profilanswer
 

J'ai une CM avec MCP-T , mdk10 avec le kernel 2.6.8-rc2 de cooker, et pas moyen de faire marcher nvsound, le système freeze pendant l'étape "modprobe" de l'installeur. J'ai testé en virant le REGPARM et 4Kstacks du kernel, ça fait toujours pareil :'(
Obligé de garder mon oss commercial pour avec un softmix correct :/

n°540119
udok
La racaille des barbus ©clémen
Posté le 14-08-2004 à 14:51:58  profilanswer
 

[Albator] a écrit :

J'ai une CM avec MCP-T , mdk10 avec le kernel 2.6.8-rc2 de cooker, et pas moyen de faire marcher nvsound, le système freeze pendant l'étape "modprobe" de l'installeur. J'ai testé en virant le REGPARM et 4Kstacks du kernel, ça fait toujours pareil :'(
Obligé de garder mon oss commercial pour avec un softmix correct :/


:??:
t'as payé ou piraté ?? :??:
le soft mix est correct avec arts :)
bon ok, c'est lourd arts, et c'est pas adapté quand on n'a pas kde, m'enfin ça fait l'affaire


---------------
Non au projet de loi DADVSI ! (droits d'auteurs)
n°540123
[Albator]
MDK un jour, MDK toujours !
Posté le 14-08-2004 à 15:01:44  profilanswer
 

udok a écrit :

:??:
t'as payé ou piraté ?? :??:
le soft mix est correct avec arts :)
bon ok, c'est lourd arts, et c'est pas adapté quand on n'a pas kde, m'enfin ça fait l'affaire


 
J'ai payé of course ... 30 euros pour 2 ans de mises à jour, c'est pas la mort. Surtout qu'à l'époque où j'ai acheté c'était le seul moyen d'avoir du multicanal et du 4.1 (ou plus ...) avec le nforce 2 ... En attendant un driver officiel avec le mix hardware, c'est à mon avis le meilleur choix :) et puis c'est compatible avec tous les logiciels existants.

n°540126
udok
La racaille des barbus ©clémen
Posté le 14-08-2004 à 15:07:32  profilanswer
 

moué, si tu bosses dans la musique pourquoi pas, mais 30€ juste pour pouvoir recevoir les sons de ton IM favori pendant que tu écoutes de la musique (c'est mon cas), ça fait cher [:god]


---------------
Non au projet de loi DADVSI ! (droits d'auteurs)
n°540130
mean
Posté le 14-08-2004 à 15:15:48  profilanswer
 

j'ai la sorti en dolby digital (d'apres mon ampli)
pas testé le hw mixing  
 

n°540823
c0wb0y
:d
Posté le 15-08-2004 à 22:02:08  profilanswer
 

Faut que j'installe ca !  :love:  
J'espere que c'est pas trop trop instable, car les problemes de son étaient la derniere bariere a mon passage sous linux (je peux pas me resoudre a me passer de mon 5.1 T_T )

n°540838
jeep05
Posté le 15-08-2004 à 22:25:36  profilanswer
 

jeep05 a écrit :

j'ai pas eu autant de chance car le son ne marche pas.
 
 
Pour la carte réseau, dans le Harddrake, il m'affiche l'ancien pilote et pas 'nvnet'. Il ne l'a pas pris en compte ? Comment le vérifier ?
 
Mon /etc/modprobes.conf  
 

Citation :

alias eth0 nvnet
alias eth1 3c59x
alias ieee1394-controller ohci1394
#alias sound-slot-0 snd-intel8x0
alias sound-slot-0 nvsound
 
install usb-interface /sbin/modprobe usb-ohci; /sbin/modprobe ehci-hcd; /bin/true
 
alias tty-ldisc-3 ppp_async
alias tty-ldisc-13 n_hdlc
alias tty-ldisc-14 ppp_synctty
alias char-major-108 ppp_generic


D'ailleurs, je ne sais pas à quoi correspondent les 4 derniers alias (tty)
 
Je suis en noyau 2.6.8 (Mandrake Cooker) - Carte mère Asus A7n8x Dlx)
 
Mon /etc/modules.conf

Citation :

probeall usb-interface usb-ohci ehci-hcd
#alias eth0 forcedeth
alias eth0 nvnet
alias eth1 3c59x
#alias eth2 3c59x
alias ieee1394-controller ohci1394
#above snd-intel8x0 snd-pcm-oss
#alias sound-slot-0 snd-intel8x0
alias sound-slot-0 nvsound


 
Si le noyau 2.6 utilise  /etc/modprobes.conf  pourquoi y a t-il toujours  /etc/modules.conf ? Faut-il quand même éditer modules.conf de la même manière que modprobes ?

personne ne sait ?


Message édité par jeep05 le 08-04-2005 à 11:30:10

---------------
"Finalement, quand on est riche, ça ne s'arrête jamais ? - Rassurez-vous, c'est pareil quand on est pauvre !" -Film "Ah ! si j'étais riche, 2002"
n°540965
cedricbrun
Posté le 16-08-2004 à 08:06:29  profilanswer
 

drapal :D

n°541627
BoB_Xygene
Posté le 17-08-2004 à 10:55:29  profilanswer
 

pour pas que votre pc freeze avec nvsound il faut désactiver l'acpi soit ds le bios soit avec lilo en spécifiant noacpi et acpi=off, vous ne freezerez plus mais de toute façon ce pilotte censé supporter des fonctions hardware de l'apu merde complettement chez moi et pour un fonctionnement correcte il faut effectuer toute les opérations en software donc nvsound ne sert a rien tant qu'il ne l'auront pas amélioré.

n°544301
c0wb0y
:d
Posté le 21-08-2004 à 17:45:02  profilanswer
 

Est ce que qqn pourrait faire un mini-howto pour expliquer comment utiliser ces nouveaux drivers ?
Actuellement j'ai alsa (en stereo via spdif) mais j'aimerai ces nouveaux drivers pour exploiter les capacités du nforce2 comme sous windows où le son est excelent :°)
Mais voila, j'ai installer les drivers (pas de probleme tout s'est bien deroulé) mais apres, j'sais pas quoi en faire :(

n°544628
[Albator]
MDK un jour, MDK toujours !
Posté le 22-08-2004 à 13:26:56  profilanswer
 

Bon, j'ai réussi à installer ce driver en désactivant l'APIC, je rajoute la ligne "alias sound-slot-0 nvsound" dans mon /etc/modprobe.conf, je lance le service sound (service sound start) de Mandrake, et miracle, ça se charge, je peux même utiliser nvmixer.
 
Problème: je ne peux écouter aucun son, par exemple avec xmms, je peux lancer un mp3, je ne vois aucune erreur, mais il reste figé sans être planté ...
 
Attendons la prochaine version :)


Message édité par [Albator] le 22-08-2004 à 13:27:14
n°544706
Coolos56
Posté le 22-08-2004 à 19:11:29  profilanswer
 

J'ai essayé moi aussi , et le nvmixer marche bien mais j'ai le meme probleme à savoir que j'arrive pas a jouer de son avec xmms (il me sors l'erreur classique comme quoi ma carte son est mal config (j'utilise le plugin ESD)) mais par contre le son dans enemy territory fonctionne .
Etant sous gentoo , je me dit que je devrait recompiler esound en enlevant des USE alsa . Et là xmms me sort plus d'erreur mais aucun son sort et la vitesse de lecture des pistes accelere .
Enfin tout ca pour dire que le driver n'est pas au top encore .


Message édité par Coolos56 le 22-08-2004 à 19:12:09
n°544888
Dark_Schne​ider
Close the World, Open the Net
Posté le 23-08-2004 à 02:35:50  profilanswer
 

utilise OSS et non ALSA


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°578689
[Albator]
MDK un jour, MDK toujours !
Posté le 23-10-2004 à 21:25:38  profilanswer
 

Nouvelle version du driver nforce: 0292
 
Testé chez moi, le gain par rapport au 0283, c'est que ça fonctionne avec APIC et ACPI activés
 
Ce qui ne fonctionne toujours pas:
- Arts (cf msg de jeep05 plus haut)
- Mplayer rame atrocement
 
Pas de problème de stabilité du système.
 
Encore un tout petit effort et ça sera utilisable :o

n°579423
c0wb0y
:d
Posté le 25-10-2004 à 12:30:16  profilanswer
 

Albator => Le hardware mixing fonctionne ? La prise en charge de l'encodage Dolby Digital ? (j'utilise un ampli, donc sortie spdif, et le son via l'encodage Dolby est excelent :°) )
 
Enfin, si tu pouvais detailler un peu tes impressions :)
(et ta config du noyau, car la precedante version j'ai jamais reussi a al faire fonctionné :/ )

n°579500
Dark_Schne​ider
Close the World, Open the Net
Posté le 25-10-2004 à 14:41:53  profilanswer
 

- avec arts il faut sélectionner OSS dans périphérique ( kcontrol -> son -> système de son )
 
- il est normal que harddrake affiche le pilote OSS puisqu'il n'affiche aps forcément le pilote utilisé. il affiche le pilote que lui avait conf, si tu modifies manuellement il ne le sais pas ( surtout si le pilote n'est pas dans sa base de donnée )


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°579520
[Albator]
MDK un jour, MDK toujours !
Posté le 25-10-2004 à 15:01:17  profilanswer
 

Pour le pb de arts, il est bien évident que j'ai en premier lieu tenté de forcer l'utilisation d'OSS dans le panneau de conf KDE. Mais rien n'y fait. Même avec tout par défaut ça ne marche pas.

n°579523
Dark_Schne​ider
Close the World, Open the Net
Posté le 25-10-2004 à 15:02:25  profilanswer
 

en forçant un sample rate à 48kHz ?


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°579524
[Albator]
MDK un jour, MDK toujours !
Posté le 25-10-2004 à 15:03:36  profilanswer
 

Dark_Schneider a écrit :

en forçant un sample rate à 48kHz ?


 
Non plus, bien tenté ;)
En virant ou activant le full duplex non plus.

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  nouveau driver nforce : hw mixing

 

Sujets relatifs
installation ut2004 - driver ati problemeSagem 1000 F@st - LINUX Driver
Besoin coup de pouce install Nvidia Driverprobleme install driver alsa pour un sblive
[Xorg] Compliqué pour un nouveau ?MDK 10 install driver NVidia (résolu)
appels aux possesseurs de xbox, nforce et nforce2Nouveau forum postfix
[Thunderbird] Notification de nouveau messagecomment installer un driver SCSI à l'installation de linux ?
Plus de sujets relatifs à : nouveau driver nforce : hw mixing


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR