Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1884 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Logitech MX1000

 



 Mot :   Pseudo :  
 
 Page :   1  2  3  4
Page Précédente
Auteur Sujet :

Logitech MX1000

n°570011
ICE
Posté le 11-10-2004 à 05:50:38  profilanswer
 

Tous les boutons fonctionnent sauf les deux boutons latéraux de la roulette ainsi que le bouton qui permet de passer d'une application à l'autre. Sous xev ces trois boutons ne renvois rien.
 
pour info je suis sous debian unstable
 
J'utilise  xmodmap -e "pointer = 1 2 3 11 12 6 7 8 9 10 4 5"
 
puis dans le fichier XF86Config-4
 
Section "InputDevice"
        Identifier      "Logitech MX 1000"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/event0"
        Option          "Dev Phys"              "isa0060/serio1/input0"
        Option          "Protocol"              "evdev"
        Option          "Buttons"               "12"
        Option          "ZAxisMapping"          "11 12"
        Option          "Resolution"            "800"
EndSection
 
 

mood
Publicité
Posté le 11-10-2004 à 05:50:38  profilanswer
 

n°577923
dastormtro​oper
Posté le 22-10-2004 à 15:27:50  profilanswer
 

@helloz
 
Merci pour cette info, je compte bientôt m'en acheter une, cela m'aidera au moment de basculer la config.
 
@peluche


Message édité par dastormtrooper le 22-10-2004 à 15:28:08

---------------
http://lotus.bluegeek.fr
n°577925
mirtouf
Light is right !
Posté le 22-10-2004 à 15:31:20  profilanswer
 

Option          "Protocol"              "evdev"


 
Kécè ?


---------------
-~- Libérez Datoune ! -~- Camarade, toi aussi rejoins le FLD pour que la flamme de la Révolution ne s'éteigne pas ! -~- A VENDRE -
n°591999
benhuros
Posté le 17-11-2004 à 13:27:53  profilanswer
 

[mode newbie]
est ce que cette manip fonctionne sous mandrake?
Ou existe t il une autre solution car j'ai essayé en vain...
 
Merci d'avance

n°592011
alien cons​piracy
hardtrance addict
Posté le 17-11-2004 à 13:54:29  profilanswer
 

ICE a écrit :

Tous les boutons fonctionnent sauf les deux boutons latéraux de la roulette ainsi que le bouton qui permet de passer d'une application à l'autre. Sous xev ces trois boutons ne renvois rien.
 
pour info je suis sous debian unstable
 
J'utilise  xmodmap -e "pointer = 1 2 3 11 12 6 7 8 9 10 4 5"
 
puis dans le fichier XF86Config-4
 
Section "InputDevice"
        Identifier      "Logitech MX 1000"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/event0"
        Option          "Dev Phys"              "isa0060/serio1/input0"
        Option          "Protocol"              "evdev"
        Option          "Buttons"               "12"
        Option          "ZAxisMapping"          "11 12"
        Option          "Resolution"            "800"
EndSection

idem, à la differrence près que chez moi ils clonent d'autres bouttons. J'utilise le driver IntelliMouse et je suis en USB.

n°592687
BMOTheKill​er
Posté le 18-11-2004 à 18:19:13  profilanswer
 

déjà il faut :
 
1°)

Citation :


xorg-x11 recompilé avec les patchs :
 
9000_all_6.7.99.1-lnx-evdev-core-v2.patch
9001_all_4.3.0-lnx-evdev-keyboard.patch
9002_all_6.7.0-lnx-evdev-mouse.patch
 
inutile sous gentoo


 
2°)

Citation :


mettre ça dans xorg.conf :
 
#-------------------
Section "InputDevice"
 Identifier "Logitech MX1000 USB"
 Driver  "mouse"
 Option  "Protocol" "evdev"
 Option  "Dev Name" "Logitech USB Receiver"
Option  "Dev Phys" "usb-0000:00:02.0-1/input0"
 Option  "Device" "/dev/input/mice"
 Option  "Buttons" "12"
 Option  "ZAxisMapping" "11 12"
 Option  "Resolution" "800"
 Option  "SampleRate" "800"
 Option  "CorePointer"
EndSection
#-------------------
 
Pour la ligne en rouge, 2 cas :
- notau 2.4 : cette ligne est inutile, donc la commenter ou la virer
- noyau 2.6 : il va falloir chercher un peu par vous même, suffit de lire la sortie de "cat /proc/bus/input/devices"
 
pour plus de détails sur la partie xorg.conf : http://forums.gentoo.org/viewtopic.php?t=246605


 
3°)

Citation :


mon xmodmap :
 
xmodmap -e 'pointer = 1 8 3 7 6 2 9 10 11 12 4 5'
 
avec le bouton "8" (celui qui sensé zapper entre les applies sous windows) en bouton "2" (middle-clic), c'est plus pratique que de cliquer sur la molette pour copier/coller ou ouvrir un onglet sous moz/ff/konq... et bien sûr les boutons de la molette (cruise control) pour les déplacements par clics et les 2 autres boutons latéraux qui font précédent/suivant dans les browsers


 
Il existe un patch pour modifier la résolution de la souris sur les kernel 2.6 (cf le forum gentoo)
 
Expérience perso : je suis repassé en 2.4 (2.4.28-rc) et la souris fonctionne bien mieux je trouve (problème de décrochages (quand ça lui chante) avec ou sans patch polling sur les 2.6). Les boutons de déplacement latéraux de la molette n'ont pas l'air de fonctionner comme il faut sous 2.6 (kernel: keyboard.c: can't emulate rawmode for keycode 240), pas cherché plus loin
 
4°)

Citation :


besoin de plus ?
STFW : google répond à ça

n°592694
mirtouf
Light is right !
Posté le 18-11-2004 à 18:39:18  profilanswer
 

mirtouf a écrit :

Option          "Protocol"              "evdev"


 
Kécè ?


ça ajoute quoi de plus ça ?


---------------
-~- Libérez Datoune ! -~- Camarade, toi aussi rejoins le FLD pour que la flamme de la Révolution ne s'éteigne pas ! -~- A VENDRE -
n°592696
BMOTheKill​er
Posté le 18-11-2004 à 18:43:49  profilanswer
 

Event character device
 
c'est clair

n°592701
mirtouf
Light is right !
Posté le 18-11-2004 à 18:47:20  profilanswer
 

Pour quels boutons supplémentaires justement ?


---------------
-~- Libérez Datoune ! -~- Camarade, toi aussi rejoins le FLD pour que la flamme de la Révolution ne s'éteigne pas ! -~- A VENDRE -
n°592704
BMOTheKill​er
Posté le 18-11-2004 à 18:56:13  profilanswer
 

pour avoir 12 boutons au lieu de 7 (donc cruise-control et 1 bouton latéral)

mood
Publicité
Posté le 18-11-2004 à 18:56:13  profilanswer
 

n°632437
bastien59
Posté le 06-02-2005 à 21:53:43  profilanswer
 

xmodmap -e "pointer = 1 2 3 11 12 6 7 8 9 10 4 5"  
 
Question : ou je mets cette commande pour que ça soit automatique car pour le moment je dois la lancer à chaque démarrage.

n°632438
mirtouf
Light is right !
Posté le 06-02-2005 à 21:54:42  profilanswer
 
n°632449
bastien59
Posté le 06-02-2005 à 22:35:16  profilanswer
 

j'ai essayé mais ça marche pas...

n°638707
Mjules
Modérateur
Parle dans le vide
Posté le 18-02-2005 à 18:36:01  profilanswer
 

le patch evdev peut il s'appliquer sur Xorg 6.7.0 ? j'ai cherché mais pas trouvé d'info à ce sujet :/


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°638770
Pillow
'cos the trees won't talk
Posté le 18-02-2005 à 19:50:06  profilanswer
 

Mjules a écrit :

le patch evdev peut il s'appliquer sur Xorg 6.7.0 ? j'ai cherché mais pas trouvé d'info à ce sujet :/

oui.

n°638772
Mjules
Modérateur
Parle dans le vide
Posté le 18-02-2005 à 19:53:25  profilanswer
 

merci


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°639309
Mjules
Modérateur
Parle dans le vide
Posté le 20-02-2005 à 14:25:55  profilanswer
 

bon, malgré un patchage réussi et une recompilation, xorg 6.7.0 n'a toujours pas le suppor evdev :/
 
ya un truc à faire en particulier pour l'activer (genre un --with-evdev au configure ou autre) ?


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°639486
jebb
pacman -S fantomes
Posté le 20-02-2005 à 21:50:38  profilanswer
 

bastien59 a écrit :

xmodmap -e "pointer = 1 2 3 11 12 6 7 8 9 10 4 5"  
 
Question : ou je mets cette commande pour que ça soit automatique car pour le moment je dois la lancer à chaque démarrage.


 
~/.Xmodmap
 
Chez moi la roulette marche, mais pas en side scrolling (me bagarre avec xev et xbindkeys, mais je dois faire un truc de travers....). Par contre, le forward/backward sous firefox fonctionne avec les boutons sous le pouce.

n°639489
Pillow
'cos the trees won't talk
Posté le 20-02-2005 à 21:57:02  profilanswer
 

Mjules a écrit :

bon, malgré un patchage réussi et une recompilation, xorg 6.7.0 n'a toujours pas le suppor evdev :/
 
ya un truc à faire en particulier pour l'activer (genre un --with-evdev au configure ou autre) ?

Visiblement, non il n'y a rien d'autre à faire du coté serveur X. Par contre il faut surement le support evdev dans le kernel (en dur ou en module). Vérifie bien que l'adresse physique de ton périphérique est bien réglée. Donne le message d'erreur si le problème persiste [:petrus75]  
 
FYI, xorg est complètement basé sur imake et n'a pas de configure (pour configurer, il faut éditer le host.def). Mais X11R7 sera modulaire et autotoolé :)

n°639752
VenerZen
M - D - M
Posté le 21-02-2005 à 15:33:49  profilanswer
 

jebb a écrit :

~/.Xmodmap
 
Chez moi la roulette marche, mais pas en side scrolling (me bagarre avec xev et xbindkeys, mais je dois faire un truc de travers....). Par contre, le forward/backward sous firefox fonctionne avec les boutons sous le pouce.


Chez moi ça passe. Pas dans un navigateur, mais je l'utilise pour changer de bureau avec fvwm.

n°639810
jebb
pacman -S fantomes
Posté le 21-02-2005 à 17:00:35  profilanswer
 

VenerZen a écrit :

Chez moi ça passe. Pas dans un navigateur, mais je l'utilise pour changer de bureau avec fvwm.


Yabon ! T'as fait ça avec xbindkeys ? Si oui, tu pourrais donner ton .xbindkeysrc ?

n°639840
VenerZen
M - D - M
Posté le 21-02-2005 à 18:07:09  profilanswer
 

Nope, directement dans le .fvwmrc.

n°639888
Mjules
Modérateur
Parle dans le vide
Posté le 21-02-2005 à 19:58:38  profilanswer
 

pillow a écrit :

Visiblement, non il n'y a rien d'autre à faire du coté serveur X. Par contre il faut surement le support evdev dans le kernel (en dur ou en module). Vérifie bien que l'adresse physique de ton périphérique est bien réglée. Donne le message d'erreur si le problème persiste [:petrus75]  
 
FYI, xorg est complètement basé sur imake et n'a pas de configure (pour configurer, il faut éditer le host.def). Mais X11R7 sera modulaire et autotoolé :)


 
je me disais bien que je trouvais pas de configure [:petrus75]  
 
sinon, message d'erreur classique protocole evdev non supporté ou un truc du genre :/ et je suis sur qu'il n'est pas supporté parce que la vérification avec strings montre que le binaire X ne contient aucune référence à evdev :/


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°652221
Mjules
Modérateur
Parle dans le vide
Posté le 19-03-2005 à 21:59:46  profilanswer
 

bon cette fois ci j'ai réussi à compiler xorg correctement, le binaire /usr/X11R6/bin/Xorg a bien les bonnes chaines dedans. En chargeant le module evdev, ça démarre bien.
 
l'ennui, c'est que les touches surnuméraires (par rapport à la MX700) n'envoient aucun événement à xev :/
 
je me retrouve avec une gestion équivalente à la MX700 (soit 3 boutons inutiles)
 
 
est ce que ça pourrait avoir un rapport avec le fait que /usr/X11R6/bin/X pointe vers Xwrapper et pas vers Xorg ? EDIT : a priori c'est pas ça le problème :/
 
tout le reste semble correct (xorg.conf et xmodmap)
 
mon xorg.conf :

Section "InputDevice"
        Identifier "MX1000"
        Driver "mouse"
        Option "Dev Name" "ImExPS/2 Logitech Explorer Mouse"
        Option "Device" "/dev/input/mouse0"
        Option "Dev Phys" "isa0060/serio1/input0"
        Option "Protocol"              "evdev"
        Option "Buttons"                "12"
        Option "ZAxisMapping"          "11 12"
        Option "Resolution"            "800"  
EndSection


Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "MX1000" "CorePointer"
    Screen "screen1"
EndSection


 
le xmodmap :

[jules@tue-amour2 jules]$ less /etc/X11/xinit.d/souris  
#!/bin/sh
xmodmap -e "pointer = 1 2 3 6 7 8 9 10 11 12 4 5"
exit


 
les modules :


[jules@tue-amour2 jules]$ /sbin/lsmod|grep evdev  
evdev                   8960  1  


Message édité par Mjules le 19-03-2005 à 22:03:37

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°652462
BMOTheKill​er
Posté le 20-03-2005 à 18:42:48  profilanswer
 

quelle version de xorg et quel patch ?
 
chez moi ça fonctionne avec la mouture 6.8.2 issue des sources xorg-x11 de fedora + des morceaux de patchs evdev (dont j'ai fait une compile en un seul patch), au cas où ça t'intéresse, la version gzipée : xorg-x11-6.8.2_all_lnx-evdev-core.patch.gz
 
si tu veux le voir en ligne : xorg-x11-6.8.2_all_lnx-evdev-core.patch
 
il s'applique sans problème sur des sources "vanilla" :D de xorg 6.8.2

n°652479
Mjules
Modérateur
Parle dans le vide
Posté le 20-03-2005 à 20:00:38  profilanswer
 

X Window System Version 6.8.1.904 (6.8.2 RC 4)
Release Date: 2 February 2005
X Protocol Version 11, Revision 0, Release 6.8.1.904
 
 
avec un paquet de patchs mandrake :
 
Patch4: X11R6.7.0-libfreetype-xtt2-1.2a.patch.bz2
Patch5: Xorg-6.7.0-isolate_device.patch.bz2
Patch102: Xorg-6.7.1-xman-bzip2.patch.bz2
Patch104: XFree86-4.3.99.902-startx.patch.bz2
Patch106: XFree86-4.2.1-gl-matrix-man-fixes.patch.bz2
Patch110: XFree86-4.3-xdm-reserve.patch.bz2
Patch200: XFree86-4.2.99.3-parallel-make.patch.bz2
Patch201: XFree86-4.2.99.3-mandrakelinux-blue.patch.bz2
Patch202: XFree86-4.3.99.901-xwrapper.patch.bz2
Patch209: XFree86-4.2.0-xkb-hp_symbols.patch.bz2
Patch210: XFree86-4.3-build-libs-with-pic.patch.bz2
Patch212: XFree86-4.3-mouse-twice.patch.bz2
Patch213: XFree86-4.3.0-gb18030.patch.bz2
Patch214: XFree86-4.3.0-gb18030-enc.patch.bz2
Patch216: XFree86-4.3-_LP64-fix.patch.bz2
Patch514: XFree86-4.1.0-agpgart-load.patch.bz2
Patch528: XFree86-4.2.0-vt7.patch.bz2
Patch531: XFree86-4.2.1-kbd-error.patch.bz2
Patch532: XFree86-4.2.1-chips-CT69000-noaccel.patch.bz2
Patch533: XFree86-4.2.1-chips-CT65550-swcursor.patch.bz2
Patch536: XFree86-4.2.99.3-savage-pci-id-fixes.patch.bz2
Patch537: XFree86-4.2.99.902-savage-Imakefile-vbe-fixup.patch.bz2
Patch538: XFree86-4.2.99.902-savage-1.1.26cvs-1.1.27t-fixups.patch.bz2
Patch539: XFree86-4.2.99.902-savage-1.1.26cvs-1.1.27t-accel-fixup.patch.bz2
Patch540: XFree86-4.3-ati-r300.patch.bz2
Patch541: XFree86-4.3-radeon-1-igp.patch.bz2
Patch542: XFree86-4.3-radeon-2-rv280.patch.bz2
Patch543: XFree86-4.3-radeon-3-lcd.patch.bz2
Patch544: XFree86-4.3-radeon-4-recycle-lockup.patch.bz2
Patch550: XFree86-4.3-nv-init.patch.bz2
Patch560: XFree86-4.3-vt_fix.patch.bz2
Patch562: xorg-x11-6.8.2-mk712.patch.bz2  
Patch563: xorg-x11-6.8.2-calibration.patch.bz2
Patch564: xorg-x11-6.8.2-nvxbox.patch.bz2
Patch700: XFree86-4.2.99.3-acecad-debug.patch.bz2
Patch9601: XFree86-4.3.99.902-mozilla-flash.patch.bz2
Patch10012: xorg-redhat-libGL-exec-shield-fixes.patch.bz2
Patch10015: XFree86-4.3.0-redhat-nv-riva-videomem-autodetection-debugging.patch.bz2
Patch10101: XFree86-4.3.0-makefile-fastbuild.patch.bz2
Patch20000: XFree86-4.4-libviaXvMC-%{unichromexvmc}-patch.bz2
Patch40002: lib_freetype_module.patch.bz2  
Patch40011: linuxwacom-0.6.3_drop_i386_defines.patch.bz2
Patch40012: linuxwacom-0.6.3-do-not-build-libwacomcfg.patch.bz2
Patch40013: xorg-x11-6.7.0-wacom-dynamic.patch.bz2
Patch40014: xorg-DRI-TLS-01.patch.bz2
Patch40015: xorg-Mesa-TLS-01.patch.bz2
Patch40019: xorg-x11-6.8.1-radeon-ppc-fixes.patch.bz2
Patch40020: xorg-x11-6.8.1-xvfb-backingstore.patch.bz2
Patch40021: xorg-x11-6.8.2-ppc-segfault-fix.patch.bz2
 
ces 3 là, c'est les patch evdev :
 
Patch250001: 9000_all_6.7.99.2-lnx-evdev-core-v2.patch.bz2
Patch250002: 9001_all_4.3.0-lnx-evdev-keyboard-v2.patch.bz2
Patch250003: 9002_all_6.7.0-lnx-evdev-mouse.patch.bz2


Message édité par Mjules le 20-03-2005 à 20:01:00

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°653583
Mjules
Modérateur
Parle dans le vide
Posté le 22-03-2005 à 18:42:31  profilanswer
 

j'ai testé avec la version finale de xorg et ça marche toujours pas :fou:
 

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.8.1-24mdk x86_64 [ELF]  
Current Operating System: Linux tue-amour2.jules.ici 2.6.8.1-24mdk #1 Fri Jan 14 11:43:02 MST 2005 x86_64
Build Date: 22 March 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present


 

[jules@tue-amour2 jules]$ sudo strings /usr/X11R6/bin/Xorg |grep evdev
evdevStart
evdevNewDriver
evdevGetFDForDriver
%s: cannot register with evdev brain
evdev
%s: cannot start evdev brain
evdev
%s: cannot register with evdev brain
%s: cannot start evdev brain
/tmp/.X11-unix/evdev%d
evdev brain


 
patchs ajoutés par mandrake :
 
Patch4: X11R6.7.0-libfreetype-xtt2-1.2a.patch.bz2
Patch5: Xorg-6.7.0-isolate_device.patch.bz2
Patch50: xorg-x11-6.8.2-libxft.patch.bz2
Patch102: Xorg-6.7.1-xman-bzip2.patch.bz2
Patch104: XFree86-4.3.99.902-startx.patch.bz2
Patch106: XFree86-4.2.1-gl-matrix-man-fixes.patch.bz2
Patch110: XFree86-4.3-xdm-reserve.patch.bz2
 
Patch200: XFree86-4.2.99.3-parallel-make.patch.bz2
Patch201: XFree86-4.2.99.3-mandrakelinux-blue.patch.bz2
Patch202: XFree86-4.3.99.901-xwrapper.patch.bz2
 
Patch209: XFree86-4.2.0-xkb-hp_symbols.patch.bz2
Patch210: XFree86-4.3-build-libs-with-pic.patch.bz2
Patch212: XFree86-4.3-mouse-twice.patch.bz2
Patch213: XFree86-4.3.0-gb18030.patch.bz2
Patch214: XFree86-4.3.0-gb18030-enc.patch.bz2
Patch216: XFree86-4.3-_LP64-fix.patch.bz2
 
 
Patch514: XFree86-4.1.0-agpgart-load.patch.bz2
Patch528: XFree86-4.2.0-vt7.patch.bz2
Patch531: XFree86-4.2.1-kbd-error.patch.bz2
Patch532: XFree86-4.2.1-chips-CT69000-noaccel.patch.bz2
Patch533: XFree86-4.2.1-chips-CT65550-swcursor.patch.bz2
Patch536: XFree86-4.2.99.3-savage-pci-id-fixes.patch.bz2
Patch537: XFree86-4.2.99.902-savage-Imakefile-vbe-fixup.patch.bz2
Patch538: XFree86-4.2.99.902-savage-1.1.26cvs-1.1.27t-fixups.patch.bz2
Patch539: XFree86-4.2.99.902-savage-1.1.26cvs-1.1.27t-accel-fixup.patch.bz2
Patch540: XFree86-4.3-ati-r300.patch.bz2
Patch541: XFree86-4.3-radeon-1-igp.patch.bz2
Patch542: XFree86-4.3-radeon-2-rv280.patch.bz2
Patch543: XFree86-4.3-radeon-3-lcd.patch.bz2
Patch544: XFree86-4.3-radeon-4-recycle-lockup.patch.bz2
Patch550: XFree86-4.3-nv-init.patch.bz2
Patch560: XFree86-4.3-vt_fix.patch.bz2
 
Patch562: xorg-x11-6.8.2-mk712.patch.bz2  
Patch563: xorg-x11-6.8.2-calibration.patch.bz2
Patch564: xorg-x11-6.8.2-nvxbox.patch.bz2
Patch565: xorg-x11-6.8.2-perm.patch.bz2
Patch700: XFree86-4.2.99.3-acecad-debug.patch.bz2
 
 
Patch5000: xorg-x11-6.8.2-radeon-render.patch.bz2
Patch5001: xorg-x11-6.8.2-nv-ids.patch.bz2
Patch5002: xorg-x11-6.8.2-void-driver.patch.bz2
Patch5003: xorg-x11-6.8.2-radeon-merge.patch.bz2
 
 
Patch9325: xorg-x11-6.8.2-gcc4-fix.patch.bz2
Patch9327: xorg-x11-6.8.2-ati-radeon-gcc4-fix.patch.bz2
Patch9601: XFree86-4.3.99.902-mozilla-flash.patch.bz2
Patch10012: xorg-redhat-libGL-exec-shield-fixes.patch.bz2
Patch10015: XFree86-4.3.0-redhat-nv-riva-videomem-autodetection-debugging.patch.
bz2
Patch10101: XFree86-4.3.0-makefile-fastbuild.patch.bz2
Patch20000: XFree86-4.4-libviaXvMC-%{unichromexvmc}-patch.bz2
Patch40002: lib_freetype_module.patch.bz2  
Patch40012: linuxwacom-0.6.3-do-not-build-libwacomcfg.patch.bz2
Patch40013: xorg-x11-6.7.0-wacom-dynamic.patch.bz2
Patch40014: xorg-DRI-TLS-01.patch.bz2
Patch40015: xorg-Mesa-TLS-01.patch.bz2
Patch40019: xorg-x11-6.8.1-radeon-ppc-fixes.patch.bz2
Patch40020: xorg-x11-6.8.1-xvfb-backingstore.patch.bz2
Patch40021: xorg-x11-6.8.2-ppc-segfault-fix.patch.bz2
 
 
 
Patch250001: 9000_all_6.7.99.2-lnx-evdev-core-v2.patch.bz2
Patch250002: 9001_all_4.3.0-lnx-evdev-keyboard-v2.patch.bz2
Patch250003: 9002_all_6.7.0-lnx-evdev-mouse.patch.bz2
 
le module evdev est bien chargé, mon xorg.conf est bien configuré, le xmodmap est bon (ça fait 4 fois que je vérifie, et j'ai testé en le copiant collant du tuto linux gamer). La souris est déclaré avec 12 boutons.
 
 
Et je n'ai toujours aucun événement avec xev quand j'appuie sur le bouton au centre de "précédent/suivant" ou sur ceux de l'ascenceur latéral.
 
bref, j'ai une MX1000 reconnu comme une MX700 ; c'est frustrant


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°653718
BMOTheKill​er
Posté le 23-03-2005 à 01:39:38  profilanswer
 

essaye avec le patch que je t'ai cité plus haut, ça devrait fonctionner si mdk n'a pas de patchs qui entrent en conflit....
 
d'ailleurs tu ne risques pas de faire fonctionner evdev avec la 6.8.2 et ces 3 patchs-là puisqu'ils sont obsolètes maintenant, j'ai eu le problème aussi ;)
 
edit : issu du log


(**) Option "Protocol" "evdev"
(**) Logitech MX1000 USB: Protocol: evdev
(II) XINPUT: Adding extended input device "evdev brain" (type: evdev brain)


Message édité par BMOTheKiller le 23-03-2005 à 01:43:44
n°653969
gandalf-ze​-wizard
Vous n'avez besoin de rien ?
Posté le 23-03-2005 à 15:29:50  profilanswer
 

quand je tappe

Citation :

xmodmap -e "pointer = 1 2 3 11 12 6 7 8 9 10 4 5"


il me repond :

Citation :

xmodmap:  commandline:0:  bad number of buttons, must have 5 instead of 12  
xmodmap:  1 error encountered, aborting.

n°653990
BMOTheKill​er
Posté le 23-03-2005 à 15:59:08  profilanswer
 

Option "Buttons"                "12"

n°654024
Mjules
Modérateur
Parle dans le vide
Posté le 23-03-2005 à 17:23:38  profilanswer
 

BMOTheKiller a écrit :

essaye avec le patch que je t'ai cité plus haut, ça devrait fonctionner si mdk n'a pas de patchs qui entrent en conflit....

d'ailleurs tu ne risques pas de faire fonctionner evdev avec la 6.8.2 et ces 3 patchs-là puisqu'ils sont obsolètes maintenant, j'ai eu le problème aussi ;)

edit : issu du log


(**) Option "Protocol" "evdev"
(**) Logitech MX1000 USB: Protocol: evdev
(II) XINPUT: Adding extended input device "evdev brain" (type: evdev brain)



 
ça me rassure un peu, bon je sens que c'est reparti pour une compilation d'une heure :D
 
merci de ton aide
 
bizarrement, j'avais quand même les 3 même lignes dans mon log


Message édité par Mjules le 23-03-2005 à 17:28:35

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°654061
Mjules
Modérateur
Parle dans le vide
Posté le 23-03-2005 à 18:09:47  profilanswer
 

ça marche toujours pas avec ton patch :/
, vais tester en passant ma souris en USB
 
 
EDIT : c'est ça le problème \o/ en usb, j'ai bien les 12 boutons qui renvoient un événement. bon, ça m'arrange pas ça, une souris, ça se branche en PS/2 :/


Message édité par Mjules le 23-03-2005 à 18:16:25

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°654069
BMOTheKill​er
Posté le 23-03-2005 à 18:30:30  profilanswer
 

ah ben oui, faut la brancher en USB
 
j'étais contre avant aussi, mais finalement elle fonctionne très bien en USB, pour peu que l'on ait suffisament de ports :/

n°654071
Mjules
Modérateur
Parle dans le vide
Posté le 23-03-2005 à 18:31:50  profilanswer
 

bon, ben on fera comme ça, j'aime pas l'usb mais tant pis


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°654118
gandalf-ze​-wizard
Vous n'avez besoin de rien ?
Posté le 23-03-2005 à 20:01:47  profilanswer
 

damned !
en usb, la souris est meme pas detectee ...
le pointeur bouge pas ...

n°654119
Mjules
Modérateur
Parle dans le vide
Posté le 23-03-2005 à 20:02:46  profilanswer
 

tu as bien rentré les bonnes valeurs de dev phys ?


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°654139
gandalf-ze​-wizard
Vous n'avez besoin de rien ?
Posté le 23-03-2005 à 21:17:16  profilanswer
 

je suis contraint d'avouer que je suis un debutant complet dans le monde de linux ...
je ne sais donc pas si je fais les bonnes manips ...
 
il me semble neanmoins que ce sont mes ports USB en totalite qui ont un probleme avec l'OS du manchot ...

n°659144
Mjules
Modérateur
Parle dans le vide
Posté le 05-04-2005 à 18:22:14  profilanswer
 

BMOTheKiller a écrit :


(..)
Expérience perso : je suis repassé en 2.4 (2.4.28-rc) et la souris fonctionne bien mieux je trouve (problème de décrochages (quand ça lui chante) avec ou sans patch polling sur les 2.6). Les boutons de déplacement latéraux de la molette n'ont pas l'air de fonctionner comme il faut sous 2.6 (kernel: keyboard.c: can't emulate rawmode for keycode 240), pas cherché plus loin
 
(...)


 
salut, j'ai le même message dans mes logs mais les boutons fonctionnent quand même (je leur ai attribué une fonction avec xbindkeys)


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°659147
BMOTheKill​er
Posté le 05-04-2005 à 18:26:20  profilanswer
 

Chez moi je n'ai plus le message et les boutons fonctionnent (ascenceur vertical s'il n'y en a pas un horizontal), je ne sais pas ce qui change dans le noyau pour ce support en fait.
Peut-être le module evdev...

n°659149
Mjules
Modérateur
Parle dans le vide
Posté le 05-04-2005 à 18:27:22  profilanswer
 

probablement, j'ai vu un post sur la lkml mais sans réponse
 
mon noyau est un 2.6.8.1


Message édité par Mjules le 05-04-2005 à 18:27:38

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Logitech MX1000

 

Sujets relatifs
Webcam Logitech MessengerProbleme de scrolling dans firefox avec souris logitech MX700
MDK 10 ne reconnaît pas ma souris Logitech Cordless Mouse PS2/USBMDK 10 ne reconnaît pas ma souris Logitech Cordless Mouse PS2/USB
[Config Souris] Logitech Dual OptiqueProblème souris-sans fil Logitech MX700
logitech quickcam messenger...utiliser raccourci du clavier logitech ?
Logitech MX700 sous linuxun petit prob sous debian config souris logitech cordless
Plus de sujets relatifs à : Logitech MX1000


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR