Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1670 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Installation d'un adpatateur USB>RS232 HL-340

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

Installation d'un adpatateur USB>RS232 HL-340

n°930454
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 04-07-2007 à 19:23:56  profilanswer
 

Hello :hello:
 
Je cherche désespérément à connecter le portable de ma mère équipé d'un soft modem Motorola SM56 qui ne semble plus supporté sur les noyau 2.6 (et encore, ça avait l'air rock 'n' roll sur les 2.4). Vu que je me refuse à faire tourner ce portable sous Windows (c'est moi qui l'entretient après :/), et qu'elle n'a pas accès à ADSL, il me faut lui trouver une solution de connexion RTC, et le portable n'a pas de ports série (je sais, c'est pénible).
Il me reste donc la carte du modem RTC PCMCIA. Mais avant d'acheter, j'aimerai être sur que le modem sera supporté sous Ubuntu Feisty Fawn. Donc si vous avez des infos là dessus, je suis preneur.
 
A moins qu'il existe un équivalent de ndiswrapper pour les softmodems ? Ce serai vraiment génial :) Mais je n'ose y croire...

 
/!\ Edit /!\
le problème a évolué. Je cherche dorénavant à faire fonctionner l'adaptateur USB>RS232 acheté suite aux conseils de Geant_bleu pour piloter un modem série. Actuellement, ce problème n'est pas résolu, l'adaptateur ne semblant pas pris en charge correctement malgré sa compatibilité annoncé par le vendeur. L'affaire commence ici :
http://forum.hardware.fr/forum2.ph [...] =0#t940402
 
Merci d'avance pour votre aide.


Message édité par Kortex@HFR le 06-08-2007 à 10:32:08
mood
Publicité
Posté le 04-07-2007 à 19:23:56  profilanswer
 

n°930544
geant_bleu
Et non vert :fou:
Posté le 05-07-2007 à 00:25:31  profilanswer
 

Ptéte que c'est un peu tard, mais gutsy supportera les softs modems outofthebox, voilà ce que l'on aura :

 

List of modems and their status

 

There are no reasonable Free Software drivers; all the information in this section refers to non-free drivers usually containing binary blobs of one kind or another.

 

Of the drivers mentioned in [WWW] https://help.ubuntu.com/community/DialupModemHowto or which appear to be available elsewhere:

 

   *

 

     ALSA-based modems: generally work with sl-modem-daemon on i386 only. Polish required; also, Canonical should talk to sl-modem upstream about possible improvements, eg relicensing or at least support for amd64.
    *

 

     Lucent: ltmodem driver is in linux-restricted-modules for UP i386 only. It has had some difficulty with SMP systems; this is being reenabled now even for SMP kernels and will be disabled again if it causes trouble.
    *

 

     Conexant: payware drivers only. These modems are very common. Canonical should talk to Dell about whether there is room for improvement here.
    *

 

     Modems supported by snd-ali5454-modem: this kernel driver appears to be fictional. If a proper reference becomes available we will consider it.
    *

 

     Intel 536 and 537: drivers with binary blobs available from Intel; however the licence does not permit us to redistribute and the driver is not compatible with current kernels. Canonical could ask Intel about this but there doesn't currently seem to be any effort available to keep the drivers up to date.
    *

 

     3780i Mwave/ACP (eg in older Thinkpads): The "mwavem" package in multiverse allegedly supports these. It is not maintained in Ubuntu and was autosynced from Debian. PTS data in Debian suggests this package is not widely used and not actively maintained. We don't know whether it works.
    *

 

     PCTel: drivers are not compatible with recent kernels.
    *

 

     Ambient's "Host Accelerated Modem": from 1999; there do not seem to be any recent drivers.
    *

 

     CL-MD5620DT (Ambient Tech) chipset: Mikhail Moreyra wrote a driver however it is not suitable. Eg, the driver needs the card PCI address compiling into it, and it has not been modified since 2000.


Message édité par geant_bleu le 05-07-2007 à 00:25:41

---------------
34cv pour pourrir mon bandit
n°930562
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 05-07-2007 à 07:57:28  profilanswer
 

Arf... même si ma mère n'est pas pressée d'avoir son portable, attendre jusqu'en Octobre, ça risque de ne pas la faire rire... J'ai commencé à chercher, notamment sur eBay, il y a des modem pas cher du tout en PCMCIA.
Existe-t-il une liste de compatibilité quelconque, comme il existe, au moins à titre informatif, pour les cartes son sur le site d'ALSA ? J'ai remarqué notamment un 3COM 3CCM156, j'aimerai trouver plus d'infos là dessus.

n°930593
geant_bleu
Et non vert :fou:
Posté le 05-07-2007 à 09:14:19  profilanswer
 

linuxcompatible.org ?


---------------
34cv pour pourrir mon bandit
n°930597
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 05-07-2007 à 09:30:25  profilanswer
 

geant_bleu a écrit :

linuxcompatible.org ?


A pourquoi pas... :whistle:
 
Je jette un oeil à midi :) Merci.

n°930615
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 05-07-2007 à 09:58:18  profilanswer
 

L'y est pas ce modem 3Com sur linuxcompatible :cry: J'imagine que cela ne signifie pas forcément que le modem n'est pas compatible, mais ça m'aurait bien arrangé d'avoir une confirmation avant d'acheter, même si apparemment le type qui le vend le certifie sous une Mandrake 9.1.
 
Edit
La Mandrake 9.1 était basée sur un noyau 2.4. Hors, si je prend le softmodem du portable, il était plus ou moins supporté par le noyau 2.4, mais plus du tout sur le 2.6. J'aimerai pas que ça se passe pareil avec ce modem PCMCIA.
 
Edit 2
D'après cette page, que diriez vous de la compatibilité de ce modem 3CCM156 :
http://www.linuxsecurity.com.br/in [...] modem.html
La majorité des références correspondantes semblent supportées, mais par contre il ne parlent du kernel, ce qui m'inquiète. Néanmoins, il semblent confirmer que le SM56 Motorola n'est pas supporté, ce qui apporterait du crédit aux infos qu'ils annoncent, non ?


Message édité par Kortex@HFR le 05-07-2007 à 12:41:59
n°930678
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 05-07-2007 à 13:11:49  profilanswer
 

Bon, après avoir vu les photos du modem en question, et notamment celle du dos sur lequel on peut voir le numéro de série du chipset du modem, voici ce qui apparait :
5QPUSA-24948-M5-E
Hors dans le tableau du lien que j'ai posté plus haut, cette référence exacte est indiquée comme compatible. Je vais donc acheter le modem et advienne que pourra :D Par contre, si vous y voyez une quelconque contre indication, prevenez moi que j'annule la vente.

n°930679
geant_bleu
Et non vert :fou:
Posté le 05-07-2007 à 13:13:47  profilanswer
 

Non aucune contre indication, 3com est connu pour faire du matos compatible linux :jap:


---------------
34cv pour pourrir mon bandit
n°930696
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 05-07-2007 à 14:10:15  profilanswer
 

geant_bleu a écrit :

Non aucune contre indication, 3com est connu pour faire du matos compatible linux :jap:


Ah ben voila, il suffisait de le dire :D Bon, pour le moment je n'ai pas de nouvelles de mon vendeur, donc j'attends, mais j'espère qu'il va répondre vite, j'ai hâte de voir ma mère se faire les dents sur Ubuntu ;)

n°930708
geant_bleu
Et non vert :fou:
Posté le 05-07-2007 à 14:42:47  profilanswer
 

Poutre lui un fusion avec des centaines d'effets [:ddr555]
 
La mienne elle reste bloqué à windows :/ D'un coté ça me dérange pas, vu la config de xorg qu'il faudrait faire j'ai pas envie de lui mettre linux :D (2 carte ati pour 3écran [:ddr555]


---------------
34cv pour pourrir mon bandit
mood
Publicité
Posté le 05-07-2007 à 14:42:47  profilanswer
 

n°930716
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 05-07-2007 à 15:01:06  profilanswer
 

geant_bleu a écrit :

Poutre lui un fusion avec des centaines d'effets [:ddr555]

 

La mienne elle reste bloqué à windows :/ D'un coté ça me dérange pas, vu la config de xorg qu'il faudrait faire j'ai pas envie de lui mettre linux :D (2 carte ati pour 3écran [:ddr555]


Laptop Fujitsu Pi 1556, CG nVidia, Feisty est déjà installé, Fusion également, avec des effets légers pour pas qu'elle pète un plomb :whistle: En même temps, Fusion, avec le topic que je viens de monter là dessus, c'était un peu innévitable, et puis vu qu'elle ne sait rien faire avec Windows (bien qu'elle l'utilise depuis maintenant 2 ans), elle va switcher sans même s'en rendre compte en vérité :D

 

Sachant que c'est moi qui fait la maintenance derrirère, et que les MAJ d'antivirus en 56K c'est un peu la mort, c'est Ubuntu ou que dalle. Non mais...

 

Ceci dit, j'aimerai bien que mon vendeur me réponde rapidement, ma mère commence déjà à me demander si on peut pas switcher plus tard pour qu'elle puisse commencer à utiliser le portable. L'impatience pointe son nez, il va falloir agir vite pour ne pas avoir à réaliser un switch plus complexe plus tard...


Message édité par Kortex@HFR le 05-07-2007 à 15:05:08
n°933375
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 12-07-2007 à 10:39:42  profilanswer
 

Bon, j'ai un peu honte... Même complètement honte...

 

J'ai bien reçu le modem PCMCIA, mais... car il y a un mais... je n'ai pas fait attention, j'étais persuadé que le portable avait du PCMCIA et en fait il ne possède que de... l'ExpressCard ! Je ne peux donc pas le mettre dans le portable de mouman :cry: Pour le topic honte, pas besoin d'adresse, je sais où c'est ;)

 

En tout cas, je suis dégouté et ça ne résout pas mon problème de connexion. Et pour trouver un 56K en ExpressCard, bonjour... Et alors en plus compatible Linux, j'ai plus qu'à me pendre je crois.


Message édité par Kortex@HFR le 12-07-2007 à 10:40:13
n°933634
geant_bleu
Et non vert :fou:
Posté le 12-07-2007 à 23:05:19  profilanswer
 
n°933637
geant_bleu
Et non vert :fou:
Posté le 12-07-2007 à 23:09:30  profilanswer
 

Et si tu essayais avec un modem série sur un adaptateur usb ?


---------------
34cv pour pourrir mon bandit
n°933641
geant_bleu
Et non vert :fou:
Posté le 12-07-2007 à 23:14:10  profilanswer
 

Mais il faut un adaptateur compatible linux [:klemton]
 
 
http://cgi.ebay.fr/Cable-Adaptateu [...] dZViewItem
 
Voilà c'est compatible linux, après tu nous prends un modem serial (nimporte lequel, ce ne sont pas des winmodems ... reconnu d'office) et ça roule, c'est moche, mais ça fonctionne  :o

Message cité 1 fois
Message édité par geant_bleu le 12-07-2007 à 23:15:57

---------------
34cv pour pourrir mon bandit
n°933670
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 13-07-2007 à 00:39:34  profilanswer
 

geant_bleu a écrit :

Mais il faut un adaptateur compatible linux [:klemton]
 
 
http://cgi.ebay.fr/Cable-Adaptateu [...] dZViewItem
 
Voilà c'est compatible linux, après tu nous prends un modem serial (nimporte lequel, ce ne sont pas des winmodems ... reconnu d'office) et ça roule, c'est moche, mais ça fonctionne  :o


Je vais essayer de mettre ça au point, avec le soutient des assembleurs de ma contrée. Ils doivent bien avoir un adaptateur série en stock, je pourrai donc tester sur place et voir si ça fonctionne. Quelle galère quand même... C'est pas croyable d'être emmerdé à ce point avec une connexion à la con à l'heure d'ADSL.

n°933697
geant_bleu
Et non vert :fou:
Posté le 13-07-2007 à 08:52:04  profilanswer
 

Attention :/ En france un tel adaptateur vaut 30€, 10€ celui de hongkong avec les fdp, et ils fonctionnent tout aussi bien :)


---------------
34cv pour pourrir mon bandit
n°933733
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 13-07-2007 à 10:16:11  profilanswer
 

geant_bleu a écrit :

Attention :/ En france un tel adaptateur vaut 30€, 10€ celui de hongkong avec les fdp, et ils fonctionnent tout aussi bien :)


Ah ouais, chaud ! Je vais voir sur place comment ça se goupille... mais j'aimerai commencer à limiter les frais là. C'est juste une connexion RTC que je veux, j'aimerai bien que ça me coute moins cher que 2 ans d'abonnement ADSL j'ai je sais pas qui ;)

n°933874
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 13-07-2007 à 16:47:31  profilanswer
 

Une petite question : ce qui est supporté dans (par exemple) le noyau 2.4.x est-il automatiquement supporté par le noyau 2.6.x ? Parce que j'ai trouvé un adaptateur USB > Série, certifié pour les modems à partir du noyau 2.4.x, mais il ne parlent pas du 2.6.x...

n°936083
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 20-07-2007 à 20:54:48  profilanswer
 

J'ai eu une autre idée : un routeur avec une ligne de secours RTC sur port série. Problème : le seul que je trouve pour le moment, c'est un Netgear qui coûte près de 140€, c'est un peu cher. Ca existe pas en occaz ces choses là ?

n°940402
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 04-08-2007 à 16:49:10  profilanswer
 

J'ai commandé le cable en question, je l'ai reçu ce matin. J'ai pas de modem sous la main avant Lundi, mais je voulais tester si ça fonctionnait ou pas, donc j'y ai connecté une vieille souris série. Boot sous Gnome : pas de mouvement :( Est-ce parce que ça ne fonctionne pas du tout ou parce qu'il faut spécifier une souris série dans xorg.conf, je ne sais pas, mais en l'état, c'est un échec.
J'espère que ça se passera mieux avec un modem série, sinon c'est vraiment la dèche.
 
Sinon, geant_bleu, tu avais l'air de le connaitre ce cable, tu sais si il faut faire quelque chose pour qu'il fonctionne sous Linux ? La doc est innexistante sur le CD livré, et les seuls pilotes dispos sont pour Windows.


Message édité par Kortex@HFR le 04-08-2007 à 16:50:39
n°940590
enfoiro
a nickname is just a nickname
Posté le 05-08-2007 à 16:49:12  profilanswer
 

pour voir si le cable est reconnu tail -f /var/log/messages et tu connecte le cable.
normalement ca fonctionne out of the box mais parfois les revisions des chips changent et tu dois attendre un peu pour avoir le pilote.

n°940605
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 05-08-2007 à 17:57:03  profilanswer
 

enfoiro a écrit :

pour voir si le cable est reconnu tail -f /var/log/messages et tu connecte le cable.
normalement ca fonctionne out of the box mais parfois les revisions des chips changent et tu dois attendre un peu pour avoir le pilote.


Voici ce qu'il se passe lorsque je branche le cable USB>RS232 :

[342.597000] usb 4-1: new full speed USB device using uhci_hcd and address 2
[342.798000] usb 4-1: configuration #1 chosen from 1 choice


Plutôt bon ou mauvais signe ?

n°940632
enfoiro
a nickname is just a nickname
Posté le 05-08-2007 à 20:28:50  profilanswer
 

plutot mauvais signe : le périphérique est reconnu en tant que périphérique usb mais aparemment ne possède pas de driver spécifique :/
edit : au pif tu a testé modprobe pl2303, il semblerait que ca puisse marcher

 

cf ici http://www.eham.net/reviews/detail/3704

Message cité 1 fois
Message édité par enfoiro le 05-08-2007 à 20:37:42
n°940700
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 06-08-2007 à 09:46:07  profilanswer
 

enfoiro a écrit :

plutot mauvais signe : le périphérique est reconnu en tant que périphérique usb mais aparemment ne possède pas de driver spécifique :/
edit : au pif tu a testé modprobe pl2303, il semblerait que ca puisse marcher

 

cf ici http://www.eham.net/reviews/detail/3704


J'ai effectué le modprobe que tu m'as conseillé. Le résultat du tail lorsque je branche le cable (avec un modem série branché dessus cette fois) est le même que précédent à part l'adresse qui change (address 2 la première fois, address 4 la seconde, address 6 la troisième).
Ensuite, j'essaie piloter le modem depuis pppd, mais je n'arrive pas à l'identifier, ce qui peut être complètement normal si l'adaptateur USB>RS232 n'est pas pris en charge. Bref, j'ai l'impression que je ne suis pas encore connecté avec ce fichu portable...

 

Concernant le reste du lien que tu as posté, j'y jette un oeil plus tard, probablement cette aprem.


Message édité par Kortex@HFR le 06-08-2007 à 09:46:51
n°940712
enfoiro
a nickname is just a nickname
Posté le 06-08-2007 à 10:06:44  profilanswer
 

que ca change d'adresse, c'est un problème de bus usb et c'est normal.
donc ce driver ne correspond pas, puisqu'il ne reconnait toujours pas le cable.
après avoir branché le cable,
lsusb pour avoir plus d'infos
peut être essayer avec le dernier kernel.

n°940719
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 06-08-2007 à 10:28:44  profilanswer
 

enfoiro a écrit :

que ca change d'adresse, c'est un problème de bus usb et c'est normal.
donc ce driver ne correspond pas, puisqu'il ne reconnait toujours pas le cable.
après avoir branché le cable,
lsusb pour avoir plus d'infos
peut être essayer avec le dernier kernel.


Je viens de brancher le cable avec tail dans un terminal, l'adresse reçue est la 5.
lsusb renvoie la chose suivante pour l'adresse 5 :
Bus 004 Device 005: ID 4348:5523
J'en conclurai donc que le cable est bien vu, mais peut-être mal installé (le manque de pilote se confirmerai), puisque la ligne ne contient rien d'autre. Pour comparaison, le dongle RF pour la souris sans fil indique la chose suivante :
Bus 004 Device 003: ID 1020:0586 Labtec
J'imagine que si l'adaptateur RS232 était reconnu correctement, il y aurait une indication supplémentaire après cette ligne non ?

n°940725
enfoiro
a nickname is just a nickname
Posté le 06-08-2007 à 12:06:00  profilanswer
 

Kortex@HFR a écrit :


Je viens de brancher le cable avec tail dans un terminal, l'adresse reçue est la 5.
lsusb renvoie la chose suivante pour l'adresse 5 :
Bus 004 Device 005: ID 4348:5523
J'en conclurai donc que le cable est bien vu, mais peut-être mal installé (le manque de pilote se confirmerai), puisque la ligne ne contient rien d'autre. Pour comparaison, le dongle RF pour la souris sans fil indique la chose suivante :
Bus 004 Device 003: ID 1020:0586 Labtec
J'imagine que si l'adaptateur RS232 était reconnu correctement, il y aurait une indication supplémentaire après cette ligne non ?


oui mais pas nécessairement. La base de périphériques sur laquelle se base lsusb peut lister des périphériques qui n'ont pas encore de driver. Quand tu vois labtec ca veut dire que lsusb a reconnu la premiere partie de l'identifiant soit le fabricant (4348) mais il ne connait pas le modèle, cependant ton périphérique possède un pilote.
En l'occurence lsusb reconnait mal ton périphérique puisqu'il ne connait pas le modèle mais il existe un driver, tu a donc l'exemple opposé.
petite explication ici par exemple http://www.hboeck.de/plugin/tag/lsusb
C'est juste une source d'infos potentielle.

n°940747
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 06-08-2007 à 13:07:02  profilanswer
 

enfoiro a écrit :


oui mais pas nécessairement. La base de périphériques sur laquelle se base lsusb peut lister des périphériques qui n'ont pas encore de driver. Quand tu vois labtec ca veut dire que lsusb a reconnu la premiere partie de l'identifiant soit le fabricant (4348) mais il ne connait pas le modèle, cependant ton périphérique possède un pilote.
En l'occurence lsusb reconnait mal ton périphérique puisqu'il ne connait pas le modèle mais il existe un driver, tu a donc l'exemple opposé.
petite explication ici par exemple http://www.hboeck.de/plugin/tag/lsusb
C'est juste une source d'infos potentielle.


OK, merci enfoiro, j'y vois un peu plus pour ce qui est d'interpréter les résultats des commandes que tu m'as passé :) Par contre concernant ce problème de prise en charge du cable RS232 et plus généralment de connexion RTC avec ce portable, c'est toujours la merde... Pour info, le modèle de l'adaptateur est un HL-340, au cas où ça puisse aider les gens.

n°940776
enfoiro
a nickname is just a nickname
Posté le 06-08-2007 à 14:41:04  profilanswer
 

Bon j'ai fait une recherche pour toi, il semble bien que le module pl2303 convienne, cependant il ne reconnait pas ton matériel car le vendor id:product id a été changé.
Il faut que tu modifie toi même le driver pour qu'il reconnaisse le cable et ensuite si ca marche soumettre un patch à l'auteur du driver. C'est pas très dur mais il faut avoir le courage de regarder les sources du driver kernel puis le recompiler.
En effet parfois les vendeurs modifient l'identifiant du périphérique usb même s'ils utilisent un chip générique.
Références :
http://www.google.fr/search?q=usb+ [...] rt=10&sa=N
http://www.gossamer-threads.com/li [...] ist=mythtv
http://www.nslu2-info.de/showthread.php?p=26027
http://forums.gentoo.org/viewtopic [...] c189786bad  <- la + importante

 

edit essaie aussi le dernier kernel

Message cité 1 fois
Message édité par enfoiro le 06-08-2007 à 15:23:22
n°940802
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 06-08-2007 à 16:01:09  profilanswer
 

enfoiro a écrit :

Bon j'ai fait une recherche pour toi, il semble bien que le module pl2303 convienne, cependant il ne reconnait pas ton matériel car le vendor id:product id a été changé.
Il faut que tu modifie toi même le driver pour qu'il reconnaisse le cable et ensuite si ca marche soumettre un patch à l'auteur du driver. C'est pas très dur mais il faut avoir le courage de regarder les sources du driver kernel puis le recompiler.
En effet parfois les vendeurs modifient l'identifiant du périphérique usb même s'ils utilisent un chip générique.
Références :
http://www.google.fr/search?q=usb+ [...] rt=10&sa=N
http://www.gossamer-threads.com/li [...] ist=mythtv
http://www.nslu2-info.de/showthread.php?p=26027
http://forums.gentoo.org/viewtopic [...] c189786bad  <- la + importante

 

edit essaie aussi le dernier kernel


Enfoiro, t'es vraiment sympa :) Par contre, je dois avouer que je l'ai un peu mauvaise quand même. Faut vraiment être stupide pour pas utiliser un product ID standard, ou vraiment avoir envie de faire chier le monde. Bref, c'est le lieu pour s'énerver, mais voila quoi.
Je vais tenter de réaliser la manipulation, mais c'est pas trop le genre de chose que je sais faire. J'y jette un oeil ce soir si j'ai le temps, sinon, je regarderai demain. Encore merci pour les liens et tout ça. :jap:

 

Sinon, pour le kernel, je suis en 2.6.20-16 lowlatency. Le fait que je ne tourne pas avec un generic peut-il avoir une influence ? Je ne vois pas trop pourquoi, mais bon, on ne sait jamais... D'autre part, si ce kernel n'est pas le dernier, il va falloir que j'attende que le plus récent déboule dans les dépôts, je n'ai pas envie de m'amuser à casser la cohérence de la distrib. :/

 

Edit :
Sinon, il y aurait pas moyen de remplacer le product ID du matos pour le forcer à porter celui que le pl2303 attend :p ? Ou de forcer une liaison entre un product ID et un pilote ?

Message cité 1 fois
Message édité par Kortex@HFR le 06-08-2007 à 16:02:29
n°940840
enfoiro
a nickname is just a nickname
Posté le 06-08-2007 à 17:07:53  profilanswer
 

Kortex@HFR a écrit :


Enfoiro, t'es vraiment sympa :) Par contre, je dois avouer que je l'ai un peu mauvaise quand même. Faut vraiment être stupide pour pas utiliser un product ID standard, ou vraiment avoir envie de faire chier le monde. Bref, c'est le lieu pour s'énerver, mais voila quoi.
Je vais tenter de réaliser la manipulation, mais c'est pas trop le genre de chose que je sais faire. J'y jette un oeil ce soir si j'ai le temps, sinon, je regarderai demain. Encore merci pour les liens et tout ça. :jap:

 

Sinon, pour le kernel, je suis en 2.6.20-16 lowlatency. Le fait que je ne tourne pas avec un generic peut-il avoir une influence ? Je ne vois pas trop pourquoi, mais bon, on ne sait jamais... D'autre part, si ce kernel n'est pas le dernier, il va falloir que j'attende que le plus récent déboule dans les dépôts, je n'ai pas envie de m'amuser à casser la cohérence de la distrib. :/

 

Edit :
Sinon, il y aurait pas moyen de remplacer le product ID du matos pour le forcer à porter celui que le pl2303 attend :p ? Ou de forcer une liaison entre un product ID et un pilote ?

 

Merci, le seul moteur ici de toute facon c'est l'entraide, pour avoir des utilisateurs de linux *heureux*, d'autant plus que tu donne pas mal de ta personne sur ce forum  :)

 

Les constructeurs de matos ne sont pas libre-compliant, c'est rien de le dire :/ Et ne nous facilitent pas la tache.

 

Installer un kernel compilé maison ne risque pas de casser ta distro, le kernel est une sorte de boite noire mais ses interfaces externes sont assez stables (API/ABI), c'est pour ca qu'on peut recompiler son kernel sans risque. De plus sous debian par exemple un certain nombres d'outils te permettent de packager toi même ton kernel en .deb à partir des sources pour qu'il s'intègre de facon harmonieuse au système de paquets. Ca doit être idem pour ubuntu, donc.

 

D'après tes posts tu es sous ubuntu et si tu veux tester avec le 2.6.22 il existe cette procédure qui utilisent des paquets "standard"
http://www.ubuntugeek.com/fr/howto [...] -fawn.html

 

Tu peux tester ces commandes mais d'après le post en allemand le résultat est foireux

 

modprobe usbserial vendor=0x4348 product=0x5523
modprobe pl2303 vendor=0x4348 product=0x5523

 

ou

 

modprobe usbserial vendor=0x4348 product=0x5523
modprobe pl2303

 

ou juste ca

 

modprobe pl2303 vendor=0x4348 product=0x5523

 

car l'interface usbserial "generique" ne permet pas de bien prendre en compte l'interface usb serie avec toutes ses particularites

 

N'ayant pas le matos sous la main je ne suis pas trop sur...

 

En gardant une console pour voir si le module se lance avec tail -f blabla comme au début

 

Voir des explications ici
http://linuxfr.org/~davB/6643.html

 

Le fait que tu sois en lowlatency ne change rien, car cela ne modifie pas les drivers mais une autre partie du kernel.

 

Si tu es tenté par la modif que j'ai donnée elle est vraiment pas compliquée : changer les valeurs vers les valeurs de ton matos dans pl2303.h
http://www.koders.com/c/fid7730B67 [...] 568DB.aspx

 

Quelques infos ici bien qu'attention cette procédure de compilation n'est pas la procédure debian standard qui passe par make-kpkg
http://gentoo-wiki.com/HOWTO_GPS_/_Microsoft_GPS-360

 

Puis recompiler le module en question.

 

Tu peux créer une règle udev pour forcer le lancement du pilote à chaque branchement du cable, si les commandes au dessus marchent, voir par exemple

 

http://www.owfs.org/index.php?page=udev

 

Oh mais excellent, cette page http://jk.ufisa.uninett.no/usb/ semble détailler un mode qui permet de changer les vendor id acceptables par un module sans recompilation ! Si c'est trop dur je t'explique la procédure.


Message édité par enfoiro le 06-08-2007 à 17:17:49
n°940859
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 06-08-2007 à 18:30:28  profilanswer
 

Oula, le post de ouf...
 
Bon, je crois qu'on progresse ! Si si, tout n'est pas tout perdu (je sais ce n'est pas français, mais bon...).
 
J'ai éxécuté les commandes suivantes :

modprobe usbserial vendor=0x4348 product=0x5523
modprobe pl2303 vendor=0x4348 product=0x5523


La première est bien passée, la seconde a provoqué une erreur, apparemment un pépin dans pl2303.ko. Néanmoins, j'ai refait le tail puis connecté le câble, voici le résultat :

[641.926000] usb 4-1: new full speed USB device using uhci_hcd and address 4
[642.076000] usb 4-1: configuration #1 chosen from 1 choice
[642.079000] usbserial_generic 4-1:1.0: generic converter detected
[642.079000]usb 4-1: generic converter now attached to ttyUSB1


En revanche, lsusb ne me renvoi rien de plus qu'avant.
Le modem branché dessus, Gnome PPP le détecte automatiquement sur /dev/ttyUSB0 et semble être en mesure de l'initialiser (j'ai les trois bips lors de la détection ou lorsque je lance la numérotation).
 
Les problèmes encore présents :
- Le modem change de tty à chaque fois que le cable RS232 est branché ou débranché. Du coup, il faut refaire une détection à chaque fois, il navigue entre ttyUSB0, ttyUSB1 ou ttyUSB2.
- La numérotation ne semble pas fonctionner. Le truc, c'est que vu que je suis en dégroupé chez Neuf, je ne sais pas si c'est ma ligne qui ne va pas pour un modem RTC ou pas (je me branche sur la prise marquée téléphonie de ma NeufBox, et mon téléphone standard fonctionne très bien dessus). Si je lance une numérotation, je n'ai pas de tonalité, le modem ne semble rien composer, les lupiotes restent éteintes, bref, rien ne semble se passer.
 
C'est donc pas encore gagné, mais j'ai l'impression que ça progresse quand même :)
 
Je vais jeter un oeil à la page qui parle de changer les vendor ID sans compilation.

n°940860
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 06-08-2007 à 18:38:39  profilanswer
 

Bon, en fait, c'est GnomePPP qui déconne, en passant par la configuration de manuelle de Network Manager, le modem est bien piloté, il numérote une fois qu'il a détecté la tonalité (preuve que la ligne fonctionne), et ensuite j'ai les bruits horribles de la connexion RTC qui s'enchainent, tout normal quoi.
Après, je crois que la connexion n'aboutit pas car il faudrait que je sois chez ma mère pour que Tiscali laisse passer la connexion (connexion liée à un numéro de téléphone ). Et tout cas, ça semble s'arranger encore un peu.
 
Edit : j'ai réussi à faire sonner mon portable avec le modem ! Donc ça a l'air de pas mal aller. Je vais essayer de rebooter pour voir comment se comporte ce cable une fois redémarrer, ou s'il il faut réexécuter le modprobe de usbserial à chaque boot.


Message édité par Kortex@HFR le 06-08-2007 à 18:40:45
n°940864
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 06-08-2007 à 18:54:28  profilanswer
 

Alors, après un boot, il faut repasser le modprobe de usbserial, sinon, il coince sur la détection de l'adaptateur. Je vais essayer de me pencher sur la page permettant de réaliser la configuration du vendor directement.
 
Une fois ceci fait, faudra que j'aille tester directement chez ma mère. Ca lui fera plaisir, son fils passe la voir :)
 
Reste donc à trouver comment :
- forcer automatiquement la détection du vendor
- forcer le montage sur le même tty systématiquement

n°940866
enfoiro
a nickname is just a nickname
Posté le 06-08-2007 à 18:57:01  profilanswer
 

Pour que l'adresse du cable ne change pas il faut créer une règle udev qui permet de définir l'interface qui va être créee en fonction du périphérique branché. Cette règle te permet de plus d'executer le bon modprobe lorsque le cable est branché. Ca c'st dans les liens.
Sinon en fait c'est normal que ca marche pas la séquence avec 2 commandes car les commandes que je t'ai donné il faut les essayer 1 à la fois et pas les deux sinon ca rentre en conflit (oops  :whistle: ) et bien décharger le module avant de tenter d'en recharger un autre après avoir débranché le cable.

 

rmmod usbserial

 

par exemple

Message cité 1 fois
Message édité par enfoiro le 06-08-2007 à 18:57:42
n°940868
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 06-08-2007 à 19:12:08  profilanswer
 

enfoiro a écrit :

Pour que l'adresse du cable ne change pas il faut créer une règle udev qui permet de définir l'interface qui va être créee en fonction du périphérique branché. Cette règle te permet de plus d'executer le bon modprobe lorsque le cable est branché. Ca c'st dans les liens.
Sinon en fait c'est normal que ca marche pas la séquence avec 2 commandes car les commandes que je t'ai donné il faut les essayer 1 à la fois et pas les deux sinon ca rentre en conflit (oops  :whistle: ) et bien décharger le module avant de tenter d'en recharger un autre après avoir débranché le cable.
 

rmmod usbserial


 
par exemple


Ah d'accord... Je comprend mieux. Maintenant que j'ai réussi à faire fonctionner le modem avec le modprobe sur usbserial, est-ce que je peux considérer que l'application du modprobe sur pl2303 en lieu et place du premier ne serait pas plus efficace ? Ou faut-il que je teste les deux pour voir celui qui fonctionne le mieux ?
 
A côté de ça, pour le moment je patauge avec l'histoire des règle udev... Mais je m'accroche, si vraiment je nage, j'appellerai à l'aide ;)

n°940869
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 06-08-2007 à 19:17:18  profilanswer
 

Sinon, il y a pas moyen d'ajouter le modprobe dans un script de démarrage pour qu'il fasse ce qu'il faut lors du boot ? Ce serait bien ça non ? :D

n°940874
Kortex@HFR
Qu'ils sont cons ces lamas !!!
Posté le 06-08-2007 à 19:45:50  profilanswer
 

En tout cas si je tiens le connard qui a changé les ID du chip chez le fabricant de mon câble, je l'émascule.

n°940880
enfoiro
a nickname is just a nickname
Posté le 06-08-2007 à 20:37:22  profilanswer
 

Kortex@HFR a écrit :

En tout cas si je tiens le connard qui a changé les ID du chip chez le fabricant de mon câble, je l'émascule.


lol
 
crée la règle udev, c'est la méthode idoine car ca permet d'éviter tout souci et c'est dynamique, ca permet le branchement/débranchement, un modprobe au boot c'est statique donc moins bien mais c'est faisable aussi

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Installation d'un adpatateur USB>RS232 HL-340

 

Sujets relatifs
installer linux sur clé USB[Résolu] script au montage d'une clé USB
Problème d'installation Ubuntu[debian etch] Pb d'écriture sur une clé USB
souris USB saccadé sous debian testingMulti boot sur cle USB
impossible d'installer le driver Thomson des Speedtouch USBinstallation d'une webcam
Installation drivers WDM impossibleInstallation Squid 2.6 stable 13
Plus de sujets relatifs à : Installation d'un adpatateur USB>RS232 HL-340


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR