Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1692 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  [Résolu] Linux et Hyperthreading

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] Linux et Hyperthreading

n°1009558
couroc
Posté le 09-02-2008 à 19:06:57  profilanswer
 

Bonsoir le forum,  
 
Est-il possible de forcer le noyau à prendre en charge l'hyperthreading si le dernier bios disponible ne le permet pas ? J'ai un soucis avec une carte mère MSI/Compaq MS-6541 reprise dans un compaq evo D310. Evidement, le bios ne permet de ne rien faire.
 
J'ai remplacé le céléron 1,7Ghz par un p4 2,8. Je me demandais, au cas ou, si il était possible de passer outre en demandant au noyau de se passer de l'avis du bios.
 
Ah, j'oubliais, le Northbridge est un 845G. J'ai essayé de passer en paramètre ht=on, ou acpismp=force, en vain.
 
Merci de vos réponses.


Message édité par couroc le 10-02-2008 à 13:31:53
mood
Publicité
Posté le 09-02-2008 à 19:06:57  profilanswer
 

n°1009669
dr-freuder​ick
Asymétrie Cognitive.
Posté le 10-02-2008 à 11:44:25  profilanswer
 
n°1009676
couroc
Posté le 10-02-2008 à 11:52:19  profilanswer
 

dr-freuderick a écrit :

ta pas de mise à jour du bios ?


 
J'ai installé la dernière disponible sur le site de compaq. La carte n'est pas répertoriée par MSI.  
 
J'ai trouvé cette page sur google :
http://h18002.www1.hp.com/products [...] 8_div.HTML
 
NOTE: Hyperthreading Support - Systems shipped after February 1st, 2003 will include support for Hyperthreading. To take advantage of Hyperthreading, the system must be configured with a minimum processor speed of 3.06GHz.
 
Ça me parait louche. 3,06 c'est le dernier processeur supporté par cette carte mère (elle supporte pas les p4 sur bus 800Mhz)  :/
 
Merci de ton aide.


Message édité par couroc le 10-02-2008 à 16:09:26
n°1009696
couroc
Posté le 10-02-2008 à 12:10:48  profilanswer
 

Ah, j'oubliais, dans mon dmesg, j'ai une erreur acpi étrange.


ACPI: Processor [CPU0] (supports 8 throttling states)
ACPI Exception (processor_core-0816): AE_NOT_FOUND, Processor Device is not present [20070126]


 
Comme si j'avais oublié de mettre le processeur  :lol: (noyal 2.4.24).

n°1009699
couroc
Posté le 10-02-2008 à 12:19:46  profilanswer
 

Ah oui, autre point important, mon noyal supporte bien le smp, évidement.
 


houblon:/home/xof# uname -a
Linux houblon 2.6.24-1-686 #1 SMP Wed Feb 6 15:20:27 UTC 2008 i686 GNU/Linux


 

n°1009702
Zogzog4
Posté le 10-02-2008 à 12:23:49  profilanswer
 

couroc a écrit :

Ah oui, autre point important, mon noyal supporte bien le smp, évidement.
 


houblon:/home/xof# uname -a
Linux houblon 2.6.24-1-686 #1 SMP Wed Feb 6 15:20:27 UTC 2008 i686 GNU/Linux


 


Non seulement il supporte bien le SMP, mais il est activé. Par conséquent, l'hyperthreading me semble bien activé...
Si ce n'était pas le cas, le même noyau n'afficherait pas SMP.


---------------

n°1009703
couroc
Posté le 10-02-2008 à 12:31:56  profilanswer
 

Zogzog4 a écrit :


Non seulement il supporte bien le SMP, mais il est activé. Par conséquent, l'hyperthreading me semble bien activé...
Si ce n'était pas le cas, le même noyau n'afficherait pas SMP.


 
J'ai à côté de moi un celeron M qui ne fait pas hyperthreading et le tag SMP est lui aussi affiché dans le uname [:aloy]
 


root@brasserie:/root# uname -a
Linux brasserie 2.6.24-1-686 #1 SMP Thu Jan 31 20:35:50 UTC 2008 i686 GNU/Linux
root@brasserie:/root# cat /proc/cpuinfo  
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 9
model name      : Intel(R) Celeron(R) M processor         1300MHz
stepping        : 5
cpu MHz         : 1295.821
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe up bts
bogomips        : 2593.61
clflush size    : 64


 
Les mêmes commandes, sur la machine sur laquelle je souhaite activer l'hyperthreading :

houblon:/home/xof# uname -a  
Linux houblon 2.6.24-1-686 #1 SMP Wed Feb 6 15:20:27 UTC 2008 i686 GNU/Linux
houblon:/home/xof# cat /proc/cpuinfo  
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.80GHz
stepping        : 9
cpu MHz         : 2790.133
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe up pebs bts sync_rdtsc cid xtpr
bogomips        : 5584.95
clflush size    : 64
 


 
En plus on voit le flag ht, comme quoi, le processeur le supporte bien. Sur les machines ou le bousin est activé, on voit dans le /proc/cpuinfo deux processeurs.


Message édité par couroc le 10-02-2008 à 12:33:15
n°1009707
couroc
Posté le 10-02-2008 à 12:39:56  profilanswer
 

Pour illustrer mes propos, voici un uname et un /proc/cpuinfo sur une P4P800-X avec un p4 3Ghz dont l'hyperthreading est activé :

kangourou:~# uname -a
Linux kangourou 2.6.22-3-686 #1 SMP Mon Nov 12 08:32:57 UTC 2007 i686 GNU/Linux
kangourou:~# cat /proc/cpuinfo  
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 3
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping        : 4
cpu MHz         : 3000.003
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc pni monitor ds_cpl cid xtpr
bogomips        : 6004.04
clflush size    : 64
 
processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 3
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping        : 4
cpu MHz         : 3000.003
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc pni monitor ds_cpl cid xtpr
bogomips        : 5999.78
clflush size    : 64


Message édité par couroc le 10-02-2008 à 12:41:23
n°1009720
couroc
Posté le 10-02-2008 à 13:03:27  profilanswer
 

Erratum, je suis tombé sur ce lien thread :
http://linuxfr.org/comments/748541.html#748541
Il y est dit que le kernel linux met le flag HT à tout les pentium 4. [...] C'est normal, l'HT était supporté depuis les premiers, mais pas actif (merci les microcodes).
 
Et sur cet autre lien
http://developer.intel.com/design/ [...] 298643.htm
2 GHz — 3.40 GHz Frequencies Supporting Hyper-Threading Technology† at 3.06 GHz with 533 MHz System Bus and All Frequencies with 800 MHz System Bus
 
Mon processeur serait donc hyperthreading capable, mais non activé !? Il semble effectivement que seul le 3,06Ghz permet de disposer de l'hyperthreading sur bus 533Mhz ! Contrairement aux 2,8Ghz sur bus 800 qui, eux, le supportent. Vive le marketing.


Message édité par couroc le 10-02-2008 à 18:05:09
n°1009727
couroc
Posté le 10-02-2008 à 13:20:22  profilanswer
 

Je crois qu'on va pouvoir marquer ce topic résolu.
 
Ici, c'est écrit noir sur blanc :
http://developer.intel.com/product [...] g_more.htm
Intel® Pentium® 4 processors supporting Hyper-Threading Technology:
* 800 MHz system bus: 3.80 GHz, 3.60 GHz, 3.40 GHz, 3.20 GHz, 3 GHz, 2.80 GHz
* 533 MHz system bus: 3.06 GHz

 
Tous les p4 disposent du flag HT. Je pensais que le problème venait de la carte mère (elle m'en a fait voir des vertes et des pas mûres), il ne m'est même pas venu à l'esprit que celà pouvait venir du processeur.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  [Résolu] Linux et Hyperthreading

 

Sujets relatifs
Kubuntu 7.10 Pb Audio Asus Z53JM-AP016H [RESOLU][résolu] probleme eth* debian : help svp
emacs et la touche alt en mode console (linux)Thumbnail video Linux
Démon PHP sous Linux[Résolu] [Apache 2] Délai d'attente dépassé
[RESOLU][Dell] 5 partitions préinstallée , dual boot impossible ?problemen échange linux/windows
Linux sait plus compter ?Mini-boitiers et Linux: l'invasion a déjà commencée.
Plus de sujets relatifs à : [Résolu] Linux et Hyperthreading


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR