Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1068 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Ecran et/ou carte graphique qui ne démarrent pas sous Linux

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Ecran et/ou carte graphique qui ne démarrent pas sous Linux

n°1449668
Ze_Fab
Posté le 28-05-2020 à 15:30:30  profilanswer
 

Bonjour à tous
 
Je viens vers vous car j'ai un problème que je n'arrive pas à résoudre. Sur le PC de mon fils, je viens de changer sa vieille 750 Ti par une RX 570 moins vieille. Tout fonctionne parfaitement sous Windows. Sous Linux impossible de démarrer, j'ai le menu grub qui s'affiche puis plus rien. J'ai pu me connecter en ssh, preuve que le PC fonctionne, mais rien à l'écran. Aucune erreur dans le dmsg ni dans le log du xorg. Alors que fonctionnait parfaitement avec la 750 Ti, son système est une majaro en 64bit mise à jour il y a 2-3 jours, avec le dernier kernel. J'ai essayé de booter sur clé USB : ubuntu 20.04, 18.04, manjaro (la dernière), linux mint 19.3, fedora (la dernière). Même résultat, je vois le menu de démarrage, puis plus rien, et rien n'indique que le PC ait planté. Honnêtement, je ne sais plus quoi faire. J'ai testé en branchant en DVI au lieu de HDMI, pareil.La carte mère est une Gigabyte basée sur un Z77 avec un 3770K, 8 Go de ram qui ont été plus que testé avec memtest. Sous Windows, tout est normal, les benchs graphiques ou systèmes renvoient des résultats qui sont cohérents avec le matos, ce qui permet de penser que la carte graphique et la carte mère fonctionnent correctement.
Si quelqu'un a une idée, je suis preneur.
Merci de votre aide.

mood
Publicité
Posté le 28-05-2020 à 15:30:30  profilanswer
 

n°1449669
memaster
ki a volé mon 62?
Posté le 28-05-2020 à 16:00:52  profilanswer
 

750 ti = nvidia
RX 570 = AMD radeon.
 
il faut booter en rescue et virer le pilote proprio nvidia.


---------------
ma conduite intérieure .:R | memaster pilote officiel de la HFR Badoit-Auchan F1 Team | zéro tracas, zéro blabla MMa.ster
n°1449670
Ze_Fab
Posté le 28-05-2020 à 16:50:40  profilanswer
 

J'ai viré le pilote nvidia dans le xorg.conf, et puis ça n'explique pas pourquoi je ne peux pas booter avec une clé d'install ....

n°1449671
memaster
ki a volé mon 62?
Posté le 28-05-2020 à 17:06:13  profilanswer
 

Ze_Fab a écrit :

J'ai viré le pilote nvidia dans le xorg.conf, et puis ça n'explique pas pourquoi je ne peux pas booter avec une clé d'install ....


ce n'est pas ce qu'il fallait faire :non:  
 
si le paquet pour radeon n'est pas installé + xorg-server, il ne reconnaitra pas la carte automatiquement.
et donc ton écran restera noir. il faut booter en rescue et désintaller proprement le pilote nvidia,
cela virera également le module kernel concerné...
 
si ta clef d'install ne boot pas, regarde l'ordre de demarrage dans le bios ;)
 
tu peux également vérifier que l'alim soit suffisante pour bien alimenter la carte.
sous windows, il utilise peut etre un pilote générique et tu ne vois pas forcément la différence. [:blessure]


Message édité par memaster le 28-05-2020 à 17:08:53

---------------
ma conduite intérieure .:R | memaster pilote officiel de la HFR Badoit-Auchan F1 Team | zéro tracas, zéro blabla MMa.ster
n°1449673
Ze_Fab
Posté le 28-05-2020 à 17:09:05  profilanswer
 

Je me suis mal exprimé pour la clé d'install, elle démarre, menu habituel, puis écran noir au bout de quelques instants.

n°1449674
memaster
ki a volé mon 62?
Posté le 28-05-2020 à 17:12:53  profilanswer
 

voici ce que donne ma config

Code :
  1. #lsmod | grep nvidia
  2. nvidia_uvm            757760  0
  3. nvidia_drm             45056  3
  4. nvidia_modeset       1056768  7 nvidia_drm
  5. nvidia              14655488  278 nvidia_uvm,nvidia_modeset
  6. drm_kms_helper        172032  1 nvidia_drm
  7. drm                   401408  6 drm_kms_helper,nvidia_drm
  8. ipmi_msghandler        53248  2 ipmi_devintf,nvidia


si ces modules chargent encore pour ton ex-nvidia, il y a conflit. [:blessure]  
il faut vraiment que tu ailles en mode rescue pour virer les paquets nvidia proprio
avant de faire autre chose.


---------------
ma conduite intérieure .:R | memaster pilote officiel de la HFR Badoit-Auchan F1 Team | zéro tracas, zéro blabla MMa.ster
n°1449675
memaster
ki a volé mon 62?
Posté le 28-05-2020 à 17:16:05  profilanswer
 

#apt-get remove --purge nvidia*
 
si ton écran reste noir, tu peux acceder à une console aussi
avec alt+F1
 
ensuite passer en root ou faire des sudo avec l'utilisateur par defaut


---------------
ma conduite intérieure .:R | memaster pilote officiel de la HFR Badoit-Auchan F1 Team | zéro tracas, zéro blabla MMa.ster
n°1449676
Ze_Fab
Posté le 28-05-2020 à 17:24:21  profilanswer
 

Quand je fais un lsmod | grep nvidia, je n'ai rien.
 
Le Alt+F1 ne fonctionne pas.
 
Je ne peux me connecter à mon PC qu'à distance en ssh.

n°1449677
Trit'
Posté le 28-05-2020 à 17:35:50  profilanswer
 

memaster a écrit :

#apt-get remove --purge nvidia*


Il est sur Manjaro, pas Ubuntu : la commande serait plutôt :

 

# pacman -Rs nvidia


(Enfin, pour être sûr du nom du paquet, faire un « pacman -Qq | grep nvidia » avant).

 
Ze_Fab a écrit :

Le Alt+F1 ne fonctionne pas.


Et Alt-F2 à F6 non plus ?


Message édité par Trit' le 28-05-2020 à 17:36:51
n°1449678
Ze_Fab
Posté le 28-05-2020 à 17:50:14  profilanswer
 

Alt + F? non plus .......
 
Le paquet nvidia est supprimé, mais même avant, il ne se chargeait pas ..... Cela n'explique pas pourquoi toutes les clés USB en install calent systématiquement ..... J'ai aussi essayé une debian 10 en netinstall, tout se déroule bien, et lors du reboot, même chose .......

mood
Publicité
Posté le 28-05-2020 à 17:50:14  profilanswer
 

n°1449679
Ze_Fab
Posté le 28-05-2020 à 17:51:31  profilanswer
 

Apparament, je ne suis pas le seul à avoir ce souci ...
 
https://bugs.launchpad.net/ubuntu/+ [...] ug/1837945

n°1449680
memaster
ki a volé mon 62?
Posté le 28-05-2020 à 18:37:17  profilanswer
 

Ze_Fab a écrit :

Apparament, je ne suis pas le seul à avoir ce souci ...
 
https://bugs.launchpad.net/ubuntu/+ [...] ug/1837945


il aurait pas une carte graphique intégrée ce PC? et dans ce cas blacklisté le module correspondant?


---------------
ma conduite intérieure .:R | memaster pilote officiel de la HFR Badoit-Auchan F1 Team | zéro tracas, zéro blabla MMa.ster
n°1449681
Ze_Fab
Posté le 28-05-2020 à 18:48:57  profilanswer
 

Il y a un chip graphique intégré au CPU, un 3770K, mais la carte mère ne semble pas le gérer puisqu'il n'y a pas de connectique sur la carte mère. De plus, je n'avais ce souci là avec la 750 ti.
 
Mais effectivement, il se peut que cela arrive, je ne sais pas comment voir cela.

n°1449690
Mjules
Modérateur
Parle dans le vide
Posté le 28-05-2020 à 23:12:50  profilanswer
 

pour tester, si tu démarres avec l'option noyau nomodeset au boot, tu vois quelque chose ? (ça désactive le kernel mode setting)

 

https://en.opensuse.org/SDB:Nomodes [...] _Obstacles


Message édité par Mjules le 28-05-2020 à 23:13:02

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1449703
Ze_Fab
Posté le 29-05-2020 à 13:17:51  profilanswer
 

nomodeset ne change rien.
 
Par contre, j'ai testé avec une linux mint en compatibility mode, j'ai pu faire l'install et cela a fonctionné lors du reboot et aussi après le reboot de la mise à jour. Je ne comprends pas ce qui bloque, mais en tout cas j'ai une mint 19.3 dessus. Dommage que la 20.0 ne soit pas encore sortie.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Ecran et/ou carte graphique qui ne démarrent pas sous Linux

 

Sujets relatifs
Choix de passer à linux ? (GPU Pas..., Shadow)[GNU/Linux][Debain] Problème de path entre console et xterm
Pb resolution écran KUBUNTU dans vbox[LINUX] Extraire les lignes d'un fichier à partir d'un champ avec grep
Installer Linux sans le mot de passe BIOS[Noob] java et Linux...
Retrouver dans le code linux un paramètre issu de sysctlLinux Live et monter disques SSD NTFS
Clé USB Linux Live refuse de booterPuis-je démonter la carte graphique après l'installation?
Plus de sujets relatifs à : Ecran et/ou carte graphique qui ne démarrent pas sous Linux


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR