Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1483 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  Plantage Régulier : incompatibilité : RS480 / Nvidia - Résolu !

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

Plantage Régulier : incompatibilité : RS480 / Nvidia - Résolu !

n°885147
dr-freuder​ick
Asymétrie Cognitive.
Posté le 08-02-2007 à 17:31:47  profilanswer
 

Bonjour,
 
Le problème que je vais vous évoquer se passe sous gentoo, mais j'avais également les mêmes sous Ubuntu.
 
Ma machine planté régulièrement. C'est aléatoire, mais défois je peux redemarrer la machine toutes les 5 minutes. IL s'agit de freeze, de perte d'écran (devient noir).  
 
Mon materiels :
 
Athlon X2 4200
Carte ASUS M8V-MRP
Geforce 7300 GS
1 go de ram
/ & /home en Reiserfs
 
Après avoir fait une serie de test, j'ai cru voir que c'était xorg qui plantait tout le temps sans trop savoir pourquoi (que ça soit en x86 ou en amd64). J'ai bien cru que c'était la configuration SATA, mais c'est pas le cas. Voir même, le drivers ethernet qui est dépréciated... et meme un instant j'ai cru que ct folding@home qui provoquait ces plantage, puis ensuite flash, puis mplayer etc..
 
Mais le sys ne plante pas quand je lance pas GDM/GNOME donc ça ne peut pas être ça, et a force de déduction j'en suis quasiment sur.
 
Les freeze sont les plus fréquent :
- quand je lis de vidéos
- quand j'utilise la roulette de la souris (avec firefox toussa)
- quand Beryl se lance (je le lance donc plus)
- defois au demarrage meme de gdm (blocage)
- lorsque je laisse la machine sans activité (je suppute que que xscreensaver fait quelque chose - mais j'ai pas l'impression que ça se lance)
 
Donc je pense réellement que j'ai un soucis avec xorg. Mais ou ? que ça soit en stable ou pas, ça deconne. Je peux pas utiliser ma machine plus de 15 minutes en moyenne, et ça devient très emmerdant...
 
Si vous aviez des idées, je vous en serait extrèmement reconnaissant !
 
Update
 
Il s'agirait selon les forums qui recoupent mes configurations et mes problèmes, d'une incompatibilité entre le chipset RS480 et Nvidia (en l'occurence la mienne : une 7300 GS)


Message édité par dr-freuderick le 04-08-2007 à 12:39:19

---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
mood
Publicité
Posté le 08-02-2007 à 17:31:47  profilanswer
 

n°885149
dr-freuder​ick
Asymétrie Cognitive.
Posté le 08-02-2007 à 18:14:55  profilanswer
 
n°885150
j_c_p
Linux user
Posté le 08-02-2007 à 18:21:59  profilanswer
 

Ça peut aussi être un souci matériel, genre ton alimentation, de la mémoire.


Message édité par j_c_p le 08-02-2007 à 18:22:44
n°885156
dr-freuder​ick
Asymétrie Cognitive.
Posté le 08-02-2007 à 18:42:51  profilanswer
 

L'ordi est neuf.
 
Aucun soucis sous windows.. :(


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°885162
j_c_p
Linux user
Posté le 08-02-2007 à 19:06:25  profilanswer
 

Oui, enfin, ça dépend ce que tu fais sous Windows avec aussi (pas la même solicitation quoi). En tout cas, un matos défectueux l'est souvent tout au début.
 
Sinon, tu devrais donner plus de renseignement (noyau notamment, car il y a eu des soucis de corruption de données jusqu'au 2.6.19.2 exclu).
 
Bref, il est nécessaire que ton système soit à jour aussi (et je te conseillerai aussi un noyau Vanilla pour être sûr que certains patchs additifs ne soient pas en cause).
 
nb : je te conseille de cocher le timer haute précision dans le noyau (je n'ai plus le nom en tête, mais c'est dans les dernières mises à jour), car cela joue sur un double coeur.
 
nb2 : je peux te donner mon fichier .config pour le 2.6.20 si tu veux (faudrait mettre le smp aussi :D, et quelques options si tu n'es pas en Nforce4).

n°885181
dr-freuder​ick
Asymétrie Cognitive.
Posté le 08-02-2007 à 20:00:44  profilanswer
 

avec plaisir pour le fichier de conf.
 
Au niveau noyau, je suis toujours en 2.6.18 (le stable amd64), high timer je regarderai.  
 
Je suis sous Xpress 200 de ati !


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°885185
j_c_p
Linux user
Posté le 08-02-2007 à 20:08:24  profilanswer
 
n°885187
dr-freuder​ick
Asymétrie Cognitive.
Posté le 08-02-2007 à 20:11:14  profilanswer
 

c'est un conf de vanilla ?


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°885189
j_c_p
Linux user
Posté le 08-02-2007 à 20:12:04  profilanswer
 

Oui ;).

n°885275
dr-freuder​ick
Asymétrie Cognitive.
Posté le 09-02-2007 à 08:26:02  profilanswer
 

Je comprend plus trop qu'est ce qu'il vaut mieux préférer, vanilla ou gentoo sources ?


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
mood
Publicité
Posté le 09-02-2007 à 08:26:02  profilanswer
 

n°885322
Mjules
Modérateur
Parle dans le vide
Posté le 09-02-2007 à 10:34:33  profilanswer
 

quand ça freeze, tu peux accéder à la machine en ssh ?
 
pilotes libres ou proprio ?


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°885337
memaster
ki a volé mon 62?
Posté le 09-02-2007 à 11:05:43  profilanswer
 

tu voudrais pas essayer un autre wm? :??:  
au hasard xfce :o

n°885338
wedgeant
Da penguin inside
Posté le 09-02-2007 à 11:09:43  profilanswer
 

memaster a écrit :

tu voudrais pas essayer un autre wm? :??:  
au hasard xfce :o


Fluxbox !!!!
[:dawa_neowen]

Spoiler :

ben quoi, on est bien vendredi non ?


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°885348
dr-freuder​ick
Asymétrie Cognitive.
Posté le 09-02-2007 à 11:38:38  profilanswer
 

J'ai les drivers non libre de nvidia.
 
ça plante plus trop depuis que j'ai enlever omitdga dans xorg.conf, mais en meme temps j'essaye de mettre le kernel vanilla (j'ai un kernel panic, il reconnait pas ma partition de boot).


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°885361
j_c_p
Linux user
Posté le 09-02-2007 à 12:39:46  profilanswer
 

Pour le noyau vanilla, il suffit juste d'ajouter ton contrôleur, rien de plus (reiserfs et ext3 sont déjà activés).

n°885380
arghbis
salops de dauphins
Posté le 09-02-2007 à 13:54:30  profilanswer
 

avant de tester les soft, tu as testé la ram (avec un memtest?). Car "ça plante pas sous windows" n'est pas un argument valide pour dire qu'un matos est stable

 

Ensuite, Si ce n'est pas la ram, ça peut être une défaillance de la carte graphique. Regarde si la quantité de mémoire associée au GPU est correctement détectée. Essaye aussi, si possible, une autre carte.

 

bon courage :hello:


Message édité par arghbis le 09-02-2007 à 13:54:42
n°885399
THRAK
- THR4K -
Posté le 09-02-2007 à 14:35:25  profilanswer
 

Comme on te l'a dit, s'il doit y avoir des problèmes, c'est souvent dès le départ avec du matos neuf: pas encore vraiment rôdé, rapidement testé en usine par le constructeur mais sans plus... Seul des tests approfondis ou un usage poussé permettent de se rendre compte de défauts d'usine.
 
À chaque fois que j'achète une bécane neuve, j'utilise d'abord plusieurs utilitaires (dont ceux fournis par le constructeur, par ex. avec Dell) pour vérifier si tout à l'air normal ; puis après je lance des benchs en boucle pour la faire tourner à fond pendant 24h (cpuburn, glxgears, etc.).
 
Idéal pour bien rôder le matos et voir s'il y a le moindre soucis ; si la bécane tiens le choc alors je sais que je serais tranquille pour quelques années (normalement ) :D  
 
 
Le dénominateur commun entre toutes les applications que tu cites c'est lors d'opérations qui implique une charge élevé pour le CPU et la carte vidéo, voire l'alimentation. Soit le CPU ou la carte vidéo est mal ventilé/surchauffe, soit l'alim ne délivre pas un ampérage suffisant lors de fortes charges. Éventuellement ça pourrait aussi venir d'un driver proprio foireux comme Nvidia ou Ati savent si bien les faire.
 
Donc : vire les drivers foireux et refais des tests, si ça plante toujours essayes avec une autre alim, puis une autre carte vidéo et enfin un autre processeur ; surveille aussi la chauffe des composants.
 


---------------
THRAK (def.) : 1) A sudden and precise impact moving from intention, direction and commitment, in service of an aim. 2) 117 guitars almost striking the same chord simultaneously.
n°885496
yuggoth
Plus optimiste que jamais...
Posté le 09-02-2007 à 19:43:46  profilanswer
 

J'ai eu ce genre de problème dans les situations suivantes:
- CPU overclocké (même un tout petit peu et sans impact sous windows)
- surchauffe du GPU lors de l'utilisation des fonctions 3D (ventillo un peu faible)


---------------
A la limite du bon goût sans jamais y tomber
n°885570
mikala
Souviens toi du 5 Novembre...
Posté le 10-02-2007 à 01:19:21  profilanswer
 

et sans les drivers proprio cela plante autant ?


---------------
Intermittent du GNU
n°885779
dr-freuder​ick
Asymétrie Cognitive.
Posté le 11-02-2007 à 00:55:09  profilanswer
 

Je suis pas chez moi en ce moment, mais les drivers nv n'arriver pas afficher quelque chose de visible la dernière fois que j'ai esssayé.


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°886143
dr-freuder​ick
Asymétrie Cognitive.
Posté le 12-02-2007 à 22:19:59  profilanswer
 

J'ai fait un test de memtest et ça n'a rien donné.
 
Ce dont je suis quasiment sur c'est que ça vient de l'acceleration 3D/open gl. Beryl plante, quand je met en AIGLX ça plante, la lecteur video faisait planter. Je suppose que la navigation web via firefox peut faire appel a de l'opengl.
 
Bien sur ce n'est pas sur sur mais ça temps.
 
Pour la temperature du GPU, elle est stable selon nvidia-settings... a 49°


Message édité par dr-freuderick le 12-02-2007 à 22:20:31

---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°886145
dr-freuder​ick
Asymétrie Cognitive.
Posté le 12-02-2007 à 22:26:10  profilanswer
 
n°886197
arghbis
salops de dauphins
Posté le 13-02-2007 à 10:21:14  profilanswer
 

avec un livecd genre kororoa (avec beryl+nvidia proprio), ça plante ou pas?

n°886199
memaster
ki a volé mon 62?
Posté le 13-02-2007 à 10:25:35  profilanswer
 

dr-freuderick a écrit :

glxgears plante également.


ça c'est une decouverte qui confirme ton pb avec ta CG, reste à savoir si c'est soft ou hard.
peut on tester la ram de la CG?

n°886294
dr-freuder​ick
Asymétrie Cognitive.
Posté le 13-02-2007 à 15:42:18  profilanswer
 

Je me demandais,
 
Dans cat /proc/driver/nvidia/registry , il me dit enable aliagp=0 alors que j'ai un truc ALI. C'est normal ?
 
J'ai relancé glxgears après quelques modif, ça semble ne plus planter sur l'instant. Par contre beryl freeze complètement mon système. Comme les plantage sont assez intermittent je peux rien prévoir
 
EDIt : juste après ce post, glxgears (ou autre chose ... :() a fait écran noir, plus de freeze... galère


Message édité par dr-freuderick le 13-02-2007 à 15:42:44

---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°886297
memaster
ki a volé mon 62?
Posté le 13-02-2007 à 15:50:42  profilanswer
 

tu peux aussi regarder du côté souris+clavier :??:

n°886326
j_c_p
Linux user
Posté le 13-02-2007 à 18:57:27  profilanswer
 

Hum, chez moi, j'ai un truc du genre :

Citation :

jcp@phoenix64 ~ $ cat /proc/driver/nvidia/registry
VideoMemoryTypeOverride: 1
EnableVia4x: 0
EnableALiAGP: 0
NvAGP: 3
ReqAGPRate: 15
EnableAGPSBA: 0
EnableAGPFW: 0
SoftEDIDs: 1
Mobile: 4294967295
ResmanDebugLevel: 4294967295
FlatPanelMode: 0
DevicesConnected: 0
RmLogonRC: 1
VbiosFromROM: 0
ModifyDeviceFiles: 1
DeviceFileUID: 0
DeviceFileGID: 0
DeviceFileMode: 438
RemapLimit: 0
UseCPA: 4294967295
DetectPrimaryVga: 1
SaveVBios: 0
EnableBrightnessControl: 0
PanelPWMFrequency: 1018
PanelBrightnessLimits: 65280
UseVBios: 1
RMEdgeIntrCheck: 1
jcp@phoenix64 ~ $ cat /proc/driver/nvidia/cards/0
Model:           GeForce 7900 GTO
IRQ:             18
Video BIOS:      05.71.22.39.09
Card Type:       PCI-E
DMA Size:        39 bits
DMA Mask:        0x7fffffffff

n°886540
dr-freuder​ick
Asymétrie Cognitive.
Posté le 14-02-2007 à 14:06:28  profilanswer
 

Et moi :  
 

Citation :

localhost frederick # cat /proc/driver/nvidia/registry  
VideoMemoryTypeOverride: 1
EnableVia4x: 0
EnableALiAGP: 0
NvAGP: 3
ReqAGPRate: 15
EnableAGPSBA: 0
EnableAGPFW: 0
SoftEDIDs: 1
Mobile: 4294967295
ResmanDebugLevel: 4294967295
FlatPanelMode: 0
DevicesConnected: 0
RmLogonRC: 1
VbiosFromROM: 0
ModifyDeviceFiles: 1
DeviceFileUID: 0
DeviceFileGID: 0
DeviceFileMode: 438
RemapLimit: 0
UseCPA: 4294967295
DetectPrimaryVga: 1
SaveVBios: 0
EnableBrightnessControl: 0
PanelPWMFrequency: 1018
PanelBrightnessLimits: 65280
UseVBios: 1
RMEdgeIntrCheck: 1
localhost frederick # cat /proc/driver/nvidia/cards/0
Model:           GeForce 7300 GS
IRQ:             18
Video BIOS:      05.72.22.34.00
Card Type:       PCI-E
DMA Size:        39 bits
DMA Mask:        0x7fffffffff


Message édité par dr-freuderick le 14-02-2007 à 14:07:14

---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°886742
esox_ch
Posté le 15-02-2007 à 07:52:05  profilanswer
 

Salut,
 
J'ai un problème similaire avec ma sid x64 ...
Si je mets les drivers proprio d'ati et après le lance totem/vlc/xine ça freeze .. Impossible de rebasculer en console ou de faire planter xorg .. Par contre je peux toujours rebooter avec le ctrl-alt-b...

n°886745
dr-freuder​ick
Asymétrie Cognitive.
Posté le 15-02-2007 à 08:29:54  profilanswer
 

cette combi ne marche pas avec moi (ctrl alt back)


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°886753
esox_ch
Posté le 15-02-2007 à 09:15:25  profilanswer
 

c'est pas ctrl-alt-back mais ctrl-alt-b, essaie en console. tu fais un ctrl-alt-print_screen , ça va t'afficher une liste de commandes (remount d'urgence, reboot,...) et ctrl-alt-b equivaut à reboot

n°886823
arghbis
salops de dauphins
Posté le 15-02-2007 à 11:45:21  profilanswer
 

perso, je préfères s, puis u puis b (sync, umount, boot). C'est plus prudent

n°887740
dr-freuder​ick
Asymétrie Cognitive.
Posté le 18-02-2007 à 22:46:21  profilanswer
 

aucun d'eux ne marche chez moi...
 
et puis je sais pas si ça peut avoir un rapport mais gdmsetup refuse de lancer.
 
En console, je tape gdmsetup, et rien ne se passe.


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°891517
dr-freuder​ick
Asymétrie Cognitive.
Posté le 01-03-2007 à 22:16:09  profilanswer
 

J'ai  
 

Citation :

localhost frederick # cat /proc/interrupts  
           CPU0       CPU1        
  0:        840     147402   IO-APIC-edge      timer
  1:          0          2   IO-APIC-edge      i8042
  8:          0          0   IO-APIC-edge      rtc
  9:          0          0   IO-APIC-fasteoi   acpi
 12:          0          4   IO-APIC-edge      i8042
 14:          1        479   IO-APIC-edge      ide0
 17:         16       4092   IO-APIC-fasteoi   ohci_hcd:usb2
 18:         18      11739   IO-APIC-fasteoi   ohci_hcd:usb3, nvidia, EMU10K1
 19:         17      12738   IO-APIC-fasteoi   libata, ohci_hcd:usb4
 21:         10        668   IO-APIC-fasteoi   eth0
 23:          3        667   IO-APIC-fasteoi   ehci_hcd:usb1
NMI:        224        150  
LOC:     148111     148035  
ERR:          0


 
J'ai lu que partager la carte graphique en IRQ pose bcp de problème surtout avec les cartes emu10k1. comment mettre l'irq de nvidia seule ?


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°891522
enfoiro
a nickname is just a nickname
Posté le 01-03-2007 à 22:36:38  profilanswer
 

ton plantage semble venir de la carte graphique.
 
Il faudrait tester avec une autre carte graphique, un livecd qui comprend les drivers nvidia.
 
distinguer le souci si il est matériel ou logiciel. es ce que glxgears marche en mode software (sans driver proprio) ? glxgears sur un livecd avec le kernel patche nvidia proprio: ca marche ?
 
+1 pour la possibilité d'un souci matériel non visible sous windows.
 
Faire un bench sous windows avec 3dmark par exemple, si la carte graphique a un souci ca devrait se voir dans ce genre de test.
Comme l'a dit thr4k, il faudrait tester le cpu avec cpuburn, avec un livecd mais aussi avec ton systeme.
 
bon courage.

n°891544
dr-freuder​ick
Asymétrie Cognitive.
Posté le 01-03-2007 à 23:39:20  profilanswer
 

tu as un livecd en particulier ?


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
n°891547
enfoiro
a nickname is just a nickname
Posté le 01-03-2007 à 23:46:06  profilanswer
 

je ne connais que celui-la mais il doit en exister d'autres, celui la est en 32bits
http://www.games-knoppix.org/

n°891554
bimon
Posté le 02-03-2007 à 00:41:43  profilanswer
 

T'as essayé de désactivier l'acpi ?? Je me souviens que j'avais un peu le même problême sur mes premières distrib quand le support du nforce2 était pas tout à fait au point.... En tout cas tu peux toujours essayer, ilsuffit de passer les options "noapic", "nolapic" et "acpi=no" au noyau.
bon courage.

n°891609
Combi_A_Ve​ndre
Posté le 02-03-2007 à 10:10:59  profilanswer
 

J'avais le même genre de problème :
http://forum.hardware.fr/hfr/Hardw [...] 3735_1.htm
 
vw.

n°892237
dr-freuder​ick
Asymétrie Cognitive.
Posté le 05-03-2007 à 09:49:31  profilanswer
 

bimon a écrit :

T'as essayé de désactivier l'acpi ?? Je me souviens que j'avais un peu le même problême sur mes premières distrib quand le support du nforce2 était pas tout à fait au point.... En tout cas tu peux toujours essayer, ilsuffit de passer les options "noapic", "nolapic" et "acpi=no" au noyau.
bon courage.


 
oui j'ai essayé, ça n'arrange pas grand chose.
 
Par contre j'ai une piste, celle des IRQ.
 
quand je fais cat /proc/interrupt j'ai :
 

Citation :

frederick@localhost ~ $ cat /proc/interrupts  
           CPU0       CPU1        
  0:       3043     652301   IO-APIC-edge      timer
  1:          0          2   IO-APIC-edge      i8042
  8:          0          0   IO-APIC-edge      rtc
  9:          0          0   IO-APIC-fasteoi   acpi
 12:          0          4   IO-APIC-edge      i8042
 14:          4       2011   IO-APIC-edge      ide0
 17:         56      14427   IO-APIC-fasteoi   ohci_hcd:usb2
 18:         77      55863   IO-APIC-fasteoi   ohci_hcd:usb3, nvidia, EMU10K1
 19:        233      70562   IO-APIC-fasteoi   libata, ohci_hcd:usb4
 21:        276      66561   IO-APIC-fasteoi   eth0
 23:          0          8   IO-APIC-fasteoi   ehci_hcd:usb1
NMI:        753        669  
LOC:     655154     655079  
ERR:          0


 
Or, on m'a déja dit que EM10K1 se mariait très mal avec nvidia, et pire que nvidia devrait mieux être seul.
Mais j'ai aucune idée de savoir comment faire.


---------------
The Toast, un docu-fiction qui teste la loi de murphy et les films en carton
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  Plantage Régulier : incompatibilité : RS480 / Nvidia - Résolu !

 

Sujets relatifs
[Résolu] [Apache2] Autorisation d'une plage d'adresse IP[Résolu] [AWK] Problème de séparateur
[linksys wag200g] [résolu] probleme tunnel ssh pour VNC[Résolu] Mac OS X en live cd ??
[RÉSOLU] Vous arrivez à lire les cartes mémoires SDHC sous Linux?[RÉSOLU]Lecteur de cartes mémoires visible dans /dev mais inaccessible
[resolu] mandriva 2007 , installation erreur[résolu] installation apache 2.2.4 php 5.2.0 pb installation apache
[résolu] [Samba] Auto-connexion depuis XP[Résolu]qui consomme de la ram
Plus de sujets relatifs à : Plantage Régulier : incompatibilité : RS480 / Nvidia - Résolu !


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR