Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2406 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  Accès à une partition et installation d'un logiciel sous Suse

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Accès à une partition et installation d'un logiciel sous Suse

n°1063955
Halfsup
Posté le 02-08-2008 à 20:52:39  profilanswer
 

Bonjour à tous  :hello:  
 
Voila je suis l'heureux possesseur d'un MSI Wind sous Linux Suse 10 sp1 (du moins je crois :o), je m'étais mis dans la tête qu'il serait temps que je change un peu mes vieilles habitudes sous XP pour passer du côté obscur afin de gagner en stabilité et en personnalisation.
 
Force est de constater que je suis... un gros noob. Malgré mes recherches (infructueuses) je n'arrive pas à résoudre deux problèmes vraiment embêtants.
 
Déjà, le disque dur fourni avec le MSI Wind fait 80Go, le système occupe il me semble 8Go, y a une partoche swat, et une partition avec le gros de l'espace disque libre seulement je n'arrive pas à y accéder.
Quand je tape /home je tombe sur mes Documents personnels, et là mon espace de stockage est de 800Mo (c'est ce qu'il reste sur la partition systeme :/), impossible d'accéder à l'autre partition de 50GO pour copier un misérable films ou quelques chansons.  :sweat:  
J'ai plus ou moins réussi à identifier le dossier ou se trouve les 60Go manquant mais malgré que je me sois loggé en root dans la Konsole il m'est interdit d'accéder au répertoire (il me répète de me logger en root alors qu'il n'y a qu'un seul compte...). Qu'ais je raté? :p
 
Deuxième problème, installer MPlayer, en effet le logiciel de base ne permet pas de lire des divx et j'ai donc décidé d'installer ce soft qui semble être la référence, j'ai essayé plusieurs fois avec la commande yast -i ou rpm -i mais à chaque fois il m'affiche un message d'erreur comme quoi il manque un gcc compiler (il me semble). Pourriez vous m'aider? Une procédure particulière à suivre?
 
Merci d'avance à tous pour votre aide!  :jap:

mood
Publicité
Posté le 02-08-2008 à 20:52:39  profilanswer
 

n°1063957
Fork Bomb
Obsédé textuel
Posté le 02-08-2008 à 21:04:25  profilanswer
 

Identification du problème disque dur :
fdsik -l
dans une console root
----
Ainsi qu'un cat /etc/fstab


Message édité par Fork Bomb le 02-08-2008 à 21:05:08

---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1063961
Halfsup
Posté le 02-08-2008 à 22:19:16  profilanswer
 


Ok je vais voir ce que ça me donne lorsque je l'entre dans ma console même si je ne pense pas qu'il y ait le moindre problème, mais plutôt que je n'arrive pas à y accéder car je suis un groos noob de nux!

n°1063984
Halfsup
Posté le 03-08-2008 à 09:14:38  profilanswer
 

Voila alors j'ai tapé la première commande, voici ce qu'il m'a donné :

 

Disque /dev/sda: 80Go

 

Periphérique Amorce

 

/dev/sda1                  blocs:  8393931  Linux
/dev/sda2                  blocs:  1052257+  Linux swap
/dev/sda3                  blocs:  9772267+  Linux
/dev/sda4                  blocs: 58926420  Linux

 

Si j'ai bien compris la partition /dev/sda4 'est bien celle ou est disponible le gros de mon espace de stockage?

 

Quand je tape la commande suivante (cat /etc/fstab) il me dit que la partoche /dev/sda4 est accessible via /media/data
Seulement quand je tapes cela dans l'explorateur il me dit que je n'ai pas la permission pour accéder au dossier qui possède effectivement environ 60Go de libre, pourtant je suis le seul utilisateur de la machine et évidement logger en root sur la console (il faut se logger encore autre part? pourtant j'ai qu'une seule session)

 

Si j'arrivais à accéder à ce dossier cela réglerait un problème sur trois, je pourrais enfin copier mes fichiers :jap:

 

Merci d'avance


Message édité par Halfsup le 03-08-2008 à 09:16:22
n°1063985
zeblods
Posté le 03-08-2008 à 09:23:46  profilanswer
 

Est ce que /dev/sda4 appairait quand tu tape : "df -h" ?

 

Si non, tu tape (en root) :
#mkdir /mnt/data
#mount -o uid=1000,guid=1000 /dev/sda4 /mnt/data

 

Avec :
/mnt/data le dossier où tu souhaite monter (et accéder) à ton disque
uid la valeur correspondante à ton UID (pour être propriétaire du montage)
gid la valeur correspondante ) ton GID (pour que ton groupe puisse accéder au dossier)

 

Pour connaitre ton UID et GID, utilise la commande "id" en étant loggé en simple utilisateur.

 

PS : un linux ne s'utilise qu'en simple utilisateur, le root ne s'utilise que pour l'installation/configuration/maintenance

 

[EDIT] J'avais pas tout bien lu...

 

Fais en root :
#umount /media/data
#mount -o uid=1000,guid=1000 /dev/sda4 /media/data

 

uid la valeur correspondante à ton UID (pour être propriétaire du montage)
gid la valeur correspondante ) ton GID (pour que ton groupe puisse accéder au dossier)

 

Si ça ne marche pas, essaye un (en root aussi) :
#chown ton_user:ton_group /data
#chmod 755 /data

 

Tu définis d'abord le dossier comme t'appartenant, puis tu te donne les droits d'écriture


Message édité par zeblods le 03-08-2008 à 09:27:05
n°1063987
Halfsup
Posté le 03-08-2008 à 09:30:46  profilanswer
 

Oula, je crois comprendre la manip mais ça a l'air relativement complexe (ça change de XP...). Je teste ceci de suite! Merci à toi pour ta réactivité :hello:

 

Message cité 1 fois
Message édité par Halfsup le 03-08-2008 à 09:33:26
n°1063988
zeblods
Posté le 03-08-2008 à 09:32:05  profilanswer
 

Halfsup a écrit :


Oula, je crois comprendre la manip mais ça a l'air relativement complexe (ça change de XP...). Je teste ceci de suite! Merci à toi pour ta réactivité :hello:


Ce sont des tests, si le premier est concluant il suffira d'ajouter l'entrée dans fstab pour que ça soit executé au démarage.

 

Sinon il faudra quelqu'un de plus expérienté que moi...

 

Petite question : ta partition de 60Go est formaté avec quel FS ? (ext3 ? fat ? ntfs ?)

 

PS : certaines distribution sont plus simple et user-friendly que d'autre. Je ne connais pas Suse (enfin que de nom) mais je sais que Ubuntu est un des meilleur en terme de simplicité pour les débutants (dont moi d'ailleurs...)


Message édité par zeblods le 03-08-2008 à 09:36:45
n°1063990
Halfsup
Posté le 03-08-2008 à 09:40:08  profilanswer
 

Je viens de tester la premiere commande, il m'affiche le message d'erreur suivant :

 

mount : type erroné de systeme de fichier, options erronnées etc... /dev/sda4

 

codepage manquante ou autre erreur
Dans quelques cas certaines info sont utiles dans le syslog, essayez dmesg | tail ou quelque chose du genre (:lol: la dernire ligne)

 

Mon UID et GUID est de valeur 0, je pense que le problème vient de là.

 

Il ne me retrouve même plus ma partition now, donc pire qu'avant :ouch:

 


Ma partition /media/data est en ext3!

  


Apparement, Ubuntu a l'air plus simple mais pour l'instant je n'ai pas la possibilité de l'utiliser.


Message édité par Halfsup le 03-08-2008 à 09:44:15
n°1063993
zeblods
Posté le 03-08-2008 à 09:51:00  profilanswer
 

Ton UID et GID sont 0 car tu est en root... met ceux de ton utilisateur normal (su ton_user -c "id" )

 

Type erroné de système de fichier... euh la partition n'est pas bonne ?!
et avec un "mount -t ext3 -o uid=1000,guid=1000 /dev/sda4 /media/data" ?

 

Que t'affiche le fameux "dmesg | tail" ? et "ls /dev | grep sda" ?

Message cité 1 fois
Message édité par zeblods le 03-08-2008 à 09:52:34
n°1063996
Fork Bomb
Obsédé textuel
Posté le 03-08-2008 à 10:58:01  profilanswer
 

Tu peux me donner le résultat de ls /home/ s'il te plait ?


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
mood
Publicité
Posté le 03-08-2008 à 10:58:01  profilanswer
 

n°1064056
crouik
Posté le 03-08-2008 à 19:22:09  profilanswer
 

tu peux le faire à la bourrin, un peu comme sur XP (je suis bourrin excusez moi !)
 
tu te connecte en root (en graphique, suse le permet) Donc au démarrage tu met root et le mot de passe qui va bien.
Puis tu remonte à la racine (là ou tu as le dossier "media" )
 
Tu clique sur ce dossier, puis sur le dossier data tu clique droit, sélectionne "propriétés"
Tu sélectionne dans la boite découlante propriétaire du dossier: le nom de l'utilisateur (exemple "toto" )
Puis en groupe du dossier "user".
 
tu referme tout et tu quitte l'utilisateur "root" (menu changement d'utilisateur)
Tu te connecte ensuite avec ton utilisateur normale (exemple "toto" )
et tu devrais pouvoir écrire dans ton dossier data.
 
Je l'ai fait comme ça sur cette machine ...
Par contre pour Mplayer ... comme c'est une suse 10.1 pro qu'ils ont mis la dessus, les seuls dépôts que je trouve encore pour suse commence à la 10.2 ...
 
 
Je trouve qu'il vaudrait mieux essayer de déplacer le home sur cette partition plutôt que d'essayer d'utiliser ce dossier "data". (là ce n'est que mon avis)

Message cité 1 fois
Message édité par crouik le 03-08-2008 à 19:23:17
n°1064107
Halfsup
Posté le 04-08-2008 à 08:17:17  profilanswer
 

zeblods a écrit :

Ton UID et GID sont 0 car tu est en root... met ceux de ton utilisateur normal (su ton_user -c "id" )

 

Type erroné de système de fichier... euh la partition n'est pas bonne ?!
et avec un "mount -t ext3 -o uid=1000,guid=1000 /dev/sda4 /media/data" ?

 

Que t'affiche le fameux "dmesg | tail" ? et "ls /dev | grep sda" ?

 

effectivement j'ai réussi a avoir le bon UID et GID en étant pas en root mais même avec les bons la commande que tu m'as dicté ne fonctionne pas :/

 

J'ai de nouveau possibilité de voir le dossier mais sans y accéder hélas, je vais essayer la technique de crouik pour voir

  

ls /home/  :  HalF (mon pseudo).

 

dmesg | tail : Bluetooth :  Core ver 2.8
et pleins d'autres infos, pas de message d'erreur rien, apparemment y a effectivement un soft pour gérer mes périphériques bluetooth, mais impossible de faire détecter ma souris !

 

ls /dev | grep sda :

 

sda
sda1
sda2
sda3
sda4

 


VOila  :hello:


Message édité par Halfsup le 04-08-2008 à 08:20:11
n°1064111
Halfsup
Posté le 04-08-2008 à 08:24:19  profilanswer
 

crouik a écrit :

tu peux le faire à la bourrin, un peu comme sur XP (je suis bourrin excusez moi !)
 
tu te connecte en root (en graphique, suse le permet) Donc au démarrage tu met root et le mot de passe qui va bien.
Puis tu remonte à la racine (là ou tu as le dossier "media" )
 
Tu clique sur ce dossier, puis sur le dossier data tu clique droit, sélectionne "propriétés"
Tu sélectionne dans la boite découlante propriétaire du dossier: le nom de l'utilisateur (exemple "toto" )
Puis en groupe du dossier "user".

 
tu referme tout et tu quitte l'utilisateur "root" (menu changement d'utilisateur)
Tu te connecte ensuite avec ton utilisateur normale (exemple "toto" )
et tu devrais pouvoir écrire dans ton dossier data.
 
Je l'ai fait comme ça sur cette machine ...
Par contre pour Mplayer ... comme c'est une suse 10.1 pro qu'ils ont mis la dessus, les seuls dépôts que je trouve encore pour suse commence à la 10.2 ...
 
 
Je trouve qu'il vaudrait mieux essayer de déplacer le home sur cette partition plutôt que d'essayer d'utiliser ce dossier "data". (là ce n'est que mon avis)


 
J'ai la possibilité de faire cela nulle part après avoir fait clique droit => propriété sur le dossier!
 
Il m'affiche juste :
 
Propriétaire du fichier : root
Groupe du fichier : root
 
Et aucun accès possible, mais bordel je suis loggé en root pourtant! et s'il me demandait au moins un mot de passe à taper, là non, que dalle juste accès interdit :/
 
 
 
Comme j'ai la Suse 10.1 je ne pourrais pas du tout installer de lecteur de divx?  :ouch:  :(  

n°1064140
Fork Bomb
Obsédé textuel
Posté le 04-08-2008 à 10:55:45  profilanswer
 

Ok.
Tu vas me tester ça.
 
Connectes en graphique avec ton utilisateur régulier (HalF)
Sors une console, mets toi root.
Pour être root dans une console, il faut taper su puis le mot de passe de root (défini à l'install de ta Suse). Rien n'apparaitra quand tu taperas le mot de passe et ça sera normal.
 
Une fois root, tapes ces commandes les unes à la suite des autres.

mkdir /media/mon_point_de_montage


--> Tu mets ce que tu veux, évidemment :)
 

mount /dev/sda4 /media/mon_point_de_montage


--> Avec cette commande, tu fais apparaitre le contenu du HDD/de la partition dans /media/mon_point_de_montage
 

echo "# ------ [ADDED BY ROOT : BEGIN] ------
/dev/sda4 /media/mon_point_de_montage ext3 defaults,rw,users 0 0
# ------- [ADDED BY ROOT : END] -------" >> /etc/fstab


--> Là, on ajoutes les infos a fstab (fichier lu au démarrage)
 

mount -a


--> On monte tout (forçant la lecture du fstab).
 

chown -R half /media/mon_point_de_montage


--> On donne les droits a "half".
----------------------
 /!\ ATTENTION /!\
 
Je suis parti du principe que ton sda4 était un HDD/une partition de stockage, pas un HDD/une partition système.
 
Ah ! Et désolé de te faire utiliser la console, je sais pas faire autrement perso ;(


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1064164
Halfsup
Posté le 04-08-2008 à 11:55:55  profilanswer
 


WOOOT, ça a fonctionné :d

 

Merci merci, mille merci à vous tous, vous vous êtes donnés beaucoup beaucoup de mal et vos posts étaient tous complets et facile à comprendre même pour un noob comme moi. Je peux enfin copier tous mes fichiers, Merci encore une fois!

 

Second problème, comment installer un lecteur de films/codecs pour me permettre de voir divx? :o


Message édité par Halfsup le 04-08-2008 à 11:56:56
n°1064168
Fork Bomb
Obsédé textuel
Posté le 04-08-2008 à 12:19:29  profilanswer
 

Niveau player, j'en utilise trois en alternance.
mplayer, vlc et xine.
 
Sous Debian, j'installe les paquets mplayer, gmplayer, vlc, wxvlc et xine-ui.
Niveau codecs, le paquets w32codecs ou win32codecs est indispensable.
Il ne faut pas oublier lame (mp3), vorbis (ogg), mkv (container libre), ffmpeg (euh.... je sais plus) et d'autres que j'oublie.
Pour faire des recherches en mode graphique, il me semble que tu devras appeler yast2 (yast étant en ligne de commande).


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1064170
Halfsup
Posté le 04-08-2008 à 12:31:11  profilanswer
 

YAst2 cherchera tout seul sur le web les versions adéquates et fera une installation automatique?
 
Car j'avais déjà essayé mais sans succés.
 
Les lignes de commande en apt get, rpm, ou yast -i ça ne donnait pas grand chose. Je vais réessayer.
 
Merci à toi pour tes réponses rapides et précises :jap:

n°1064171
Fork Bomb
Obsédé textuel
Posté le 04-08-2008 à 12:44:24  profilanswer
 

Pour remplir ton fichier de miroirs, tu peux utiliser :
>> http://www.kameleon-facile.org/script/
 
Je l'avais utilisé il y a longtemps.
 
Plus de miroirs --> Plus de programmes disponibles :)


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1064180
Halfsup
Posté le 04-08-2008 à 14:14:45  profilanswer
 


Merci pour les infos, je vais voir si j'arrive à me débrouiller.
 
y a quelques années j'avais utilisé mandriva et red hat, et pour installer des softs assez basique (style firefox), on pouvait taper une commande assez simple + nom_du_fichier et l'OS l'installait automatiquement. C'est pas possible de faire la même chose sur la Konsole sous Suse?

n°1064187
Fork Bomb
Obsédé textuel
Posté le 04-08-2008 à 14:23:41  profilanswer
 

Si, bien sûr.
Il me semble que c'est yast qui gères ça.
 
Un ptit coup de man yast en shell pour avoir les options ou yast --help pour les principales options devrait t'aider.


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1064236
Halfsup
Posté le 04-08-2008 à 16:17:38  profilanswer
 


Oki je vais checker ça cet aprem! Je reviens vers toi si je bloque :p

n°1064260
Halfsup
Posté le 04-08-2008 à 18:00:55  profilanswer
 

Bon man yast ne fonctionne pas, j'ai donc essayer yast -i vlc par exemple, cela lance une console bleu mais après il ne trouve rien sur le support (?) et ne m'installe donc rien :(

 

Quand j'utilise la console bleu j'ai nombre restreint de softs installables (certains sont même déjà installés), mais aucune options pour rafraîchir via internet ou chercher sur le web de nouveaux softs.

 

J'ai essayé une installation via l'interface graphique et j'ai rien compris, j'ai essayé d'ajouter des url pour télécharger par exemple vlc directement sur le site des créateurs mais sans succés :/


Message édité par Halfsup le 04-08-2008 à 18:09:47
n°1064264
Fork Bomb
Obsédé textuel
Posté le 04-08-2008 à 18:28:29  profilanswer
 

Et avec le script de "kaméléon facile", ça n'a rien donné non plus ?
Pour ce que j'ai testé tout à l'heure, il faut cliquer sur les ptites icônes et ça t'amènes sur une nouvelle page.


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1064269
Halfsup
Posté le 04-08-2008 à 19:01:21  profilanswer
 


En cliquant sur l'icone yast je tombe sur la page avec pleins de softs installables mais pas de vlc/mplayer ni de codec!
 
En plus ce n'est que pour Suse 10.3 et 11.0 (j'ai la 10.1 avec mon Wind).
 

n°1064935
crouik
Posté le 06-08-2008 à 22:07:15  profilanswer
 

Fork Bomb a écrit :


 
Ah ! Et désolé de te faire utiliser la console, je sais pas faire autrement perso ;(


 
Bah, c'est comme sur XP en graphique !  les mêmes menus pratiquement, pas tout à fait nommé pareil mais enfin ...
Le principal étant d'arriver au même résultat.
 
L'interface graphique pour un vrai, c'est de la déco  :)  
 
Pour suse malheureusement, il n'y a plus de dépôts pour la 10.1 (en tout cas je n'en ai plus trouvé)


Message édité par crouik le 06-08-2008 à 22:09:02
n°1067909
gilcog
Posté le 19-08-2008 à 15:04:07  profilanswer
 

Hello a tous !
 
Halfsup je suis dans exactement la meme situation que toi !!!
 
sous wind suse d'origine et j'essai d'installer des softs et j'arrive pas !!!
 
pour les partitions je suis arrivé aux meme conclusions, je mets mes docs dans media/data en root... pas terrible...
 
as tu finalement reussi a installer un player correct pour lire divx quicktime et autres formats mpeg2 ???
 
Je veux bien rester sous Suse, mais il me faut le minimum !!!
 
thx

n°1067993
crouik
Posté le 19-08-2008 à 20:12:57  profilanswer
 

Je trouve que suse à installé ça comme un cochon sur ce MSI wind.
 
Je l'ai eu un peu en main et franchement, ça incite à migrer sur XP.
 
Pour une suse entreprise en plus, la 10.1, il n'y a plus de dépôts de logiciels, j'ai lancé plusieurs live CD et le wifi jamais reconnu (faut compiler le pilote je crois) les touches FN aucune ne fonctionne (nécessaire pour activer le wifi) Surement d'autres surprises, mais pas eu longtemps assez.
 
A moins qu'un passionné fasse une installation spécifique pour ce portable (un peu comme pour l'eepc) je n'en voudrais pas de cette machine.

n°1077376
Halfsup
Posté le 27-09-2008 à 13:26:53  profilanswer
 

gilcog a écrit :

Hello a tous !
 
Halfsup je suis dans exactement la meme situation que toi !!!
 
sous wind suse d'origine et j'essai d'installer des softs et j'arrive pas !!!
 
pour les partitions je suis arrivé aux meme conclusions, je mets mes docs dans media/data en root... pas terrible...
 
as tu finalement reussi a installer un player correct pour lire divx quicktime et autres formats mpeg2 ???
 
Je veux bien rester sous Suse, mais il me faut le minimum !!!
 
thx


 
Non je n'ai toujours pas réussi à installer quoique ce soit, je vais en cours avec et je peux prendre mes cours et surfer en wifi donc c'est le principal...
 
Mais ne pas pouvoir mater quelques divx dans le train c'est vraiment gavant :/

n°1077384
samuelp
Posté le 27-09-2008 à 14:26:32  profilanswer
 

Halfsup a écrit :


 
Non je n'ai toujours pas réussi à installer quoique ce soit, je vais en cours avec et je peux prendre mes cours et surfer en wifi donc c'est le principal...
 
Mais ne pas pouvoir mater quelques divx dans le train c'est vraiment gavant :/


J'ai pas suivi toute l'histoire :
Tu n'arrives pas à installer des Softs avec YaST c'est ça ?
Quels softs voudrais tu ? Win32-Codec ? Xine ?
On peut les installer sans passer par YaST

n°1079699
Halfsup
Posté le 07-10-2008 à 21:09:23  profilanswer
 


Un lecteur vidéo ou au moins un pack de codec pour lire des divx!
 
Impossible d'y arriver en passant par Yast ou autrement, si t'as des suggestions je suis preneur :jap:

n°1079790
samuelp
Posté le 08-10-2008 à 09:07:00  profilanswer
 

http://rpm.pbone.net/index.php3/st [...] n32-codecs
 
Tu prends le rpm SuSE 10.x qui te convient.
 
Tu fais un rpm -Uhv <fichier_rpm> et dis ce qu'il se passe ?

n°1080191
Halfsup
Posté le 09-10-2008 à 08:05:38  profilanswer
 


Oki merci beaucoup, je vais tester ceci dans la matinée et je te tiens au courant, merci pour ton aide. ;)
 
Dommage que l'installation de logicielle ne soit pas aussi simple sur un EEE PC :/

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Divers

  Accès à une partition et installation d'un logiciel sous Suse

 

Sujets relatifs
Redirection des requetes web sur un LAN / Régulation d'accès au net[linux live OS] installation sur carte SD possible? sur mobal port ?
besoin d'aide au niveau logiciel pour faire un serveurInstallation manuelle de gcc 3.2 sous debian
Traduction d'un message sous Suseinstallation programme linux Opensuse
pbm pour redimensionner une partition sous vistaChoix sur l'installation de ma 1ere distrib
Installation MacOs après installation de XPCherche un logiciel de transfert d'adresse pour mac
Plus de sujets relatifs à : Accès à une partition et installation d'un logiciel sous Suse


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR