Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1317 connectés 

  FORUM HardWare.fr
  Hardware
  Matériels & problèmes divers

  Installation driver DD Sata

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Installation driver DD Sata

n°7041948
hhenri
Posté le 20-07-2009 à 00:42:11  profilanswer
 

Bonjour,
 
Ce post pour demander de l'aide avant de faire une bêtise. J'ai essayé de trouver des posts relatifs au sujet, sans succès.
 
Mon PC est assez ancien et tourne sous XP-home SP2. Ma carte mère n'a pas de ports Sata.
 
J'ai récemment acheté un dd "WD Caviar blue sata 2". Pour le monter j'ai installé un adapteur Sata-Pci fourni avec le chipset "VIA VT6421 V100A". Sans les pilotes mon dd sata n'est pas reconnu. Je veux juste installer le pilote nécessaire à la reconnaissance du dd (pas de raid, je n'ai qu'un disque).
 
Voici les instructions données dans le fichier README.TXT du mini-cd contenant les drivers.
 
***********************************************************************
2. Install Windows NT 4.0, 2000, XP, or Server 2003
 
        * Copy all files and directories from the DriverDisk folder to a floppy disk.  
          Make sure the following directories and files are copied into the floppy disk.
 
      A:\
        \2003IA32
             VIAsprid.inf
             VIAsprid.sys
             VIAsprid.cat
        \Win2000
             VIAsprid.inf
             VIAsprid.sys
             VIAsprid.cat
        \Winnt40
             VIAsprid.inf
             VIAsprid.sys
        \WinXP
             VIAsprid.inf
             VIAsprid.sys
             VIAsprid.cat
        Txtsetup.oem
        VT6421
 
 
        * Boot system from OS installing CD-ROM.
 
        * Make sure VT6421 BIOS is executed by the system BIOS when POST.
 
        * Press "F6" when OS installer starts running.
 
        * Insert floppy disk.
 
        * Choose the OS device driver wanted for loading.
 
        * Install OS.
 
        * Install RAID utility after OS is installed.
***********************************************************************
 
1/ Je crée la disquette sans pb,
2/ Je boote sur le cd XP qui demande la disquette et s'installe sans pb.
 
3/ C'est au reboot que le problème apparait. Je ne peut booter sur le dd.
    En regardant de plus près je constate que j'ai négligé l'instruction suivante : <<<* Make sure VT6421 BIOS is executed by the system BIOS when POST.">>>
 
    Effectivement sur le cd j'ai un répertoire <<Bios>> avec le fichier "6421V100.rom".  
 
    Mon problème : Comment activer et utiliser ce fichier ".rom" ?
 
Merci d'avance de votre aide :D  
 
 
NB : Pourquoi un Sata et pas un Ide ? Je prévois de reprendre à terme, les éléments utilisables de mon ancien PC dans un nouveau boitier avec une nouvelle carte mère.

mood
Publicité
Posté le 20-07-2009 à 00:42:11  profilanswer
 

n°7042140
HiSpeed
Where is the limit?
Posté le 20-07-2009 à 11:38:03  profilanswer
 

Salut,
 
Première remarque: ce n'est pas parce que tu ne veux pas faire de raid qu'il ne faut pas installer le driver raid.
Le driver raid apporte généralement le "hot-swap" et n'oblige en rien à faire du raid...
 
Deuxième remarque: le fichier ".rom" est probablement le BIOS de la carte déjà installé dessus...
 
Première question: quand tu entres dans le BIOS de ta carte mère, tu vois ta carte ou pas ?
 
Deuxième question: as-tu un disque Pata qui fonctionne sur ce PC ?


Message édité par HiSpeed le 20-07-2009 à 11:42:40
n°7042590
hhenri
Posté le 20-07-2009 à 17:23:24  profilanswer
 

Salut HiSpeed,

Citation :

Première question: quand tu entres dans le BIOS de ta carte mère, tu vois ta carte ou pas ?


Je ne la vois pas.  
Ceci dit je connais moyennement le bios. Mais il me semble que je devrais la voir dans le menu "Standard cmos features" sous l'item <<ide primary slave>>. Cependant je récupère "none" à la détection.
NB : Je ne vois rien non plus dans "Integrated peripherals"

Citation :

Deuxième question: as-tu un disque Pata qui fonctionne sur ce PC ?


Oui, c'est lui que j'utilise en ce moment et que je veux virer quand je pourrai booter sur le sata.  
C'est un vieux disque, de petite capacité et avec lequel j'ai déja eu quelques problèmes.
 
Ceci dit il est bien utile en ce moment où les deux dd sont montés. Pour mes tests je débranche juste l'alimentation du Pata.
 

Citation :

Première remarque: ce n'est pas parce que tu ne veux pas faire de raid qu'il ne faut pas installer le driver raid.
Le driver raid apporte généralement le "hot-swap" et n'oblige en rien à faire du raid...


Suite à ta remarque j'ai chargé le driver sous xp (pata). En rebootant et pour la première fois, je vois le sata (la partition créée) comme un disque local. :)  

Citation :

Deuxième remarque: le fichier ".rom" est probablement le BIOS de la carte déjà installé dessus...


C'est probable, mais comment procéder pour que la carte apparaisse dans le bios ? Je conclus de tes remarques que tant qu'elle ne sera pas détectée je ne pourrai pas booter sur le dd sata.
 
Merci de ton aide :D  
 
 
 

n°7042626
HiSpeed
Where is the limit?
Posté le 20-07-2009 à 17:47:01  profilanswer
 

hhenri a écrit :

Suite à ta remarque j'ai chargé le driver sous xp (pata). En rebootant et pour la première fois, je vois le sata (la partition créée) comme un disque local. :)


Bien, c'est justement ce que je voulais te faire faire...  ;)  
 
Il faudrait aussi déclarer le raid quelque part dans le BIOS...
 
Je cherche à t'aider par analogie à ce que j'ai fait récemment sur ma carte P5Q-E ou j'avais un pata avec XP et un sata.
La seule différence avec toi est que le controleur sata est sur la carte mère...
 

hhenri a écrit :

comment procéder pour que la carte apparaisse dans le bios ?[/b][/#0e00f0] Je conclus de tes remarques que tant qu'elle ne sera pas détectée je ne pourrai pas booter sur le dd sata.


Oui, tu dois probablement avoir une déclaration quelque part dans ton BIOS (disque, port PCI, etc.)...
Au besoin, change l'affichage de la séquence de boot pour voir ce que le BIOS affiche au boot-up...


Message édité par HiSpeed le 20-07-2009 à 18:05:29
n°7042705
hhenri
Posté le 20-07-2009 à 18:39:15  profilanswer
 

Salut HiSpeed,
 
Je viens de refaire un test et je vais un peu plus loin (chargement du driver ?). J'ai le message suivant au démarrage sur le sata :
 
----------------------------------------------------------
CLIENT MAC ADDR : 00 10 DC CE 06 B8
GUID : 20202020-2020-2020-2020-202020202020
PXE-E53 : No boot filename received
 
PXE-M0F : Exiting NVIDIA boot agent
Disk boot failure, Insert system disk and presse enter
----------------------------------------------------------
 
Le bios cherche un fichier qu'il ne trouve pas. J'ai un bouquin sur le bios, je vais me pencher de plus prés sur les réglages.
 
cdlmt

n°7042734
HiSpeed
Where is the limit?
Posté le 20-07-2009 à 18:57:53  profilanswer
 

Mais s'il n'est pas bootable ton sata, c'est normal que tu ais ce message...
 
Moi quand j'avais le pata et le sata connectés ensemble, il fallait que j'indique dans le BIOS le disque qui doit booter en premier...


Message édité par HiSpeed le 20-07-2009 à 18:58:17
n°7042824
hhenri
Posté le 20-07-2009 à 20:00:04  profilanswer
 

Salut HiSpeed,
 
Après un coup d'œil à mon bouquin j'ai activé la fonction "Reset configuration data" du menu Pnp. Sans succès, la carte n'est toujours pas détectée.
 
Je vais essayer les manip suivantes :
 
1/ Changer de port pci, on ne sait jamais.
2/ Essayer d'ajouter la carte manuellement.
 
cdlmt

n°7043116
hhenri
Posté le 21-07-2009 à 01:09:13  profilanswer
 

Salut,
 
1/ J'ai changé de port pci, mais même résultat.
2/ Je n'ai pas la main pour un ajout manuel dans la mesure où la carte n'est pas détectée.
 
Je ne sais plus trop quoi faire. :??:  Je vais voir si un upgrade du bios est possible.  
 
cdlmt

n°7043254
HiSpeed
Where is the limit?
Posté le 21-07-2009 à 09:21:18  profilanswer
 

Bonjour,
 
C'est quoi comme carte mère ?
Lorsque le pata et le sata son connectés, est-ce qu'au moins les 2 sont visibles dans le BIOS ?

n°7043748
hhenri
Posté le 21-07-2009 à 14:52:19  profilanswer
 

Bonjour HiSpeed,
 

Citation :

C'est quoi comme carte mère ?


1/ La Carte Mère :
- Fabriquant : NEC C.I.
- Modèle : MS-6367 NOVA LEGEND
- Version 1.0
 
2/ Le bios
Marque Award S.I.
Version (lu dans le bios) : W367P3 V2.1 071503 CONEXANT
Version (vu par SIW) : 2.1
Firmware (SIW) : 97.114
Date bios (SIW) : 07/15/2003
 
Je peux donner plus de détail si nécessaire.  
Dans les caractéristiques du bios et de la CM je ne vois de référence au SCSI ou au RAID.
Pour le bios j'ai un item : ""Supporte les spécifications pour un pilote amélioré de disque"" ???

Citation :

Lorsque le pata et le sata son connectés, est-ce qu'au moins les 2 sont visibles dans le BIOS ?


Malheureusement non. C'est çà le problème. Malgré toutes les manip je n'arrive pas à voir le disque sata dans le bios.
 
C'est pour ça que je pense à un upgrade du bios. Il faudrait qu'il reste compatible avec la CM et je ne sais pas trop où chercher.
Le bios actuel est le plus récent fourni par Packard Bell pour le PC.
 
cdlmt

mood
Publicité
Posté le 21-07-2009 à 14:52:19  profilanswer
 

n°7043768
HiSpeed
Where is the limit?
Posté le 21-07-2009 à 15:05:06  profilanswer
 

C'est celle-là ta carte ?

n°7043819
HiSpeed
Where is the limit?
Posté le 21-07-2009 à 15:33:30  profilanswer
 

Bootable Add-in Cards
C'est probablement là qu'il faut déclarer ta carte...

n°7046186
hhenri
Posté le 23-07-2009 à 00:39:58  profilanswer
 

Salut,

Citation :

C'est celle-là ta carte ?


Oui c'est bien ça.

Citation :

C'est probablement là qu'il faut déclarer ta carte...


Suite à tes info j'ai avancé :
- En first boot device j'ai sélectionné ""Internal lan"" (2: floppy, 3: cdrom, 4: Other : Enabled)
- Dans le menu adéquat j'ai passé ""bootable add-in cards"" en position 1.
 
Je démarre avec les deux dd connectés et au "post" je retrouve le message d'erreur (ci-après).
----------------------------------------------------------
CLIENT MAC ADDR : 00 10 DC CE 06 B8
GUID : 20202020-2020-2020-2020-202020202020
PXE-E53 : No boot filename received
 
PXE-M0F : Exiting NVIDIA boot agent
Disk boot failure, Insert system disk and presse enter
----------------------------------------------------------  
 
Puis le démarrage se fait par défaut sur le dd Ide. ==> L'adapteur ide-sata est bien détecté en premier, même s'il n'apparait pas dans le bios, mais le pc ne peut booter dessus.
 
Je pense qu'il me faudrait un bios plus récent avec un flag SCSI/IDE. Ceci dit le support SCSI n'apparait pas dans la description de la CM.  
D'après une info du forum Packard Bell cette CM ne peut gérer le sata.
 
Je vais voir ce que je peux trouver côté bios compatible. Au pire j'utiliserai le sata comme disque de données jusqu'à ce que ma nouvelle tour soit opérationnelle.
 
cdlmt
 
 
 
 
 
 

n°7046265
Bred
Posté le 23-07-2009 à 05:34:10  profilanswer
 

Salut,
 
j'ai eu 2 carte controleur sata, l'une en pci, l'autre (actuellement) en pci-x, c'est simple, lorsque la carte controleur est détectée par le pc, on le voit à l'écran avant le démarrage de windows par un nouvel écran du style "pci card silicon etc....(nom du chip de la carte) et les disques durs qui lui sont reliés. Et ce même si windows n'est pas installé, donc si tu n'as même pas un "nouvel écran" au démarrage quand ta carte est branchée, c'est que soit ta carte mère ne la détecte pas, soit le port pci est mort..Voilà mon avis^^

n°7047459
hhenri
Posté le 23-07-2009 à 22:46:14  profilanswer
 

Salut verbuate,
 

Citation :

...donc si tu n'as même pas un "nouvel écran" au démarrage quand ta carte est branchée, c'est que soit ta carte mère ne la détecte pas, soit le port pci est mort...


Renseignements pris je pense que ça vient de la CM elle est de 2002 et le sata est apparu en 2003. Je vais faire cependant une permutation supplémentaire avec un port dont je suis sur vu qu'il y a déjà une carte.
 
cdlmt

n°7047597
hhenri
Posté le 24-07-2009 à 01:45:23  profilanswer
 

Bonjour,
 
A partir d'une info récupérée dans un post je viens de voir qu'il existe des adaptateurs sata-ide destinés à palier le pb des cartes mères anciennes. :)  Exemple ci-après :  
 
http://www.amazon.fr/Adaptateur-ID [...] ce_title_3
 
Je vais monter un adaptateur de ce type, ça devrait résoudre mon pb. Je donnerai des nouvelles dès que je l'aurai testé.
 
cdlmt :D  

n°7047667
Bred
Posté le 24-07-2009 à 09:19:54  profilanswer
 

Yop,
 
Le fait que la carte sata soit plus récente que la CM ne change normalement rien à la détection (ma 1ere carte sata je l'avais branché en pci sur une A7N8X de 2001 env).
En plus je me souviens avoir eu des problèmes à l'installation de windows et ce même avec "F6" et la disquette de drivers (il m'installait les pilotes...ok....et plus tard il me les redemandait sans les trouver).
La seule chose qui a résolu ce problème est un cd de XP avec les drivers sata inclus....
Bah....j'espère que ton adaptateur va bien marcher sinon a aura fait cher le disque sata+la carte+l'adaptateur!!!
Tcho^^

n°7048288
hhenri
Posté le 24-07-2009 à 16:39:32  profilanswer
 

Salut verbuate,
 
 

Citation :

Le fait que la carte sata soit plus récente que la CM ne change normalement rien à la détection (ma 1ere carte sata je l'avais branché en pci sur une A7N8X de 2001 env).


Très intéressant car le contraire m'a été dit par des ""spécialistes""...
 

Citation :

La seule chose qui a résolu ce problème est un cd de XP avec les drivers sata inclus....


Toute information est bonne à prendre. Peux tu m'expliquer comment tu as fait, que je fasse un essai préalable. As tu utilisé nlite et intégré les drivers fournis avec la carte sata-pci ?  
 

Citation :

....j'espère que ton adaptateur va bien marcher sinon a aura fait cher le disque sata+la carte+l'adaptateur!!!


Je suis un peu dans la vasouille sur ce coup là, mais il faut payer pour apprendre.  
- Pour le disque pas de pb il est prévu pour ma nouvelle tour.  
- Restent l'adaptateur et la carte qui ne représentent que de petites dépenses nécessaires à mon planning de développement.
  - Pour l'adaptateur, je vais faire un essai préalable avec un cd xp tel que tu l'indiques.  
  - Reste la carte. Dans une deuxième étape je prévois de passer ma nouvelle tour en raid. Mais il y a fort à parier que sur la nouvelle CM il y aura du pci-express...
 
cdlmt

n°7048861
Bred
Posté le 25-07-2009 à 05:00:37  profilanswer
 

yop,
 
Pour le cd d'XP, euh....je ne l'ai pas crée moi même (un pote me l'a passé), mais des tuto sur nlite doivent se trouver facilement (mais bon faut-il encore que la carte sata ainsi que le disque soit détectés).
Pour info sur ma CM il y a pci-express ET pci ;)
PS : comment on fait pour faire des citations??

n°7049743
hhenri
Posté le 26-07-2009 à 00:18:02  profilanswer
 

Salut verbuate,
 

Citation :

Pour le cd d'XP, euh....je ne l'ai pas crée moi même (un pote me l'a passé), mais des tuto sur nlite doivent se trouver facilement

 
Pour nlite pas de pb. J'ai utilisé un tuto c'est très simple ==> boote et install sans pb.
 

Citation :

(mais bon faut-il encore que la carte sata ainsi que le disque soit détectés).


C'est tout le problème. Suite à tes remarques j'ai contrôlé tous mes ports pci avec une carte témoin. Pas de pb ils sont tous bons.  
Le hic c'est que la carte sata-pci n'est pas reconnue par le bios. Et pourtant elle fonctionne. ==> lorsque le pilote est passé à l'os le disque sata est vu et accessible.
J'ai fais plusieurs essais en modifiant les paramètres de détection du bios, sans succès.  
Il faudrait trouver un bios plus ouvert (avec plus d'options) et compatible avec la CM. Ce n'est pas évident et je ne veux pas me prendre la tête avec ça, d'où l'adaptateur.
 

Citation :

comment on fait pour faire des citations??


Très simple, tu mets ta phrase entre balises.
 - Balise de début : [] crochets fermant et ouvrant, entre les crochets tu marques "quote"
 - Balise de fin : [/] crochets fermant et ouvrant avec slash ente les deux. Entre les crochets juste derrière le slash tu marque "quote".
 
cdlmt

n°7049807
Bred
Posté le 26-07-2009 à 01:58:38  profilanswer
 

salut,
 
Je ne comprends pas : si ton DD sata (via la carte controleur) est détecté à l'installation, tu ne devrais plus avoir besoin de l'adaptateur....

n°7051703
hhenri
Posté le 27-07-2009 à 19:08:26  profilanswer
 

Salut,
 

Citation :

...si ton DD sata (via la carte controleur) est détecté à l'installation, tu ne devrais plus avoir besoin de l'adaptateur....


Comme je le dis juste dans le post précédent, malgré toutes mes tentatives  elle n'est pas reconnue par le bios (contrôle des ports pci et modification adéquate des paramètres du bios).  
 
Cependant elle fonctionne. Après démarrage de l'os je vois le disque.
 
cdlmt

n°7051808
Bred
Posté le 27-07-2009 à 20:22:41  profilanswer
 

yop,
 
....au fait, j'ai jamais trouvé mes cartes controleur sata ou que ce soit dans le bios, je savais juste qu'elles étaient détectées via un nouvel "écran" pdt le démarrage^^.

n°7053381
hhenri
Posté le 28-07-2009 à 23:21:11  profilanswer
 

Salut,
 

Citation :

...j'ai jamais trouvé mes cartes controleur sata ou que ce soit dans le bios, je savais juste qu'elles étaient détectées via un nouvel "écran" pdt le démarrage.


Pour moi pas de démarrage et accessoirement pas d'écran. Et pourtant j'ai insisté.
 
cdlmt  

n°7058043
hhenri
Posté le 01-08-2009 à 22:48:28  profilanswer
 

Bonjour,
 
Je viens de récupérer l'adaptateur sata-ide double sens. Il a 2 canaux de compatibilité sata 1 et sata 2.  
 
- Sur le sata-2 le disque sata n'est pas reconnu par le bios.
- Sur le sata-1 le disque sata est reconnu. C'est bien la 1ère fois ! Mais au boote ça mouline plusieurs minutes puis j'ai le message <<Primary master hard disk fail>> cela sans code d'erreur. Puis si j'essaie d'installer l'Os  il ne trouve pas le dd.
 
Si vous avez une idée n'hésitez pas :??:
 
cdlmt
 

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Matériels & problèmes divers

  Installation driver DD Sata

 

Sujets relatifs
Problème appareils électroniques et installation électrique?démarrage hotplug DD esata uniquement si DD externe USB en service!!
Qui sait configuer le gestionnaire DD Realtek de Gygabyte?installation win impossible
probleme installation processeur core duo E8500Un DD pour l'OS, et un dd pour les applications ???
Problème pilotes sata - Vistatransfert fichier DD externe en esata qui plante
Problème DD externe : endommagé et illisibleDisque dur SATA I ou SATA II sur un compaq ??
Plus de sujets relatifs à : Installation driver DD Sata


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR