Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
468 connectés 

  FORUM HardWare.fr
  Hardware
  Disque dur

  Problème suite à un débranchement de disque d'une grappe RAID1

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème suite à un débranchement de disque d'une grappe RAID1

n°6870744
cimourdain
Posté le 04-03-2009 à 18:38:37  profilanswer
 

Bonjour à tous,
 
On m'a demandé de regarder un problème sur un PC.
Il y avait un message après le POST au démarrage de l'ordi indiquant une erreur critique.
 
Ce message est affiché par le BIOS d'une carte contrôleur RAID et dit qu'un des deux disques de la grappe est mort ou débranché (c'est du RAID1).
J'ai ouvert le PC et c'est effectivement le cas: un des deux disques SATA est débranché de la carte contrôleur. La carte ne comporte que deux connecteurs SATA. Rebrancher le disque n'a pas suffit, le problème reste le même.
Inutile de dire qu'avant que la personne débranche le disque et oublie de le rebrancher tout marchait bien. Ce RAID était destiné à sauvegarder en cas de crash d'un disque.
 
La carte est la suivante: PROMISE FastTrack TX 2300.
 
Voici le menu principale du BIOS de la carte:
 

Citation :

Main Menu
 
View Drive Assignment     [1]
Define LD                        [2]
Delete LD                        [3]
Controller Configuration   [4]


 
Déjà, savez vous à quoi correspond LD ?
 
Quand je rentre dans [1], voici ce que je vois:
 

Citation :

Channel: ID    Drive Model    Capacity    Assignment
1:           Mas  Samsung...      20004,9             LD1
2:           Mas  Samsung...      20004,9             Free


 
Dites moi si je me trompe mais j'interprète ça comme: le premier disque physique fait partie de la grappe LD1 (LD signifierait du coup grappe RAID), et le 2ème disque n'est dans aucune grappe.
 
D'où l'idée d'aller dans le menu [2] (Define LD) pour ajouter le disque que je viens de rebrancher dans la grappe LD1.
 
Voici ce que je vois quand je rentre dans ce menu:
 

Citation :

LD No        RAID Mode    Total Drv      Capacity     Status
LD 1          RAID 1          2                 19998,2     Critical
LD 2          _ _ _ _          _ _ _ _         _ _ _ _ _   _ _ _ _


 
Cela signifie, selon moi, que initialement la grappe RAID 1 contenait bien les deux disques (voir Total Drv = 2) et que la 2ème grappe (LD 2) n'est pas définie.
 
Jusque là tout semble aller.
Si j'appuie sur entrée sur la deuxième ligne, je vois alors:
 
 

Citation :

[Drive Assignments]
Channel: ID         Drive Model                  Capacity (MB)
1:           Mas       Samsung...                   20004,9
?:           ?           failed or disconnected


 
On voit donc bien que dans le LD1 il manque le 2ème disque, d'où le message alarmant. Et pourtant celui ci est bien rebranché sur la carte.
 
Le deuxième disque je ne peux que le mettre dans une nouvelle grappe apparement, impossible de le faire revenir dans celle qui existe déjà.
 
D'où l'idée du troisième menu (Delete LD): supprimer la grappe et tout recréer mais là, gros problème puisque le programme m'indique que si je continue, toutes les données des disques seront perdues ! Donc je suis bloqué.
 
 
Je suis vraiment surpris que débrancher un câble, utiliser le PC comme ça quelque temps et rebrancher le câble plus tard puisse poser un si gros problème ! Ne peut-on pas tout simplement rebranche le 2ème disque dur et lui dire de faire une nouvelle réplication de l'intégralité du premier et de revenir ainsi dans une situation normale ?
 
Merci pour votre aide.


Message édité par cimourdain le 04-03-2009 à 18:44:23
mood
Publicité
Posté le 04-03-2009 à 18:38:37  profilanswer
 

n°6873644
groux
Intolérant au sans Gluten!
Posté le 06-03-2009 à 17:51:44  profilanswer
 

LD ca veut dire Logical Disk : c'est effectivement ta grappe RAID.
 
Il te marque cette grappe comme Critical car comme un des disques a été débranchés, ils sont dé-synchronisés.
 
Je pense que tu doit avoir qquepart un menu te permettant de reconstruire (rebuild) ta grappe RAID .
 
Ou alors, peut être que dans ton menu Define LD tu peut redéfinir ta grappe RAID en lui spécifiant les deux disques; de cette façon il va reconstruire la grappe en re-synchronisant les deux disques.

n°6875298
cimourdain
Posté le 08-03-2009 à 00:37:09  profilanswer
 

Merci pour cette réponse, mais comme je l'ai expliqué, quand je vais dans le menu Define LD, il me propose de faire LD2 et ne me propose pas de modifier LD1.
Comment faire ?
 
Pensez vous que le fait d'installer l'utilitaire de gestion sous Windows pourrait permettre de faire des choses qu'on ne peut pas faire dans ce BIOS ?

n°6878365
cimourdain
Posté le 10-03-2009 à 15:08:57  profilanswer
 

up

n°6881026
cimourdain
Posté le 12-03-2009 à 16:38:25  profilanswer
 

encore un ptit up  :$

n°6886309
fikou
Posté le 17-03-2009 à 08:33:04  profilanswer
 

Bonjour,
Sous Windows server 2003
J'ai pratiquement le même prob que Cimourdain avec une carte Promise fastTrack sx4000.
J'ai changé les 2 DD, j'ai sauvegardé et restauré l'image disque.
Je n'arrive pas à resyncronisé ces deux disques.  
Le serveur fonctionne, aucunnes pertes de donnée.
Mais lors du boot, message indentique à celui de Cimourdain.
Je ne trouve pratiquement pas d'aide sur la carte promise qui est en ATA.
 
Si quelqu'un à une piste je suis preneur.
@+FikoU

n°6933438
T3K
Berserk Overkill Certified
Posté le 25-04-2009 à 02:40:28  profilanswer
 

Je répond très tardivement à ce topic, mais bon on sait jamais ^^
 
j'ai exactement la même carte dans une de mes machines
 
LD veut dire logical device.
Alors voilà comment ça se passe avec cette carte : quand un des disques est débranché, il ne fait plus partie de la grappe et est passé automatiquement en free, hors tout disque free est considéré comme un spare, donc en gros il n'y a rien à faire : rebrancher le disque, démarrer, la reconstruction commence 1 ou 2 minutes après le chargement du pilote de la carte. Si tu reboot par accident en milieu de reconstruction, ta LD sera en état rebuilding au moment du chargement du bios de la carte.
 
Il n'y a aucuns pb, tout fonctionne normalement.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Disque dur

  Problème suite à un débranchement de disque d'une grappe RAID1

 

Sujets relatifs
configuration disque dur externe dane elecProbleme fréquence p4 sur shuttle
Quel disque 1To pour SATA1Problême processeur instable depuis ati 4870
Problème avec graveur DVD sur pc portable...Erreur sur disque en RAID 0
Problème affichage vidéo sur TV LCD depuis PCAugmenter la taille d'un Array RAID1 ?
Problème carte graphique 
Plus de sujets relatifs à : Problème suite à un débranchement de disque d'une grappe RAID1


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR