Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2070 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Carte réseau paramétrée mais interruption de connexion

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Carte réseau paramétrée mais interruption de connexion

n°148271
hironieave​cunh
Qui peut le plus peut le moins
Posté le 07-08-2017 à 11:51:37  profilanswer
 

Bonjour à toutes et à tous,
 
Je suis actuellement sur un problème sur lequel je suis penché depuis plus d'une semaine.
En effet, j'ai un serveur Windows Server 2012 R2 avec deux cartes réseaux l'une donnant vers l'extérieur,
et une donnant vers le réseau interne.
 
Je tiens à mentionner qu'il n'y a pas de routage de paramétrer sur ce serveur.
 
Les deux cartes réseaux sont connectées sur un switch différent.
 
Les paramétrages IP des cartes sont en statiques et communique bien pendant quelques temps.
 
De plus, il y a d'installé un HYPER-V avec une machine virtuelle qui gère un serveur de données.
Cependant, d'où le nom du sujet, il y a des interruptions de connexions.
C'est-à-dire, table ARP vide et ping en délai d'attente dépassé.
 
Le seul moyen que j'ai trouvé pour revenir sur une connexion fonctionnelle est de redémarrer le serveur physique.
 
Cette solution n'étant pas quelque chose de très bon pour un serveur de production, je cherche une solution alternative,
réglant le problème définitivement.
 
Je tiens à préciser que ces anomalies apparaissent de façon aléatoire en règle général 1 fois par semaine et ce sur les deux interfaces,
mais pas forcément en même temps.
 
J'ai tenté bon nombre de manipulation :
- Désactiver la possibilité que Windows désactive la carte réseau pour économiser de l'énergie
- Ecouter le réseau à la recherche de trames signalant un problème quelconque
 
Je suis un peu désespéré du problème que je rencontre, je reste à votre disposition si vous avez besoin de plus de renseignements.
 
Cordialement, un gentil monsieur.

mood
Publicité
Posté le 07-08-2017 à 11:51:37  profilanswer
 

n°148272
loganfox
Posté le 07-08-2017 à 14:41:18  profilanswer
 

Et si tu désactive et réactive la ou les cartes réseaux ?


---------------
Le savoir est la seule matière qui s'accroît quand on la partage "Socrate"
n°148273
hironieave​cunh
Qui peut le plus peut le moins
Posté le 07-08-2017 à 14:45:00  profilanswer
 

loganfox a écrit :

Et si tu désactive et réactive la ou les cartes réseaux ?


 
J'ai effectivement oublié de mentionné que j'avais testé cette possibilité, mais hélas,
ça ne permet pas de relancer la connectivité de l'interface avec le réseau.

n°148275
Lone Morge​n
Forever HB
Posté le 07-08-2017 à 16:11:41  profilanswer
 

Recherche avec la marque et le modèle de la carte réseau
pour les broadcom par exemple il y a des paramètres a désactiver pour que la carte fonctionne correctement avec hyper-v.


---------------
In ITIL we trust.
n°148276
hironieave​cunh
Qui peut le plus peut le moins
Posté le 07-08-2017 à 16:25:13  profilanswer
 

Lone Morgen a écrit :

Recherche avec la marque et le modèle de la carte réseau
pour les broadcom par exemple il y a des paramètres a désactiver pour que la carte fonctionne correctement avec hyper-v.


 
Ok je vais orienter mes recherches là dessus, même si de mémoire les cartes réseaux sont des HP.
 
Vous pensiez à des paramètres ou options particulières par rapport à Hyper-V ?

n°148278
nnwldx
Posté le 07-08-2017 à 22:01:00  profilanswer
 

installe la dernière version du Service Pack for ProLiant (SPP) si ton serveur est un HP.

n°148279
okinawa02
Posté le 08-08-2017 à 07:56:04  profilanswer
 

Lone Morgen a écrit :

Recherche avec la marque et le modèle de la carte réseau
pour les broadcom par exemple il y a des paramètres a désactiver pour que la carte fonctionne correctement avec hyper-v.


 
Exact, avec une broadcom et Hyper-V, je devais désactiver la VMQ dans les paramètres de la carte réseau.
Sinon je perdais la connexion à mes VM de temps à autre, et ça revenait.

n°148280
hironieave​cunh
Qui peut le plus peut le moins
Posté le 08-08-2017 à 09:33:46  profilanswer
 

nnwldx a écrit :

installe la dernière version du Service Pack for ProLiant (SPP) si ton serveur est un HP.


 
Je ne suis pas très connaisseur de HP.
 
SP Proliant s'applique sur des serveur HPE avec iLO ou en passant par le SUM ?
 
Cette mise à jour ne modifiera pas les paramètres déjà appliqués ?
 
C'est un serveur en production et je suis un peu réticent à faire ce genre de manipulations.
 
Peut-être ai-je tort.

n°148281
hironieave​cunh
Qui peut le plus peut le moins
Posté le 08-08-2017 à 09:43:46  profilanswer
 

okinawa02 a écrit :


 
Exact, avec une broadcom et Hyper-V, je devais désactiver la VMQ dans les paramètres de la carte réseau.
Sinon je perdais la connexion à mes VM de temps à autre, et ça revenait.


 
Par VMQ, vous parlez de Virtual Machine Queues ou VMQ VLAN Filtering ?
 
Sachant que Virtual Machine Queues est activé et que VMQ VLAN Filtering est désactivé.
 
Je ne suis pas sûr que les cartes réseaux soient des Broadcom.

n°148282
Av3k
Posté le 08-08-2017 à 09:53:27  profilanswer
 

hironieavecunh a écrit :


 
Je ne suis pas très connaisseur de HP.
 
SP Proliant s'applique sur des serveur HPE avec iLO ou en passant par le SUM ?
 
Cette mise à jour ne modifiera pas les paramètres déjà appliqués ?
 
C'est un serveur en production et je suis un peu réticent à faire ce genre de manipulations.
 
Peut-être ai-je tort.


 
Tu passes par iLo pour appliquer le SP.
 
Le SP est une maj des firmwares de ton serveur, cela remplacera tous tes paramètres HW par ceux d'usine. Par contre ton Esxi ne sera pas impacté.
 
Quoiqu'il en soit ne fait pas une mise à jours du SP en production, mets ton hote en maintenance et applique le SP.

Message cité 1 fois
Message édité par Av3k le 08-08-2017 à 09:53:52
mood
Publicité
Posté le 08-08-2017 à 09:53:27  profilanswer
 

n°148283
hironieave​cunh
Qui peut le plus peut le moins
Posté le 08-08-2017 à 10:12:59  profilanswer
 

Av3k a écrit :


 
Tu passes par iLo pour appliquer le SP.
 
Le SP est une maj des firmwares de ton serveur, cela remplacera tous tes paramètres HW par ceux d'usine. Par contre ton Esxi ne sera pas impacté.
 
Quoiqu'il en soit ne fait pas une mise à jours du SP en production, mets ton hote en maintenance et applique le SP.


 
Ok, merci pour ces explications.
 
Cependant je ne suis pas sûr que ce problème vienne de cela, étant donné qu'il y a d'autres serveurs avec le même paramétrage/configuration  
 
lesquels sont plus anciens de quelques mois/années et n'ont aucuns problème de ce type.
 
Je tenterai tout de même d'effectuer ces mises à jours Firmware quand je le pourrai.


Message édité par hironieavecunh le 08-08-2017 à 10:15:04
n°148284
hironieave​cunh
Qui peut le plus peut le moins
Posté le 08-08-2017 à 10:34:19  profilanswer
 

https://support.microsoft.com/fr-fr [...] dcom-netxt
 
J'ai trouvé ce support sur le site officiel de Microsoft parlant de BroadCom et grâce à vos remarques sur le mélange
pas très catholique entre carte réseau BroadCom, hyperviseur Hyper-V et paramètre VMQ (en somme un beau cocktail).
 
Je vais tenter certaines manipulations proposées par Microsoft et je reviens vous voir pour vous dire si ça fonctionne.
 
Pendant ce temps, je vous remercie d'avance et n'hésitez pas à continuer de proposer des solutions, si jamais vous en connaissez.
 

n°148285
nnwldx
Posté le 08-08-2017 à 12:33:48  profilanswer
 

J'ai eu pas mal de problèmes réseau avec les hyper v et les serveurs HP.
Le SPP a corrigé cela, c'est sûr que cela fera un hors prod mais cela ne va pas changer la configuration.
Tu peux lancer la mise à jour depuis Windows.
Tu peux contacter HP si tu souhaites du support.

n°148299
Av3k
Posté le 09-08-2017 à 09:40:00  profilanswer
 

Je connais mal Hyper-V mais en tout cas passer le SPP ne peux que t'enlever des problèmes potentiels.
 
Si tu es frileux, passe le SPP en interactif et vois si il te propose une MAJ des interfaces réseaux et n'applique que ces correctifs pour voir si cela résoud ton problème.
 
Quoique tu fasses et si tu as besoin de support auprès d'HP, il faut que tes firmwares soient à jour donc ca ne coute rien de le faire :)


Message édité par Av3k le 09-08-2017 à 09:40:13
n°148615
hironieave​cunh
Qui peut le plus peut le moins
Posté le 25-08-2017 à 11:33:10  profilanswer
 

Mesdames et Messieurs,
 
Je suis heureux de vous annoncer que mon problème est résolu.  :bounce:  
 
En effet l'erreur venait bien du firmware non à jour de la carte réseau ce qui causait des perturbations à ce niveau.
 
Voici le lien de la carte réseau défaillante : https://www.hpe.com/us/en/product-c [...] 69168.html
 
Et voici le ticket Microsoft à ce sujet : https://support.microsoft.com/fr-fr [...] dcom-netxt
 
Comme énoncé dans le ticket Microsoft, pour résoudre ce problème il faut soit :
 
- Mettre à jour le firmware de la carte réseau ;
- Désactiver l'option VMQ de la carte réseau.
 
Voilà, j'espère que cela aidera d'autres personnes que moi rencontrant ce problème.
 
Je tiens à remercier toutes les personnes plus hauts qui m'ont donné des indications pour résoudre ce problème.
 
Merci à Hardware.fr et longue vie au réseau.  :jap:


Message édité par hironieavecunh le 25-08-2017 à 11:34:19

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Carte réseau paramétrée mais interruption de connexion

 

Sujets relatifs
[GPO] Ajouter un emplacement réseauDeux passerelles sur un réseau ?
connexion LDAP pour copieur multi fonctionProtection des données sur disque réseau
Besoin de conseil technique pour raccordement reseau pcWindows 2008 R2 - Code erreur 31 réseau
Box 4G + livebox sur même réseau. DHCP ???Nouveau NAS et perte de connexion
Connexion bureau à distance / Erreur session en cours [résolu] 
Plus de sujets relatifs à : Carte réseau paramétrée mais interruption de connexion



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR