Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1744 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  [RESOLU] Samba et non visibilité de dossier pour certains users

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

[RESOLU] Samba et non visibilité de dossier pour certains users

n°45193
Cr@zyV
Posté le 27-10-2008 à 21:09:03  profilanswer
 

Bonjour!
 
Voila j'ai quelques petits soucis avec la configuration de mon serveur samba.
Donc je suis sous Debian, et j'ai installer tout les packets samba comme il faut. J'ai essayer d'editer le fichier smb.conf mais je n'arrive pas a obtenir ce que je veux. Apres avoir longuement chercher sur le net, je n'ai trouver aucun cas de configuration comme le mien (peut être que ce n'est pas possible?)
Bref, j'ai un DD monté dans /mnt/hdb1 qui contient 2 dossiers:
-Projet
-backup
 
Donc dans le dossier backup, tout le monde dois pouvoir acceder a ce dossier et avoir les droits d'écriture dessus
A coté, dans le fichier Projet, j'aimerais qu'il soit en Read Only mais que lorsque je me connecte avec un Username/password spécial, il m'autorise a écrire dessus.
Je ne veux aps que les autres utilisateurs aient a connaitre un mot de passe et un username pour acceder aux ressources du disque.
 
Cordialement,
 
REbonjour!
J'ai un nouveau probleme avec Samba, je me permet de remonter ce post:
 
Alors maintenant j'ai partager bien tout mes dossier mais j'ai un probleme:
J'ai 2 utilisateurs, X et Y
J'ai un dossier "test" que je partage à l'aide de samba.
J'aimerais que X puisse voir le dossier "test" quand il se connecte avec son pw + user
mais que l'utilisateur Y ne voit pas le dossier "test" quand il se connecte.
 
Quand je met browseable = Yes, les deux utilisateurs peuvent voir le dossier
Quand je met browseable = No, les deux utilisateurs ne voient pas le dossier.
 
Quelqu'un peut il m'aider??
Cdlt


Message édité par Cr@zyV le 28-11-2008 à 17:16:39
mood
Publicité
Posté le 27-10-2008 à 21:09:03  profilanswer
 

n°45230
Cr@zyV
Posté le 28-10-2008 à 19:38:39  profilanswer
 

up!

n°45243
rgoezinn
Posté le 29-10-2008 à 10:34:23  profilanswer
 

Bonjour,
 
Pour administrer facilement SAMBA sans avoir à éditer violemment le fichier de config, essayez d'utiliser SWAT (Admin Samba par interface Web)
 
Rob

n°45259
Cr@zyV
Posté le 29-10-2008 à 13:20:21  profilanswer
 

SAlut!
Merci pour ton astuce Rob, c'est vrai que c'est beaucoup plus convivial! Seulement, je n'arrive toujorus pas a faire ce que je veux :(
Voila ce que je n'arrive pas a faire:
Un dossier Projet, ou les utilisateurs non authentifiés ai un accès de lecteure et d'execution seulement, alors que l'utilisateur "admin" par exemple ai un droit d'ecriture en plus dessus. Une petite aide pour ceci?

n°45283
Cr@zyV
Posté le 29-10-2008 à 19:23:48  profilanswer
 

re up

n°45324
Cr@zyV
Posté le 30-10-2008 à 20:22:13  profilanswer
 

UPPPP personne n'est calé en SAMBA??

n°45330
boobaka
Posté le 31-10-2008 à 08:23:20  profilanswer
 

La partie Os alternatif serait certainement plus adéquat...
Peux tu poster ton smb.conf + droits sur répertoires de ton DD amovible ?
Quel FS sur le DD ?
 
+


---------------
www.google.fr  
n°45341
Cr@zyV
Posté le 31-10-2008 à 13:11:56  profilanswer
 

Euh, FS ca veut dire quoi?
Le DD n'est pas amovible, et j'ai fais un chmod 755
Ce que je voudrais faire:
Lorsque qu'un PC 1 essaie d'acceder au serveur, celui ci lui demande un mot de passe et un username. Si la personne du PC1 laisse les champs vides, il a acces en LECTURE et EXECUTION seule au dossier projet.
En revanche, si la personne du PC1 possede un login et un pass que je lui aurait communiqué, elle aura acces en ECRITURE, en LECTURE et en EXECUTION au dossier projet.  
 
Je pense que c'est une simple configuration a faire, mais je n'y arrive pas :(
 
Cordialement,

n°45366
foobar47
Posté le 31-10-2008 à 17:07:52  profilanswer
 

FS = File System = Système de fichier
 
Avis perso : Laisse tomber les interfaces d'administration web and co, surtout sur du debian. Edite tes fichiers de configuration toi-même, ça t'évitera des ennuis par la suite.

n°45400
Cr@zyV
Posté le 01-11-2008 à 14:03:40  profilanswer
 

Mouai ok, jvais le faire a la main. Mais ca regle pas mon probleme!
Quels droits dois-je mettre? Quel option? (Share user)
dois je activer l'option map guest etc?
Mon FS est ext3
 
Cordialement, en esperant avoir des reponse complete!

mood
Publicité
Posté le 01-11-2008 à 14:03:40  profilanswer
 

n°45576
Cr@zyV
Posté le 04-11-2008 à 16:03:54  profilanswer
 

UPP

n°45582
boobaka
Posté le 04-11-2008 à 16:22:29  profilanswer
 

Cr@zyV a écrit :

Mouai ok, jvais le faire a la main. Mais ca regle pas mon probleme!
Quels droits dois-je mettre? Quel option? (Share user)
dois je activer l'option map guest etc?
Mon FS est ext3
 
Cordialement, en esperant avoir des reponse complete!


 :hello: ,
comme le dit le smb.conf :

Citation :

# "security = user" is always a good idea
 


Maintenant faudrait savoir ce que tu comptes faire exactement ... Parce que te conseiller avec si peu de details pourrait te mettre dans l'erreur .
++


---------------
www.google.fr  
n°45638
Cr@zyV
Posté le 05-11-2008 à 12:48:24  profilanswer
 

"Bref, j'ai un DD monté dans /mnt/hdb1 qui contient 2 dossiers:
-Projet
-backup
 
Donc dans le dossier backup, tout le monde dois pouvoir acceder a ce dossier et avoir les droits d'écriture dessus
A coté, dans le fichier Projet, j'aimerais qu'il soit en Read Only mais que lorsque je me connecte avec un Username/password spécial, il m'autorise a écrire dessus.
Je ne veux pas que les autres utilisateurs aient a connaitre un mot de passe et un username pour acceder aux ressources du disque.
 
Cordialement,"
 
Désolé mais que veux tu que j'ajoute de plus!!
Je pense etre assez complet dans ma question!!
Cordialement,

n°45639
boobaka
Posté le 05-11-2008 à 14:20:40  profilanswer
 

Tu es en domaine ou en worgroup ?  
Combien d'utilisateurs ?  
 
Tu veux un tutorial ou tu veux essayer par toi même ?
 
Tu te mets en security = user
tu mets ton répertoires backup en 777 ( accès complet pout tout le monde) !// garde en tête le paquet acl quand tu seras embêter pour la suite
 
Tu mets ton répertoire projet en chmod 755, tu crées un user sur ton linux avec le même nom que ton user windows (user pour l'exemple) puis  
chown user projet
et smbpasswd -a user
et lui lui colles le même password que sous windows ...
 
Ca devrait rouler  


---------------
www.google.fr  
n°45644
Cr@zyV
Posté le 05-11-2008 à 14:53:29  profilanswer
 

Enfin une aide utile =D
Alors, je suis en workgroup, 1 utilisateur ayant accès total a Projet, le reste en droit de lecture seulement sur le dossier.
Je veux bien un ptit tuto :P
J'ai fait tout ce que tu m'a dit, mais meme après avoir essayer de me connecter au server avec la session "user" avec le apss "toto" sous windows, je n'ai que "Imprimante et télécopieurs"
 
Merci pour ton aide. Tu recommande desinstallation complete de swat et de samba?
Cordialement,
 
EDIT: vla mon smb cfg
 

Code :
  1. # Samba config file created using SWAT
  2. # from 192.168.1.2 (192.168.1.2)
  3. # Date: 2008/10/30 21:43:29
  4. [global]
  5. server string = Serveur de fichier
  6. security = user
  7. passwd program = /usr/bin/passwd %u
  8. passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
  9. syslog = 0
  10. log file = /var/log/samba/log.%m
  11. max log size = 1000
  12. dns proxy = No
  13. ldap ssl = no
  14. panic action = /usr/share/samba/panic-action %d
  15. invalid users = root
  16. include = /etc/samba/dhcp.conf
  17. [projets]
  18. path = /home/manzana/projets
  19. guest ok = Yes
  20. available = No


Message édité par Cr@zyV le 05-11-2008 à 14:58:49
n°45645
boobaka
Posté le 05-11-2008 à 14:58:20  profilanswer
 

Le tuto c'etait sur le ton de l'humour, je t'ai deja bien maché le travail ...
 

Citation :

je n'ai que "Imprimante et télécopieurs
 


 [:antoni]  
il faut quand même remplir le fichier smb.conf pour lui dire quel répertoires tu partages par ex
 

[Projet]
path = /home/projet
writable = yes
browseable = yes


la même avec backup ...
 
Quant à swat, je ne conseille pas, je trouve qu'il est préférable de mettre les mains direcetment dans le smb.conf puis de tester avec testparm ... enfin quand les gens sont motivés  [:puncherello]


---------------
www.google.fr  
n°45750
Cr@zyV
Posté le 06-11-2008 à 18:46:02  profilanswer
 

Ok! Merci bien ca marche niquel!!
Maintenant j'ai un autre problème: je ne peut pas écrire dans les sous dossier quand je me logue en tant que "user" sur le serveur samba!
Je peux écrire dans le dossier Projet mais pas dans le sous dossier Projet/test  
Merci pour ton aide!
 
EDIT: Resolu, je m'etait planté en tapant mes commandes "chown"
 
Merci bien


Message édité par Cr@zyV le 06-11-2008 à 18:50:33
n°46030
Cr@zyV
Posté le 14-11-2008 à 20:51:25  profilanswer
 

REbonjour!
J'ai un nouveau probleme avec Samba, je me permet de remonter ce post:
 
Alors maintenant j'ai partager bien tout mes dossier mais j'ai un probleme:
J'ai 2 utilisateurs, X et Y
J'ai un dossier "test" que je partage à l'aide de samba.
J'aimerais que X puisse voir le dossier "test" quand il se connecte avec son pw + user
mais que l'utilisateur Y ne voit pas le dossier "test" quand il se connecte.
 
Quand je met browseable = Yes, les deux utilisateurs peuvent voir le dossier
Quand je met browseable = No, les deux utilisateurs ne voient pas le dossier.
 
Quelqu'un peut il m'aider??
Cdlt

n°46031
sohiermdp
Posté le 14-11-2008 à 21:33:13  profilanswer
 

bah c'est un peu normal... après c'est de la gestion de groupe au niveau de samba. X appartient à un groupe et Y appartient à un autre groupe, ou alors c'est de la gestion d'utilisateurs...
il me semble qu'en ajoutant le paramètres "users only = x" et "users only = Y" dans les partages ca fonctionne... mais c'est lointain...

n°46036
splurf
Rm -Rf / && oops :o
Posté le 14-11-2008 à 22:53:46  profilanswer
 

map to guest ...
force user ....
valid users ....
....

n°46058
Cr@zyV
Posté le 15-11-2008 à 18:48:38  profilanswer
 

splurf a écrit :

map to guest ...
force user ....
valid users ....
....


 
Euh Spurlf, je comprend rien ^^
Explique ce que t'écris stp!!

n°46062
splurf
Rm -Rf / && oops :o
Posté le 15-11-2008 à 19:20:05  profilanswer
 

as tu regardé dans les pages man de smb.conf ?
Regarde la description des options que je t'ai indiquées

n°46063
Cr@zyV
Posté le 15-11-2008 à 19:30:08  profilanswer
 

Je crois que tu n'as pas très bien compris ce que j'essai de faire.
Je veux que quand l'utilisateur X se connecte avec son password et son login, il ne puisse VOIR le dossier "test" dans la liste des partages.
En revanche, je veux que l'utilisateur Y, quand il se connecte, puisse voir le dossier "test" pour y acceder.
 
En gros, j'aimerais le même systeme que les dossiers "homes" (chaque users peut voir SEULEMENT son dossier HOME et pas celui des autres)
 
C'est bon :P??
Cordialement,

n°46067
splurf
Rm -Rf / && oops :o
Posté le 15-11-2008 à 23:22:23  profilanswer
 


       hide unreadable (S)
 
           This parameter prevents clients from seeing the existance of files that cannot be read. Defaults to off.
 
           Default: hide unreadable = no

n°46069
Cr@zyV
Posté le 15-11-2008 à 23:55:30  profilanswer
 

J'ai ajouter hide unreadable a mon global mais ca marche toujorus pas... L'utilisateur arrive toujours a voir les dossiers qui ne lui sont pas destinés.
Jbalance mon smb.conf
 

Code :
  1. [global]
  2. server string = Serveur de fichier
  3. passwd program = /usr/bin/passwd %u
  4. passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
  5. syslog = 0
  6. log file = /var/log/samba/log.%m
  7. max log size = 1000
  8. dns proxy = No
  9. ldap ssl = no
  10. panic action = /usr/share/samba/panic-action %d
  11. invalid users = root
  12. include = /etc/samba/dhcp.conf
  13. use client driver = yes
  14. load printers = yes
  15. printing = cups
  16. printer admin = root
  17. printcap name = cups
  18. hide unreadable = Yes
  19. [Films]
  20. path = mnt/hdb1/movies
  21. read only = No
  22. guest ok = Yes
  23. [App]
  24. path = mnt/hdb1/game+app
  25. read only = No
  26. guest ok = Yes
  27. [Dossier publique]
  28. path = mnt/hdb1/public
  29. read only = No
  30. guest ok = Yes
  31. [Stockage]
  32. path = /mnt/hdb1/stockage
  33. valid users = admin manzana
  34. writeable = yes
  35. write list = admin manzanaes
  36. hide unreadable = Yes
  37. browseable = Yes
  38. [homes]
  39. path = mnt/hda6
  40. read only = No
  41. browseable = No
  42. [printers]
  43. comment = Imprimantes
  44. path = /var/spool/samba
  45. guest ok = yes
  46. public = yes
  47. printable = Yes
  48. printer name = Canoni455


Message édité par Cr@zyV le 15-11-2008 à 23:55:48
n°46070
splurf
Rm -Rf / && oops :o
Posté le 15-11-2008 à 23:59:12  profilanswer
 

si tu donnais le nom de tes utilisateurs et montrais un ls -al des répertoires concernés ça serait pas mal aussi

n°46071
Cr@zyV
Posté le 16-11-2008 à 00:15:55  profilanswer
 

Commande ls -al du dossier Stockage
 
drwxr-xr-x  4 admin root  4096 2008-11-15 18:45 .
drwxrwxrwx  9 root  root  4096 2008-11-14 20:59 ..
drwxr-xr-x 24 admin admin 4096 2008-11-15 18:24 Backup Constance
drwxr-xr-x 20 admin admin 4096 2008-11-15 18:38 Project
 
2 utilisateurs enregsitré avec smbpasswd;
admin (celui qui doit tout voir, protégé par MDP)
utilisateur (celui qui ne doit pas voir "Stockage", ne possede pas de password smb)

n°46072
splurf
Rm -Rf / && oops :o
Posté le 16-11-2008 à 00:44:47  profilanswer
 

Rends toi dans le dossier Stockage
chmod 700 .

n°46080
Cr@zyV
Posté le 16-11-2008 à 13:16:33  profilanswer
 

Ne fonctionne toujours pas. Je vois toujours le dossier Stockage quand je suis loggé avec l'utilisateur "utilisateur"

n°46081
splurf
Rm -Rf / && oops :o
Posté le 16-11-2008 à 15:06:16  profilanswer
 

fais un ls -al du dossier stockage

n°46082
Cr@zyV
Posté le 16-11-2008 à 16:05:46  profilanswer
 

FileServer:/mnt/hdb1/stockage# ls -al
total 16
drwx------  4 admin root  4096 2008-11-15 18:45 .
drwxrwxrwx 11 root  root  4096 2008-11-16 15:17 ..
drwxr-xr-x 24 admin admin 4096 2008-11-15 18:24 Backup Constance
drwxr-xr-x 20 admin admin 4096 2008-11-15 18:38 Projet

n°46084
splurf
Rm -Rf / && oops :o
Posté le 16-11-2008 à 16:31:56  profilanswer
 

es tu sur d'avoir rechargé samba depuis les modifs sur la conf ?

n°46085
Cr@zyV
Posté le 16-11-2008 à 20:35:02  profilanswer
 

Oui, samba rechargé et serveur redémarrer ensuite.
Cdlt

n°46087
splurf
Rm -Rf / && oops :o
Posté le 16-11-2008 à 22:00:08  profilanswer
 

Es tu sur de te connecter sur la machine windows avec des noms d'utilisateurs samba ?
 
As tu utilisé smbpasswd -a nom_utilisateur ?

n°46108
Cr@zyV
Posté le 17-11-2008 à 17:26:42  profilanswer
 

Oui, j'ai fait smbpasswd -a name_users, sauf que pour l'utilisateur, je n'ai pas mis de mdp pour ce compte, car je ne veux pas compliquer la tache de connexion au serveur avec en plus un mot de passe. On aime aps trop taper souvent les mot de passe de part chez nous ;)
Cdlt

n°46110
splurf
Rm -Rf / && oops :o
Posté le 17-11-2008 à 19:37:12  profilanswer
 

logues toi avec 2 machines différentes sur ton serveur samba
chacune avec un user différent
 
et montre nous la sortie de la commande suivante:
smbstatus

n°46115
Cr@zyV
Posté le 17-11-2008 à 21:27:14  profilanswer
 

WARNING: The "printer admin" option is deprecated
 
Samba version 3.0.24
PID     Username      Group         Machine
-------------------------------------------------------------------
 4311   utilisateur        utilisateur        lp-3800      (192.168.1.2)
 4311   admin         admin         lp-3800      (192.168.1.2)
 
Service      pid     machine       Connected at
-------------------------------------------------------
Projet        4322   fileserver    Mon Nov 17 21:13:45 2008
Projet        4311   lp-3800       Mon Nov 17 21:16:40 2008
IPC$         4311   lp-3800       Mon Nov 17 21:16:37 2008
Projet        4311   lp-3800       Mon Nov 17 21:17:34 2008
IPC$         4311   lp-3800       Mon Nov 17 21:17:31 2008
Racine       4311   lp-3800       Mon Nov 17 21:13:10 2008
IPC$         4320   fileserver    Mon Nov 17 21:13:27 2008
 
Locked files:
Pid          Uid        DenyMode   Access      R/W        Oplock           SharePath   Name   Time
--------------------------------------------------------------------------------------------------
4311         1001       DENY_WRITE 0x20089     RDONLY     NONE             /mnt/hdb1/projet   Arnaque.mp3   Mon Nov 17 21:16:52 2008
4311         1004       DENY_NONE  0x100001    RDONLY     NONE             /mnt/hdb1/projet   .   Mon Nov 17 21:17:34 2008
4311         1004       DENY_WRITE 0x20089     RDONLY     NONE             /mnt/hdb1/projet   Bruce.mp3  Mon Nov 17 21:17:38 2008

n°46116
splurf
Rm -Rf / && oops :o
Posté le 17-11-2008 à 21:43:02  profilanswer
 

ton pc lp-3800 est de quel type ?
 
XP, Vista, 2003 ?
 
Tu as 2 users connectés sur la *meme* machine ?

n°46123
Cr@zyV
Posté le 18-11-2008 à 07:54:52  profilanswer
 

Meme machine, mais sessions différentes, donc connectés avec des users différents. Windows XP SP3 pour lp-3800.
lp-3800 est un pc fixe.
Cdlt

n°46125
splurf
Rm -Rf / && oops :o
Posté le 18-11-2008 à 09:01:20  profilanswer
 

samba est lancé en demon ou via inetd ?
 
ce qui est bizare est le pid identique des process
 
c'est quelle distrib ?

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  [RESOLU] Samba et non visibilité de dossier pour certains users

 

Sujets relatifs
(RESOLU) Renseignement sur le serveur nagios (sous Debian)Soucis FTP avec Routeur [RESOLU]
Question pour controleur de domaine samba.[Résolu] Clonage dans VMware Server 2 ?
Inactivite du disque dur a certains momentsDroits sur un dossier - groupe
Serveur DHCP 2003 / Erreur 1003 sur XP [Résolu][Résolu]Mise à zéro d'un switch 3Com SuperStack3 3870
Plus de sujets relatifs à : [RESOLU] Samba et non visibilité de dossier pour certains users


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR