Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
945 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Serveur zabbix en fonction : Non

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Serveur zabbix en fonction : Non

n°110040
Marine6259
Posté le 24-04-2013 à 11:25:33  profilanswer
 

Bonjour à tous,
 
mon problème est le suivant,
 
j'ai installé sur un serveur virtuel, le logiciel de supervision Zabbix.
Je me suis aidée de ce tuto :http://wiki.monitoring-fr.org/zabb [...] es-sources
 
Malheureusement, quand je me connecte avec admin (username) et zabbix (password) pour accéder à zabbix, dans l'interface du tableau de bord, l'état du serveur zabbix est indiqué comme non fonctionnel.
 
Pourtant, j'ai bien démarré le service:
 
root@ubuntu-virtuel:~# /etc/init.d/zabbix-server start
 * Starting zabbix_server                                                                    [ OK ]  
 
Dans mon fichier zabbix_server.conf, voici les données que j'ai renseigné :
 
DBName=zabbix
DBUser=zabbix
DBPassword=zabbix
 
Et mon fichier zabbix.conf.php se présente de la manière suivante :
 
<?php
// Zabbix GUI configuration file
global $DB;
 
$DB['TYPE']     = 'MYSQL';
$DB['SERVER']   = 'localhost';
$DB['PORT']     = '0';
$DB['DATABASE'] = 'zabbix';
$DB['USER']     = 'zabbix';
$DB['PASSWORD'] = 'zabbix';
 
// SCHEMA is relevant only for IBM_DB2 database
$DB['SCHEMA'] = '';
 
$ZBX_SERVER      = '@ip de mon serveur';
$ZBX_SERVER_PORT = '10051';
$ZBX_SERVER_NAME = '';
 
$IMAGE_FORMAT_DEFAULT = IMAGE_FORMAT_PNG;
?>
 
Quand je me connecte à la base de données, quand j'exécute la commande SELECT user, host FROM mysql.user; voici ce que j'obtiens :
 
+------------------+----------------+
| user             | host           |
+------------------+----------------+
| root             | 127.0.0.1      |
| root             | ::1            |
|                  | localhost      |
| debian-sys-maint | localhost      |
| root             | localhost      |
| zabbix           | localhost      |
|                  | ubuntu-virtuel |
| root             | ubuntu-virtuel |
+------------------+----------------+
8 rows in set (0.00 sec)
 
 
J'ai remarqué également que dans les logs, j'ai une erreur que je ne comprends pas :
 
20037:20130424:112102.855 [Z3001] connection to database 'zabbix' failed: [1045] Access denied for user 'zabbi'@'localhost' (using password: YES)
 20037:20130424:112102.855 Database is down. Reconnecting in 10 seconds.
 
Comme vous pouvez le voir dans la base de données, je n'ai pas d'utilisateur zabbi alors je ne comprends pas.
Le problème doit certainement venir de là mais je ne vois pas ce que je pourrais faire pour y remédier.
 
Est-ce que vous pouvez m'aider svp ?
 
 

mood
Publicité
Posté le 24-04-2013 à 11:25:33  profilanswer
 

n°110056
le capitai​ne lamar
Posté le 24-04-2013 à 13:00:39  profilanswer
 

tu dois avoir une erreur dans le paramétrage de l'utlisateur de la db c'est zabbix et non zabbi du moins si tu as suivi la doc de zabbix.

n°110080
Marine6259
Posté le 24-04-2013 à 14:53:49  profilanswer
 

le capitaine lamar a écrit :

tu dois avoir une erreur dans le paramétrage de l'utlisateur de la db c'est zabbix et non zabbi du moins si tu as suivi la doc de zabbix.


 
 
Pourtant je ne pense pas avoir fait d'erreur, quand je regarde les utilisateurs de la base, il n'y a aucun 'zabbi'.

n°110182
dohkoo001
Posté le 26-04-2013 à 16:31:14  profilanswer
 

Citation :

20037:20130424:112102.855 [Z3001] connection to database 'zabbix' failed: [1045] Access denied for user 'zabbi'@'localhost' (using password: YES)
 20037:20130424:112102.855 Database is down. Reconnecting in 10 seconds.


 
Tu devrais vérifier dans ce fichier de conf : /usr/local/zabbix/etc/zabbix_server.conf  
Il faut que tu retrouves la ligne DBUser=zabbix  et non zabbi.
 
Si ce n'est pas ça, vérifies que ton utilisateur zabbix ait bien les droits sur la base de données.

n°110498
Marine6259
Posté le 06-05-2013 à 16:34:37  profilanswer
 

dohkoo001 a écrit :

Citation :

20037:20130424:112102.855 [Z3001] connection to database 'zabbix' failed: [1045] Access denied for user 'zabbi'@'localhost' (using password: YES)
 20037:20130424:112102.855 Database is down. Reconnecting in 10 seconds.


 
Tu devrais vérifier dans ce fichier de conf : /usr/local/zabbix/etc/zabbix_server.conf  
Il faut que tu retrouves la ligne DBUser=zabbix  et non zabbi.
 
Si ce n'est pas ça, vérifies que ton utilisateur zabbix ait bien les droits sur la base de données.


 
 
Mon DBUser est bien zabbix et non zabbi.
Mon utilisateur a bien tous les droits sur la base de données.
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Serveur zabbix en fonction : Non

 

Sujets relatifs
Quel solution serveur pour une PME ?basoin d'aide pour serveur proxy avec trois WAN
Dimensionnement serveur impressionremettre la config usine pré-installée serveur Dell
(Résolu) Configurer plusieurs serveur de temps sous WS2003Mon serveur DELL Poweredge 1800 ne démarre plus
Serveurs pour accueillir AD/ExchangeAcces simultané à plusieurs serveurs VPN ?
Serveur 2008 - Le nom du compte cible est incorrecteDDoS sur mon serveur
Plus de sujets relatifs à : Serveur zabbix en fonction : Non


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR