Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1698 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Infrastructures serveurs

  Problème de réplication DNS/AD

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème de réplication DNS/AD

n°110713
mftech
Posté le 13-05-2013 à 14:25:31  profilanswer
 

Bonjour à tous
 
Je rencontre un petit problème de non réplication des données DNS/AD sur un mes serveur. Deux trois mots sur la typologie.
 
Au siège, 2 serveur 2K3 avec DNS/AD. Sur le site distant un serveur 2k avec DNS/AD (réplication depuis le siège). Je me suis rendu compte récemment que la réplication ne se faisait plus car la résolution DNS de certaines machines ne fonctionnait plus.
 
Le site distant est bien déclaré dans Site et Service AD.
 
D'après la doc MS un dcdiag + un netdiag peuvent aider à trouver le problème.
 
 
dcdiag :

Citation :


Domain Controller Diagnosis
 
Performing initial setup:
   Done gathering initial info.
 
Doing initial required tests
   
   Testing server: SaintLouis\ULYSSE
      Starting test: Connectivity
         ......................... ULYSSE passed test Connectivity
 
Doing primary tests
   
   Testing server: SaintLouis\ULYSSE
      Starting test: Replications
        [Replications Check,ULYSSE] A recent replication attempt failed:
            From STRG-SERVER-03 to ULYSSE
            Naming Context: CN=Schema,CN=Configuration,DC=mfa,DC=local
            The replication generated an error (5):
            Accès refusé.

            The failure occurred at 2013-05-11 12:11.10.
            The last success occurred at 2012-02-05 23:50.36.
            11016 failures have occurred since the last success.
         [Replications Check,ULYSSE] A recent replication attempt failed:
            From STRG-SERVER-03 to ULYSSE
            Naming Context: CN=Configuration,DC=mfa,DC=local
            The replication generated an error (5):
            Accès refusé.

            The failure occurred at 2013-05-11 12:11.10.
            The last success occurred at 2012-02-05 23:50.36.
            11016 failures have occurred since the last success.
         [Replications Check,ULYSSE] A recent replication attempt failed:
            From STRG-SERVER-03 to ULYSSE
            Naming Context: DC=mfa,DC=local
            The replication generated an error (5):
            Accès refusé.

            The failure occurred at 2013-05-11 12:11.10.
            The last success occurred at 2012-02-05 23:50.36.
            11016 failures have occurred since the last success.
         ......................... ULYSSE passed test Replications
      Starting test: NCSecDesc
         ......................... ULYSSE passed test NCSecDesc
      Starting test: NetLogons
         ......................... ULYSSE passed test NetLogons
      Starting test: Advertising
         ......................... ULYSSE passed test Advertising
      Starting test: KnowsOfRoleHolders
         [STRG-SERVER-03] DsBind() failed with error -2146893022,
         Le nom principal de la cible n'est pas correct..
         Warning: STRG-SERVER-03 is the Schema Owner, but is not responding to DS RPC Bind.
         [STRG-SERVER-03] LDAP bind failed with error 31,
         Un périphérique attaché au système ne fonctionne pas correctement..
         Warning: STRG-SERVER-03 is the Schema Owner, but is not responding to LDAP Bind.
         Warning: STRG-SERVER-03 is the Domain Owner, but is not responding to DS RPC Bind.
         Warning: STRG-SERVER-03 is the Domain Owner, but is not responding to LDAP Bind.
         Warning: STRG-SERVER-03 is the PDC Owner, but is not responding to DS RPC Bind.
         Warning: STRG-SERVER-03 is the PDC Owner, but is not responding to LDAP Bind.
         Warning: STRG-SERVER-03 is the Rid Owner, but is not responding to DS RPC Bind.
         Warning: STRG-SERVER-03 is the Rid Owner, but is not responding to LDAP Bind.
         Warning: STRG-SERVER-03 is the Infrastructure Update Owner, but is not responding to DS RPC Bind.
         Warning: STRG-SERVER-03 is the Infrastructure Update Owner, but is not responding to LDAP Bind.
         ......................... ULYSSE failed test KnowsOfRoleHolders

      Starting test: RidManager
         [ULYSSE] DsBindWithCred() failed with error -2146893022. Le nom principal de la cible n'est pas correct.
         ......................... ULYSSE failed test RidManager
      Starting test: MachineAccount
         ......................... ULYSSE passed test MachineAccount
      Starting test: Services
         ......................... ULYSSE passed test Services
      Starting test: ObjectsReplicated
         ......................... ULYSSE passed test ObjectsReplicated
      Starting test: frssysvol
         There are errors after the SYSVOL has been shared.
         The SYSVOL can prevent the AD from starting.
         ......................... ULYSSE passed test frssysvol
      Starting test: kccevent
         An Warning Event occured.  EventID: 0x800004F1
            Time Generated: 05/11/2013   12:11:07
            (Event String could not be retrieved)
         An Warning Event occured.  EventID: 0x800004F1
            Time Generated: 05/11/2013   12:11:07
            (Event String could not be retrieved)
         An Warning Event occured.  EventID: 0x800004F1
            Time Generated: 05/11/2013   12:11:07
            (Event String could not be retrieved)
         ......................... ULYSSE failed test kccevent
      Starting test: systemlog
         An Error Event occured.  EventID: 0x0000165B
            Time Generated: 05/11/2013   11:34:35
            (Event String could not be retrieved)
         ......................... ULYSSE failed test systemlog
   
   Running enterprise tests on : mfa.local
      Starting test: Intersite
         ......................... mfa.local passed test Intersite
      Starting test: FsmoCheck
         ......................... mfa.local passed test FsmoCheck


 
J'ai mis en gras les éléments les plus "inquiétants"
 
 
netdiag :
 

Citation :


 
......................................
 
    Computer Name: ULYSSE
    DNS Host Name: ULYSSE.mfa.local
    System info : Windows 2000 Server (Build 2195)
    Processor : x86 Family 15 Model 2 Stepping 7, GenuineIntel
    List of installed hotfixes :  
        KB823559
        KB823980
        KB893803v2
        KB957097
        KB958215-IE6SP1-20081016.120000
        KB958644
        KB958687
        KB960714-IE6SP1-20081211.120000
        Q147222
        Q818043
 
 
Netcard queries test . . . . . . . : Passed
    GetStats failed for 'Parallèle direct'. [ERROR_NOT_SUPPORTED]
    GetStats failed for 'Miniport réseau étendu (PPTP)'. [ERROR_GEN_FAILURE]
    [WARNING] The net card 'Miniport réseau étendu (IP)' may not be working because it has not received any packets.
    [WARNING] The net card 'Miniport réseau étendu (Moniteur réseau)' may not be working because it has not received any packets.
    GetStats failed for 'Miniport réseau étendu (L2TP)'. [ERROR_NOT_SUPPORTED]
 
 
 
Per interface results:
 
    Adapter : Connexion au réseau local
 
        Netcard queries test . . . : Passed
 
        Host Name. . . . . . . . . : ULYSSE
        IP Address . . . . . . . . : 192.168.11.100
        Subnet Mask. . . . . . . . : 255.255.255.0
        IP Address . . . . . . . . : 192.168.11.1
        Subnet Mask. . . . . . . . : 255.255.255.0
        Default Gateway. . . . . . : 192.168.11.252
        Dns Servers. . . . . . . . : 192.168.11.100
                                     192.168.0.8
 
 
        AutoConfiguration results. . . . . . : Passed
 
        Default gateway test . . . : Passed
 
        NetBT name test. . . . . . : Passed
 
        WINS service test. . . . . : Skipped
            There are no WINS servers configured for this interface.
 
 
Global results:
 
 
Domain membership test . . . . . . : Passed
 
 
NetBT transports test. . . . . . . : Passed
    List of NetBt transports currently configured:
        NetBT_Tcpip_{2AA2A5C2-D33F-451C-85FC-E5A759027D2B}
    1 NetBt transport currently configured.
 
 
Autonet address test . . . . . . . : Passed
 
 
IP loopback ping test. . . . . . . : Passed
 
 
Default gateway test . . . . . . . : Passed
 
 
NetBT name test. . . . . . . . . . : Passed
 
 
Winsock test . . . . . . . . . . . : Passed
 
 
DNS test . . . . . . . . . . . . . : Failed
              [FATAL]: The DNS registration for 'ULYSSE.mfa.local' is incorrect on all DNS servers.
    PASS - All the DNS entries for DC are registered on DNS server '192.168.11.100' and other DCs also have some of the names registered.
    [WARNING] The DNS entries for this DC are not registered correctly on DNS server '192.168.0.8'. Please wait for 30 minutes for DNS server replication.
 
 
Redir and Browser test . . . . . . : Passed
    List of NetBt transports currently bound to the Redir
        NetBT_Tcpip_{2AA2A5C2-D33F-451C-85FC-E5A759027D2B}
    The redir is bound to 1 NetBt transport.
 
    List of NetBt transports currently bound to the browser
        NetBT_Tcpip_{2AA2A5C2-D33F-451C-85FC-E5A759027D2B}
    The browser is bound to 1 NetBt transport.
 
 
DC discovery test. . . . . . . . . : Passed
 
 
DC list test . . . . . . . . . . . : Passed
 
 
Trust relationship test. . . . . . : Passed
    Secure channel for domain 'MFA' is to '\\strg-server-03.mfa.local'.
 
 
Kerberos test. . . . . . . . . . . : Passed
 
 
LDAP test. . . . . . . . . . . . . : Passed
 
 
Bindings test. . . . . . . . . . . : Passed
 
 
WAN configuration test . . . . . . : Skipped
    No active remote access connections.
 
 
Modem diagnostics test . . . . . . : Passed
 
IP Security test . . . . . . . . . : Passed
    IPSec policy service is active, but no policy is assigned.
 
 
The command completed successfully
 


 
Question : Je soupçonne fortement mon DNS d’être dans les choux. Si je supprime le rôle DNS, et que je le réinstalle dans la foulée est ce qu'il y a un risque de pertes de données ? Un DCPROMO est nécessaire pour re-interfacer le DNS avec AD ? Une réinstallation complète d'AD est à prévoir ?  
 
Merci d'avance.
 
Cordialement  

mood
Publicité
Posté le 13-05-2013 à 14:25:31  profilanswer
 

n°110715
boobaka
Posté le 13-05-2013 à 14:34:27  profilanswer
 

Effectivement, en regardant en diagonale il me semble que tous tes rôles fsmo sont contenu sur STRG-SERVER-03 mais ne semble pas accessible de la machine d’où tu lances de dcdiag ...

 

Tu résouds ? Tu pings ?


Message édité par boobaka le 13-05-2013 à 15:23:31

---------------
www.google.fr  
n°110717
mftech
Posté le 13-05-2013 à 15:12:05  profilanswer
 

La résolution et le ping depuis le serveur distant vers le strg-server-03 est OK

n°110719
boobaka
Posté le 13-05-2013 à 15:26:17  profilanswer
 

STRG-SERVER-03 to ULYSSE .... Et he DNS registration for 'ULYSSE.mfa.local' is incorrect on all DNS servers.  
Firewall ?  
Tu as clairement un soucis de resolution de nom et/ou site et/ou adressage ??


---------------
www.google.fr  
n°110721
Je@nb
Modérateur
In ze cloud
Posté le 13-05-2013 à 15:31:56  profilanswer
 

tu as ce soucis depuis combien de temps (basé sur les logs, pas à l'intuition hein)
les dates de l'attribut lastpasswordchanged et whenmodified des 2 comptes ordinateurs des DC est-elle identique sur chaque dc que tu regardes ?
tu peux binder via ldp le service ldap de chaque dc depuis l'autre ? (ou fait un portquery de chaque dc vers chaque dc pour les services rpc, ldap, dns and co)

n°110726
nebulios
Posté le 13-05-2013 à 20:27:40  profilanswer
 

Citation :


The last success occurred at 2012-02-05 23:50.36.  
11016 failures have occurred since the last success


 
Ouch
 
Quand tu fais un netdom query fsmo tu obtiens quoi ?

n°110728
Je@nb
Modérateur
In ze cloud
Posté le 13-05-2013 à 22:11:16  profilanswer
 

Ah ouais là j'avais pas vu :D Ca sent le rebuild d'AD ça :D

n°110785
Mysterieus​eX
Chieuse
Posté le 15-05-2013 à 08:30:43  profilanswer
 

Je@nb a écrit :

Ah ouais là j'avais pas vu :D Ca sent le rebuild d'AD ça :D


Ca sent l'intégrateur qu'a mal fait son taff quand il a installé le 2nd serveur  :whistle:

n°110798
mftech
Posté le 15-05-2013 à 12:02:18  profilanswer
 

nebulios a écrit :

Citation :


The last success occurred at 2012-02-05 23:50.36.  
11016 failures have occurred since the last success


 
Ouch
 
Quand tu fais un netdom query fsmo tu obtiens quoi ?


 
Bonjour
 
Voici le retour de la commande  
 
http://img4.hostingpics.net/pics/180318netdom.jpg
 
 
Si je comprend bien, tout mes clients ne tapent plus dans l'AD local pour s'authentifier mais sur le strg-server-03 ? Autant dire qu'il ne sert plus à rien sauf a bouffer du courant et autant le réinstaller ?  
 

n°110824
nebulios
Posté le 15-05-2013 à 18:50:42  profilanswer
 

En partie oui, mais le principal souci, c'est que potentiellement ton AD est en vrac (au moins partiellement).
 
En plus 2000 n'est plus supporté depuis des années (et 2003 dans deux ans), donc ça n'arrange pas le problème.
 
Actuellement il te reste les deux 2003 c'est ça ?
 
Il faudrait vérifier qu'ils fonctionnent bien, puis nettoyer l'AD du 2000 qui est KO, puis remonter un DC propre sur le site distant.
 
Tu as combien d'utilisateur sur le site et combien d'utilisateurs en tout ?


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Infrastructures serveurs

  Problème de réplication DNS/AD

 

Sujets relatifs
Modem+Routeur+DNS Windows ServerProblème avec mon serveur FTP
Sauvegarde Win 2008 - AD - Exchangesuppression ancien ordinateurs dans le AD
Problème de compaibilité avec RDS - Hyper-v3 - [ Résolu ]Probleme DD sur HP Proliant DL380 G7
[Résolue]Adresse DNS pour mon GLPIProblème configuration interface ( cisco 878 )
Migration d'un annuaire NT4 vers un AD 2012problème de routage
Plus de sujets relatifs à : Problème de réplication DNS/AD


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR