Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1499 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Infrastructures serveurs

  Hyper-V Server 2008 R2 Probleme de connexion via Gestionnaire Hyper-V

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Hyper-V Server 2008 R2 Probleme de connexion via Gestionnaire Hyper-V

n°61053
Diesel93
Powered By Diesel
Posté le 04-12-2009 à 11:35:48  profilanswer
 

Bonjour,  
Je suis étudiant en dernière année d'école d'ingénieur et dans le cadre de mon projet de fin d'étude je dois comparer différents systèmes de virtualisation.  
 
En ce moment je suis en train de tester Hyper-V Server 2008 R2 et Hyper-V sous Windows Server 2008
Je travaille sur un poste qui tourne sous Windows Seven Business X64
j'ai donc télécharger l'outils d'administration des serveurs prévu à cette effet.
Je travail sur le compte Administrateur sur les trois machines avec le même mot de passes.
Mon problème est que lorsque j'utilise le "Gestionnaire Hyper-V" fournis dans le pack d'administration des serveurs, je peux me connecter via l'adresse IP ou le nom de la machine, mais une fois que la connexion est établie j'obtiens le message suivant :
Accès refusé. impossible d'établir la communication entre "Nom du Server" et "Nom de l'ordinateur sous Seven"
Cependant j'ai accès au tous les menus permettant de paramétrer le Serveur mais je ne peux pas créer de machines virtuel tant que j'a ce message.
Le même message d'erreur apparait quand j'essais de me connecter sur Hyper-V server ou Server 2008.
Avez-vous s'il vous plaie une solution pour moi ?


Message édité par Diesel93 le 04-12-2009 à 11:36:44
mood
Publicité
Posté le 04-12-2009 à 11:35:48  profilanswer
 

n°61058
Je@nb
Modérateur
Kindly give dime
Posté le 04-12-2009 à 12:02:12  profilanswer
 

Normal, faudrait qu'ils soient dans le meme domaine.
 
Tu peux bypasser ça en modifiant la sécu.
http://code.msdn.microsoft.com/HVRemote fait ça très bien.
(Toi tu dois etre dans le cas server et client workgroup)

n°61061
Diesel93
Powered By Diesel
Posté le 04-12-2009 à 12:46:09  profilanswer
 

Effectivement je suis sur un groupe de travail : WORKGROUP

n°61062
Diesel93
Powered By Diesel
Posté le 04-12-2009 à 13:15:41  profilanswer
 

je@nb Merci pour ta reponse aussi rapide mais au risque de passer pour un novice je comprend pas trop ce que je dois faire pour Hyper-V server 2008 R2 par exemple


Message édité par Diesel93 le 04-12-2009 à 13:15:58
n°61063
Je@nb
Modérateur
Kindly give dime
Posté le 04-12-2009 à 13:18:36  profilanswer
 

:/ C'est un peu marqué sur le site que je t'ai mis :/
le guide en 10' pour que ça marche :/ et je t'ai meme indiqué quelle partie du tableau regarder :/

n°61064
Diesel93
Powered By Diesel
Posté le 04-12-2009 à 13:20:41  profilanswer
 

Oui oui Désolé j'allais editer mon message car j'ai compris juste apres avoir ecris mon message Désolé  :sleep:  :pt1cable:


Message édité par Diesel93 le 04-12-2009 à 14:24:29
n°61066
Diesel93
Powered By Diesel
Posté le 04-12-2009 à 14:36:43  profilanswer
 

Ok ca fonctionne super bien j'ai utilisé que ces lignes la pour Hyper-V Server 2008 R2
Pour garantire les droits
Client  Allow Anonymous Logon remote DCOM access  cscript hvremote.wsf /anondcom:grant  
Pour l'exeption du firewall:
Client  Set firewall exception  cscript hvremote.wsf /mmc:enable  
 
Merci 1000 fois


Message édité par Diesel93 le 04-12-2009 à 14:37:08
n°64853
JiMiX974
Posté le 16-03-2010 à 10:51:39  profilanswer
 

Salut,
 
J'ai le même problème que toi, sauf que quand je tape la commande, j'ai un message d'erreur qui s'affiche:
 
"Erreur en entrée: Impossible de trouver le fichier script "C\users\"l'utilisateur"\hvremote.wsf".
 
Est qu'il faut se placer dans un dossier spécial? activer le hvremote?
 
Merci beaucoup

n°64880
Je@nb
Modérateur
Kindly give dime
Posté le 16-03-2010 à 11:52:36  profilanswer
 

bah faut se placer là où tu as télécharger hvremote ...

n°64928
switch
Posté le 16-03-2010 à 23:31:23  profilanswer
 

Une fois qu'on a la main ca se fait en 3 minutes pour la base :
 
Crée sur ton server et client un compte local identique.
 
Ensuite sur le serveur :
 
place hvremote à la racine c:.
 
1) cscript //h:cscript (les scripts sont directement traités)
2) hvremote /add:tonutilisateur
 
Ensuite sur le host, tu vérifies que le host arrive bien à pinger ton host (par son nom machine!!!). Si c'est pas le cas, édite HOSTS dans c:\windows\system32\drivers\etc
 
Sur ton client :
 
dans une ligne de commande tu fais :
 
cmdkey /add:nomdetonserveur /user:nomdetonserveur\tonutilisateur /pass
 
(remplace nomdetonserveur et tonutilisateur pour tes choix. /pass va te demander d'encoder ton mdp).
 
>> Ca stocke un credential local.
 
Tu reboot les deux et ca devrait passer.
 
Si pas tu exécute hvremote avec la commande /show /target:nomdelamachineopposée
 
Ca fera des checks pour voir si tout est bien configuré. Si pas et que tu trouves pas, postes ici !
 

mood
Publicité
Posté le 16-03-2010 à 23:31:23  profilanswer
 

n°64929
switch
Posté le 16-03-2010 à 23:34:37  profilanswer
 

Après il restera quelques joyeusetés si tu veux administrer à distance (genre ouvrir le firewall, activer dans la MMC le truc des périph pnp,..).
 
Par contre la vraie crasse c'est ton poste local dans un domaine et ton serveur distant en workgroup ! Il y a pas mal de limitations chiantes (genre pour administrer le firewall du serveur distant, tu dois te logger dans un compte local sur le pc .. et donc pas dans le domaine !).
 
Par contre WinRS veut pas de moi pour la partie Server management  :fou: (j'ai pourtant joué avec les TrustedHosts)

n°64954
JiMiX974
Posté le 17-03-2010 à 16:28:04  profilanswer
 

Salut et merci beaucoup pour tes réponses.
 
alors
 
sur le serveur:
 
- j'ai tapé la commande "cscript hvremote.wsf /add:xxxx" ca a l'air de fonctionner (pas de message d'erreur...)
-par contre "  
1) cscript //h:cscript (les scripts sont directement traités)  
2) hvremote /add:tonutilisateur "
 
ca me met "accès refuséé".
 
j'ai continué la manip que tu m'a décris. tous ce passe bien
 
je fais enfin le test avec le /show /target sur les 2 machines.
-sur le client il me met 2 erreurs: "anonymous logon doesn t have remote access" et "firewall exception rule for mmc is missing"
 
-sur le serveur pas d'erreur sauf quand le firewall est desactivé (car j'ai désactiver pour autoriser le ping).
 
Bref ca marche toujours pas.
 
Il y a quelque chose que j'ai oublié?

n°64956
switch
Posté le 17-03-2010 à 16:41:18  profilanswer
 

Diesel93 avait donné la solution plus haut ;)
 
cscript hvremote.wsf /anondcom:grant  
et
cscript hvremote.wsf /mmc:enable
 
(tous les deux sur le client ! )
 
Tu as bien une commande avec droits élevés ? (cmd dans ton menu démarrer + click droit "Run as admin.." )
 
Sur le serveur, réactive le firewall et relance ta commande d'ajout d'utilisateur pour qu'il modifie les règles ;) (sinon tu seras ennuyé par le suite).
 
Pour le ping, il me semble que c'est une règle ICMP ca.


Message édité par switch le 17-03-2010 à 16:42:40
n°64978
JiMiX974
Posté le 18-03-2010 à 12:05:40  profilanswer
 

Merci a toi mon ami !!!!
 
avec cette commande: cmdkey /add:nomdetonserveur /user:nomdetonserveur\tonutilisateur /pass  
 
+ le cmd en admin et le problème est résolu pour moi ...
 
Merci encore.
 
PS: Je baptiserai mon pc admin hyperV "switch" en ton honneur ... LOL
 

n°65024
switch
Posté le 18-03-2010 à 19:10:21  profilanswer
 

Pas de souci :) J'ai passé pas mal de temps pour configurer ma bécane chez OVH alors autant en faire profiter les autres !
 
Par contre bizarrement, le cmdkey dans les tutos il est partout mis de le lancer dans une cmd non élevée :o Si ca tombe il te fallait juste rebooter ;)

n°69772
samzor
Posté le 09-07-2010 à 15:32:59  profilanswer
 

Bonjour Switch,
 
J'ai aussi un hébergement chez OVH et j'ai un mal fou à faire un petit router linux pour faire du nat.
 
J'ai essayé avec floppyfw, vyatta etc et je n'arrive pas à faire conneter mon router au net.
 
Pourtant j'arrive bien à faire connecter une VM Windows sur le net via l'adresse ip failover et la mac adresse virtuel que j'assigne à la carte réseau virtuel dans la VM.

n°69841
T0ng4FF
Posté le 13-07-2010 à 16:11:25  profilanswer
 

question: si le client est dans le domaine A et le server domaine B, est ce faisable?
 
merci :)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Infrastructures serveurs

  Hyper-V Server 2008 R2 Probleme de connexion via Gestionnaire Hyper-V

 

Sujets relatifs
Problème IPSec netasq et accès internetprobleme OPENVPN windows
windows sbs 2008 et 1and1problème outlook 2003 en environnment TSE
Config VPN IPSec Win Server 2003Mise en place d’un VPN avec SFR 9pass + W2K3 Server
connexion de plusieurs switch HP Procurve comment faire ?Problème de création de profil itinérant
Problème avec Veritas Backup EXEC 10.0 
Plus de sujets relatifs à : Hyper-V Server 2008 R2 Probleme de connexion via Gestionnaire Hyper-V


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR