Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1701 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  probleme OPENVPN windows

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

probleme OPENVPN windows

n°60934
belkino
doit
Posté le 02-12-2009 à 10:17:10  profilanswer
 

Bonjour  
 
je cherche une solution pour acceder à des données sur un serveur 2003 par internet, j'ai choisi openvpn  
Avant de metre ça sur le serveur je teste en local sur une machine xp et une autre w2000
la machine xp est serveur et la w2000 client
J'ai configuré les deux machines et les iconnes sont vertes mais si je fais un ping 10.80.05 sur le serveur aucune réponse
je ne comprends plus là !
 
je joins les logs:
 
sur le serveur :
 
Wed Dec 02 08:52:16 2009 MULTI: multi_create_instance called
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 Re-using SSL/TLS context
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 LZO compression initialized
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 Control Channel MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 Local Options hash (VER=V4): '14168603'
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 Expected Remote Options hash (VER=V4): '504e774e'
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 TLS: Initial packet from 192.168.1.45:1035, sid=d1f32576 d653ad95
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 VERIFY OK: depth=1, /C=FR/ST=17/L=ST_PALAIS/O=UDMOT/OU=none/CN=udmotvpn/emailAddress=rollins@laposte.net
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 VERIFY OK: depth=0, /C=FR/ST=17/O=UDMOT/CN=poste01/emailAddress=rollins@laposte.net
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Wed Dec 02 08:52:16 2009 192.168.1.45:1035 [poste01] Peer Connection Initiated with 192.168.1.45:1035
Wed Dec 02 08:52:16 2009 poste01/192.168.1.45:1035 MULTI: Learn: 10.8.0.6 -> poste01/192.168.1.45:1035
Wed Dec 02 08:52:16 2009 poste01/192.168.1.45:1035 MULTI: primary virtual IP for poste01/192.168.1.45:1035: 10.8.0.6
Wed Dec 02 08:52:17 2009 poste01/192.168.1.45:1035 PUSH: Received control message: 'PUSH_REQUEST'
Wed Dec 02 08:52:17 2009 poste01/192.168.1.45:1035 SENT CONTROL [poste01]: 'PUSH_REPLY,route 10.8.0.0 255.255.255.0,ping 10,ping-restart 120,ifconfig 10.8.0.6 10.8.0.5' (status=1)
 
 
et le client:
Wed Dec 02 08:54:14 2009 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006
Wed Dec 02 08:54:14 2009 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Wed Dec 02 08:54:15 2009 Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
Wed Dec 02 08:54:15 2009 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Dec 02 08:54:15 2009 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Dec 02 08:54:15 2009 LZO compression initialized
Wed Dec 02 08:54:15 2009 Control Channel MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
Wed Dec 02 08:54:15 2009 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Wed Dec 02 08:54:15 2009 Local Options hash (VER=V4): '504e774e'
Wed Dec 02 08:54:15 2009 Expected Remote Options hash (VER=V4): '14168603'
Wed Dec 02 08:54:15 2009 UDPv4 link local: [undef]
Wed Dec 02 08:54:15 2009 UDPv4 link remote: 192.168.1.12:1194
Wed Dec 02 08:54:15 2009 TLS: Initial packet from 192.168.1.12:1194, sid=4cce3d24 2e3a1ed2
Wed Dec 02 08:54:15 2009 VERIFY OK: depth=1, /C=FR/ST=17/L=ST_PALAIS/O=UDMOT/OU=none/CN=udmotvpn/emailAddress=rollins@laposte.net
Wed Dec 02 08:54:15 2009 VERIFY OK: nsCertType=SERVER
Wed Dec 02 08:54:15 2009 VERIFY OK: depth=0, /C=FR/ST=17/O=UDMOT/CN=server/emailAddress=rollins@laposte.net
Wed Dec 02 08:54:15 2009 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Wed Dec 02 08:54:15 2009 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Dec 02 08:54:15 2009 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Wed Dec 02 08:54:15 2009 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Dec 02 08:54:15 2009 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Wed Dec 02 08:54:15 2009 [server] Peer Connection Initiated with 192.168.1.12:1194
Wed Dec 02 08:54:16 2009 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
Wed Dec 02 08:54:16 2009 PUSH: Received control message: 'PUSH_REPLY,route 10.8.0.0 255.255.255.0,ping 10,ping-restart 120,ifconfig 10.8.0.6 10.8.0.5'
Wed Dec 02 08:54:16 2009 OPTIONS IMPORT: timers and/or timeouts modified
Wed Dec 02 08:54:16 2009 OPTIONS IMPORT: --ifconfig/up options modified
Wed Dec 02 08:54:16 2009 OPTIONS IMPORT: route options modified
Wed Dec 02 08:54:16 2009 TAP-WIN32 device [Connexion au réseau local 6] opened: \\.\Global\{402F2736-56A6-4F50-A58E-F4A3946D31F3}.tap
Wed Dec 02 08:54:16 2009 TAP-Win32 Driver Version 8.4  
Wed Dec 02 08:54:16 2009 TAP-Win32 MTU=1500
Wed Dec 02 08:54:16 2009 Notified TAP-Win32 driver to set a DHCP IP/netmask of 10.8.0.6/255.255.255.252 on interface {402F2736-56A6-4F50-A58E-F4A3946D31F3} [DHCP-serv: 10.8.0.5, lease-time: 31536000]
Wed Dec 02 08:54:16 2009 Successful ARP Flush on interface [3] {402F2736-56A6-4F50-A58E-F4A3946D31F3}
Wed Dec 02 08:54:17 2009 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Dec 02 08:54:17 2009 Route: Waiting for TUN/TAP interface to come up...
Wed Dec 02 08:54:18 2009 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Dec 02 08:54:18 2009 Route: Waiting for TUN/TAP interface to come up...
Wed Dec 02 08:54:19 2009 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Dec 02 08:54:19 2009 Route: Waiting for TUN/TAP interface to come up...
Wed Dec 02 08:54:20 2009 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Dec 02 08:54:20 2009 Route: Waiting for TUN/TAP interface to come up...
Wed Dec 02 08:54:21 2009 TEST ROUTES: 1/1 succeeded len=1 ret=1 a=0 u/d=up
Wed Dec 02 08:54:21 2009 route ADD 10.8.0.0 MASK 255.255.255.0 10.8.0.5
Wed Dec 02 08:54:22 2009 Route addition via IPAPI succeeded
Wed Dec 02 08:54:22 2009 Initialization Sequence Completed
 
je suis avec une neufbox et dans l'onglet nat j'ai mis
# Nom        Protocole Type Ports externes  Adresse IP de destination Ports de destination Activation    
1  openvpn  les deux   Port  1194               192.168.1.12                 1194  
192.168.1.12 etant l'ip du serveur
 
voila ou j'en suis, si on pouvait m'éclairer
 
Merci pas ravance

mood
Publicité
Posté le 02-12-2009 à 10:17:10  profilanswer
 

n°60935
DraX
♪ | Membre raccourci | 12th
Posté le 02-12-2009 à 10:56:01  profilanswer
 

Ce sujet a été déplacé de la catégorie Hardware vers la categorie Systèmes & Réseaux Pro par DraCuLaX


---------------
| Un malentendu du cul | boum boum ! | La roulette
n°60949
Je@nb
Modérateur
Kindly give dime
Posté le 02-12-2009 à 14:51:58  profilanswer
 

Il doit pas y avoir de route vers ta machine

n°60997
belkino
doit
Posté le 03-12-2009 à 10:07:26  profilanswer
 

Bon après bien des essais j’ai réussi, je pense que le problème venait de la génération des clés.
 
Le ping fonctionne ; ping 10.8.0.1 du client au serveur = OK
 
En exterieur ping ; ping nom.domaineDNS.org  = OK
 
Mais là autre problème, je ne vois pas les autres postes du réseau.
 
Je suis avec un routeur neufbox de chaque coté.
 
J’ai parcouru le net  et j’ai trouvé (peut etre) la solution : le mode bridge
 
J’ai donc fais les modifications suivantes sur le serveur et le client (exterieur) :
;dev tun  
dev tap
 
Puis sur le serveur vpn :
 
;server 10.8.0.0 255.255.255.0
server-bridge 192.168.1.120 255.255.255.0 192.168.1.128 192.168.1.254
 
J’ai « ponté » la connexion opnvpn et celle de mon réseau local puis modifié les paramètres comme il suit :
Adresse ip : 192.168.1.120
Masque : 255.255.255.0
Passerelle : 192.168.1.1 (ip de la neufbox)
 
Dns : 192.168.1.1
 
En locale ça fonctionne ; le ping est ok
 
Mes questions :
 
Dois-je créer aussi un pont sur le client extérieur ?
 
Que faire les paramètres NAT de la neufbox :
Nom Protocole Type Ports externes Adresse IP de destination Ports de destination Activation  
1  openvpn  les deux  Port  1194 192.168.1.12 1194  


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  probleme OPENVPN windows

 

Sujets relatifs
windows sbs 2008 et 1and1[Windows] : Retrait de SIDs orphelins
problème outlook 2003 en environnment TSEProblème de création de profil itinérant
Problème avec Veritas Backup EXEC 10.0Problème carte Olitec
Problème configuration etherchannel switchs ciscoProbleme de route
Problème config réseau internet via une passerelle !help! 
Plus de sujets relatifs à : probleme OPENVPN windows


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR