Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
643 connectés 

 



 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  42  43  44  45  46  47
Auteur Sujet :

Réseau privé virtuel sous Windows - OpenVPN - Tutoriels.

n°510444
tdi78
Posté le 13-02-2011 à 12:15:11  profilanswer
 

Reprise du message précédent :
J'ai pas attendu assez longtemps sur le client pour voir l'erreur s'afficher:
 
Sun Feb 13 12:18:53 2011 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Sun Feb 13 12:18:53 2011 TLS Error: TLS handshake failed
Sun Feb 13 12:18:53 2011 TCP/UDP: Closing socket
Sun Feb 13 12:18:53 2011 SIGUSR1[soft,tls-error] received, process restarting
Sun Feb 13 12:18:53 2011 Restart pause, 2 second(s)

 
J'ai openVPN d'installé sur mon iphone aussi (via cydia) et il m'affiche quasiment la même erreur mais me précise:
 
WARNING:file 'client1.key' is group or others accessible


Message édité par tdi78 le 13-02-2011 à 12:20:59
mood
Publicité
Posté le 13-02-2011 à 12:15:11  profilanswer
 

n°510474
spamoi
Posté le 13-02-2011 à 14:29:29  profilanswer
 

Tu est admin sur la machine client1 ?
 
Edit. Plutôt que dmz, nat le port 1194 vers l'ip du serveur.

Message cité 1 fois
Message édité par spamoi le 13-02-2011 à 14:31:14

---------------
₪₪₪ Waze, GPS gratuit pour Androïd et iPhone ₪₪₪
n°510506
Falconpage
HFR Powered since 1998
Posté le 13-02-2011 à 18:49:05  profilanswer
 

mousou a écrit :

Merci de ton aide Falconpage  :)  Voici un schéma résumant ma situation :  
 
CLIENT --> ROUTEUR CLIENT(freebox) -->  ROUTEUR ENTREPRISE(freebox) --> SERVEUR VPN --> SERVEUR NAS
 
                                                                                                                                                                                                 
192.168.0.x --> 192.168.0.x ---------->         192.168.0.x ----------->           192.168.0.x --> 192.168.0.x
10.8.0.x            82.x.x.x                               82.x.x.x                                10.8.0.x  
Mon but étant d'accéder au données du serveur NAS a distance. Le client ping les deux interfaces du serveur mais ne ping pas le NAS.C'est effectivement un problème de route mais à ce niveau la je n'ai pas tout compris... De plus je crois qu'il n'est pas possible de rajouter des routes sur le routeur freebox...


 
Si la freebox ne te permet pas d'ajouter une route il te faudra le faire à la main sur le serveur NAS (si c'est possible).
En gros tu dis à ta freebox (passerelle) que pour le réseau 10.8.0.x le routeur est à 192.168.0.x (x à remplacer par l'ip du serveur OpenVPN dans le LAN)

n°511801
zark0s
Posté le 20-02-2011 à 05:57:53  profilanswer
 

Bonjour à tous,
 
je me suis abonné à "Golden frog" pour leur "VyprVPN pro" .
 
et lorsque je veux me connecter j'ai ça comme message :
 
 
Sun Feb 20 05:57:30 2011 us=395000 Current Parameter Settings:
Sun Feb 20 05:57:30 2011 us=395000   config = 'sample.ovpn'
Sun Feb 20 05:57:30 2011 us=395000   mode = 0
Sun Feb 20 05:57:30 2011 us=395000   show_ciphers = DISABLED
Sun Feb 20 05:57:30 2011 us=395000   show_digests = DISABLED
Sun Feb 20 05:57:30 2011 us=395000   show_engines = DISABLED
Sun Feb 20 05:57:30 2011 us=395000   genkey = DISABLED
Sun Feb 20 05:57:30 2011 us=395000   key_pass_file = '[UNDEF]'
Sun Feb 20 05:57:30 2011 us=395000   show_tls_ciphers = DISABLED
Sun Feb 20 05:57:30 2011 us=395000 Connection profiles [default]:
Sun Feb 20 05:57:30 2011 us=395000 NOTE: --mute triggered...
Sun Feb 20 05:57:30 2011 us=395000 263 variation(s) on previous 10 message(s) suppressed by --mute
Sun Feb 20 05:57:30 2011 us=395000 OpenVPN 2.2-beta5 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Nov 30 2010
Sun Feb 20 05:57:30 2011 us=395000 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Sun Feb 20 05:57:30 2011 us=395000 WARNING: --ping should normally be used with --ping-restart or --ping-exit
Sun Feb 20 05:57:30 2011 us=395000 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Sun Feb 20 05:57:30 2011 us=395000 Cannot open file key file 'key.txt': Le fichier spécifié est introuvable.   (errno=2)
Sun Feb 20 05:57:30 2011 us=395000 Exiting
 
j'ai déja contacté le SAV du site par mail , mais il n'a rien su résoudre.
 
Aidez-moi s'il vous plaît.

n°511944
livevil
Let the bassline getcha...
Posté le 20-02-2011 à 22:05:30  profilanswer
 

Tu es sûr que tu as bien configuré ton vpn ?

 

Le fichier utilisé pour le lancer d'après ton log est 'sample.ovpn', qui est le fichier par défaut lors de l'install d'openvpn. Ouvre-le et vérifie qu'il contient bien la ou les adresses des serveurs VyprVPN. S'il s'agit du fichier par défaut d'openvpn, il faut que tu récupères celui qui contient la config vyprVPN (sûrement dispo sur leur site).


Message édité par livevil le 20-02-2011 à 22:19:57

---------------
Beauty is in the eye of the beer holder ...
n°511981
zark0s
Posté le 21-02-2011 à 02:31:04  profilanswer
 

c'est bon un amis a rectifié le problème , merci a+.

n°512003
spamoi
Posté le 21-02-2011 à 09:37:56  profilanswer
 

Tu peux nous dire ce que c'était ?


---------------
₪₪₪ Waze, GPS gratuit pour Androïd et iPhone ₪₪₪
n°512606
BZH7000
Posté le 24-02-2011 à 22:54:10  profilanswer
 

Bonsoir,
 
J'ai justement un pb de routage depuis peu.
 
La connexion se passe bien mais pour obtenir le ping du client vers le serveur, je dois :
 
1) - Ajouter l'adresse de passerelle (IP VPN du serveur) sur ma carte réseau VPN TAP
2) - route add     adresse du reseau diffusé par le serveur
3) - route delete adresse du reseau diffusé par le serveur

 
Et là, j'obtiens le ping vers mon serveur, je peux voir ses dossiers partager et y acceder.
 
Si je ne fais pas cette manipulation, j'ai un ping seulement à la fin de la sequence de connexion, environ 3 ou 4 ping ok, puis, impossible je joindre...
 
Je suppose qu'il est possible de ''forcer'' en Push ces informaions à la connexion du tunnel ?
Mais où et comment ?
 
Une idée ?
Merci


Message édité par BZH7000 le 24-02-2011 à 22:57:50
n°512607
spamoi
Posté le 24-02-2011 à 22:57:05  profilanswer
 

Humm, le route add se fait tout seul à la connexion il me semble, en tt cas chez vu ça dans mes logs.


---------------
₪₪₪ Waze, GPS gratuit pour Androïd et iPhone ₪₪₪
n°512608
BZH7000
Posté le 24-02-2011 à 23:01:55  profilanswer
 

Il me semblait bien que route add se fait à la connexion.
Sur d'autres config, je n'ai pas ce problème.
 
Il faut dire que le serveur est en bridge client sur un dédié en IP publique
Mais comme le VPN se connecte bien...

mood
Publicité
Posté le 24-02-2011 à 23:01:55  profilanswer
 

n°512610
spamoi
Posté le 24-02-2011 à 23:06:45  profilanswer
 

Tu peux faire un copier/coller du log ?


---------------
₪₪₪ Waze, GPS gratuit pour Androïd et iPhone ₪₪₪
n°513284
krevard
Posté le 01-03-2011 à 12:04:15  profilanswer
 

Bonjour,  
 
j'ai suivi le tuto et je me connecte bien du coté client. BOn tuto d'ailleurs
 
Mais je désire depuis le pc Client acceder a internet par le tunnel VPN.
 
J'ai beau chercher dans toutes les pages mais je n'est pas trouvé.
 
Que manque t'il a la configuration pour que toutes les requetes internet passe par la connection internet du serveur VPN  
 
Bien cordialement,  
 
Kev

n°513627
norton768
Posté le 03-03-2011 à 08:29:31  profilanswer
 

spamoi a écrit :

Tu est admin sur la machine client1 ?
 
Edit. Plutôt que dmz, nat le port 1194 vers l'ip du serveur.


 
Bonjour,
 
J'ai le même message d'erreur que tdi78, mais j'ai aps vraiment compris la réponse. Qu'est-ce que je dois faire pour régler cela? Et comment je procède pour ta réponse ??
 
Si ça peut aider, le message d'erreur apparaît sur le client qui est avec vista et mon serveur est sous xp et relié directement à un router qui me sert de réseau local.
 
Merci.

n°513639
spamoi
Posté le 03-03-2011 à 09:22:14  profilanswer
 

Bonjour,
 
ok je vais simplifier ma réponse:
 
DMZ: en gros, un routeur "filtre" les entrées (internet) vers le réseau local. Dans le routeur, tu peux dire que l'adresse ip x.x.x.x est en DMZ, dans ce cas le routeur ne filtre rien pour cette adresse IP.
 
NAT: permet de rediriger un port d'entrée vers une machine en particulier sur le réseau local. Par comparaison, uPnP permet d'automatiser cette tâche. Par exemple uTorrent installé sur une machine du réseau local va dire au routeur "coucou, merci de me rediriger tout les ports 55951 vers mon ip x.x.x.x car c'est moi qui prend en charge la demande."
 
Voici un super site d'information sur le réseau: http://irp.nain-t.net/doku.php/080 [...] ue_logique


---------------
₪₪₪ Waze, GPS gratuit pour Androïd et iPhone ₪₪₪
n°514985
secalex
Stalker forever
Posté le 10-03-2011 à 17:32:18  profilanswer
 

Bonjour,
 
J'ai suivi le tuto page 1 qui est très clair.
Tout est OK sauf quand je lance build-dh.
Il me met une invite de commande puis rien d'autre (pendant 2h).
Testé de nombreuses fois.
Pas de . ou de +
J'ai cherché un moment mais je dois encore demander la mauvaise requête sur google.
Je suis sous 7 64bits et je travaille en mode admin avec la ligne de commande.
 
Merci d'avance pour votre aide. :jap:


---------------
FEED-BACK /   I phoque PiseptO (Paidai i7 Owner)
n°515068
secalex
Stalker forever
Posté le 11-03-2011 à 05:45:12  profilanswer
 

Problème résolu : il faut relancer vars si on a fermé la ligne de commande à un moment. :jap:


---------------
FEED-BACK /   I phoque PiseptO (Paidai i7 Owner)
n°515213
Master_Jul
Posté le 11-03-2011 à 21:47:19  profilanswer
 

Aye ! Secalex de la CGP WaterCooling sur mon topoc, le monde forum est petit. :hello:

Message cité 1 fois
Message édité par Master_Jul le 11-03-2011 à 21:47:45

---------------
En français, on écrit "connexion", pas "connection".
n°515240
seb93250
Posté le 12-03-2011 à 03:24:56  profilanswer
 

Bonjour,  
J'essaye de connecté mon téléphone à mon serveur avec une connexion OpenVPN mais le problème est que je n'arrive pas à configurer mon serveur.
Je suis cette technique : http://gueux-forum.net/index.php?showtopic=204808
 
Quand j'essaye de connecté mon serveur, voici ce qu'indique le log:
 
"Sat Mar 12 03:10:27 2011 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006
Sat Mar 12 03:10:27 2011 Diffie-Hellman initialized with 1024 bit key
Sat Mar 12 03:10:27 2011 TLS-Auth MTU parms [ L:1544 D:140 EF:40 EB:0 ET:0 EL:0 ]
Sat Mar 12 03:10:27 2011 TCP/UDP: Socket bind failed on local address [undef]:443: Permission denied (WSAEACCES)
Sat Mar 12 03:10:27 2011 Exiting"
 
 
J'ai cherché toute la journée le problème mais je ne trouve pas s'il vous plait aidez moi  :)  

n°515241
seb93250
Posté le 12-03-2011 à 03:24:56  profilanswer
 

Escusez moi mon navigateur à bugger ca a fait plein de post ...  =/


Message édité par seb93250 le 12-03-2011 à 03:30:00
n°515242
seb93250
Posté le 12-03-2011 à 03:24:57  profilanswer
 

3e post


Message édité par seb93250 le 12-03-2011 à 03:29:33
n°515243
seb93250
Posté le 12-03-2011 à 03:24:57  profilanswer
 

4e post


Message édité par seb93250 le 12-03-2011 à 03:29:26
n°515244
seb93250
Posté le 12-03-2011 à 03:24:57  profilanswer
 

5e post


Message édité par seb93250 le 12-03-2011 à 03:29:15
n°515245
seb93250
Posté le 12-03-2011 à 03:24:57  profilanswer
 

6e post


Message édité par seb93250 le 12-03-2011 à 03:29:03
n°515368
secalex
Stalker forever
Posté le 13-03-2011 à 10:29:48  profilanswer
 

Master_Jul a écrit :

Aye ! Secalex de la CGP WaterCooling sur mon topoc, le monde forum est petit. :hello:


 [:aras qui rit]  
 
Bon, j'arrive à faire mon VPN en mode bridge et tout. :love:  
Test ultime avec mon père qui est chez lui et tout parfait. [:antoni]  
 
Cependant, grosse surprise ce matin.
J'avais pas fait attention : sur le serveur OpenVPN j'ai aussi mon site web, mon serveur de messagerie et mon serveur ftp.
Tous le monde HS. :sweat:  
Pour le serveur web et le ftp, je forwarde les ports sur l'adresse du pont réseau, je change l'adresse pour le serveur Apache et tout repart pour ces deux points.
Par contre le serveur de mail est toujours KO bien que j'ai forwardé les ports SMTP, POP3 et IMAP :sweat:  
Si quelqu'un a une idée je suis preneur. :jap:  


---------------
FEED-BACK /   I phoque PiseptO (Paidai i7 Owner)
n°517479
kray
Bad show?
Posté le 28-03-2011 à 23:15:38  profilanswer
 

Bonjour,
 
J'ai suivi le tuto et fait un mix avec d'autres du net(pour Debian notamment)
J'ai quelques problèmes de connexions....  
 
J'ai mon serveur qui écoute sur le port xyz, mon client configuré pour se connecter à mon serveur via xyz. La box 2 laisse bien passer le port xyz sur 192.168.1.69
 
PC extérieur  <----LAN ----> Box 1 <----WAN---->  Box 2 <----LAN---->  =>Serveur
192.168.2.X                     192.168.2.1            192.168.1.1                  192.168.1.69
 
Jusque là tout est ok. Sauf que le serveur n'arrive pas à répondre au client. Il tente de répondre via un port au hasard(le log du serveur :
IP de la Box1 :2296 write UDPv4 []: Network is unreachable (code=101) )
 
 
J'ai alors trois hypothèses:

  • la box1 filtre à mort

Je n'ai pas a priori envie d'ouvrir tous les ports sur la box 1  pour que le serveur puisse répondre:D  
Un moindre mal serait de pouvoir coder le port de réponse au client en dur et d'ouvrir uniquement ce port sur la box. Après ce qui m'étonne c'est que ce problème soit si peu courant....
 

  • La box 2 filtre à mort(normalement non)


  • Mon bridge est en carton. Probable

Le fichier de conf du serv openvpn

Citation :


port 3945
proto udp
dev tap0
 
ca ca.crt
cert server.crt
key server.key
dh dh1024.pem
 
ifconfig-pool-persist ipp.txt
server-bridge 192.168.1.69 255.255.255.0 192.168.1.15 192.168.1.17
 
keepalive 10 120
user nobody
group nogroup
persist-key
persist-tun
status status.log
log-append openvpn.log
verb 1


les scripts bash que j'utilise pour faire mon bridge:

Citation :

Le Start
brctl addbr br0
brctl addif br0 eth0
brctl addif br0 tap0
ifconfig tap0 0.0.0.0 promisc up
ifconfig eth0 0.0.0.0 promisc up
ifconfig br0 192.168.1.69 netmask 255.255.255.0 broadcast 192.168.1.255
 
le stop
 
ifconfig br0 down
brctl delbr br0
ifconfig tap0 10.0.0.1 netmask 255.255.255.0 broadcast 10.0.0.255
ifconfig eth0 192.168.1.69 netmask 255.255.255.0 broadcast 192.168.1.255
 


 
Dès que je lance bridge-start, je n'ai plus accès au net(et c'est pas les dns). Si après je fais un bridge-stop, c'est pareil :'(. Obligé de rebooter le serveur pour retrouver l'accès au net....
 
 
Du coup je penche plutôt pour le 3, mais étant une quiche en bridge, je sèche...
Si quelqu'un a une idée...
 
merci


---------------
Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit
n°517710
kray
Bad show?
Posté le 30-03-2011 à 00:14:07  profilanswer
 

Pour ceux que ça pourrait aider, mon problème venait de routes manquantes sur le serveur VPN: lorsque le bridge était fait, la route par défaut vers ma gateway était tuée. En la créant manuellement, mon serveur VPN avait de nouveau accès au net.(J'ai aussi pris les scripts start/stop de la doc openvpn par sureté)
Par contre, j'ai désormais un énorme problème conceptuel.
 
mon PC en 192.168.2.X a aussi une IP en 192.168.1.16. Je souhaiterai que ce PC accède au net via ma box2. Et là, j'ai peur de diviser par 0.  [:kzimir]  
Car si je dit au PC extérieur de faire un bridge entre sa connexion  VPN et sa connexion au WAN, comment le client VPN va savoir qu'il doit passer par la connexion WAN pour aller taper sur mon serveur VPN, mais que toutes les autres connexions doivent passer par le LAN du VPN?(J'ai maigre espoir qu'en initialisant d'abord la connexion VPN, toutes les adresses en 192.168.1.X soit routées par là car le réseau est connu, que mon client VPN passe "en dur" par ma connexion WAN pour aller sur mon serveur VPN. Et donc si sur le bridge je défini le 192.168.1.1 comme gateway, toute requete passera par le client VPN puis ma box 2, mais j'aimerai confirmer la théorie)
 
 
Et d'ailleurs j'étends ma question : comment des PC sans aucun client VPN sur le même LAN que mon serveur VPN, arrivent à voir les PC client du serveur VPN. Je soupçonne que le serveur VPN écoute toutes les requetes ARP, réponde aux requetes correspondant à ses clients, et route ensuite les trames, mais j'aimerai bien confirmer.  
 
Bref si quelqu'un à un cours de reseau expliquant le fonctionnement "pratique" des VPN , je suis preneur. :whistle:


---------------
Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit
n°519825
3effa_br
Posté le 13-04-2011 à 12:29:52  profilanswer
 

bonjour  :hello: ,
j'ai suivi votre tuto mais j'ai bloqué dans la procédure de génération de certificat signé  :pt1cable: , j'ai copié build-req.bat sous easy-rsa client et build-key.bat sous easy-rsa serveur mais après je trouve pas le fichier client1.csr je ne le trouve pas dans keys "c'est normal puisque je l'ai crée pas et es-que la création local build-key client1?" !!
Alors si je change et je fait génération local des clés, aprés quesque je fait car ensuite la partie de certificat signé et aussi je veut utilisé openvpn comme un serveur vpn d'une entreprise n'est pas pour hamachi svp aidez-moi  :(  
Merci d'avance  :D

n°522786
benka35
Posté le 02-05-2011 à 09:33:46  profilanswer
 

Salut
 
Afin de débrider mon accès internet quand je suis connecté en 3G, j'aimerai installer un serveur OpenVPN sur mon petit serveur domestique (il est tout le temps allumé).
 
C'est possible sur un Windows 7 Pro 64 bits derrière une bbox bouygues ?

n°525003
dark_mole
Posté le 17-05-2011 à 14:12:40  profilanswer
 

Salut,
J'aimerais avoir + d'infos concernant la génération de la clé Diffie-Hellman. Personne n'explique clairement son utilité dans le contexte d'OpenVPN.
Inutile de me renvoyer vers une définition de Diffie-Hellman.
J'ai bien compris ce qu'est l'échange Diffie-Hellman.
Ce que je voudrais savoir, c'est pourquoi on l'utilise dans le contexte d'OpenVPN?
 
Merci par avance.

n°528914
marlboris
Posté le 17-06-2011 à 08:28:01  profilanswer
 

Hello,
 
Tout d'abord je voulais remercier les auteurs du tutoriel.
Je tiens aussi a amener mon expérience.
J'ai suivi le tutoriel ainsi que la création du bridge (entre le tap et la carte réseau), afin de pouvoir voir les machines dans mon réseau (NAS et autres serveur). J'ai effectué cette config sur Win7.
Toutefois je n'ai pas forcé l'adresse IP du bridge (192.168.1.120, passerelle 192.168.1.1, DNS 192.168.1.1 etc) car cela ne fonctionnait pas. J'ai donc assigné depuis mon routeur l'adresse 192.168.1.120 en fonction de l'adresse MAC de ma carte réseau. Pour le pont, j'ai simplement laissé "obtenir automatiquement une adresse IP...". Cela fonctionne.
J'ai aussi assigné le démarrage de openvpn à un service, afin de pouvoir faire une liaison terminal server dès le login.
 
Pour les possesseurs de Kaspersky anti virus 2010,2011  :sarcastic:  qui aurait effectué une mis à jour et qui n'aurait subitement plus de connection réseau, qui aurait aussi créé un pont (bridge) ,ouvrir les propriétés du bridge (pont) et déinstaller le "ndis filter" de Kaspersky et redémarrer la machine, cela devrait fonctionner.
 
Salutations
 
MArl


Message édité par marlboris le 21-06-2011 à 08:09:56
n°537997
solsibus
Posté le 18-08-2011 à 02:41:13  profilanswer
 

salut a tous!
 
alors voila mon petit soucis qui a due deja etre relevé mais j ai pas trouvé sur les 44 pages.
j'ai installé openvpn en server sur mon serveur.
j'ai installé openvpn en client sur mon pc xp pro.
tout est ok tout fonctionne comme promis.
par contre je n'arrive pas a faire le partage de connexion, est ce que quelqu'un peu me donner les lignes a mettre dans les fichiers conf.
j ai essayé sur le serveur de rajouter:
 
push "redirect-gateway def1"  
push "dhcp-option DNS 10.0.8.1"  
 
et sur le client :
 
pull "redirect-gateway def1"  
pull "dhcp-option DNS 10.8.0.1"  
 
je me connecte nickel de nouveau mais j ai pas la connexion.
 
merci d'avance.

n°538991
arthuro06
Posté le 24-08-2011 à 10:56:14  profilanswer
 

Bonjour,
 
Je n'arrive pas à connecter mon client depuis le reseau de bouygues telecom via guizmovpn .
Il me semble en lisant le log qu'il y a une erreur de certificat.
Mon serveur est hébergé sur un ordinateur qui est branché en réseau (ordinateur d'entreprise)
J'ai aussi essayé de créer un serveur sur un ordinateur branché derrière une livebox, ca ne marche pas non plus.
Dois activer le service dyndns?
Par ailleurs connaissez vous une astuce pour avoir un ip fixe derriere une livebox?
J'ai du oublier quelque chose!
 
Voici le Log de guizmovpn en essayant de me connecter en tap a un serveur hebergé par mon ordinateur d'entreprise
 
Wed Aug 24 10:23:19 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Wed Aug 24 10:23:19 2011 Re-using SSL/TLS context
Wed Aug 24 10:23:19 2011 LZO compression initialized
Wed Aug 24 10:23:19 2011 Control Channel MTU parms [ L:1576 D:140 EF:40 EB:0 ET:0 EL:0 ]
Wed Aug 24 10:23:19 2011 Socket Buffers: R=[131072->65536] S=[131072->65536]
Wed Aug 24 10:23:19 2011 Data Channel MTU parms [ L:1576 D:1450 EF:44 EB:135 ET:32 EL:0 AF:3/1 ]
Wed Aug 24 10:23:19 2011 Local Options hash (VER=V4): '31fdf004'
Wed Aug 24 10:23:19 2011 Expected Remote Options hash (VER=V4): '3e6d1056'
Wed Aug 24 10:23:19 2011 Attempting to establish TCP connection with 62.201.129.226:8080 [nonblock]
Wed Aug 24 10:23:20 2011 TCP connection established with 62.201.129.226:8080
Wed Aug 24 10:23:20 2011 Send to HTTP proxy: 'CONNECT 80.xxx.xxx.xxx:443 HTTP/1.0'
Wed Aug 24 10:23:21 2011 HTTP proxy returned: 'HTTP/1.0 200 Connection established'
Wed Aug 24 10:23:23 2011 TCPv4_CLIENT link local: [undef]
Wed Aug 24 10:23:23 2011 TCPv4_CLIENT link remote: 62.201.129.226:8080
Wed Aug 24 10:23:24 2011 Connection reset, restarting [0]
Wed Aug 24 10:23:24 2011 TCP/UDP: Closing socket
Wed Aug 24 10:23:24 2011 SIGUSR1[soft,connection-reset] received, process restarting
Wed Aug 24 10:23:24 2011 Restart pause, 5 second(s)
Wed Aug 24 10:23:29 2011 WARNING: No server certificate verification method has been enabled. See openvpn.net/howto.html#mitm for more info.
 
 
Voici mes fichiers de configuration:
 
coté client:
client
remote 80.XXX .XXX XXX 443
http-proxy 62.201.129.226 8080
dev tap
proto tcp
resolv-retry infinite
nobind
tls-client
dh dh1024.pem
ca ca.crt
cert client.crt
key client.key
persist-key
cipher BF-CBC
comp-lzo
pull
verb 3
mute 10
 
coté serveur:
 
port 443 #Port de communication sortant. 1193 est la norme pour OpenVPN, mais il est possible d'en prendre un autre
proto tcp #Protocole d'envoi des données(ou tcp).
dev tap #Mode de transmission, ici en mode route (ou tun pour un mode manuel)
mode server #Configuration serveur.
tls-server #Authentification serveur TLS.
 
#Configuration IP.
ifconfig 10.8.0.1 255.255.255.0 #Adresse du serveur, bien choisir une adresse IP différente de votre DHCP interne, si vous en posséder un Wink
;server-bridge 10.8.0.1 255.255.255.0 10.8.0.2 10.8.0.20 #serveur DHCP, ici on distribue des adresses IP de 10.8.0.2 à 10.8.020
server-bridge 126.xxx.x.1 255.255.255.0 126.xxx.xxx.110 126.xxx.xxx.254
#max-clients 5 #Nombre max de client (ne doit pas excéder la taille de la plage IP du DHCP).
client-to-client #Permet la communication entre client.
 
#Sécurité
dh dh1024.pem #Paramètre Diffie Hellman 1024bits(Protocole d'échange).
ca ca.crt #Certificat de l'administrateur réseau, il permet de signer les certificat client.
cert server.crt #Certificat du Serveur.
key server.key #Clé du certificat serveur.
persist-key #Evite de reinterroger un client qui s'est déjà authentfié.
cipher BF-CBC #Cryptage des données en Blowfish (ex: (Cryptage AES) AES-128-CBC,(Cryptage Triple-DES) DES-EDE3-CBC).
keepalive 10 120 #Effectue un ping vers le client tout les 10s pendant 120s.
duplicate-cn #Pour partager le même certificat entre plusieurs clients.
 
#Utilisateur anonyme, ne fonctionne que sous Linux !
#user nobody #Aucun utilisateur prédéfinis.
#group nogroup #Aucun groupe prédéfinis.
 
#Utiliser la compression dynamique LZO.
comp-lzo
 
#Régler le niveau de traces (0 pour un mode silencieux excepté les erreurs fatales, 4 utilisation courante par défaut, 5 et 6 pour le debugage, 9 renseigne toutes les traces).
verb 3
 
#Au bout de 10 fois la même ligne, plus de trace.
mute 10
 
 
Merci beaucoup pour votre aide!
 
Frederic


Message édité par arthuro06 le 24-08-2011 à 10:59:31
n°539015
maryacha
Posté le 24-08-2011 à 14:13:25  profilanswer
 

slt, jai le meme probleme k toi! et je voudrais si possible savoir cmt esk tu as fais pour regler le probleme. merci d'avance. c vrmt iportant pr moi

n°543897
cc13430
Posté le 24-09-2011 à 16:54:43  profilanswer
 

Bonjour, je cherche à installer openVPN
mais bloque car la commande build-req ne fonctionne pas
 
Microsoft Windows [version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. Tous droits réservés.
 
C:\Users\Administrateur>cd c:\program files (x86)\openvpn\easy-rsa
 
c:\Program Files (x86)\OpenVPN\easy-rsa>build-req
c:\Program Files (x86)\OpenVPN\easy-rsa
WARNING: can't open config file: c:\openssl/ssl/openssl.cnf
Unable to load config info from c:\openssl/ssl/openssl.cnf
'-config' n'est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.
'errors' n'est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.
Impossible de trouver c:\*.old
 
c:\Program Files (x86)\OpenVPN\easy-rsa>
 
j'ai surement oublié quelques choses mais je ne vois pas.
merci pour votre aide

n°544312
Avirex03
Posté le 27-09-2011 à 15:39:05  profilanswer
 

Bonjour,
 
Voici mon problème, je galère avec ça!
 
Donc j'ai un PC windows 7 32bits (ip=192.168.1.42) relié à une neufbox. Sur ce PC j'ai installé le server openVPN (ip=10.8.0.1), j'ai activé  
 
la DMZ, tout est OK.
 
Je me connecte du boulot chez moi avec le client (ip=10.8.0.6), je peux accéder au serveur (en tapant \\10.8.0.1 mais pas \\192.168.1.42),  
 
enfin voir les documents partagés mais pas rentrer dans les dossiers! Je peux pinger le serveur openvpn par son IP 10.8.0.1 mais par contre  
 
du serveur je ne peux rien faire, je peux pas voir les doc partagés sur le poste client ni même le pinger!!!! Je ne comprend pas où est  
 
l'erreur?
Avez vous des idées?
Peut-on modifier l'adresse 10.8.0.1 du serveur pour mettre 192.168.X.X?
 
Merci de me répondre.
 
Cordialement

n°544506
cc13430
Posté le 28-09-2011 à 20:25:31  profilanswer
 

3effa_br a écrit :

bonjour  :hello: ,
j'ai suivi votre tuto mais j'ai bloqué dans la procédure de génération de certificat signé  :pt1cable: , j'ai copié build-req.bat sous easy-rsa client et build-key.bat sous easy-rsa serveur mais après je trouve pas le fichier client1.csr je ne le trouve pas dans keys "c'est normal puisque je l'ai crée pas et es-que la création local build-key client1?" !!
Alors si je change et je fait génération local des clés, aprés quesque je fait car ensuite la partie de certificat signé et aussi je veut utilisé openvpn comme un serveur vpn d'une entreprise n'est pas pour hamachi svp aidez-moi  :(  
Merci d'avance  :D


 
 
si vous faite build-key client dans c://program files/openvpn/easy-rsa
 
moi aussi j'avais un soucis car build-req ne fonctionne pas ... mais build-req étant apparemment le copie de build-key. build-key client fonctionne parfaitement bien.

n°545570
cc13430
Posté le 07-10-2011 à 19:11:05  profilanswer
 

j'ai ce message d'erreur sur le client
 
Fri Oct 07 19:05:19 2011 write UDPv4: No Route to Host (WSAEHOSTUNREACH) (code=10065)
 
cela vient d'un problème avec le .conf du serveur ??

n°545686
kray
Bad show?
Posté le 08-10-2011 à 21:41:59  profilanswer
 

cc13430 a écrit :

j'ai ce message d'erreur sur le client
 
Fri Oct 07 19:05:19 2011 write UDPv4: No Route to Host (WSAEHOSTUNREACH) (code=10065)
 
cela vient d'un problème avec le .conf du serveur ??


Je ne sais pas quelle est ta config, mais j'avais eu le même genre de pb sur le serv & le client qui n'arrivaient pas à se joindre pour le handshake, alors que la connexion était quand même initiée. Je n'ai plus le message exact a dispo. C'était du à :  

  • un firewall trop restrictif sur le serveur  
  • le serveur qui perdait la route vers la gateway lors du bridging : sous linux un route add default gw IP_du_routeur sur le serveur après le bridging permet de redonner la route


Faudrait voir dans tes logs du serveur, si lui aussi n'arrive pas à joindre le client


---------------
Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit
n°545718
cc13430
Posté le 09-10-2011 à 11:10:15  profilanswer
 

kray a écrit :


Je ne sais pas quelle est ta config, mais j'avais eu le même genre de pb sur le serv & le client qui n'arrivaient pas à se joindre pour le handshake, alors que la connexion était quand même initiée. Je n'ai plus le message exact a dispo. C'était du à :  

  • un firewall trop restrictif sur le serveur  
  • le serveur qui perdait la route vers la gateway lors du bridging : sous linux un route add default gw IP_du_routeur sur le serveur après le bridging permet de redonner la route


Faudrait voir dans tes logs du serveur, si lui aussi n'arrive pas à joindre le client


 
 
log du serveur  
Sun Oct 09 11:06:41 2011 OpenVPN 2.1.4 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Nov  8 2010
Sun Oct 09 11:06:41 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Sun Oct 09 11:06:43 2011 Diffie-Hellman initialized with 1024 bit key
Sun Oct 09 11:06:43 2011 TLS-Auth MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
Sun Oct 09 11:06:43 2011 Socket Buffers: R=[8192->8192] S=[8192->8192]
Sun Oct 09 11:06:45 2011 ROUTE: default_gateway=UNDEF
Sun Oct 09 11:06:45 2011 TAP-WIN32 device [Connexion au réseau local 2] opened: \\.\Global\{97D72157-60A1-424A-9667-ED804EF16811}.tap
Sun Oct 09 11:06:45 2011 TAP-Win32 Driver Version 9.7  
Sun Oct 09 11:06:45 2011 TAP-Win32 MTU=1500
Sun Oct 09 11:06:45 2011 Notified TAP-Win32 driver to set a DHCP IP/netmask of 10.8.0.1/255.255.255.252 on interface {97D72157-60A1-424A-9667-ED804EF16811} [DHCP-serv: 10.8.0.2, lease-time: 31536000]
Sun Oct 09 11:06:45 2011 Sleeping for 10 seconds...
Sun Oct 09 11:06:55 2011 Successful ARP Flush on interface [2] {97D72157-60A1-424A-9667-ED804EF16811}
Sun Oct 09 11:06:55 2011 C:\WINDOWS\system32\route.exe ADD 10.8.0.0 MASK 255.255.255.0 10.8.0.2
Sun Oct 09 11:06:55 2011 Warning: route gateway is not reachable on any active network adapters: 10.8.0.2
Sun Oct 09 11:06:55 2011 Route addition via IPAPI failed [adaptive]
Sun Oct 09 11:06:55 2011 Route addition fallback to route.exe
L'ajout de l'itin‚raire a ‚chou‚ÿ: L'index d'interface est erron‚ ou la passerelle n'est pas sur le mˆme r‚seau
que l'interface. V‚rifiez la table d'adresses IP de l'ordinateur.
Sun Oct 09 11:06:55 2011 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Sun Oct 09 11:06:55 2011 UDPv4 link local (bound): [undef]:1194
Sun Oct 09 11:06:55 2011 UDPv4 link remote: [undef]
Sun Oct 09 11:06:55 2011 MULTI: multi_init called, r=256 v=256
Sun Oct 09 11:06:55 2011 IFCONFIG POOL: base=10.8.0.4 size=62
Sun Oct 09 11:06:55 2011 IFCONFIG POOL LIST
Sun Oct 09 11:06:55 2011 Initialization Sequence Completed
 
 
log du cient
Sun Oct 09 11:07:52 2011 OpenVPN 2.1.4 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Nov  8 2010
Sun Oct 09 11:07:52 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Sun Oct 09 11:07:53 2011 LZO compression initialized
Sun Oct 09 11:07:53 2011 Control Channel MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
Sun Oct 09 11:07:53 2011 Socket Buffers: R=[8192->8192] S=[8192->8192]
Sun Oct 09 11:07:53 2011 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Sun Oct 09 11:07:53 2011 Local Options hash (VER=V4): '41690919'
Sun Oct 09 11:07:53 2011 Expected Remote Options hash (VER=V4): '530fdded'
Sun Oct 09 11:07:53 2011 UDPv4 link local: [undef]
Sun Oct 09 11:07:53 2011 UDPv4 link remote: 78.125.119.69:1194
Sun Oct 09 11:07:55 2011 write UDPv4: No Route to Host (WSAEHOSTUNREACH) (code=10065)
Sun Oct 09 11:07:59 2011 write UDPv4: No Route to Host (WSAEHOSTUNREACH) (code=10065)
 
 
78.125.119.69 est mon adresse public, j'ai essayé avec 10.8.0.1 mais aucun changement
je ne sais pas si j'ai bien configuré tout ça
je test ça en privée donc pas de pare-feu particulier  
et pour internet j'ai une simple box
 
Merci pour votre aide

n°545729
kray
Bad show?
Posté le 09-10-2011 à 12:35:52  profilanswer
 

Je suis vraiment pas expert, mais le Warning: route gateway is not reachable on any active network adapters: 10.8.0.2 et le Sun Oct 09 11:06:45 2011 ROUTE: default_gateway=UNDEF me font dire que ton serveur arrive pas à accéder à un routeur(ta box en l'occurence)
Il faudrait voir si depuis ton serveur, une fois openvpn lancé et ton bridging/tunneling fait, tu arrives à pinger ton client. Je suis pas sur qu'il y arrive.
Question bête : ton serv et ton client sont bien sur deux réseaux différents? Pour ma part, sur ma box, via hotspot public(pour avoir un réseau différent entre serv et client) je suis incapable de joindre mon serveur sur mon réseau privé. Obligé de prendre des hotspots de voisin pour tester....


---------------
Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit
n°545961
cc13430
Posté le 10-10-2011 à 21:00:25  profilanswer
 

kray a écrit :

Je suis vraiment pas expert, mais le Warning: route gateway is not reachable on any active network adapters: 10.8.0.2 et le i]Sun Oc 09 11:06:45 2011 ROUTE: default_gateway=UNDEF[/i] me font dire que ton serveur arrive pas à accéder à un routeur(ta box en l'occurence)Il faudrait voir si depuis ton serveur, une fois openvpn lancé et ton bridging/tunneling fait, tu arrives à pinger ton client. Je suis pas sur qu'il y arrive.
Question bête : ton serv et ton client sont bien sur deux réseaux différents? Pour ma part, sur ma box, via hotspot public(pour avoir un réseau différent entre serv et client) je suis incapable de joindre mon serveur sur mon réseau privé. Obligé de prendre des hotspots de voisin pour tester....


 
 
problème résolu  
j'ai mis mon ip local à la ligne local.. dans conf sur le server
et j'ai mis à la ligne remote l'adresse de mon ip serveur local dans le conf du client
 
ex:  
sur server
localv192.168.1.100
sur client  
remote 192.168.1.100 1194
 
le ping du client vers le serveur fonctionne  
 
Après faut que je vois pour les fonctionnalités de partages de dossiers ...
merci pour votre aide

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  42  43  44  45  46  47

Aller à :
Ajouter une réponse
 

Sujets relatifs
*** Réseau domestique et partage de connexion Internet 
Plus de sujets relatifs à : Réseau privé virtuel sous Windows - OpenVPN - Tutoriels.


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR