Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2092 connectés 

 



 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  41  42  43  44  45  46
Auteur Sujet :

Réseau privé virtuel sous Windows - OpenVPN - Tutoriels.

n°600
Master_Jul
Posté le 06-04-2006 à 19:28:32  profilanswer
 

Reprise du message précédent :
Quelle taille fait votre .crt sur le client ? Chez d'autres personnes qui ont ce problème, le fichier fait 0 octet. Cela indique que la procédure de génération du certificat ne s'est pas correctement déroulée. Il faut le refaire.  
 
Assurez-vous également de bien mettre un nom équivalent pour le nom du certificat et le nom de son common name. Le common name de vienne.crt doit être "vienne" et non "server". J'ai trouvé une personne qui avait fait cette erreur et avait un fichier vide.
 
Le nom "common name" peut prêter à confusion.


Message édité par Master_Jul le 06-04-2006 à 19:33:32

---------------
En français, on écrit "connexion", pas "connection".
mood
Publicité
Posté le 06-04-2006 à 19:28:32  profilanswer
 

n°601
patatrack
Posté le 06-04-2006 à 21:32:15  profilanswer
 

Master_Jul a écrit :

Quelle taille fait votre .crt sur le client ? Chez d'autres personnes qui ont ce problème, le fichier fait 0 octet. Cela indique que la procédure de génération du certificat ne s'est pas correctement déroulée. Il faut le refaire.  
 
Assurez-vous également de bien mettre un nom équivalent pour le nom du certificat et le nom de son common name. Le common name de vienne.crt doit être "vienne" et non "server". J'ai trouvé une personne qui avait fait cette erreur et avait un fichier vide.
 
Le nom "common name" peut prêter à confusion.


 
 
 :bounce:  Ouuaii   :bounce:   bravo Master_Jul tu as trouvé et en plus les yeux bandés, en effet mon fichier "vienne.crt" fait 0 octet.
 
Je fais la modif demain.    :hello:  

n°602
Master_Jul
Posté le 06-04-2006 à 22:14:25  profilanswer
 

;) Ce qui m'intéresserait c'est de savoir comment tu es arrivé à cette erreur comme apparemment tu n'es pas le seul à l'avoir faite.


---------------
En français, on écrit "connexion", pas "connection".
n°603
patatrack
Posté le 06-04-2006 à 22:33:53  profilanswer
 

Master_Jul a écrit :

;) Ce qui m'intéresserait c'est de savoir comment tu es arrivé à cette erreur comme apparemment tu n'es pas le seul à l'avoir faite.


 
hé bien quand tu écris
 
"Génération des certificats et clés pour les clients. Chaque nom doit être unique et mettez le « common name » correspondant à chaque nouveau certificat « client1 », « client2 », etc. Contentez-vous de valider en tapant entrée à chaque fois et répondez deux fois « y » aux questions à la fin.  
> build-key client1  "
 
J'ai cru que le nom du client qui est passé en paramètre à "build-key" suffisait et il est vrai qu'a la fin du batch je n'ai pas eu à répondre 2 fois "Y".
Mais comme j'ai trouvé les fichiers je n'ai pas réagit  :pt1cable:  
 
Je n'ai pas pu attendre demain et je me suis connecté à distance sur mon serveur pour générer les fichiers correctement cette fois.
Il faud lancer la commande "vars" pour ensuite passer la commande "build-key client1" et ne pas oublier de taper "client1" lorsqu'il demande "common name" et là au miracle une fois les fichiers transfèrés sur le client, sa roule type top  :bounce:  
 
Grand merci à toi Master_Jul  :hello:  

n°604
Master_Jul
Posté le 06-04-2006 à 22:52:07  profilanswer
 

Pas de problème ! Content de voir que ça peut être utile. On est déjà bien référencés dans Google. :p :hello:
 
Je vais ajouter un paragraphe pour les problèmes rencontrés, demain je pense, il se fait tard.


---------------
En français, on écrit "connexion", pas "connection".
n°605
gathor
Posté le 07-04-2006 à 06:14:37  profilanswer
 

Master_Jul a écrit :

T'as lu le lien qu'on te donne ?  
http://openvpn.net/faq.html#dhcpclientserv
Ils te proposent d'essayer des trucs.


 
Oui j'ai essaye et ca ne fonctionne pas non plus :(
 
Je comprend pas, je vais continuer a chercher en tout cas super boulot vraiment :jap:
 
:hello:

n°606
gilou54
Posté le 13-04-2006 à 23:14:11  profilanswer
 

drapeau et :hello:


---------------
www.horusinformatique.fr
n°607
Master_Jul
Posté le 19-04-2006 à 11:44:06  profilanswer
 

:bounce:

n°608
LaBourse
Posté le 23-04-2006 à 10:39:21  profilanswer
 

Salut,
 
J'ai suivi ce tutorial pour l'installation d'OpenVPN entre mon réseau local (avec une Freebox comme routeur) et des ordinateurs distants. Je ne suis pas arrivé à lancer le client (essai depuis le réseau et essai en distant). Voilà mes constatations et quelques questions:
1) Remarque lors de l'installation:
- Paragraphe "Génération du certificat root et de sa clé pour le réseau": Comme j'ai pu lire dans les différents message l'importance du "Common Name" pour le client, je signale que j'ai mis pour cette partie "Serveur-VPN-Gilles" (dans le tut c'est "OpenVPN-MJ.net" ). Je ne pense pas que celà soit important
- J'ai généré les clés en local et elle ne sont pas vide (*.crt 3,46 ko, *.key 887 oct)
- Le lancement du serveur parait bon et j'obtient l'IP 10.8.0.1
    Note => Un ping depuis l'ordi ayant OpenVPN en serveur abouti mais les autres ordi du réseau local ne ping pas sur l'IP 10.8.0.1 ?
    Note => Par rapport au log du serveur, la seule différence, que je remarque, est dans "IFCONFIG POOL LIST". Dans le tut, il y a une liste de client alors que moi je n'ai rien ?
 
Sun Apr 23 09:47:06 2006 UDPv4 link remote: [undef]
Sun Apr 23 09:47:06 2006 MULTI: multi_init called, r=256 v=256
Sun Apr 23 09:47:06 2006 IFCONFIG POOL: base=10.8.0.4 size=62
Sun Apr 23 09:47:06 2006 IFCONFIG POOL LIST
Sun Apr 23 09:47:06 2006 Initialization Sequence Completed
 
- Pour le port (1194) redirigé du routeur pour le serveur, je pense qu'il faut faire une redirection en UDP (vu le fichier config du serveur) ? Dans le doute, j'ai redirigé en UDP et en TCP
- Pour faire des essais en local, doit-on aussi rediriger le port 1194 ? (je l'ai fait aussi)
- J'utilise XP familial et le pare-feu de Windows. Apparement le pare-feu bloque quelque chose car quand je l'ai desactive, dans les essais de connection client, des lignes "Sun Apr 23 09:48:20 2006 read UDPv4: ..." s'ajoute.
 
2) Se qui ne marche pas
- TLS Error dans la connection client. voir le log partiel ci-dessous:
 
Sun Apr 23 09:46:40 2006 UDPv4 link local: [undef]
Sun Apr 23 09:46:40 2006 UDPv4 link remote: 82.227.52.177:1194
Sun Apr 23 09:47:40 2006 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Sun Apr 23 09:47:40 2006 TLS Error: TLS handshake failed
Sun Apr 23 09:47:40 2006 TCP/UDP: Closing socket
Sun Apr 23 09:47:40 2006 SIGUSR1[soft,tls-error] received, process restarting
Sun Apr 23 09:47:40 2006 Restart pause, 2 second(s)
Sun Apr 23 09:47:42 2006 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Sun Apr 23 09:47:42 2006 Re-using SSL/TLS context
Sun Apr 23 09:47:42 2006 LZO compression initialized
Sun Apr 23 09:47:42 2006 Control Channel MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
Sun Apr 23 09:47:42 2006 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Sun Apr 23 09:47:42 2006 Local Options hash (VER=V4): '504e774e'
Sun Apr 23 09:47:42 2006 Expected Remote Options hash (VER=V4): '14168603'
Sun Apr 23 09:47:42 2006 UDPv4 link local: [undef]
Sun Apr 23 09:47:42 2006 UDPv4 link remote: 82.227.52.177:1194
Sun Apr 23 09:48:20 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Sun Apr 23 09:48:23 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
 
Dans l'attente de tes conseils
 
Gilles :hello:  

n°609
rp91
Posté le 23-04-2006 à 13:03:36  profilanswer
 

up pour un tuto utile et bien pratique, meme si j'ai pas essayé, ça évitera de passer des heures sur une doc

mood
Publicité
Posté le 23-04-2006 à 13:03:36  profilanswer
 

n°610
stephane75​001
Posté le 23-04-2006 à 13:29:56  profilanswer
 

re drapal

n°611
Master_Jul
Posté le 23-04-2006 à 16:25:18  profilanswer
 

Salut LaBourse, alors on va essayer de déméler tout ça.
 
Sur le serveur derrière la freebox, il faut rediriger le port en udp uniquement, comme tu l'indiques dans son fichier de configuration.
 
Tu n'as pas de pool list car aucun client n'a pu encore se connecter. C'est une sorte de "mémoire".
 
Le firewall Windows doit être désactivé. Je n'ai pas trouvé d'alternative pour le moment avec.
 
Pour l'erreur TLS, cela vient de la clé ta.key. Tu l'as bien générée et mise sur tous les postes ? Clients et serveur.


Message édité par Master_Jul le 23-04-2006 à 16:25:43

---------------
En français, on écrit "connexion", pas "connection".
n°612
LaBourse
Posté le 23-04-2006 à 17:03:09  profilanswer
 

Ok pour désactivé le Firewall Windows (éventuellement, indique moi un autre à utiliser)
Sinon, j'utilise le même ta.key sur les 2 machines (essai en local)

n°613
LaBourse
Posté le 23-04-2006 à 17:14:25  profilanswer
 

Mille excuse! C'est mon routeur US Robotics 5462 qui bloque (je l'ai remplacé pour essayé par un hub 10 mb).
Ce routeur fait aussi WIFI mais je n'arrive pas à l'utiliser correctement. Si quelqu'un peu me renseigner sur son utilisation.
 
Sinon merci pour ton tut et ton aide

n°614
LaBourse
Posté le 23-04-2006 à 17:48:41  profilanswer
 

L'informatique c'est bizarre. J'ai remis mon routeur et maintenant tout marche (essai en local pour le moment), même avec les firewall Windows !

n°615
Master_Jul
Posté le 23-04-2006 à 18:12:11  profilanswer
 

Pour ma part, j'avais du mal à faire fonctionner les partages windows avec le firewall activé. Tant mieux si tout remarche. ;)


---------------
En français, on écrit "connexion", pas "connection".
n°616
labavure1
Posté le 25-04-2006 à 07:34:48  profilanswer
 

Bonjour,
 
Grâce à votre excellent tutorial j'ai installer sous Windows XP Pro en "mode route" un vpn entre mon travail et mon pc persol. Mon serveur openvpn est démarré sur mon pc perso avec un utilisateur ayant des droits admin, appelons le "user_admin", le client est lancé à mon travail.
 
Sur mon PC perso j'ai partagé un répertoire en autorisant uniquement et sans "héritage" 2 users : "user_admin" et "guest_vpn" qui a des droits plus restreints.
 
La connexion VPN s'établie sans pb, j'ai ainsi accès depuis mon travail à mon répertoire partagé sur mon pc perso.
 
Par contre j'ai du mal à comprendre sous quel compte par défaut la connexion vpn est établie : est-ce celui qui à démarré le serveur openvpn, à savoir "user_admin" ?
 
En effet je trouve bizarre de pouvoir monter mon répertoire partagé sans aucune identification, juste en faisant "connecter un lecteur réseau", auquel cas j'ai l'air d'avoir des droits admin sur le répertoire partagé (ceux de "admin_toto" ?), alors que lorsque je veux utiliser l'autre compte "guest_vpn" il me sort l'erreur : "le dossier réseau spécifié est actuellement mappé avec un nom d'utilisateur et un mot de passe différent...." bien qu'aucun mappage n'est alors déjà actif.
 
J'ai du mal à comprendre la gestion des droits via openvpn sous Windows, contrairement à Linux où on peut utiliser les directives du fichier de config openvpn user et group.
 
Merci d'avance de m'aider sur ces différentes questions.
 
Labavure

n°617
roilived
Posté le 25-04-2006 à 10:16:04  profilanswer
 

slt Master_Jul.J'ai une livebox et j'ai ouvert le "port 1194". J'ai un souci pour mon client. Il reste jaune et m'écrit:

Spoiler :

Tue Apr 25 11:59:17 2006 OpenVPN 2.0.5 Win32-MinGW [SSL] [LZO] built on Nov  2 2005
Tue Apr 25 11:59:17 2006 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Tue Apr 25 11:59:18 2006 Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
Tue Apr 25 11:59:18 2006 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Apr 25 11:59:18 2006 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Apr 25 11:59:18 2006 LZO compression initialized
Tue Apr 25 11:59:18 2006 Control Channel MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
Tue Apr 25 11:59:18 2006 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Tue Apr 25 11:59:18 2006 Local Options hash (VER=V4): '02af3434'
Tue Apr 25 11:59:18 2006 Expected Remote Options hash (VER=V4): '3f08d474'
Tue Apr 25 11:59:18 2006 UDPv4 link local: [undef]
Tue Apr 25 11:59:18 2006 UDPv4 link remote: 10.8.0.1:1194
Tue Apr 25 12:00:18 2006 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Tue Apr 25 12:00:18 2006 TLS Error: TLS handshake failed
Tue Apr 25 12:00:18 2006 TCP/UDP: Closing socket
Tue Apr 25 12:00:18 2006 SIGUSR1[soft,tls-error] received, process restarting
Tue Apr 25 12:00:18 2006 Restart pause, 2 second(s)
Tue Apr 25 12:00:20 2006 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Tue Apr 25 12:00:20 2006 Re-using SSL/TLS context
Tue Apr 25 12:00:20 2006 LZO compression initialized
Tue Apr 25 12:00:20 2006 Control Channel MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
Tue Apr 25 12:00:20 2006 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Tue Apr 25 12:00:20 2006 Local Options hash (VER=V4): '02af3434'
Tue Apr 25 12:00:20 2006 Expected Remote Options hash (VER=V4): '3f08d474'


 :hello: Merci d'avance


Message édité par roilived le 25-04-2006 à 10:24:36
n°618
Profil sup​primé
Posté le 26-04-2006 à 10:33:57  answer
 

Salut à tous !
 
J'ai une question, pour le moment simple....
Je sauvegarde mes données professionnelles (sauvegardes photos et données courantes) sur un 2eme dd sur mon pc (je synchronise quotidiennement avec beyond compare)... mais aussi sur dvd (sauvegarde de mes photos uniquement) et pour compléter tout celà, j'ai mis un 3eme dd dans un boitier externe, chez mon père, je compte m'en servir pour faire la même chose qu'avec le 2eme dd de mon pc (photos et données courantes donc)
 
il faut maintenant connecter ce dd à mon pc... comment faire ? j'avais pensé au ftp mais beyond compare est vraiment impeccable pour mon utilisation, il faut donc que je puisse intervenir sur le dd qui est chez mon père comme s'il était branché sur mon pc, ou sur mon réseau (j'ai 4 pc connectés).
 
la solution OpenVPN vous semble-t-elle adaptée ?

n°619
Master_Jul
Posté le 26-04-2006 à 11:34:59  profilanswer
 

Je répondrai (dumoins je tenterai) à vos (labavure1, roilived & elcap)  questions et interrogations dans quelques jours si quelqu'un ne l'a pas fait avant car je suis en période d'exams.


---------------
En français, on écrit "connexion", pas "connection".
n°620
Profil sup​primé
Posté le 26-04-2006 à 11:37:28  answer
 

ok, merci :)
 
bons exams !

n°621
roilived
Posté le 26-04-2006 à 12:41:51  profilanswer
 

bonne chance! (ou merde!). Merci.

n°622
Master_Jul
Posté le 26-04-2006 à 13:23:56  profilanswer
 

Merci à vous. ;)


---------------
En français, on écrit "connexion", pas "connection".
n°623
ubuntu06
Posté le 29-04-2006 à 11:12:34  profilanswer
 

Master_Jul a écrit :

Merci à vous. ;)


 
Bonjours j'ai un gros problèmes avec le client. J'ai suivi ce tutorial pour l'installation d'OpenVPN entre mon réseau local (avec une livebox comme routeur) et un hôte distant. Je ne suis pas arrivé à lancer le client (essai depuis le réseau et essai en distant). Voilà mes constatations et quelques questions:  
 
j'ai cette erreur qui s'affiche :
 
WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Sat Apr 29 11:04:37 2006 us=25436 Cannot load private key file client1.key: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
Sat Apr 29 11:04:37 2006 us=25520 Error: private key password verification failed
Sat Apr 29 11:04:37 2006 us=25541 Exiting
 
ma clé doit etre bien était générer ( j'ai bien suivie le tutoriel, et elle ne fais pas 0 ko) et j'ai mis ca dans mon serveur (qui lui fonctionne s'en probleme):
 
OpenVPN Server (Windows XP Professional, Multiple Clients)
lport 5000
dev tap
tls-server
ca ca.crt
cert server.crt
key server.key
dh dh2048.pem
mode server
ifconfig 192.168.0.1 255.255.255.0
ifconfig-noexec
ifconfig-pool 192.168.0.110 192.168.0.119
local 192.168.0.10
push "route 10.0.0.1 255.255.255.0 192.168.39.1"
duplicate-cn #use this for testing only
client-to-client
ping 10
ping-restart 120
push "ping 10"
push "ping-restart 60"
verb 4
 
et ca dans le clients:
 
OpenVPN Client (Windows XP Professional)
remote <IP.Address.or.DNS.Name.of.OpenVPN.Server>
port 5000
dev tap
nobind
tls-client
ca ca.crt
cert client.crt
key client.key
pull
verb 4
 
 
Aider moi please, ca fais des jours que j'y suis dessus. Merci pour votre aide, et merde pour vos exam les gars.

n°624
smiley_n
Posté le 01-05-2006 à 19:52:09  profilanswer
 

Bonjour!
en avant-propos...
 
 [:acherpy] clapo-clapo mastejul!Pour ce fabuleux tuto!
 
mais ca n'empèche que cela ne marche pô! :lol:  
 
sans rire cela marche seulement à moitié,la création du reseau,le paramétrage du serveur ainsi
que des clients avec certificats crées en local se passe bien.
 
une fois les données envoyées au clients,la connexion faite,il nous est impossible de nous connecter ensemble!
ce test est en distant,je n'est pas éssayé en local.
 
quand le client(sur l'ordi distant) ping mon serveur (10.8.0.1) il à 0% de perte de paquets.
quand je teste du pc où le serveur est installé (toujours vers 10.8.0.1) j'obtient 0% de perte de paquets,par contre et c'est là le hic quand je ping du pc avec le serveur vers le client(10.8.0.6) j'obtient 100% de pertes...  
 
:??:
 
le serveur est derrière un routeur netgear wgr614 avec firmware à jour,j'ai aussi le parefeu xp
j'ai ouvert le port 1194 en udp sur le routeur ainsi que sur xp,j'ai débloquer openvpn-gui.exe sur le parefeu xp et j'ai l'ai coupé pour la connexion réseau virtuelle(on ne sait jamais)mais est toujours actif pour la connexion wifi.
 
le client est aussi derrière un routeur dont je n'ait aucune info mais je sait juste que le port 1194 udp est ouvert ainsi que sur xp.
 
en espérant que quelqu'un puisse m'aider.
 
encore  [:acherpy]  
 :)

n°625
lamk
Posté le 03-05-2006 à 17:32:12  profilanswer
 

Bonjour,
je voudrais savoir s'il était possible pour un client d'OpenVPN d'utiliser la connexion internet du serveur auquel il se connecte ?
je suis entrain de tester le forfait SFR 3G intranet illimité, dont l'accès est restreint à quelques ports uniquement (pas de web par exemple)..  
le client se connecte bien au serveur, ping même le routeur mais je ne sais pas ce qu'il faut faire après dans l'éventualité que ça soit possible :)
merci d'avance

n°626
CowboyZ
Posté le 01-06-2006 à 09:35:21  profilanswer
 

lamk a écrit :

Bonjour,
je voudrais savoir s'il était possible pour un client d'OpenVPN d'utiliser la connexion internet du serveur auquel il se connecte ?
je suis entrain de tester le forfait SFR 3G intranet illimité, dont l'accès est restreint à quelques ports uniquement (pas de web par exemple)..
le client se connecte bien au serveur, ping même le routeur mais je ne sais pas ce qu'il faut faire après dans l'éventualité que ça soit possible  :)
merci d'avance


Normalement oui. Un fois sur le réseau local ...

n°627
winnie1664
Posté le 13-06-2006 à 12:33:24  profilanswer
 

Bonjour,
J'ai un souci avec la commande build-dh.
Lorsque je la lance rien ne se passe et le fichier dh1024.pem ne se créé pas
Merci pour votre aide

n°628
seax28
Posté le 14-06-2006 à 10:40:09  profilanswer
 

Bonjour, je voudrais savoir s'il est possible d'installer openvpn sur un serveur (par exemple windows 2000) et d'utiliser les utilisateurs de l'active directory pour se connecter?
merci pour vos réponses.

n°629
jahsonB
Posté le 15-06-2006 à 21:35:57  profilanswer
 

Chapo pour le fameux Tuto, j'ai galéré 2 semaine avant de trouver ce super tuto.
Neanmoins j'ai un petit soucis, Mon serveur VPN marche pas coté client car il n'arrive pas  à se connecté. Sinon coté serveur, il démarre bien. J'ai la Freebox et lorsque je fais mes pig sur mes adresses, tout semble bien marché en local. Quelqu'un pourra me renseigner.
Lor de la connexion de mon client, il bloque et j'ai le message suivant: UDPv4 link remote : mon ip:1194
Encore Bravo.  
 

Master_Jul a écrit :

Mise en place d’un réseau privé virtuel (VPN) sous Windows avec OpenVPN
 
Dernière mise à jour : 27 mars 2006, 11h45.
 
-> Le tuto 5 mns chrono est disponible sur le 3e post de cette page.
-> Je vais faire une version 5 mns chrono du tuto. Un tuto "j'ai besoin que ça marche et pas de savoir comment ça marche", avec une faille "acceptable" dans la procédure, des fichiers format Windows pré-remplis à télécharger. Pour une utilisation personnelle entre amis, particulièrement si vous souhaitez jouer en réseau, ça sera parfait.
 
Introduction :
 
http://img106.imageshack.us/img106/9247/intro6ja.png
 
Je propose ce tutoriel car je pense qu’il pourra intéresser de nombreuses personnes, aussi bien pour des besoins privés que professionnels. Il se base sur la documentation officielle, différents tutoriels et informations sur Internet (voir Remerciements).
 
L’intérêt de ce tutoriel est qu’il est entièrement dédié à un environnement Windows et qu’il recoupe de manière la plus pertinente possible l’information de différentes documentations. La sécurité a été volontairement mise en avant et vous aurez toutes les clés en main (sans trop de jeu de mots) pour faire un VPN digne de ce nom.  
 
Ce tutoriel sera amené à évoluer avec d’éventuelles corrections, ajouts d’informations, aides à l’analyse et la réparation des erreurs. J’envisage également un appendice pour l’environnement Linux.
 
Problématique :
 
Mon problème premier était de faire jouer en réseau avec des amis sans dépendre d’un serveur Internet (BattleNet par exemple), en réseau « local » mais à distance donc. D’où l’idée de réaliser un réseau virtuel privé (VPN) entre nous. En sus de pouvoir jouer facilement, nous pourrions partager nos ressources sur un réseau entièrement sécurisé.
 
Hamachi :
 
J’ai donc fait quelques recherches sur Internet. Le premier outil que j’ai trouvé se nomme « Hamachi » ( www.hamachi.cc ). C’est un programme gratuit mais fermé. L’installation est simple et rapide, ne nécessite pas que l’un des participant au réseau (aussi appelé « groupe ») soit le serveur, c’est un serveur Hamachi qui s’en charge.
 
Pour l’avoir testé, je peux affirmer que cela marche très bien et d’ailleurs je vous invite vivement à vous tourner vers cette solution si vous recherchez une solution rapide et simple. En contrepartie, vous êtes dépendant d’un serveur d’une entreprise extérieure qui vous impose biensûr ses limitations. Par exemple, un membre peut participer à 64 groupes (sa participation en tant que créateur compte) et chaque groupe est limité à 16 comptes. Je préfère utiliser le terme de compte car il est fréquent qu’une personne ait un compte par ordinateur. Dès lors, on atteint vite cette limite.
 
A l’heure où j’écris ces lignes, cette limitation est censée évoluer hors de la phase beta du programme mais ce ne sont que des rumeurs. En outre, vous êtes invités à souscrire à un compte « premium » ( http://premium.hamachi.cc/compare.php ) pour faire évoluer, de manière trop restreinte à mon goût (impossible de proposer un groupe de taille plus importante, il faut que tous les comptes évoluent en « premium »), son compte. Cette évolution n’est pas obligatoire, mais notez bien qu’il faut payer par compte et non par utilisateur.
 
Voilà, c’est tout pour Hamachi !  
 
 
D’autres pistes :
 
Il y a d’autres solutions payantes comme Wingate VPN : http://www.quaternet.fr/wingate_vpn/wingate_vpn.asp  
Je ne l’ai pas testé personnellement.
 
Enfin, il y a la solution intégrée à Windows XP avec un tutoriel ici : http://www.commentcamarche.net/pratique/vpn-xp.php3  
Elle est indiquée comme suffisante pour des réseaux de petite taille. Peu configurable, l’identification se fait avec des comptes utilisateur. Peu d’informations sur la sécurité.


n°630
bigstyle
Posté le 16-06-2006 à 21:19:19  profilanswer
 

Merci pour ce tuto.
 
Petite question, c 'est censé marcher si on fait un test entre deux postes du meme reseau ? (un test sur mon reseau local donc)
 

n°631
Groody
Utilisez MES smileys §
Posté le 24-06-2006 à 00:14:12  profilanswer
 

Nickel, merci pour le tuto !
 
VPN installé, y'a plus qu'à tester demain depuis chez un pote.
 
Mais j'ai quelques questions (questions/réponses à ajouter sur les 1er posts, ça va intéresser du monde je pense) :
 
 1 - Côté serveur, on peut changer le mot de passe. Vu que jusqu'ici on en a pas mis, à qioi sert-il ? Bloquer l'accès à OpenVPN GUI ?
 
 2 - Par defaut, les connexions se font en UDP. Bizarre, j'imaginais ça en TCP. Que se passe t'il si y'a des paquets dropés ?
 
 
Mon besoin de VPN :
Récup d'un PC portable, ajout de carte WiFi B/G.
Depuis chez des amis/boulot/HotSpots (McDo, TGV, etc. par exemple)/etc. je veux avoir accès au net. Mais par sécurité, je ne veux pas que le trafic passe directement par le HotSpot. Je veux donc passer par "mon chez moi" (le serveur VPN), comme si j'étais chez moi (pour le routage, j'ai ce qu'il faut). Donc :
 
 3 -  

Citation :

# If enabled, this directive will configure all clients to redirect their default network gateway through the VPN, causing all IP traffic such as web browsing and and DNS lookups to go through the VPN (The OpenVPN server machine may need to NAT the TUN/TAP interface to the internet in order for this to work properly). CAVEAT: May break client's network config if client's local DHCP server packets get routed through the tunnel.  Solution: make sure client's local DHCP server is reachable via a more specific route than the default route of 0.0.0.0/0.0.0.0.
;push "redirect-gateway"


Donc (je ne peux pas encore tester), par defaut les clients passent par le VPN pour accéder au serveur VPN ou aux machines du même NetID (10.8.0.x), ou aux réseaux côté serveur VPN si on a ajouté les routes côté client ?
Comment activer cette option pour seulement un client ? (pour que tous les flux soient redirigés vers le serveur VPN ? (Je lance le VPN depuis un HotSpot, puis je peux passer par le VPN pour tous les flux, mail, http, IM, etc.)
 
 4 -  

Citation :

client # Wireless networks often produce a lot of duplicate packets. Set this flag to silence duplicate packet warnings.
;mute-replay-warnings


Bon, j'imagine qu'il faut décommenter dans mon cas ?
 
 5 - Ca me semble logique, mais j'ai assez peu de bases pour l'instant en VPN. Vu que les clefs ont été créées côté serveur et copiées de façon sûre sur le client, (en théorie) il n'y a aucun risque pour que les clefs de cryptage/décryptage soient interceptées, elles ne transitent pas ? Les flux sont directement cryptés ?


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°632
Master_Jul
Posté le 24-06-2006 à 08:25:11  profilanswer
 

Promis, j'essaie de répondre à tout le monde à partir de mercredi aprem'. J'aurai fini mes exams, en attendant c'est tendu !


---------------
En français, on écrit "connexion", pas "connection".
n°633
Groody
Utilisez MES smileys §
Posté le 25-06-2006 à 22:54:11  profilanswer
 

VPN testé ce We pendant 2 jours, nickel.
 
Pour ma question N° 3, je n'ai pas trouvé.
J'ai du activer cette option pour que tous mes flux soient redirigés vers mon serveur VPN.
 
 
Aucun prb hier. Mais aujourd'huii, j'ai eu du mal. Il fallait bcp de temps pour que la connexion se termine, puis une fois faite, impossible de l'utiliser. L'IP attribuée pour le VPN n'est pas du tout du NetID configuré côté serveur, mais du type de celui attribué automatiquement par XP quand aucune requète DHCP n'aboutit.
Reboot, même chose, puis je vois les logs, j'ai des tas de lignes dans ce genre avant que la connexion se termine :
 

Citation :

Sun Jun 25 17:43:41 2006 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Sun Jun 25 17:43:41 2006 Route: Waiting for TUN/TAP interface to come up...
Sun Jun 25 17:43:42 2006 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Sun Jun 25 17:43:42 2006 Route: Waiting for TUN/TAP interface to come up...
Sun Jun 25 17:43:44 2006 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Sun Jun 25 17:43:44 2006 Route: Waiting for TUN/TAP interface to come up...
Sun Jun 25 17:43:45 2006 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Sun Jun 25 17:43:45 2006 Route: Waiting for TUN/TAP interface to come up...
Sun Jun 25 17:43:46 2006 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Sun Jun 25 17:43:46 2006 Route: Waiting for TUN/TAP interface to come up...
Sun Jun 25 17:43:47 2006 TEST ROUTES: 2/2 succeeded len=1 ret=1 a=0 u/d=up


 
puis une erreur à la fin, mais je ne l'ai pas dans le log, et je ne peux la reproduire pour l'instant.
 
 
Puis en insistant, le VPN fonctionne. Déco, reco, re problème, jusqu'à ce que ça repasse.
 
 
Quelqu'un connait ce prb ?


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°634
passemonta​gne
Posté le 27-06-2006 à 23:12:11  profilanswer
 

Merci Master_jul pour cette doc vraiment très bien bien expliqué et très précise, j'ai installé ce VPN sans aucun soucis et ça marche tout est au vert.
Par contre maintenant, comment on accède de la machine client à la machine serveur.  
Et es ce que tout les programmes que l'on fait fonctionner entre ces deux machines sont automatiquents protégé dans le tunnel?
Si on peut accéder aux répertoires , peut-on les définir pour en restreindre l'accès.
Merci de pouvoir m'aider pour une utilisation pratique.

n°635
Groody
Utilisez MES smileys §
Posté le 27-06-2006 à 23:43:08  profilanswer
 

Ce sont les "routes" (configuré côté client) qui s'occuperont de faire passer ou non les flux dans le tunnel.
 
Si tu ajoutes une route qui dit que quand tu veux contacter du "192.168.7.x", à chaque tentative, depuis n'importe quel programme, de connexion version IP de ce NetID, ça passera direct dans le VPN. Le serveur VPN reçoit le flux, balance ça à la pile TCP/IP (la gestion TCP/IP de Windows par exemple) qui s'occupera d'envoyer ça où il faut. Perso, j'utiliser WinRoute pour l'interconnexion de réseaux, le routage, viltrage, etc.
 
De mon côté, j'ai activé l'option (voir mes posts ci dessus) côté serveur VPN pour que les routes soient modifiées de telle façon que TOUS les flux (côtés client) sauf les locaux (sinon impossible de communiquer avec le routeur (ethernet, Wi-Fi, etc.)) soient balancés dans le tunnel. Ce qui donne que n'importe quelle connexion sera renvoyée au serveur VPN (mail, http, ftp, IM, etc.).
 
 
Si tu veux partager un dossier sur le serveur VPN, bouton droit sur le serveur, puis tu actives le partage et règles les permissions.
Reviens sur le client :
Démarrer > Exécuter > \\IpDuServeur
Ca va te demander de t'identifier, il faudra utiliser un compte utilisateur valide sur le serveur (par exemple, "Barnabo" + "mot de passe de barnabo" ).
 
Et hop, tu verras le contenu.


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°636
passemonta​gne
Posté le 28-06-2006 à 00:04:40  profilanswer
 

Groody a écrit :

Ce sont les "routes" (configuré côté client) qui s'occuperont de faire passer ou non les flux dans le tunnel.
 
Si tu ajoutes une route qui dit que quand tu veux contacter du "192.168.7.x", à chaque tentative, depuis n'importe quel programme, de connexion version IP de ce NetID, ça passera direct dans le VPN. Le serveur VPN reçoit le flux, balance ça à la pile TCP/IP (la gestion TCP/IP de Windows par exemple) qui s'occupera d'envoyer ça où il faut. Perso, j'utiliser WinRoute pour l'interconnexion de réseaux, le routage, viltrage, etc.
 
De mon côté, j'ai activé l'option (voir mes posts ci dessus) côté serveur VPN pour que les routes soient modifiées de telle façon que TOUS les flux (côtés client) sauf les locaux (sinon impossible de communiquer avec le routeur (ethernet, Wi-Fi, etc.)) soient balancés dans le tunnel. Ce qui donne que n'importe quelle connexion sera renvoyée au serveur VPN (mail, http, ftp, IM, etc.).
 
 
Si tu veux partager un dossier sur le serveur VPN, bouton droit sur le serveur, puis tu actives le partage et règles les permissions.
Reviens sur le client :
Démarrer > Exécuter > \\IpDuServeur
Ca va te demander de t'identifier, il faudra utiliser un compte utilisateur valide sur le serveur (par exemple, "Barnabo" + "mot de passe de barnabo" ).
 
Et hop, tu verras le contenu.


 
 
Merci pour la réponse rapide, mais j'ai un soucis de compréhension, tu vas trop vite pour moi...
 
si je veux partager un dossier je dois aller dasn program files /openVPN et créer un dossier que je partage...  
 
j'ai essayer du coté client de faire \\10.8.0.1 puisque c'est l'adresse du serveur , mais rien ne se passe..
 
Merci d'avance pour ton aide.

n°637
Groody
Utilisez MES smileys §
Posté le 28-06-2006 à 00:14:34  profilanswer
 

Quelle version de Windows utilises-tu ?
 
 
Non, pas besoin d'aller dans le dossier d'OpenVPN. Tu choisis n'importe quel dossier sur ton PC, "clic droit, propriétés, partager", tu lui donnes un nom, et tu choisis qui à le droit d'y accéder et comment (lecture seul, écriture, etc.).
 
Bizarre que rien ne se passe. Cöté serveur, vas dans les propriétés de cette connexion réseau (via le panneau de configuration puis "connexions réseau" ). Dans le dernier onglet, désactive le "pare-feu" si il est actif.
 
 
Depuis le client, arrives-tu à pinguer le serveur ? (Démarrer > Exécuter > CMD > Ok > ping 10.8.0.1)


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°638
passemonta​gne
Posté le 28-06-2006 à 00:33:37  profilanswer
 

Groody a écrit :

Quelle version de Windows utilises-tu ?
 
 
Non, pas besoin d'aller dans le dossier d'OpenVPN. Tu choisis n'importe quel dossier sur ton PC, "clic droit, propriétés, partager", tu lui donnes un nom, et tu choisis qui à le droit d'y accéder et comment (lecture seul, écriture, etc.).
 
Bizarre que rien ne se passe. Cöté serveur, vas dans les propriétés de cette connexion réseau (via le panneau de configuration puis "connexions réseau" ). Dans le dernier onglet, désactive le "pare-feu" si il est actif.
 
 
Depuis le client, arrives-tu à pinguer le serveur ? (Démarrer > Exécuter > CMD > Ok > ping 10.8.0.1)


 
 
J'ai windows XP pro sur les deux ordis
 
c'est bon j'ai partagé un dossier et désactivé mon  "pare-feu"
 
mais depuis le client le ping ne marche pas alors que tout est Vert (openVPN)
 
et pourtant mes pare-feu sont arrétés

n°639
Groody
Utilisez MES smileys §
Posté le 28-06-2006 à 00:36:57  profilanswer
 

Tu ne dois les arrêter QUE sur les connexion VPN, surtout pas tes connexions à Internet (pour ne pas compromettre la sécurité de tes PC).
 
Regarde les logs du client pour trouver l'IP qui t'a été attribué ainsi que d'éventuels messages d'erreur.
 
Fais aussi Démarrer > Executer > CMD > ipconfig
et regarde si la connexion VPN est bien configurée (automatiquement, par le serveur VPN lors de la connexion, style 10.8.0.X etc.).


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°640
passemonta​gne
Posté le 28-06-2006 à 00:57:41  profilanswer
 

Groody a écrit :

Tu ne dois les arrêter QUE sur les connexion VPN, surtout pas tes connexions à Internet (pour ne pas compromettre la sécurité de tes PC).
 
 
Regarde les logs du client pour trouver l'IP qui t'a été attribué ainsi que d'éventuels messages d'erreur.
 
 
 
 
Fais aussi Démarrer > Executer > CMD > ipconfig
et regarde si la connexion VPN est bien configurée (automatiquement, par le serveur VPN lors de la connexion, style 10.8.0.X etc.).


 
 
OK je remettrais les pare-feu (sauf vpn) dès que cela marchera  
A priori pas de message d'erreur dans le log
pour l'ip config,  pas de problème sauf peux-être qu'il n'y a pas de passerelle par defaut, cela as-t-il de l'importance dans notre cas?

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  41  42  43  44  45  46

Aller à :
Ajouter une réponse
 

Sujets relatifs
*** Réseau domestique et partage de connexion Internet 
Plus de sujets relatifs à : Réseau privé virtuel sous Windows - OpenVPN - Tutoriels.


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR