Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
710 connectés 

 



 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  42  43  44  45  46  47
Auteur Sujet :

Réseau privé virtuel sous Windows - OpenVPN - Tutoriels.

n°640
passemonta​gne
Posté le 28-06-2006 à 00:57:41  profilanswer
 

Reprise du message précédent :

Groody a écrit :

Tu ne dois les arrêter QUE sur les connexion VPN, surtout pas tes connexions à Internet (pour ne pas compromettre la sécurité de tes PC).
 
 
Regarde les logs du client pour trouver l'IP qui t'a été attribué ainsi que d'éventuels messages d'erreur.
 
 
 
 
Fais aussi Démarrer > Executer > CMD > ipconfig
et regarde si la connexion VPN est bien configurée (automatiquement, par le serveur VPN lors de la connexion, style 10.8.0.X etc.).


 
 
OK je remettrais les pare-feu (sauf vpn) dès que cela marchera  
A priori pas de message d'erreur dans le log
pour l'ip config,  pas de problème sauf peux-être qu'il n'y a pas de passerelle par defaut, cela as-t-il de l'importance dans notre cas?

mood
Publicité
Posté le 28-06-2006 à 00:57:41  profilanswer
 

n°641
passemonta​gne
Posté le 28-06-2006 à 01:14:12  profilanswer
 

Groody a écrit :

Tu ne dois les arrêter QUE sur les connexion VPN, surtout pas tes connexions à Internet (pour ne pas compromettre la sécurité de tes PC).
 
Regarde les logs du client pour trouver l'IP qui t'a été attribué ainsi que d'éventuels messages d'erreur.
 
Fais aussi Démarrer > Executer > CMD > ipconfig
et regarde si la connexion VPN est bien configurée (automatiquement, par le serveur VPN lors de la connexion, style 10.8.0.X etc.).


 
 
J'ai changé quelques options dans la config serveur (client to client rajouté et push dhcp  rajouté également) et maintenant le ping marche  
 
et puis tout marche merci à toi pour tous tes conseils.
 
Le dossier que j'ai partagé coté serveur s'ouvre du coté client,   génial....  
 
  :bounce:  :bounce:  :bounce:

n°642
passemonta​gne
Posté le 28-06-2006 à 01:19:15  profilanswer
 

passemontagne a écrit :

OK je remettrais les pare-feu (sauf vpn) dès que cela marchera  
A priori pas de message d'erreur dans le log
pour l'ip config,  pas de problème sauf peux-être qu'il n'y a pas de passerelle par defaut, cela as-t-il de l'importance dans notre cas?


 
 
Groody,  
J'ai changé coté serveur quelques options dans le fichier config (client client   et push dhcp ), j'ai rebooté le serveur
le ping marche et maintenant le dossier coté serveur que j'ai partagé est disponible du coté client  
Super génial, merci à toi pour tout tes conseils...
 :bounce:   :bounce:   :bounce:  
 

n°643
jaguarg
Posté le 29-06-2006 à 21:05:56  profilanswer
 

Bonjour,  
 
J ai installe OpenVPN et j ai quelques problemes.  
Voici la situation  


                                                                  ------------
                                                               - |VPN SERVER| VPN IP 10.8.0.1
                                                              |   ------------  LAN IP 169.254.1.5
 ----------                  -------------           |                      XP Home
|VPN Client|---------->|ADSL ROUTER|----- O
 ----------                  -------------           |        
 INET IP xx.xx.xx.xx       LAN IP 169.254.1.1    |   -------------
 VPN IP 10.8.0.6           INET IP xx.xx.xx.xx     - |LAN CLIENT 1| LAN IP 169.254.1.3
 XP Home                                                      -------------  XP Home  


 
Ce qui marche:  
- le client arrive a sec connecter au serveur  
- le client peut pinger l'IP du serveur sur le LAN 169.254.1.5  
- le client peut pinger l'IP du serveur assignee par OpenVPN 10.8.0.1  
- le client peur acceder au dossier du serveur en utilisant son IP  
 
PROBLEMES  
- le client ne peut pas pinger les autres machines du subnet (par nom ou IP)  
- le client ne peut pas pinger le serveur par nom  
- le serveur ne peut pas pinger le client du tout  
- aucune autre station du subnet ne peut pinger le client  
 
A l aide!!!! !
 
voici ma config serveur  

Code :
  1. port 1194
  2. proto udp
  3. dev tun
  4. route-method exe
  5. ca ca.crt
  6. cert server.crt
  7. key server.key
  8. dh dh1024.pem
  9. server 10.8.0.0 255.255.255.0
  10. route 169.254.1.0 255.255.255.0
  11. ifconfig-pool-persist ipp.txt
  12. client-to-client
  13. client-config-dir \\Program Files\\OpenVPN\\config
  14. push "route 169.254.1.0 255.255.255.0"
  15. push "dhcp-option WINS 169.254.1.1"
  16. push "dhcp-option DNS 169.254.1.1"
  17. keepalive 10 120
  18. comp-lzo
  19. max-clients 5
  20. persist-key
  21. persist-tun
  22. status openvpn-status.log
  23. verb 3


 
 
voici ma config client:  

Code :
  1. client
  2. proto udp
  3. dev tun
  4. remote xx.xx.xx.xxx 1194
  5. resolv-retry infinite
  6. nobind
  7. persist-key
  8. persist-tun
  9. ca ca.crt
  10. cert client1.crt
  11. key client1.key
  12. comp-lzo
  13. verb 3

n°644
Groody
Utilisez MES smileys §
Posté le 29-06-2006 à 23:55:21  profilanswer
 

Il faut ajouter du routage. Par défaut ce n'est pas actif.
Les interfaces ne sont pas encore liées entre elles.
 
Quelle version de Win sur le serveur ? Regarde du côté du "pont réseau" à ajouter sur tes connexion réseau (comme un protocole, une carte, etc.).
 
 
Pour la résolution de nom, ton client doit utiliser le DNS de sa connexion Internet. Lorsque tu appelles \\NomDuServeur c'est le serveur DNS de ton provider qui est intérrogé.
Tu peux ajouter les entrées dans "Hosts", ou utiliser un serveur Dns de ton serveur VPN si tu en fais tourner un.


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°645
dadougump
Posté le 04-07-2006 à 14:32:03  profilanswer
 

Perso, j'arrive a me connecté à mon serveur VPN (ADSL Orange 8Mbit) sans aucun souci via un modem 56k (Connexion Free56K).
 
Par contre impossible de pinger l'ip reseau local de mon serveur VPN (192.168.2.10) via la connexion VPN sur le client.
J'arrive à pinger l'interfece 10.8.0.1 (normal la connexion est etabli).
 
Que dois je renseigner dans les fichiers de config pour avoir acces a tout mon reseau local ?
Reseau Local en 192.168.2.0 / 255.255.255.0
L'objectif est de pouvoir administrer mon reseau a distance en ouvrant juste le port VPN biensure :)
 
Merci pour votre aide.

n°646
Groody
Utilisez MES smileys §
Posté le 04-07-2006 à 15:16:55  profilanswer
 

Ce n'est pas le VPN qui doit donner accès au(x) réseau(x), mais la machine (routage/filtrage entre interfaces). Comme je l'ai expliqué juste au dessus.


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°647
dadougump
Posté le 04-07-2006 à 15:24:42  profilanswer
 

Avec la creation d'un pont réseau, les adresses IP des 2 connexions (TAP & Reseau local) disparaissent. Donc je n'arrive plus a me connecter sur le serveur VPN.

n°648
passemonta​gne
Posté le 05-07-2006 à 21:13:50  profilanswer
 

bonjour à tous, j'essais de découvrir openVPN , il y a vraiment beaucoup de possibilité, mais je suis tombé sur le problème suivant:
J'ai essayé de changé le niveau de cryptage en choisissant une des versions proposées:  
 
# Select a cryptographic cipher.
# This config item must be copied to
# the client config file as well.
;cipher BF-CBC        # Blowfish (default)
;cipher AES-128-CBC   # AES
;cipher DES-EDE3-CBC  # Triple-DES
 
déjà j'ai été surpris que le blowish soit en défaut alors qu'il y a un point virgule devant, mais en essayant les trois (un par un bien sur et en indiquant le même coté serveur et coté client) cela ne marche pas, cela me plante???
avez vous essayé et que doit on faire pour que cela marche.
 
Autre sujet dans un prog en vb ou un script , est-il possible de lancer la connexion automatiquement de open VPN et de la clore après par ce même programme.
 
Et enfin , comment fait-on pour lancer avant ou pendant ou après la connexion un script pour vérifier différentes choses chez le client comme par exemple si il a un firewall ou un antivirus par exemple. J'ai lu que l'on pouvait le faire , mais je n'ai pas trouvé les fichiers.
Merci d'avance

n°649
passemonta​gne
Posté le 06-07-2006 à 15:04:46  profilanswer
 

bonjour à tous,
Après un bon nombre de test, j'ai trouvé qu'il fallait respecter certaines règles lors des changements de paramêtres sinon cela ne marche pas, à savoir:  
Toujours arrêter les tunnels avant de changer les fichiers configs sinon ça plante même si on on lance la reconnection de OpenVPN après enregistrement du fichier config.
Et aussi si vous avez un raccourci pour accéder à un répertoire du serveur, il fvous faudra attendre une dizaine de secondes avant que l'ouverture de ce dossier "réseau" marche, plutôt j'ai une erreur de droit d'accès.
Voilà je voulais partager cela avec vous et voir si vous avez constater les mêmes choses.

mood
Publicité
Posté le 06-07-2006 à 15:04:46  profilanswer
 

n°650
Houbaa
Posté le 24-07-2006 à 11:01:06  profilanswer
 

bonjour à tous,
Je viens de découvrir OpenVPN, je l'ai installer sur windowsXP, ça fonctionne très bien.
Par contre j'aimerais savoir si il y a un moyen de connaître, à partir du serveur, quels sont les clients actuellement connectés, ainsi qu'une association "common name" <-> "IP virtuelle".
 
Dans le fichier "server.ovpn", il y a bien la ligne "ifconfig-pool-persist ipp.txt", mais dans le fichier ipp.txt les adresses ne correspondent pas. De plus, ce fichier liste tous les clients qui se sont connectés et non les clients actuellement connectés
Exemple, chez moi, j'ai ça dans ipp.txt :
client1,10.8.0.4
client2,10.8.0.8
alors que ces clients sont joignables respectivement aux adresses 10.8.0.6 et 10.8.0.10. Est-ce que quelqu'un a une explication ???
 
Sinon, il y a aussi le fichier "openvpn-status.log", où j'ai également des correspondances :
10.8.0.6,client1,...
Ici, l'adresse IP est correcte, apparemment la liste se met à jour en fonction des clients connectés, mais c'est assez lent.
 
Merci de votre aide

n°651
megatron
Posté le 25-07-2006 à 08:39:44  profilanswer
 

Bonjour,
 
 
J'ai essayé de suivre vos instructions à la lettre pour permettre à un collègue qui a déménagé à Nancy (le monde est petit) de se connecter au réseau de l'entreprise. Nous utilisons Free comme FAI mais il semble que ce fournisseur bride les ports au dessus de 1024 (du coup le VPN natif de WinXP est très lent).  Actuellement on utilise UltraVNC avec des ports inférieur à 1024 mais ca bloque un PC dans l'usine uniquement pour cette tâche.
Votre solution, puisque qu'on peut changer de port, semble être idéale.
 
Bref, à la fin de la configuration, l'icône s'allume en vert. Mon collègue arrive à se connecter, il obtient une adresse IP 10.8.0.6. Les pings fonctionnent mais on ne peut pas voir les dossiers partagés.
 
La seule différence que j'ai réussi à repérer est la suivante: dans le log du serveur, il y a un message "FlushIpNetTable failed on interface [2] {...} (status=1413) : Index non valide"
Pouvez vous m'aider à résoudre ce problème ?
Merci
 
Voici le contenu du status du serveur OpenVPN
 
Mon Jul 24 16:28:21 2006 OpenVPN 2.0.7 Win32-MinGW [SSL] [LZO] built on Apr 12 2006
Mon Jul 24 16:28:21 2006 Diffie-Hellman initialized with 1024 bit key
Mon Jul 24 16:28:21 2006 Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
Mon Jul 24 16:28:21 2006 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Mon Jul 24 16:28:21 2006 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Mon Jul 24 16:28:21 2006 TLS-Auth MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
Mon Jul 24 16:28:25 2006 TAP-WIN32 device [Connexion au réseau OpenVPN] opened: \\.\Global\{99754AE5-3AF2-4673-8275-721DC542C23F}.tap
Mon Jul 24 16:28:25 2006 TAP-Win32 Driver Version 8.1  
Mon Jul 24 16:28:25 2006 TAP-Win32 MTU=1500
Mon Jul 24 16:28:25 2006 Notified TAP-Win32 driver to set a DHCP IP/netmask of 10.8.0.1/255.255.255.252 on interface {99754AE5-3AF2-4673-8275-721DC542C23F} [DHCP-serv: 10.8.0.2, lease-time: 31536000]
Mon Jul 24 16:28:25 2006 Sleeping for 10 seconds...
Mon Jul 24 16:28:35 2006 NOTE: FlushIpNetTable failed on interface [2] {99754AE5-3AF2-4673-8275-721DC542C23F} (status=1413) : Index non valide.  
Mon Jul 24 16:28:35 2006 route ADD 10.8.0.0 MASK 255.255.255.0 10.8.0.2
Mon Jul 24 16:28:35 2006 Route addition via IPAPI succeeded
Mon Jul 24 16:28:35 2006 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Mon Jul 24 16:28:35 2006 UDPv4 link local (bound): [undef]:1000
Mon Jul 24 16:28:35 2006 UDPv4 link remote: [undef]
Mon Jul 24 16:28:35 2006 MULTI: multi_init called, r=256 v=256
Mon Jul 24 16:28:35 2006 IFCONFIG POOL: base=10.8.0.4 size=62
Mon Jul 24 16:28:35 2006 IFCONFIG POOL LIST
Mon Jul 24 16:28:35 2006 OpenVPN-Megatron.net,10.8.0.4
Mon Jul 24 16:28:35 2006 Initialization Sequence Completed

n°652
Groody
Utilisez MES smileys §
Posté le 25-07-2006 à 09:04:02  profilanswer
 

Pour ce qui est des accès aux dossiers partagés, aux autres réseaux, etc. on en a déjà parlé.
Il n'y a que 3 pages, lis tout, tu devrais trouver ce que tu cherches.


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°653
lt_pi-k_ki​ki
Vive les fleurs!
Posté le 26-07-2006 à 12:55:28  profilanswer
 

Master_Jul a écrit :

Pour ma part, j'avais du mal à faire fonctionner les partages windows avec le firewall activé. Tant mieux si tout remarche. ;)


 
Je confirme, ca ne marche pas pour moi non plus si le firewall xp est en place sur la connexion openvpn.
 
En tout cas, nikel le tuto, félicitation. [:buvons]

n°654
Groody
Utilisez MES smileys §
Posté le 08-08-2006 à 16:06:58  profilanswer
 

Quelqu'un sait comment faire pour démarrer le serveur automatiquement, en tant que service ?
Si ma machine plante/reboot/coupure de courant, tout monte sauf le serveur VPN.


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°655
k1200
Posté le 08-08-2006 à 16:13:14  profilanswer
 
n°656
Groody
Utilisez MES smileys §
Posté le 08-08-2006 à 16:31:25  profilanswer
 
n°657
PDT
いらしえいいいいいい
Posté le 23-08-2006 à 09:46:10  profilanswer
 

Les débits en passant par Hamachi sont corrects ? En fait, je viens d'acheter un portable et j'ai besoin de récupérer mes 70Go de données de mon pc fixe en un laps de temps relativement court (2-3 jours).  
 
Ca vous semble faisable ou pas ? (Je suis en dégroupé total Free)

n°658
dotheright​thing
Posté le 24-08-2006 à 18:58:50  profilanswer
 

Bonjour,
j'ai suivi le tuto à la lettre, ça marche et ça m'arrange j'ai un réseau hétérogène (Mac OSX 10.2 10.3 et 10.4 et des PC XP + un serveur 2003 R2).
J'ai pour l'instant testé entre mon serveur 2003 et un XP, voici mes remarques :
 
ça marche pas du premier coup malheureusement.
J'ai dù un peu galèrer pour que cela fonctionne.
 
- côté serveur :
-> dans routage et accès distant, ajouter la liaison TAP que j'ai renommé MyTap pour créer une règle NAT sur l'adresse 10.8.0.1 en plus de router le port 1194 comme préciser. Il faut au préalable décommenter l'usage du Tap dans la config.
-> décommenter ns-cert-type server dans la config,
-> décommenter client to client,
-> décommenter push dhcp.
 
- côté client :
-> activer dans les services le DHCP avant de lancer le client openVPN,
-> décommenter ns-cert-type server dans la config,
-> décommenter client to client,
-> décommenter push dhcp.
 
Redémarrer le serveur (je le fais à distance en ayant pris soin d'activer le démarrage automatique du service OpenVPN pour éviter de me reconnecter en "bureau à distance" ) car je fais les tests sur une machine cliente à partir de chez moi.
 
Bref, maintenant ça marche et je remercie tous ceux qui postent les messages d'erreurs, ça fait avancer et ça donne des pistes à suivre.
La FAQ est très bien faite également.
 
Petit point noir, la connexion est très lente et je ne sais pas quel port choisir car je viens de lire que Free bridait les ports < à 1024, c'est vrai ?
Autre interrogation, vais je galérer autant sur les Macs ?
 
Quel retour d'expérience pour vous ?
 
Merci

n°659
halo21
Posté le 29-08-2006 à 15:09:34  profilanswer
 

Bon j'ai du mal à voir les différentes possibilités du mode routed (dev tun). J'ai vu qu'il y avait deux modes
le mode routed et le mode bridged.  
-Le mode routed serait plutôt pour par exemple des clients nomades
-le mode bridged pour interconnecter deux lan distants.
 
Par rapport au mode routed à partir du moment ou le tunnel est fait peut-on des clients du côté serveur vpn
voir le lan du côté client vpn en rajoutant simplement la route vers la passerelle vpn de chaques sous réseaux sur les clients ?
 
merci !

n°660
anubis972
Posté le 30-08-2006 à 21:34:32  profilanswer
 

hi,
 
Voila le reseau :
 
 
machine 1 ---> machine 2 (partage de connexion)  -------INTERNET ------ Windows 2003 Server Web edition
 
 
Je suis sur la machine 1
 
J'ai l'erreur suivante : " MULTI: bad source address from client ... "
 
D'apres ce que j'ai compris il faut cree un pont entre ma connexion VPN et la carte reseau ceci sur le serveur donc :
 
- Je voudrais savoir comment cree un pont sur mon serveur (meme par logiciel si cela n'est pas possible par le serveur) ??
 
La solution viendrais je pense du Post un peu plus haut de "dotheright thing" Mais la procédure n'est pas assez développer :(
"-> dans routage et accès distant, ajouter la liaison TAP que j'ai renommé MyTap pour créer une règle NAT sur l'adresse 10.8.0.1 en plus de router le port 1194 comme préciser. Il faut au préalable décommenter l'usage du Tap dans la config. "
 
 
Anubis


Message édité par anubis972 le 31-08-2006 à 02:59:57
n°661
anubis972
Posté le 31-08-2006 à 06:40:31  profilanswer
 

voila ...
 
Ca fonctionne presque bien ...
 
Rajoutons ceci :
 
Sous Win2003 apparement les connections doivent etre active et là vous activer "le routage et l'acces distant" sur ma version il me demandais de desactiver le Service Firewall en mode "Diseable" imperativement !
Vous n'avez meme pas besoin de regler les ports apparement, si les connections etaient active il fait les ponts. O.o
 
 
Par contre mon serveur ne ping toujours pas la station je vais continuer ... :)
 
-----
 
ARRFFFF ca marche plus ... bref
 
-----
 
j'ai arreter le service routage et service distant et tout fonctionne ... j'ai rebooter pour etre sur !!! Mais toujours pas de ping Serveur to PC et de resolution de nom ...
Je suis le seul pour qui ca fonctionne pas ... :(
 
Anubis


Message édité par anubis972 le 31-08-2006 à 07:54:44
n°662
lecelte
Posté le 31-08-2006 à 17:45:47  profilanswer
 

anubis972 a écrit :


J'ai l'erreur suivante : " MULTI: bad source address from client ... "
Anubis


 
Moi aussi j'ai ce message sur le serveur lorsque je tente depuis le poste  client de connecter un lecteur réseau via \\10.8.0.1.
 
Le client ping le serveur
Le serveur ping le client
Mais je n'ai pas accès aux répertoires partagés du serveur.
 
Si je me connecte via RealVNC (sur le 10.8.0.1) , j'ai un écran noir, c'est comme si "je n'avais pas de retour du serveur".
NB: RealVNC fonctionne parfaitement sans passer par OpenVPN
 
Côté serveur :
-------------
Windows XP Pro SP2 Fiwerall désactivé
IP : 192.168.1.100
 
Derrière un Firewall Lynksys
IP : 192.168.1.1
Port 1194 ouvert
 
Connecté à une Freebox
 
Côté client :
------------
Windows XP Pro SP2 Fiwerall désactivé
IP : 10.55.10.22
 
Derriere un Firewall Netopia
IP : 10.55.10.200
Port 1194 ouvert (inutile, ouvert pour tester dans l'autre sens)
 
Connecté à une Freebox
 
------------------
fichier conf serveur
------------------
port 1194
proto udp
dev tun
ca ca.crt
cert server.crt
key server.key  # This file should be kept secret
dh dh1024.pem
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
client-to-client
keepalive 10 120
tls-auth ta.key 0 # This file is secret
comp-lzo
persist-key
persist-tun
status openvpn-status.log
verb 3
 
Les routes côté serveur
===========================================================================
Destination réseau    Masque réseau  Adr. passerelle   Adr. interface Métrique
          0.0.0.0          0.0.0.0      192.168.1.1   192.168.1.101       20
         10.8.0.0  255.255.255.252         10.8.0.1        10.8.0.1       30
         10.8.0.0    255.255.255.0         10.8.0.2        10.8.0.1       1
         10.8.0.1  255.255.255.255        127.0.0.1       127.0.0.1       30
   10.255.255.255  255.255.255.255         10.8.0.1        10.8.0.1       30
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.1.0    255.255.255.0    192.168.1.101   192.168.1.101       20
    192.168.1.255  255.255.255.255    192.168.1.101   192.168.1.101       20
        224.0.0.0        240.0.0.0         10.8.0.1        10.8.0.1       30
        224.0.0.0        240.0.0.0    192.168.1.101   192.168.1.101       20
  255.255.255.255  255.255.255.255         10.8.0.1        10.8.0.1       1
Passerelle par défaut :       192.168.1.1
===========================================================================
 
 
-----------------
fichier conf client  
-----------------
client
dev tun
proto udp
remote xxx.xxx.xxx 1194
resolv-retry infinite
nobind
persist-key
persist-tun
ca ca.crt
cert dudu1600.crt
key dudu1600.key
ns-cert-type server
tls-auth ta.key 1
comp-lzo
verb 3
 
Les routes côté client :
===========================================================================
Destination réseau    Masque réseau  Adr. passerelle   Adr. interface Métrique
          0.0.0.0          0.0.0.0     10.55.10.200     10.55.10.22       1
         10.8.0.0    255.255.255.0         10.8.0.5        10.8.0.6       1
         10.8.0.4  255.255.255.252         10.8.0.6        10.8.0.6       30
         10.8.0.6  255.255.255.255        127.0.0.1       127.0.0.1       30
       10.55.10.0    255.255.255.0      10.55.10.22     10.55.10.22       20
      10.55.10.22  255.255.255.255        127.0.0.1       127.0.0.1       20
   10.255.255.255  255.255.255.255         10.8.0.6        10.8.0.6       30
   10.255.255.255  255.255.255.255      10.55.10.22     10.55.10.22       20
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
        224.0.0.0        240.0.0.0         10.8.0.6        10.8.0.6       30
        224.0.0.0        240.0.0.0      10.55.10.22     10.55.10.22       20
  255.255.255.255  255.255.255.255         10.8.0.6        10.8.0.6       1
  255.255.255.255  255.255.255.255      10.55.10.22     10.55.10.22       1
Passerelle par défaut :      10.55.10.200
===========================================================================


---------------
Feedback achat/vente -  Photos www.lecelte.com
n°663
anubis972
Posté le 31-08-2006 à 19:16:27  profilanswer
 

Salut,
 
Du cote serveur tu as fais une connexion de pont entre la connexion OpenVPN et la carte reseau local du serveur ?
 
Anubis

n°664
lecelte
Posté le 31-08-2006 à 22:25:33  profilanswer
 

anubis972 a écrit :

Salut,
 
Du cote serveur tu as fais une connexion de pont entre la connexion OpenVPN et la carte reseau local du serveur ?
 
Anubis


non rien du tout :non:


---------------
Feedback achat/vente -  Photos www.lecelte.com
n°665
anubis972
Posté le 01-09-2006 à 02:03:07  profilanswer
 

hi,
 
Ben justement il faut que tu crees le pont !!!
tu cliques sur les deux connexions en maintenant "ctrl" et tu cree le pont :).
 
Anubis

n°666
lecelte
Posté le 01-09-2006 à 09:18:46  profilanswer
 

anubis972 a écrit :

hi,
 
Ben justement il faut que tu crees le pont !!!
tu cliques sur les deux connexions en maintenant "ctrl" et tu cree le pont :).
 
Anubis


 :ouch: je connaissait pas cette manip, trop fort  [:crevette_88]  
 
Il faut créer les ponts sur les 2 postes (serveur et client) ?


---------------
Feedback achat/vente -  Photos www.lecelte.com
n°667
halo21
Posté le 01-09-2006 à 11:51:25  profilanswer
 

Le pont est nécessaire si tu es en mode bridged pour le mode routed normalement non à ce que j'ai compris.

n°668
halo21
Posté le 01-09-2006 à 11:57:49  profilanswer
 

Bon j'ai un pb et j'arrive pas à voir ou celà ne colle pas.  
Je suis en mode routed. Le client ping bien le serveur et le sous réseau coté serveur vpn. Le serveur ne peut pas pinger le sous réseau
pourtant il y a les bonnes routes déjà celà est il normal ?  
 
Deuxio le sous réseau client avec les bonnes routes ne peut pinger le sous réseau coté serveur. Celà va bien
vers la passerelle mais aprés part dans la nature. au niveau des logs serveurs j'ai l'erreur : Multi : bad source client avec l'addresse ip du client coté lan client donc le ping arrive bien au serveur mais aprés ...
Le serveur est sous Xp non sp2 (pas de firewall ).
 
si vous avez des pistes j'ai épuisé mes idées...

n°669
anubis972
Posté le 01-09-2006 à 12:23:25  profilanswer
 

hi,
 
Ce qui serais pas mal c'est que on puisse voir les config comme plus haut ...
Moi la piste que je commence a explorer est de regarder les "bug fix" et nouvelles option dans les versions 2.1 beta !!
 
How to fix the errors "MULTI: bad source address from client [192.168.100.249], packet dropped" or "GET INST BY VIRT: 192.168.100.249 [failed]"?
 
These errors occur because OpenVPN doesn't have an internal route for 192.168.100.249. Consequently, it doesn't know how to route the packet to this machine, so it drops the packet.
 
Use client-config-dir and create a ccd file for your client containing the iroute option to tell OpenVPN that the 192.168.100.0/24 network is available behind this client.
 
http://openvpn.net/changelog-beta.html
 
http://openvpn.net/howto.html#scope
 
Anubis


Message édité par anubis972 le 01-09-2006 à 12:39:28
n°670
Groody
Utilisez MES smileys §
Posté le 01-09-2006 à 12:25:23  profilanswer
 

Plus de signe de vie de la part de MAster_Jul depuis lgtps... :/


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°671
halo21
Posté le 01-09-2006 à 12:46:05  profilanswer
 

Je commence à me demander si c'est pas en fait le mode routed (dev tun)  qui pose problème. C'est peut être tout simplement pas pour des clients nomades, on peut être pas routé un sous réseau côté client vers le coté serveur et il faut passer en mode bridged. J'aimerais bien savoir si celà marche chez quelqu'un ???

n°672
anubis972
Posté le 01-09-2006 à 13:01:29  profilanswer
 

hi,
 
oui c'est cela à mon avis :
 
- TAP vs. TUN interface: Use dev tap only if you want the client on the LAN subnet. This would require bridging, which Windows 2000 does not support, so the use of dev tap is not possible with Windows 2000. Windows XP does support bridging.
 
Il existe des softs tel que wingate (pas d'autres en tete) pouvant cree un pont sous win200 je pense :)
 
"Sous Windows 2000 : des problèmes de routages peuvent survenir, il arrive que l'interface VPN ne récupère pas les routes nécessaires. Vous pouvez alors taper la commande suivante dans un shell (cmd.exe) pour vous en assurez : route print
 
Si la route du VPN n'y est pas, faite un : route add [adresse du réseau VPN] MASK 255.255.255.0 [IP du serveur VPN] "
 
 
 
Anubis


Message édité par anubis972 le 01-09-2006 à 13:39:34
n°673
Master_Jul
Posté le 01-09-2006 à 13:09:38  profilanswer
 

Groody a écrit :

Plus de signe de vie de la part de MAster_Jul depuis lgtps... :/


 
Mais si, mais si, je regarde mais certains trucs me dépassent. :/


---------------
En français, on écrit "connexion", pas "connection".
n°674
anubis972
Posté le 01-09-2006 à 13:18:21  profilanswer
 

Salut,
 
Ceux pour qui cela fonctionne pourrais diffuser leurs "config" et fichier cela permettrais de comprendre certains parametres :).
Il y a ceux qui utilisent TAP d'autres que TUN.
Des details plus developper sur le routage sur les configs utilisant WIN2003.
 
Ca serais cool de partagé aussi les resultats positifs ...
 
Anubis

n°675
anubis972
Posté le 01-09-2006 à 13:20:34  profilanswer
 

hi,
 
J'en profite pour demander qui aurais une astuce pour sauvegarder les mots de passe windows quant on partage un dossier meme si à la connexion sur ma machine vers ce dossier partager, je coche "enregistrer le mot de passe" ... ben au prochain reboot je me reconnecte et hop il me le redemande, il garde en memoire que le USER.
 
Anubis

n°676
Groody
Utilisez MES smileys §
Posté le 01-09-2006 à 13:26:43  profilanswer
 

Master_Jul a écrit :

Mais si, mais si, je regarde mais certains trucs me dépassent. :/


 [:alberich]  
 
Et mon PM non lu depuis au moins 2 mois ??!  [:j l b]


---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°677
Master_Jul
Posté le 01-09-2006 à 13:27:48  profilanswer
 

Groody a écrit :

[:alberich]  
 
Et mon PM non lu depuis au moins 2 mois ??!  [:j l b]


 
Ah oui, il me semblait l'avoir lu. :whistle:
 
Edit : Pour la réponse rapide, je crois que c'est raté. :sweat:


Message édité par Master_Jul le 01-09-2006 à 13:28:32

---------------
En français, on écrit "connexion", pas "connection".
n°678
Groody
Utilisez MES smileys §
Posté le 01-09-2006 à 13:38:53  profilanswer
 

Pas grave [:spamafote]
 
EDIT : Perso, ça m'aurait gonflé de garder " :hello: Vous avez un nouveau message" pendant 2 mois ... :D


Message édité par Groody le 01-09-2006 à 15:20:10

---------------
Vidéo Concorde Air France | www.kiva.org | Emploi Webmarketing
n°679
anubis972
Posté le 01-09-2006 à 14:13:41  profilanswer
 

Groody  
 
Tu as ajouté des routes quels sont t'elles stp ?
 
Anubis

n°680
nabsboss
Posté le 01-09-2006 à 14:15:49  profilanswer
 

Salut les gards! je suis dans le même pétrin :o) !!
En faite je suis en dev tap + mode routed. Mon Vpn est en 10.8.0.0 du client j'arrive à pinger l'ip VPN du server et du server j'arrive à pinger l'ip vpn du client.
Le lan coté serveur est en 192.168.1.0.
Le client arrive à ping l'adresse du server 192.168.1.12 côté Lan mais il n'arrive pas à pinger la passerelle du lan en 192.168.1.1 du couq je peux pas sortir pour surfer ou allez sur internet !!!!

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  42  43  44  45  46  47

Aller à :
Ajouter une réponse
 

Sujets relatifs
*** Réseau domestique et partage de connexion Internet 
Plus de sujets relatifs à : Réseau privé virtuel sous Windows - OpenVPN - Tutoriels.


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR